]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
928f46efbe025426494670ab16b761b7b7307439
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Name:           flux
3 Version:        0.4.1
4 Release:        1
5 Group:          Libraries
6 Group(fr):      Librairies
7 Group(pl):      Biblioteki
8 License:        GPL
9 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
10 URL:            http://projects.simplemente.net/flux/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Flux is a survival-through-structure library, whose goal is to reduce
15 the complexity of C programming. To this end, it supplies high-level
16 functions for manipulating data and communication with specialized
17 handles, masking typically tedious programming tasks. Common
18 instruction blocks are wrapped in higher-level calls with intuitive
19 names. In short: Do it once, do it right, then forget about it.
20
21 Abstracting things this way involves speed compromises. In Flux, these
22 should be minimal, and sometimes, when superiour algorithms are easily
23 accessible, efficiency is actually gained.
24
25 Another important goal is bridging gaps between typical tasks - like
26 parsing, storage, retrieval, buffering and transfer, data structures -
27 like generic tree structures, generic network structures, XML and
28 presentation formats, and protocols - like FluxComm, Unix protocols
29 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
30 and masking is particularly useful here).
31
32 %description -l pl
33 Flux jest bibliotek± typu "", której celem jest redukcja z³o¿ono¶ci
34 programowania w C. W tym celu zaprojektowano funkcje wysokiego poziomu
35 s³u¿±ce manipulacji danymi i komunikacji z wyspecjalizowanymi
36 uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania programistyczne.
37 Popularne bloki instrukcji s± zawiniête w wywo³aniach wy¿szego poziomu
38 o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz, zrób to dobrze i
39 zapomnij o tym. Takie wyabstrahowywanie wymaga wielu kompromisów. We
40 Fluksie powinny byæ one ograniczone do minimum, czasem za¶, kiedy
41 ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na wydajno¶ci. Inn±
42 wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi zadaniami
43 (parsowanie, przechowywanie, wydobywanie, buforowanie i transfer),
44 strukturami danych (generyczne struktury drzew, generyczne struktury
45 sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm, protoko³y
46 uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
47 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
48 ukazuj± swoja warto¶æ).
49
50 %package devel
51 Summary:        Header files and development documentation for flux
52 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
53 Group:          Development/Libraries
54 Group(fr):      Development/Librairies
55 Group(pl):      Programowanie/Biblioteki
56 Requires:       %{name} = %{version}
57
58 %description devel
59 Header files and development documentation for flux.
60
61 %description -l pl devel
62 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
63
64 %package static
65 Summary:        Static flux libraries
66 Summary(pl):    Biblioteki statyczne flux
67 Group:          Development/Libraries
68 Group(fr):      Development/Librairies
69 Group(pl):      Programowanie/Biblioteki
70 Requires:       %{name}-devel = %{version}
71
72 %description static
73 Static flux libraries.
74
75 %description -l pl static
76 Biblioteki statyczne flux.
77
78 %prep
79 %setup -q
80
81 %build
82 LDFLAGS="-s"; export LDFLAGS
83 %configure
84 echo n | make
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 make install DESTDIR=$RPM_BUILD_ROOT
90
91 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
92
93 gzip -9nf AUTHORS README NEWS TODO 
94
95 %find_lang %{name}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc *.gz doc/*
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %attr(755,root,root) %{_libdir}/lib*.la
112 %{_includedir}/*
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
This page took 0.065262 seconds and 3 git commands to generate.