]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- updated to 2.3.4
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # ladcca sesion management support (deprecated) (GPL)
4 %bcond_without  lash            # LASH support (GPL)
5 %bcond_with     midishare       # MidiShare support
6 %bcond_without  readline        # readline line editing (GPL)
7 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
8 %bcond_without  static_libs     # don't build static library
9 #
10 %ifarch pentium3 pentium4 %{x8664}
11 %define         with_sse        1
12 %endif
13 #
14 Summary:        FluidSynth - a software, real-time synthesizer
15 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
16 Name:           fluidsynth
17 Version:        1.1.8
18 Release:        1
19 %if %{with ladcca} || %{with lash} || %{with readline}
20 License:        GPL v2+ (enforced by ladcca/lash/readline), LGPL v2+ (fluidsynth itself)
21 %else
22 License:        LGPL v2+
23 %endif
24 Group:          Applications/Sound
25 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
26 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
27 # Source0-md5:  623bb3b8d3a3ef3c4dc0d4cdbfc311a5
28 Patch0:         %{name}-midishare.patch
29 Patch1:         %{name}-soname.patch
30 URL:            http://www.fluidsynth.org/
31 BuildRequires:  alsa-lib-devel >= 0.9.1
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 BuildRequires:  dbus-devel >= 1.0.0
35 BuildRequires:  gettext-tools
36 BuildRequires:  glib2-devel >= 1:2.6.5
37 BuildRequires:  jack-audio-connection-kit-devel
38 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
39 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
40 BuildRequires:  ladspa-devel
41 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
42 BuildRequires:  libsndfile-devel >= 1.0.18
43 BuildRequires:  libtool
44 %{?with_midishare:BuildRequires:        midishare-devel}
45 BuildRequires:  pkgconfig
46 BuildRequires:  portaudio-devel >= 19
47 BuildRequires:  pulseaudio-devel >= 0.9.8
48 %{?with_readline:BuildRequires: readline-devel}
49 BuildRequires:  rpmbuild(macros) >= 1.213
50 Requires:       alsa-lib >= 0.9.1
51 Requires:       glib2 >= 1:2.6.5
52 Requires:       libsndfile >= 1.0.18
53 Suggests:       soundfont-fluid
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Fluid Synth is a software, real-time synthesizer based on the
58 Soundfont 2 specifications.
59
60 %description -l pl.UTF-8
61 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
62 oparty na specyfikacji Soundfont 2.
63
64 %package devel
65 Summary:        Development files for the FluidSynth
66 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       alsa-lib-devel >= 0.9.1
70 Requires:       dbus-devel >= 1.0.0
71 Requires:       glib2-devel >= 1:2.6.5
72 Requires:       jack-audio-connection-kit-devel
73 %{?with_lash:Requires:  lash-devel >= 0.3}
74 Requires:       libsndfile-devel >= 1.0.18
75 %{?with_midishare:Requires:     midishare-devel}
76 Requires:       portaudio-devel >= 19
77 Requires:       pulseaudio-devel >= 0.9.8
78 %{?with_readline:Requires:      readline-devel}
79
80 %description devel
81 This package contains the header files necessary to develop
82 applications using FluidSynth.
83
84 %description devel -l pl.UTF-8
85 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
86 kompilacji aplikacji korzystających z bibliotek FluidSynth.
87
88 %package static
89 Summary:        Static FluidSynth library
90 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 This package contains static version of the FluidSynth library.
96
97 %description static -l pl.UTF-8
98 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111
112 %configure \
113         %{!?with_ladcca:--disable-ladcca} \
114         %{!?with_lash:--disable-lash} \
115         %{!?with_midishare:--disable-midishare} \
116         %{!?with_static_libs:--disable-static} \
117         %{?with_sse:--enable-SSE} \
118         --enable-jack-support \
119         --enable-ladspa \
120         --enable-profiling \
121         %{!?with_readline:--without-readline}
122
123 # define missing in autotools suite
124 echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfluidsynth.la
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS NEWS README.md THANKS TODO
145 %attr(755,root,root) %{_bindir}/fluidsynth
146 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
148 %{_mandir}/man1/fluidsynth.1*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libfluidsynth.so
153 %{_includedir}/fluidsynth.h
154 %{_includedir}/%{name}
155 %{_pkgconfigdir}/fluidsynth.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libfluidsynth.a
161 %endif
This page took 0.234547 seconds and 3 git commands to generate.