]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- genreic athlon doesn't have SSE.
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca  # enable ladcca sesion managment support
4 %bcond_with     sse     # use the SSE instructions of Pentium3+ or Athlon XP
5 #
6 %ifarch pentium3 pentium4 amd64
7 %define         with_sse        1
8 %endif
9 #
10 Summary:        FluidSynth is a software, real-time synthesizer
11 Summary(pl):    FluidSynth to programowy syntezator dzia³aj±cy w czasie rzeczywistym
12 Name:           fluidsynth
13 Version:        1.0.3
14 Release:        3
15 License:        LGPL
16 Group:          Applications/Sound
17 Source0:        http://savannah.nongnu.org/download/fluid/stable.pkg/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  fbdccd05e538626888e27b58d3bdbc2b
19 URL:            http://www.fluidsynth.org/
20 BuildRequires:  alsa-lib-devel >= 0.9.0
21 BuildRequires:  jack-audio-connection-kit-devel
22 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
23 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
24 BuildRequires:  ladspa-devel
25 Requires:       alsa-lib
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Fluid Synth is a software, real-time synthesizer based on the
30 Soundfont 2 specifications.
31
32 %description -l pl
33 Fluid Synth to programowy, dzia³aj±cy w czasie rzeczywistym syntezator
34 oparty na specyfikacji Soundfont 2.
35
36 %package devel
37 Summary:        Development files for the FluidSynth
38 Summary(pl):    Pliki nag³ówkowe dla FluidSynth
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 This package contains the header files necessary to develop
44 applications using FluidSynth.
45
46 %description devel -l pl
47 Pakiet ten zawiera pliki nag³ówkowe potrzebne do tworzenia i
48 kompilacji aplikacji korzystaj±cych z bibliotek FluidSynth.
49
50 %package static
51 Summary:        Static FluidSynth library
52 Summary(pl):    Statyczna wersje biblioteki FluidSynth
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 This package contains static version of the FluidSynth library.
58
59 %description static -l pl
60 Ten pakiet zawiera bibliotekê statyczn± FluidSynth.
61
62 %prep
63 %setup -q
64
65 %build
66
67 cp /usr/share/automake/config.sub .
68
69 %configure \
70         %{!?with_ladcca:--disable-ladcca} \
71         %{?with_sse:--enable-SSE} \
72         --enable-coreaudio \
73         --enable-jack-support \
74         --enable-ladspa \
75         --enable-midishare \
76         --enable-profiling
77         
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc ChangeLog README
96 %{_mandir}/man1/*
97 %attr(755,root,root) %{_bindir}/*
98 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/lib%{name}.so
103 %attr(755,root,root) %{_libdir}/lib%{name}.la
104 %{_includedir}/%{name}.h
105 %{_includedir}/%{name}
106 %{_libdir}/pkgconfig/fluidsynth.pc
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/lib%{name}.a
This page took 0.028336 seconds and 3 git commands to generate.