]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- updated to 2.1.6
[packages/fluidsynth.git] / fluidsynth.spec
1 # TODO: OBOE support, BR: pkgconfig(oboe-1.0)
2 #
3 # Conditional build:
4 %bcond_without  lash            # LASH support (GPL)
5 %bcond_with     midishare       # MidiShare support
6 %bcond_without  portaudio       # portaudio support
7 %bcond_without  readline        # readline line editing (GPL)
8 %bcond_without  systemd         # systemd notify support
9 #
10 Summary:        FluidSynth - a software, real-time synthesizer
11 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
12 Name:           fluidsynth
13 Version:        2.1.6
14 Release:        1
15 %if %{with lash} || %{with readline}
16 License:        GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
17 %else
18 License:        LGPL v2+
19 %endif
20 Group:          Applications/Sound
21 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
22 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  4e5111b59ba4b91c549f9eb088da0a52
24 URL:            http://www.fluidsynth.org/
25 BuildRequires:  SDL2-devel >= 2
26 BuildRequires:  alsa-lib-devel >= 0.9.1
27 BuildRequires:  cmake >= 3.1.0
28 BuildRequires:  dbus-devel >= 1.0.0
29 BuildRequires:  gettext-tools
30 BuildRequires:  glib2-devel >= 1:2.6.5
31 BuildRequires:  jack-audio-connection-kit-devel
32 BuildRequires:  ladspa-devel
33 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
34 # OpenMP 4.0
35 BuildRequires:  libgomp-devel >= 6:4.9
36 BuildRequires:  libinstpatch >= 1.1.0
37 BuildRequires:  libsndfile-devel >= 1.0.18
38 %{?with_midishare:BuildRequires:        midishare-devel}
39 BuildRequires:  pkgconfig
40 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
41 BuildRequires:  pulseaudio-devel >= 0.9.8
42 %{?with_readline:BuildRequires: readline-devel}
43 BuildRequires:  rpmbuild(macros) >= 1.213
44 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
45 Requires:       alsa-lib >= 0.9.1
46 Requires:       glib2 >= 1:2.6.5
47 Requires:       libsndfile >= 1.0.18
48 Suggests:       soundfont-fluid
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Fluid Synth is a software, real-time synthesizer based on the
53 Soundfont 2 specifications.
54
55 %description -l pl.UTF-8
56 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
57 oparty na specyfikacji Soundfont 2.
58
59 %package devel
60 Summary:        Development files for the FluidSynth
61 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       alsa-lib-devel >= 0.9.1
65 Requires:       dbus-devel >= 1.0.0
66 Requires:       glib2-devel >= 1:2.6.5
67 Requires:       jack-audio-connection-kit-devel
68 %{?with_lash:Requires:  lash-devel >= 0.3}
69 Requires:       libsndfile-devel >= 1.0.18
70 %{?with_midishare:Requires: midishare-devel}
71 %{?with_portaudio:Requires:     portaudio-devel >= 19}
72 Requires:       pulseaudio-devel >= 0.9.8
73 %{?with_readline:Requires: readline-devel}
74 Obsoletes:      fluidsynth-devel < 2
75
76 %description devel
77 This package contains the header files necessary to develop
78 applications using FluidSynth.
79
80 %description devel -l pl.UTF-8
81 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
82 kompilacji aplikacji korzystających z bibliotek FluidSynth.
83
84 %prep
85 %setup -q
86
87 %build
88 mkdir -p build
89 cd build
90 %cmake .. \
91         -Denable-midishare=%{with midishare} \
92         -Denable-lash=%{with lash} \
93         -Denable-portaudio=%{with portaudio} \
94         -Denable-readline=%{with readline} \
95         %{!?with_systemd:-Denable-systemd=OFF}
96
97 # define missing in autotools suite
98 echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 cd build
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS README.md THANKS TODO
118 %attr(755,root,root) %{_bindir}/fluidsynth
119 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.2
121 %{_mandir}/man1/fluidsynth.1*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libfluidsynth.so
126 %{_includedir}/fluidsynth.h
127 %{_includedir}/fluidsynth
128 %{_pkgconfigdir}/fluidsynth.pc
This page took 0.055375 seconds and 3 git commands to generate.