]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- updated to 2.1.1
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_without  lash            # LASH support (GPL)
4 %bcond_with     midishare       # MidiShare support
5 %bcond_without  portaudio       # portaudio support
6 %bcond_without  readline        # readline line editing (GPL)
7 %bcond_without  systemd         # systemd notify support
8 #
9 Summary:        FluidSynth - a software, real-time synthesizer
10 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
11 Name:           fluidsynth
12 Version:        2.1.1
13 Release:        1
14 %if %{with lash} || %{with readline}
15 License:        GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
16 %else
17 License:        LGPL v2+
18 %endif
19 Group:          Applications/Sound
20 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
21 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
22 # Source0-md5:  165902909092c818a24517de6a4f2f83
23 URL:            http://www.fluidsynth.org/
24 BuildRequires:  alsa-lib-devel >= 0.9.1
25 BuildRequires:  cmake >= 3.1.0
26 BuildRequires:  dbus-devel >= 1.0.0
27 BuildRequires:  gettext-tools
28 BuildRequires:  glib2-devel >= 1:2.6.5
29 BuildRequires:  jack-audio-connection-kit-devel
30 BuildRequires:  ladspa-devel
31 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
32 # OpenMP 4.0
33 BuildRequires:  libgomp-devel >= 6:4.9
34 BuildRequires:  libinstpatch >= 1.1.0
35 BuildRequires:  libsndfile-devel >= 1.0.18
36 %{?with_midishare:BuildRequires:        midishare-devel}
37 BuildRequires:  pkgconfig
38 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
39 BuildRequires:  pulseaudio-devel >= 0.9.8
40 %{?with_readline:BuildRequires: readline-devel}
41 BuildRequires:  rpmbuild(macros) >= 1.213
42 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
43 Requires:       alsa-lib >= 0.9.1
44 Requires:       glib2 >= 1:2.6.5
45 Requires:       libsndfile >= 1.0.18
46 Suggests:       soundfont-fluid
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Fluid Synth is a software, real-time synthesizer based on the
51 Soundfont 2 specifications.
52
53 %description -l pl.UTF-8
54 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
55 oparty na specyfikacji Soundfont 2.
56
57 %package devel
58 Summary:        Development files for the FluidSynth
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       alsa-lib-devel >= 0.9.1
63 Requires:       dbus-devel >= 1.0.0
64 Requires:       glib2-devel >= 1:2.6.5
65 Requires:       jack-audio-connection-kit-devel
66 %{?with_lash:Requires:  lash-devel >= 0.3}
67 Requires:       libsndfile-devel >= 1.0.18
68 %{?with_midishare:Requires: midishare-devel}
69 Requires:       portaudio-devel >= 19
70 Requires:       pulseaudio-devel >= 0.9.8
71 %{?with_readline:Requires: readline-devel}
72 Obsoletes:      fluidsynth-devel < 2
73
74 %description devel
75 This package contains the header files necessary to develop
76 applications using FluidSynth.
77
78 %description devel -l pl.UTF-8
79 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
80 kompilacji aplikacji korzystających z bibliotek FluidSynth.
81
82 %prep
83 %setup -q
84
85 %build
86 mkdir -p build
87 cd build
88 %cmake .. \
89         -Denable-midishare=%{with midishare} \
90         -Denable-lash=%{with lash} \
91         -Denable-portaudio=%{with portaudio} \
92         -Denable-readline=%{with readline} \
93         %{!?with_systemd:-Denable-systemd=OFF}
94
95 # define missing in autotools suite
96 echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 cd build
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS README.md THANKS TODO
116 %attr(755,root,root) %{_bindir}/fluidsynth
117 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.2
119 %{_mandir}/man1/fluidsynth.1*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libfluidsynth.so
124 %{_includedir}/fluidsynth.h
125 %{_includedir}/fluidsynth
126 %{_pkgconfigdir}/fluidsynth.pc
This page took 0.063901 seconds and 3 git commands to generate.