]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- Up to 1.1.1
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # enable ladcca sesion managment support
4 %bcond_with     readline        # build with readline lib line editing
5 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifarch pentium3 pentium4 %{x8664}
9 %define         with_sse        1
10 %endif
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.1.1
16 Release:        1
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
20 # Source0-md5:  0db3da78028d255026230809c6e21b44
21 URL:            http://www.fluidsynth.org/
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  jack-audio-connection-kit-devel
26 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
27 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
28 BuildRequires:  ladspa-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 %{?with_readline:BuildRequires: readline-devel}
32 BuildRequires:  rpmbuild(macros) >= 1.213
33 Requires:       alsa-lib
34 Suggests:       soundfont-fluid
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Fluid Synth is a software, real-time synthesizer based on the
39 Soundfont 2 specifications.
40
41 %description -l pl.UTF-8
42 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
43 oparty na specyfikacji Soundfont 2.
44
45 %package devel
46 Summary:        Development files for the FluidSynth
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %{?with_readline:Requires:      readline-devel}
51
52 %description devel
53 This package contains the header files necessary to develop
54 applications using FluidSynth.
55
56 %description devel -l pl.UTF-8
57 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
58 kompilacji aplikacji korzystających z bibliotek FluidSynth.
59
60 %package static
61 Summary:        Static FluidSynth library
62 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 This package contains static version of the FluidSynth library.
68
69 %description static -l pl.UTF-8
70 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
71
72 %prep
73 %setup -q
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__autoheader}
80 %{__automake}
81
82 %configure \
83         %{!?with_ladcca:--disable-ladcca} \
84         %{!?with_static_libs:--disable-static} \
85         %{?with_sse:--enable-SSE} \
86         --enable-coreaudio \
87         --enable-jack-support \
88         --enable-ladspa \
89         --enable-profiling \
90         %{!?with_readline:--without-readline}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ChangeLog README
110 %attr(755,root,root) %{_bindir}/fluidsynth
111 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
113 %{_mandir}/man1/fluidsynth.1*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libfluidsynth.so
118 %{_libdir}/libfluidsynth.la
119 %{_includedir}/fluidsynth.h
120 %{_includedir}/%{name}
121 %{_pkgconfigdir}/fluidsynth.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libfluidsynth.a
127 %endif
This page took 0.11144 seconds and 3 git commands to generate.