]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
290273de1491a9d1451361e2f813ffe65e8febf9
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_without  lash            # LASH support (GPL)
4 %bcond_with     midishare       # MidiShare support
5 %bcond_without  portaudio       # portaudio support
6 %bcond_without  readline        # readline line editing (GPL)
7 #
8 Summary:        FluidSynth - a software, real-time synthesizer
9 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
10 Name:           fluidsynth
11 Version:        2.0.6
12 Release:        1
13 %if %{with lash} || %{with readline}
14 License:        GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
15 %else
16 License:        LGPL v2+
17 %endif
18 Group:          Applications/Sound
19 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
20 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
21 # Source0-md5:  7ffb3df1e9b6e71cb2cb15b4608cc8c9
22 URL:            http://www.fluidsynth.org/
23 BuildRequires:  alsa-lib-devel >= 0.9.1
24 BuildRequires:  cmake >= 3.1.0
25 BuildRequires:  dbus-devel >= 1.0.0
26 BuildRequires:  gettext-tools
27 BuildRequires:  glib2-devel >= 1:2.6.5
28 BuildRequires:  jack-audio-connection-kit-devel
29 BuildRequires:  ladspa-devel
30 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
31 # OpenMP 4.0
32 BuildRequires:  libgomp-devel >= 6:4.9
33 BuildRequires:  libsndfile-devel >= 1.0.18
34 %{?with_midishare:BuildRequires:        midishare-devel}
35 BuildRequires:  pkgconfig
36 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
37 BuildRequires:  pulseaudio-devel >= 0.9.8
38 %{?with_readline:BuildRequires: readline-devel}
39 BuildRequires:  rpmbuild(macros) >= 1.213
40 Requires:       alsa-lib >= 0.9.1
41 Requires:       glib2 >= 1:2.6.5
42 Requires:       libsndfile >= 1.0.18
43 Suggests:       soundfont-fluid
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Fluid Synth is a software, real-time synthesizer based on the
48 Soundfont 2 specifications.
49
50 %description -l pl.UTF-8
51 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
52 oparty na specyfikacji Soundfont 2.
53
54 %package devel
55 Summary:        Development files for the FluidSynth
56 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       alsa-lib-devel >= 0.9.1
60 Requires:       dbus-devel >= 1.0.0
61 Requires:       glib2-devel >= 1:2.6.5
62 Requires:       jack-audio-connection-kit-devel
63 %{?with_lash:Requires:  lash-devel >= 0.3}
64 Requires:       libsndfile-devel >= 1.0.18
65 %{?with_midishare:Requires: midishare-devel}
66 Requires:       portaudio-devel >= 19
67 Requires:       pulseaudio-devel >= 0.9.8
68 %{?with_readline:Requires: readline-devel}
69 Obsoletes:      fluidsynth-devel < 2
70
71 %description devel
72 This package contains the header files necessary to develop
73 applications using FluidSynth.
74
75 %description devel -l pl.UTF-8
76 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
77 kompilacji aplikacji korzystających z bibliotek FluidSynth.
78
79 %prep
80 %setup -q
81
82 %build
83 mkdir -p build
84 cd build
85 %cmake .. \
86         -Denable-midishare=%{with midishare} \
87         -Denable-lash=%{with lash} \
88         -Denable-portaudio=%{with portaudio} \
89         -Denable-readline=%{with readline}
90
91 # define missing in autotools suite
92 echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 cd build
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS NEWS README.md THANKS TODO
112 %attr(755,root,root) %{_bindir}/fluidsynth
113 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.2
115 %{_mandir}/man1/fluidsynth.1*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libfluidsynth.so
120 %{_includedir}/fluidsynth.h
121 %{_includedir}/fluidsynth
122 %{_pkgconfigdir}/fluidsynth.pc
This page took 0.115624 seconds and 2 git commands to generate.