]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- cosmetics
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca  # enable ladcca sesion managment support
4 %bcond_with     sse     # use the SSE instructions of Pentium3+ or Athlon XP
5 #
6 %ifarch pentium3 pentium4 %{x8664}
7 %define         with_sse        1
8 %endif
9 #
10 %define         rversion 1.0.7
11 #
12 Summary:        FluidSynth - a software, real-time synthesizer
13 Summary(pl):    FluidSynth - programowy syntezator dzia³aj±cy w czasie rzeczywistym
14 Name:           fluidsynth
15 Version:        1.0.7a
16 Release:        1
17 License:        LGPL
18 Group:          Applications/Sound
19 Source0:        http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
20 # Source0-md5:  0f73d47990d859f19b8e9840bdab5c60
21 URL:            http://www.fluidsynth.org/
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  automake
24 BuildRequires:  jack-audio-connection-kit-devel
25 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
26 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
27 BuildRequires:  ladspa-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.213
30 Requires:       alsa-lib
31 # supports also Mac OS X Darwin, so probably it is easy to extend
32 ExclusiveArch:  %{ix86} %{x8664}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Fluid Synth is a software, real-time synthesizer based on the
37 Soundfont 2 specifications.
38
39 %description -l pl
40 Fluid Synth to programowy, dzia³aj±cy w czasie rzeczywistym syntezator
41 oparty na specyfikacji Soundfont 2.
42
43 %package devel
44 Summary:        Development files for the FluidSynth
45 Summary(pl):    Pliki nag³ówkowe dla FluidSynth
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 This package contains the header files necessary to develop
51 applications using FluidSynth.
52
53 %description devel -l pl
54 Pakiet ten zawiera pliki nag³ówkowe potrzebne do tworzenia i
55 kompilacji aplikacji korzystaj±cych z bibliotek FluidSynth.
56
57 %package static
58 Summary:        Static FluidSynth library
59 Summary(pl):    Statyczna wersje biblioteki FluidSynth
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 This package contains static version of the FluidSynth library.
65
66 %description static -l pl
67 Ten pakiet zawiera bibliotekê statyczn± FluidSynth.
68
69 %prep
70 %setup -qn %{name}-%{rversion}
71
72 %build
73
74 cp /usr/share/automake/config.sub .
75
76 %configure \
77         %{!?with_ladcca:--disable-ladcca} \
78         %{?with_sse:--enable-SSE} \
79         --enable-coreaudio \
80         --enable-jack-support \
81         --enable-ladspa \
82         --enable-midishare \
83         --enable-profiling
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog README
103 %{_mandir}/man1/*
104 %attr(755,root,root) %{_bindir}/*
105 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/lib%{name}.so
110 %{_libdir}/lib%{name}.la
111 %{_includedir}/%{name}.h
112 %{_includedir}/%{name}
113 %{_pkgconfigdir}/fluidsynth.pc
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/lib%{name}.a
This page took 0.06673 seconds and 3 git commands to generate.