]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
ef8d2df72d306ca7407f39d0505153c0e624547e
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 %bcond_without  gl      # without OpenGL libraries
4 %bcond_without  xft     # without Xft support
5 #
6 Summary:        Fast Light Tool Kit
7 Summary(pl):    FLTK - "lekki" X11 toolkit
8 Summary(pt_BR): Interface gráfica em C++ para X, OpenGL e Windows
9 Name:           fltk
10 Version:        1.1.6
11 Release:        2
12 License:        LGPL with amendments (see COPYING)
13 Group:          X11/Libraries
14 Source0:        http://dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}-source.tar.bz2
15 # Source0-md5:  95d340977d13edea12e98d787a668b32
16 Source1:        http://www.fltk.org/doc-1.1/%{name}.ps.gz
17 # Source1-md5:  2a77aaee928670ce224c676d3c2b66f8
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-cxx.patch
20 URL:            http://www.fltk.org/
21 %{?with_gl:BuildRequires:       OpenGL-devel}
22 BuildRequires:  XFree86-devel >= 3.3.6
23 BuildRequires:  autoconf
24 BuildRequires:  libstdc++-devel
25 %{?with_xft:BuildRequires:      xft-devel}
26 Obsoletes:      libfltk1.1
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
33 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
34 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
35 by Mr. Bill Spitzak and is currently maintained by a small group of
36 developers across the world with a central repository in the US.
37
38 %description -l pl
39 Fast Light Tool Kit ("FLTK", wymawiane "faltik"), jest rozprowadzanym
40 na licencji LGPL narzêdziem do tworzenia graficznych interfejsów
41 u¿ytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
42 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
43 Spitzak; obecnie pakiet jest rozwijany przez niewielk± grupê
44 deweloperów z ró¿nych stron ¶wiata (centralne repozytorium znajduje
45 siê w USA).
46
47 %description -l pt_BR
48 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
49 ferramenta e interface gráfica feita em C++ para desenvolver
50 aplicativos para o X, OpenGL e Windows.
51
52 %package devel
53 Summary:        FLTK development files
54 Summary(pl):    Narzêdzia programistyczne dla FLTK
55 Summary(pt_BR): Arquivos de inclusão para o FLTK
56 Group:          X11/Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libstdc++-devel
59 Obsoletes:      libfltk1.1-devel
60
61 %description devel
62 FLTK development files.
63
64 %description devel -l pl
65 Narzêdzia programistyczne dla FLTK.
66
67 %description devel -l pt_BR
68 Arquivos de inclusão para o FLTK.
69
70 %package static
71 Summary:        FLTK static library
72 Summary(pl):    Biblioteka FLTK konsolidowana statycznie
73 Summary(pt_BR): Bibliotecas estáticas para o FLTK
74 Group:          X11/Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 FLTK static library.
79
80 %description static -l pl
81 Biblioteka FLTK konsolidowana statycznie.
82
83 %description static -l pt_BR
84 Bibliotecas estáticas para o FLTK.
85
86 %package gl
87 Summary:        FLTK GL library
88 Summary(pl):    Biblioteka FLTK GL
89 Group:          X11/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       OpenGL
92
93 %description gl
94 FLTK GL library.
95
96 %description gl -l pl
97 Biblioteka FLTK GL.
98
99 %package gl-devel
100 Summary:        Header files for FLTK GL library
101 Summary(pl):    Pliki nag³ówkowe biblioteki FLTK GL
102 Group:          X11/Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104 Requires:       %{name}-gl = %{version}-%{release}
105
106 %description gl-devel
107 Header files for FLTK GL library.
108
109 %description gl-devel -l pl
110 Pliki nag³ówkowe biblioteki FLTK GL.
111
112 %package gl-static
113 Summary:        FLTK GL static library
114 Summary(pl):    Statyczna biblioteka FLTK GL
115 Group:          X11/Development/Libraries
116 Requires:       %{name}-gl-devel = %{version}-%{release}
117 Requires:       %{name}-static = %{version}-%{release}
118
119 %description gl-static
120 FLTK GL static library.
121
122 %description gl-static -l pl
123 Statyczna biblioteka FLTK GL.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129
130 install %{SOURCE1} .
131
132 %build
133 CPPFLAGS="-I/usr/X11R6/include"
134 CXXFLAGS="%{rpmcflags} -I/usr/include/freetype2"
135 # no "-s" in LDFLAGS, they are propagated to fltk-config
136 # (together with -L/usr/X11R6/lib, so cannot be removed)
137 LDFLAGS=" "
138 %{__autoconf}
139 %configure \
140         --enable-shared \
141         --with-x \
142         %{!?with_gl:--disable-gl} \
143         %{?with_xft:--enable-xft}
144
145 %{__make} depend
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/FL,%{_libdir},%{_mandir}/man{1,3}}
151
152 if [ "%{_lib}" != "lib" ] ; then
153         ln -sf $RPM_BUILD_ROOT%{_libdir} $RPM_BUILD_ROOT%{_prefix}/lib
154 fi
155
156 %{__make} install \
157         libdir=$RPM_BUILD_ROOT%{_libdir} \
158         includedir=$RPM_BUILD_ROOT%{_includedir} \
159         bindir=$RPM_BUILD_ROOT%{_bindir}
160
161 if [ "%{_lib}" != "lib" ] ; then
162         rm $RPM_BUILD_ROOT%{_prefix}/lib
163 fi
164
165 install documentation/fltk-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk-config.1
166 install documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
167 install documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post   -p /sbin/ldconfig
173 %postun -p /sbin/ldconfig
174
175 %files
176 %defattr(644,root,root,755)
177 # note: COPYING contains amendments to LGPL, so don't remove!
178 %doc CHANGES COPYING CREDITS README
179 %attr(755,root,root) %{_libdir}/libfltk.so.*.*
180 %attr(755,root,root) %{_libdir}/libfltk_forms.so.*.*
181 %attr(755,root,root) %{_libdir}/libfltk_images.so.*.*
182
183 %files devel
184 %defattr(644,root,root,755)
185 %doc documentation/*.{html,gif,jpg} fltk.ps.gz
186 %attr(755,root,root) %{_bindir}/fltk-config
187 %attr(755,root,root) %{_bindir}/fluid
188 %attr(755,root,root) %{_libdir}/libfltk.so
189 %attr(755,root,root) %{_libdir}/libfltk_forms.so
190 %attr(755,root,root) %{_libdir}/libfltk_images.so
191 %{_includedir}/FL
192 %exclude %{_includedir}/FL/Fl_Gl_Window.*
193 %exclude %{_includedir}/FL/gl*
194 %{_mandir}/man[13]/*
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libfltk.a
199 %{_libdir}/libfltk_forms.a
200 %{_libdir}/libfltk_images.a
201
202 %if %{with gl}
203 %files gl
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libfltk_gl.so.*.*
206
207 %files gl-devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libfltk_gl.so
210 %{_includedir}/FL/Fl_Gl_Window.*
211 %{_includedir}/FL/gl*
212
213 %files gl-static
214 %defattr(644,root,root,755)
215 %{_libdir}/libfltk_gl.a
216 %endif
This page took 0.049385 seconds and 2 git commands to generate.