]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
- link libraries with what they need
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 # _without_gl   - without OpenGL support
4 #
5 Summary:        Fast Light Tool Kit
6 Summary(pl):    FLTK - "lekki" X11 toolkit
7 Summary(pt_BR): Interface gráfica em C++ para X, OpenGL e Windows
8 Name:           fltk
9 Version:        1.0.11
10 Release:        8
11 License:        LGPL with amendments (see COPYING)
12 Group:          X11/Libraries
13 Source0:        ftp://ftp.easysw.com/pub/%{name}/%{version}/%{name}-%{version}-source.tar.bz2
14 Source1:        http://www.fltk.org/doc/%{name}.ps.gz
15 Patch0:         %{name}-fluid-shared.patch
16 URL:            http://www.fltk.org/
17 %{!?_without_gl:BuildRequires: OpenGL-devel}
18 BuildRequires:  XFree86-devel >= 3.3.6
19 BuildRequires:  gcc-c++
20 %{!?_without_gl:Requires: OpenGL}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 Obsoletes:      libfltk1.1
23
24
25 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
26
27 %description
28 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
29 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
30 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
31 by Mr. Bill Spitzak and is currently maintained by a small group of
32 developers across the world with a central repository in the US.
33
34 %description -l pl
35 Fast Light Tool Kit ("FLTK", wymawiane "faltik"), jest rozprowadzanym
36 na licencji LGPL narzêdziem do tworzenia graficznych interfejsów
37 u¿ytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
38 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
39 Spitzak; obecnie pakiet jest rozwijany przez niewielk± grupê
40 deweloperów z ró¿nych stron ¶wiata (centralne repozytorium znajduje
41 siê w USA).
42
43 %description -l pt_BR
44 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
45 ferramenta e interface gráfica feita em C++ para desenvolver
46 aplicativos para o X, OpenGL e Windows.
47
48 %package devel
49 Summary:        FLTK development files
50 Summary(pl):    Narzêdzia programistyczne dla FLTK
51 Summary(pt_BR): Arquivos de inclusão para o FLTK
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}
54 Obsoletes:      libfltk1.1-devel
55
56 %description devel
57 FLTK development files.
58
59 %description devel -l pl
60 Narzêdzia programistyczne dla FLTK.
61
62 %description devel -l pt_BR
63 Arquivos de inclusão para o FLTK.
64
65 %package static
66 Summary:        FLTK static library
67 Summary(pl):    Biblioteka FLTK linkowana statycznie
68 Summary(pt_BR): Bibliotecas estáticas para o FLTK
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-devel = %{version}
71
72 %description static
73 FLTK static library.
74
75 %description static -l pl
76 Biblioteka FLTK linkowana statycznie.
77
78 %description static -l pt_BR
79 Bibliotecas estáticas para o FLTK.
80
81 %prep
82 %setup -q
83 %patch -p1
84
85 install %{SOURCE1} .
86
87 %build
88 CPPFLAGS="-I/usr/X11R6/include"; export CPPFLAGS
89 %configure2_13 \
90         --libdir=$RPM_BUILD_ROOT%{_libdir} \
91         --includedir=$RPM_BUILD_ROOT%{_includedir} \
92         --bindir=$RPM_BUILD_ROOT%{_bindir} \
93         --enable-shared \
94         --with-x \
95         %{?_without_gl:--disable-gl}
96
97 %{__make} depend
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/FL,%{_libdir},%{_mandir}/man1}
103
104 cd fluid
105 %{__make} install
106 cd ../src
107 %{__make} install
108 cd ..
109
110 rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
111 mv -f $RPM_BUILD_ROOT%{_libdir}/libfltk.so.1 \
112         $RPM_BUILD_ROOT%{_libdir}/libfltk.so.%{version}
113 ln -sf libfltk.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libfltk.so
114 mv -f documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk.1
115 mv -f documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 # note: COPYING contains amendments to LGPL, so don't remove!
126 %doc CHANGES COPYING README
127 %attr(755,root,root) %{_libdir}/*.so.*.*.*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %doc documentation/* fltk.ps.gz
132 %attr(755,root,root) %{_libdir}/libfltk.so
133 %attr(755,root,root) %{_bindir}/fluid
134 %{_includedir}/FL
135 %{_mandir}/man1/*
136
137 %files static
138 %defattr(644,root,root,755)
139 %attr(644,root,root) %{_libdir}/*.a
This page took 0.084503 seconds and 3 git commands to generate.