]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
- disabled KDE-specific x-fluid.desktop to avoid KDE dependency
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl  # without OpenGL libraries
4 %bcond_without  xft     # without Xft support
5 #
6 Summary:        Fast Light Tool Kit
7 Summary(pl.UTF-8):      FLTK - "lekki" X11 toolkit
8 Summary(pt_BR.UTF-8):   Interface gráfica em C++ para X, OpenGL e Windows
9 Name:           fltk
10 Version:        1.1.8
11 Release:        2
12 License:        LGPL with amendments (see COPYING)
13 Group:          X11/Libraries
14 Source0:        http://ftp.easysw.com/pub/fltk/%{version}/%{name}-%{version}-source.tar.bz2
15 # Source0-md5:  0f272d7299778e42fcbedf3c01741f4f
16 Source1:        http://www.fltk.org/doc-1.1/%{name}.pdf
17 # Source1-md5:  d3a073741c94d532ec7af9d96c138ea3
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-desktop.patch
20 URL:            http://www.fltk.org/
21 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
22 BuildRequires:  autoconf
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  rpmbuild(macros) >= 1.315
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRequires:  xorg-lib-libXext-devel
27 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
28 BuildRequires:  xorg-util-makedepend
29 Obsoletes:      libfltk1.1
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
33
34 # don't propagate strip-flags to fltk-config.
35 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
36
37 %description
38 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
39 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
40 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
41 by Mr. Bill Spitzak and is currently maintained by a small group of
42 developers across the world with a central repository in the US.
43
44 %description -l pl.UTF-8
45 Fast Light Tool Kit ("FLTK", wymawiane "fultik"), jest rozprowadzanym
46 na licencji LGPL narzędziem do tworzenia graficznych interfejsów
47 użytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
48 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
49 Spitzak; obecnie pakiet jest rozwijany przez niewielką grupę
50 deweloperów z różnych stron świata (centralne repozytorium znajduje
51 się w USA).
52
53 %description -l pt_BR.UTF-8
54 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
55 ferramenta e interface gráfica feita em C++ para desenvolver
56 aplicativos para o X, OpenGL e Windows.
57
58 %package devel
59 Summary:        FLTK development files
60 Summary(pl.UTF-8):      Narzędzia programistyczne dla FLTK
61 Summary(pt_BR.UTF-8):   Arquivos de inclusão para o FLTK
62 Group:          X11/Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       libstdc++-devel
65 Obsoletes:      libfltk1.1-devel
66
67 %description devel
68 FLTK development files.
69
70 %description devel -l pl.UTF-8
71 Narzędzia programistyczne dla FLTK.
72
73 %description devel -l pt_BR.UTF-8
74 Arquivos de inclusão para o FLTK.
75
76 %package static
77 Summary:        FLTK static library
78 Summary(pl.UTF-8):      Biblioteka FLTK konsolidowana statycznie
79 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o FLTK
80 Group:          X11/Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 FLTK static library.
85
86 %description static -l pl.UTF-8
87 Biblioteka FLTK konsolidowana statycznie.
88
89 %description static -l pt_BR.UTF-8
90 Bibliotecas estáticas para o FLTK.
91
92 %package gl
93 Summary:        FLTK GL library
94 Summary(pl.UTF-8):      Biblioteka FLTK GL
95 Group:          X11/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       OpenGL
98
99 %description gl
100 FLTK GL library.
101
102 %description gl -l pl.UTF-8
103 Biblioteka FLTK GL.
104
105 %package gl-devel
106 Summary:        Header files for FLTK GL library
107 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLTK GL
108 Group:          X11/Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110 Requires:       %{name}-gl = %{version}-%{release}
111
112 %description gl-devel
113 Header files for FLTK GL library.
114
115 %description gl-devel -l pl.UTF-8
116 Pliki nagłówkowe biblioteki FLTK GL.
117
118 %package gl-static
119 Summary:        FLTK GL static library
120 Summary(pl.UTF-8):      Statyczna biblioteka FLTK GL
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-gl-devel = %{version}-%{release}
123 Requires:       %{name}-static = %{version}-%{release}
124
125 %description gl-static
126 FLTK GL static library.
127
128 %description gl-static -l pl.UTF-8
129 Statyczna biblioteka FLTK GL.
130
131 %package games
132 Summary:        FLTK Games
133 Summary:        Gry FLTK
134 Group:          X11/Applications/Games
135 Requires:       %{name} = %{version}-%{release}
136
137 %description games
138 FLTK games: Block Attack!, Checkers, or Sudoku on your computer.
139
140 %description -l pl.UTF-8
141 Gry FLTK: Atak Klocków!, Warcaby, Sudoku. 
142
143 %prep
144 %setup -q
145 %patch0 -p1
146 %patch1 -p1
147
148 install %{SOURCE1} .
149
150 %build
151 %{__autoconf}
152 %configure \
153         --enable-shared \
154         --with-x \
155         --with-optim="%{rpmcxxflags}" \
156         %{!?with_opengl:--disable-gl} \
157         %{?with_xft:--enable-xft}
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         install-desktop \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 # less generic games' names
169 for f in blocks checkers sudoku ; do
170 mv -f $RPM_BUILD_ROOT%{_bindir}/{,fltk-}${f}
171 mv -f $RPM_BUILD_ROOT%{_mandir}/man6/{,fltk-}${f}.6
172 done
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 # note: COPYING contains amendments to LGPL, so don't remove!
183 %doc CHANGES COPYING CREDITS README
184 %attr(755,root,root) %{_libdir}/libfltk.so.*.*
185 %attr(755,root,root) %{_libdir}/libfltk_forms.so.*.*
186 %attr(755,root,root) %{_libdir}/libfltk_images.so.*.*
187
188 %files devel
189 %defattr(644,root,root,755)
190 %doc documentation/*.{html,gif,jpg} fltk.pdf
191 %attr(755,root,root) %{_bindir}/fltk-config
192 %attr(755,root,root) %{_bindir}/fluid
193 %attr(755,root,root) %{_libdir}/libfltk.so
194 %attr(755,root,root) %{_libdir}/libfltk_forms.so
195 %attr(755,root,root) %{_libdir}/libfltk_images.so
196 %{_includedir}/FL
197 %exclude %{_includedir}/FL/Fl_Gl_Window.*
198 %exclude %{_includedir}/FL/gl*
199 %{_iconsdir}/*/*/*/fluid.png
200 %{_desktopdir}/fluid.desktop
201 # move to some KDE package?
202 #%{_datadir}/mimelnk/application/x-fluid.desktop
203 %{_mandir}/man1/fltk-config.1*
204 %{_mandir}/man1/fluid.1*
205 %{_mandir}/man3/fltk.3*
206
207 %files static
208 %defattr(644,root,root,755)
209 %{_libdir}/libfltk.a
210 %{_libdir}/libfltk_forms.a
211 %{_libdir}/libfltk_images.a
212
213 %if %{with opengl}
214 %files gl
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/libfltk_gl.so.*.*
217
218 %files gl-devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libfltk_gl.so
221 %{_includedir}/FL/Fl_Gl_Window.*
222 %{_includedir}/FL/gl*
223
224 %files gl-static
225 %defattr(644,root,root,755)
226 %{_libdir}/libfltk_gl.a
227 %endif
228
229 %files games
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/%{name}-blocks
232 %attr(755,root,root) %{_bindir}/%{name}-checkers
233 %attr(755,root,root) %{_bindir}/%{name}-sudoku
234 %{_iconsdir}/*/*/*/blocks.png
235 %{_iconsdir}/*/*/*/checkers.png
236 %{_iconsdir}/*/*/*/sudoku.png
237 %{_desktopdir}/blocks.desktop
238 %{_desktopdir}/checkers.desktop
239 %{_desktopdir}/sudoku.desktop
240 %{_mandir}/man6/%{name}-blocks.6*
241 %{_mandir}/man6/%{name}-checkers.6*
242 %{_mandir}/man6/%{name}-sudoku.6*
This page took 0.081022 seconds and 3 git commands to generate.