]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
- massive attack: adding Source-md5
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 # _without_gl   - without OpenGL libraries
4 # _without_xft  - without Xft support
5 #
6 Summary:        Fast Light Tool Kit
7 Summary(pl):    FLTK - "lekki" X11 toolkit
8 Summary(pt_BR): Interface gráfica em C++ para X, OpenGL e Windows
9 Name:           fltk
10 Version:        1.1.3
11 Release:        1
12 License:        LGPL with amendments (see COPYING)
13 Group:          X11/Libraries
14 Source0:        ftp://ftp.easysw.com/pub/%{name}/%{version}/%{name}-%{version}-source.tar.bz2
15 # Source0-md5: f32b4acc456d567a6bd554ac03c24055
16 Source1:        http://www.fltk.org/doc-1.1/%{name}.ps.gz
17 # Source1-md5:  eb8f5a4a02d8ca2111ff007daea601b6
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-acfix.patch
20 URL:            http://www.fltk.org/
21 %{!?_without_gl:BuildRequires: OpenGL-devel}
22 BuildRequires:  XFree86-devel >= 3.3.6
23 BuildRequires:  autoconf
24 BuildRequires:  libstdc++-devel
25 %{!?_without_xft:BuildRequires: xft-devel}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Obsoletes:      libfltk1.1
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
33 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
34 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
35 by Mr. Bill Spitzak and is currently maintained by a small group of
36 developers across the world with a central repository in the US.
37
38 %description -l pl
39 Fast Light Tool Kit ("FLTK", wymawiane "faltik"), jest rozprowadzanym
40 na licencji LGPL narzêdziem do tworzenia graficznych interfejsów
41 u¿ytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
42 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
43 Spitzak; obecnie pakiet jest rozwijany przez niewielk± grupê
44 deweloperów z ró¿nych stron ¶wiata (centralne repozytorium znajduje
45 siê w USA).
46
47 %description -l pt_BR
48 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
49 ferramenta e interface gráfica feita em C++ para desenvolver
50 aplicativos para o X, OpenGL e Windows.
51
52 %package devel
53 Summary:        FLTK development files
54 Summary(pl):    Narzêdzia programistyczne dla FLTK
55 Summary(pt_BR): Arquivos de inclusão para o FLTK
56 Group:          X11/Development/Libraries
57 Requires:       %{name} = %{version}
58 Obsoletes:      libfltk1.1-devel
59
60 %description devel
61 FLTK development files.
62
63 %description devel -l pl
64 Narzêdzia programistyczne dla FLTK.
65
66 %description devel -l pt_BR
67 Arquivos de inclusão para o FLTK.
68
69 %package static
70 Summary:        FLTK static library
71 Summary(pl):    Biblioteka FLTK linkowana statycznie
72 Summary(pt_BR): Bibliotecas estáticas para o FLTK
73 Group:          X11/Development/Libraries
74 Requires:       %{name}-devel = %{version}
75
76 %description static
77 FLTK static library.
78
79 %description static -l pl
80 Biblioteka FLTK linkowana statycznie.
81
82 %description static -l pt_BR
83 Bibliotecas estáticas para o FLTK.
84
85 %package gl
86 Summary:        FLTK GL library
87 Summary(pl):    Biblioteka FLTK GL
88 Group:          X11/Libraries
89 Requires:       %{name} = %{version}
90 Requires:       OpenGL
91
92 %description gl
93 FLTK GL library.
94
95 %description gl -l pl
96 Biblioteka FLTK GL.
97
98 %package gl-devel
99 Summary:        Header files for FLTK GL library
100 Summary(pl):    Pliki nag³ówkowe biblioteki FLTK GL
101 Group:          X11/Development/Libraries
102 Requires:       %{name}-devel = %{version}
103 Requires:       %{name}-gl = %{version}
104
105 %description gl-devel
106 Header files for FLTK GL library.
107
108 %description gl-devel -l pl
109 Pliki nag³ówkowe biblioteki FLTK GL.
110
111 %package gl-static
112 Summary:        FLTK GL static library
113 Summary(pl):    Statyczna biblioteka FLTK GL
114 Group:          X11/Development/Libraries
115 Requires:       %{name}-gl-devel = %{version}
116 Requires:       %{name}-static = %{version}
117
118 %description gl-static
119 FLTK GL static library.
120
121 %description gl-static -l pl
122 Statyczna biblioteka FLTK GL.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127 %patch1 -p1
128
129 install %{SOURCE1} .
130
131 %build
132 CPPFLAGS="-I/usr/X11R6/include"
133 CXXFLAGS="%{rpmcflags} -I/usr/include/freetype2"
134 # no "-s" in LDFLAGS, they are propagated to fltk-config
135 # (together with -L/usr/X11R6/lib, so cannot be removed)
136 LDFLAGS=" "
137 %{__autoconf}
138 %configure \
139         --enable-shared \
140         --with-x \
141         %{?_without_gl:--disable-gl} \
142         %{!?_without_xft:--enable-xft}
143
144 %{__make} depend
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/FL,%{_libdir},%{_mandir}/man{1,3}}
150
151 %{__make} install \
152         libdir=$RPM_BUILD_ROOT%{_libdir} \
153         includedir=$RPM_BUILD_ROOT%{_includedir} \
154         bindir=$RPM_BUILD_ROOT%{_bindir}
155
156 install documentation/fltk-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk-config.1
157 install documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
158 install documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 # note: COPYING contains amendments to LGPL, so don't remove!
169 %doc CHANGES COPYING CREDITS README
170 %attr(755,root,root) %{_libdir}/libfltk.so.*.*
171 %attr(755,root,root) %{_libdir}/libfltk_forms.so.*.*
172 %attr(755,root,root) %{_libdir}/libfltk_images.so.*.*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %doc documentation/*.{html,gif,jpg} fltk.ps.gz
177 %attr(755,root,root) %{_bindir}/fltk-config
178 %attr(755,root,root) %{_bindir}/fluid
179 %attr(755,root,root) %{_libdir}/libfltk.so
180 %attr(755,root,root) %{_libdir}/libfltk_forms.so
181 %attr(755,root,root) %{_libdir}/libfltk_images.so
182 %{_includedir}/FL
183 %exclude %{_includedir}/FL/Fl_Gl_Window.*
184 %exclude %{_includedir}/FL/gl*
185 %{_mandir}/man[13]/*
186
187 %files static
188 %defattr(644,root,root,755)
189 %attr(644,root,root) %{_libdir}/libfltk.a
190 %attr(644,root,root) %{_libdir}/libfltk_forms.a
191 %attr(644,root,root) %{_libdir}/libfltk_images.a
192
193 %if 0%{!?_without_gl:1}
194 %files gl
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libfltk_gl.so.*.*
197
198 %files gl-devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libfltk_gl.so
201 %{_includedir}/FL/Fl_Gl_Window.*
202 %{_includedir}/FL/gl*
203
204 %files gl-static
205 %defattr(644,root,root,755)
206 %attr(644,root,root) %{_libdir}/libfltk_gl.a
207 %endif
This page took 0.034859 seconds and 3 git commands to generate.