]> git.pld-linux.org Git - packages/fltk.git/blob - fltk.spec
- Release: 3 (STBR after AMD64 fixes)
[packages/fltk.git] / fltk.spec
1 #
2 # Conditional build:
3 # _without_gl   - without OpenGL libraries
4 # _without_xft  - without Xft support
5 #
6 Summary:        Fast Light Tool Kit
7 Summary(pl):    FLTK - "lekki" X11 toolkit
8 Summary(pt_BR): Interface gráfica em C++ para X, OpenGL e Windows
9 Name:           fltk
10 Version:        1.1.3
11 Release:        3
12 License:        LGPL with amendments (see COPYING)
13 Group:          X11/Libraries
14 Source0:        ftp://ftp.easysw.com/pub/%{name}/%{version}/%{name}-%{version}-source.tar.bz2
15 # Source0-md5:  f32b4acc456d567a6bd554ac03c24055
16 Source1:        http://www.fltk.org/doc-1.1/%{name}.ps.gz
17 # Source1-md5:  eb8f5a4a02d8ca2111ff007daea601b6
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-acfix.patch
20 Patch2:         %{name}-fluid-color.patch
21 URL:            http://www.fltk.org/
22 %{!?_without_gl:BuildRequires:  OpenGL-devel}
23 BuildRequires:  XFree86-devel >= 3.3.6
24 BuildRequires:  autoconf
25 BuildRequires:  libstdc++-devel
26 %{!?_without_xft:BuildRequires: xft-devel}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28 Obsoletes:      libfltk1.1
29
30 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
31
32 %description
33 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
34 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
35 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
36 by Mr. Bill Spitzak and is currently maintained by a small group of
37 developers across the world with a central repository in the US.
38
39 %description -l pl
40 Fast Light Tool Kit ("FLTK", wymawiane "faltik"), jest rozprowadzanym
41 na licencji LGPL narzêdziem do tworzenia graficznych interfejsów
42 u¿ytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
43 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
44 Spitzak; obecnie pakiet jest rozwijany przez niewielk± grupê
45 deweloperów z ró¿nych stron ¶wiata (centralne repozytorium znajduje
46 siê w USA).
47
48 %description -l pt_BR
49 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
50 ferramenta e interface gráfica feita em C++ para desenvolver
51 aplicativos para o X, OpenGL e Windows.
52
53 %package devel
54 Summary:        FLTK development files
55 Summary(pl):    Narzêdzia programistyczne dla FLTK
56 Summary(pt_BR): Arquivos de inclusão para o FLTK
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}
59 Requires:       libstdc++-devel
60 Obsoletes:      libfltk1.1-devel
61
62 %description devel
63 FLTK development files.
64
65 %description devel -l pl
66 Narzêdzia programistyczne dla FLTK.
67
68 %description devel -l pt_BR
69 Arquivos de inclusão para o FLTK.
70
71 %package static
72 Summary:        FLTK static library
73 Summary(pl):    Biblioteka FLTK konsolidowana statycznie
74 Summary(pt_BR): Bibliotecas estáticas para o FLTK
75 Group:          X11/Development/Libraries
76 Requires:       %{name}-devel = %{version}
77
78 %description static
79 FLTK static library.
80
81 %description static -l pl
82 Biblioteka FLTK konsolidowana statycznie.
83
84 %description static -l pt_BR
85 Bibliotecas estáticas para o FLTK.
86
87 %package gl
88 Summary:        FLTK GL library
89 Summary(pl):    Biblioteka FLTK GL
90 Group:          X11/Libraries
91 Requires:       %{name} = %{version}
92 Requires:       OpenGL
93
94 %description gl
95 FLTK GL library.
96
97 %description gl -l pl
98 Biblioteka FLTK GL.
99
100 %package gl-devel
101 Summary:        Header files for FLTK GL library
102 Summary(pl):    Pliki nag³ówkowe biblioteki FLTK GL
103 Group:          X11/Development/Libraries
104 Requires:       %{name}-devel = %{version}
105 Requires:       %{name}-gl = %{version}
106
107 %description gl-devel
108 Header files for FLTK GL library.
109
110 %description gl-devel -l pl
111 Pliki nag³ówkowe biblioteki FLTK GL.
112
113 %package gl-static
114 Summary:        FLTK GL static library
115 Summary(pl):    Statyczna biblioteka FLTK GL
116 Group:          X11/Development/Libraries
117 Requires:       %{name}-gl-devel = %{version}
118 Requires:       %{name}-static = %{version}
119
120 %description gl-static
121 FLTK GL static library.
122
123 %description gl-static -l pl
124 Statyczna biblioteka FLTK GL.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131
132 install %{SOURCE1} .
133
134 %build
135 CPPFLAGS="-I/usr/X11R6/include"
136 CXXFLAGS="%{rpmcflags} -I/usr/include/freetype2"
137 # no "-s" in LDFLAGS, they are propagated to fltk-config
138 # (together with -L/usr/X11R6/lib, so cannot be removed)
139 LDFLAGS=" "
140 %{__autoconf}
141 %configure \
142         --enable-shared \
143         --with-x \
144         %{?_without_gl:--disable-gl} \
145         %{!?_without_xft:--enable-xft}
146
147 %{__make} depend
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/FL,%{_libdir},%{_mandir}/man{1,3}}
153
154 if [ "%{_lib}" != "lib" ] ; then
155         ln -sf $RPM_BUILD_ROOT%{_libdir} $RPM_BUILD_ROOT%{_prefix}/lib
156 fi
157
158 %{__make} install \
159         libdir=$RPM_BUILD_ROOT%{_libdir} \
160         includedir=$RPM_BUILD_ROOT%{_includedir} \
161         bindir=$RPM_BUILD_ROOT%{_bindir}
162
163 if [ "%{_lib}" != "lib" ] ; then
164         rm $RPM_BUILD_ROOT%{_prefix}/lib
165 fi
166
167 install documentation/fltk-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk-config.1
168 install documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
169 install documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 # note: COPYING contains amendments to LGPL, so don't remove!
180 %doc CHANGES COPYING CREDITS README
181 %attr(755,root,root) %{_libdir}/libfltk.so.*.*
182 %attr(755,root,root) %{_libdir}/libfltk_forms.so.*.*
183 %attr(755,root,root) %{_libdir}/libfltk_images.so.*.*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %doc documentation/*.{html,gif,jpg} fltk.ps.gz
188 %attr(755,root,root) %{_bindir}/fltk-config
189 %attr(755,root,root) %{_bindir}/fluid
190 %attr(755,root,root) %{_libdir}/libfltk.so
191 %attr(755,root,root) %{_libdir}/libfltk_forms.so
192 %attr(755,root,root) %{_libdir}/libfltk_images.so
193 %{_includedir}/FL
194 %exclude %{_includedir}/FL/Fl_Gl_Window.*
195 %exclude %{_includedir}/FL/gl*
196 %{_mandir}/man[13]/*
197
198 %files static
199 %defattr(644,root,root,755)
200 %attr(644,root,root) %{_libdir}/libfltk.a
201 %attr(644,root,root) %{_libdir}/libfltk_forms.a
202 %attr(644,root,root) %{_libdir}/libfltk_images.a
203
204 %if 0%{!?_without_gl:1}
205 %files gl
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libfltk_gl.so.*.*
208
209 %files gl-devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libfltk_gl.so
212 %{_includedir}/FL/Fl_Gl_Window.*
213 %{_includedir}/FL/gl*
214
215 %files gl-static
216 %defattr(644,root,root,755)
217 %attr(644,root,root) %{_libdir}/libfltk_gl.a
218 %endif
This page took 0.096864 seconds and 3 git commands to generate.