]> git.pld-linux.org Git - packages/flowd.git/blame - flowd.spec
- rel 2
[packages/flowd.git] / flowd.spec
CommitLineData
f51ce8dd
MP
1#
2# Conditional build:
f51ce8dd
MP
3%bcond_without tests # build without tests
4#
0ead87ef 5%include /usr/lib/rpm/macros.perl
f51ce8dd 6Summary: The flowd NetFlow collector daemon
310b3877 7Summary(pl.UTF-8): flowd - demon zbierania danych NetFlow
f51ce8dd
MP
8Name: flowd
9Version: 0.9
15de0a57 10Release: 2
f51ce8dd
MP
11License: BSD
12Group: Applications/Networking
f51ce8dd
MP
13Source0: http://www.mindrot.org/files/flowd/%{name}-%{version}.tar.gz
14# Source0-md5: 442917bb3c66a81786e9ab1d40006122
0ead87ef 15URL: http://www.mindrot.org/flowd.html
5df1ef9a 16BuildRequires: byacc
17BuildRequires: python-devel
f51ce8dd
MP
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
0ead87ef
JB
20BuildRequires: rpmbuild(macros) >= 1.268
21Requires(pre): /bin/id
22Requires(pre): /usr/bin/getgid
23Requires(pre): /usr/sbin/groupadd
24Requires(pre): /usr/sbin/useradd
25Requires(post,preun): /sbin/chkconfig
26Requires(postun): /usr/sbin/groupdel
27Requires(postun): /usr/sbin/userdel
28Requires: rc-scripts
29Provides: group(_flowd)
30Provides: user(_flowd)
f51ce8dd
MP
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
f51ce8dd
MP
33%description
34This is flowd, a NetFlow collector daemon intended to be small, fast
35and secure.
36
37It features some basic filtering to limit or tag the flows that are
38recorded and is privilege separated, to limit security exposure from
39bugs in flowd itself.
40
2b90fc17
JR
41%description -l pl.UTF-8
42Ten pakiet zawiera program flowd - demona zbierającego dane NetFlow,
43mającego być małym, szybkim i bezpiecznym.
0ead87ef 44
2b90fc17
JR
45Obsługuje podstawowe filtrowanie w celu ograniczania lub znakowania
46zapisywanych przepływów, ma rozdzielenie uprawnień w celu ograniczenia
47wpływu własnych błedów na bezpieczeństwo.
0ead87ef
JB
48
49%package perl
50Summary: Perl API to access flowd logfiles
310b3877 51Summary(pl.UTF-8): Perlowe API do dostępu do plików logów flowd
0ead87ef
JB
52Group: Development/Languages/Perl
53
f51ce8dd
MP
54%description perl
55This is a Perl API to the binary flowd network flow log format and an
0ead87ef
JB
56example reader application.
57
2b90fc17
JR
58%description perl -l pl.UTF-8
59Ten pakiet zawiera API Perla dla binarnego formatu plików logów
60przepływów sieciowych flowd oraz przykładowy program czytający.
0ead87ef
JB
61
62%package python
63Summary: Python API to access flowd logfiles
310b3877 64Summary(pl.UTF-8): Pythonowe API do dostępu do plików logów flowd
0ead87ef
JB
65Group: Applications/Networking
66Requires: python
f51ce8dd
MP
67
68%description python
69This is a Python API to the binary flowd network flow log format and
0ead87ef
JB
70an example reader application.
71
2b90fc17
JR
72%description python -l pl.UTF-8
73Ten pakiet zawiera API Pythona dla binarnego formatu plików logów
74przepływów sieciowych flowd oraz przykładowy program czytający.
0ead87ef
JB
75
76%package tools
77Summary: Collection of example flowd tools
310b3877 78Summary(pl.UTF-8): Zbiór przykładowych narzędzi dla flowd
0ead87ef 79Group: Applications/Networking
f51ce8dd
MP
80
81%description tools
0ead87ef
JB
82A collection of tools for use with flowd.
83
2b90fc17
JR
84%description tools -l pl.UTF-8
85Zbiór narzędzi do używania z flowd.
0ead87ef
JB
86
87%package devel
88Summary: C API to access flowd logfiles
310b3877 89Summary(pl.UTF-8): API C do dostępu do plików logów flowd
0ead87ef 90Group: Development/Libraries
f51ce8dd
MP
91
92%description devel
93This is a C API to the binary flowd network flow log format.
94
2b90fc17
JR
95%description devel -l pl.UTF-8
96Ten pakiet zawiera API C dla binarnego formatu plików logów przepływów
0ead87ef
JB
97sieciowych flowd.
98
f51ce8dd
MP
99%prep
100%setup -q
101
102%build
103%configure
104# --enable-gcc-warnings \
105
106%{__make}
107
108cd Flowd-perl
109%{__perl} Makefile.PL \
110 INSTALLDIRS=vendor
111%{__make}
112%{?with_tests:%{__make} test}
113
114#python setup.py install --root=$RPM_BUILD_ROOT --optimize=2
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
121
122# Misc stuff
123install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
124install flowd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/flowd
125
126# Perl module
0ead87ef 127%{__make} -C Flowd-perl pure_install \
f51ce8dd 128 DESTDIR=$RPM_BUILD_ROOT
f51ce8dd
MP
129
130# Python module
131./setup.py install --optimize 1 --root=$RPM_BUILD_ROOT
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%pre
0ead87ef
JB
137%groupadd -g XXX _flowd
138%useradd -u XXX -d /usr/share/empty -s /bin/false -c "flowd user" -g _flowd _flowd
f51ce8dd
MP
139
140%post
141/sbin/chkconfig --add flowd
0ead87ef 142%service flowd restart "flowd daemon"
f51ce8dd
MP
143
144%preun
0ead87ef
JB
145if [ "$1" = "0" ]; then
146 %service flowd stop
f51ce8dd
MP
147 /sbin/chkconfig --del flowd
148fi
149
0ead87ef
JB
150%postun
151if [ "$1" = "0" ]; then
152 %userremove _flowd
153 %groupremove _flowd
154fi
155
f51ce8dd
MP
156%files
157%defattr(644,root,root,755)
158%doc ChangeLog LICENSE README TODO
159#%%dir %%attr(111,root,root) %{_var}/empty
0ead87ef
JB
160%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/flowd.conf
161%attr(754,root,root) /etc/rc.d/init.d/flowd
f51ce8dd 162%attr(755,root,root) %{_bindir}/flowd-reader
f51ce8dd 163%attr(755,root,root) %{_sbindir}/flowd
0ead87ef
JB
164%{_mandir}/man5/flowd.conf.5*
165%{_mandir}/man8/flowd.8*
166%{_mandir}/man8/flowd-reader.8*
f51ce8dd
MP
167
168%files perl
169%defattr(644,root,root,755)
170#%%doc reader.pl
171%{perl_vendorarch}/Flowd.pm
0ead87ef 172%dir %{perl_vendorarch}/auto/Flowd
f51ce8dd 173%{perl_vendorarch}/auto/Flowd/Flowd.bs
0ead87ef 174%attr(755,root,root) %{perl_vendorarch}/auto/Flowd/Flowd.so
f51ce8dd
MP
175%{_mandir}/man3/*
176
177%files python
178%defattr(644,root,root,755)
179%doc reader.py
180
181%files tools
182%defattr(644,root,root,755)
183%doc tools/*
184
185%files devel
186%defattr(644,root,root,755)
0ead87ef
JB
187%{_includedir}/flowd
188%{_libdir}/libflowd.a
This page took 0.129953 seconds and 4 git commands to generate.