]> git.pld-linux.org Git - packages/flow-tools.git/commitdiff
- rel 7; openssl 1.1.1 fix auto/th/flow-tools-0.68.5-7
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Sep 2018 07:06:56 +0000 (09:06 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Sep 2018 07:06:56 +0000 (09:06 +0200)
flow-tools.spec
openssl.patch [new file with mode: 0644]

index dae8b1b3e992b90c8baea6097c77abf3b0d0440c..1bf4bad66aa1240ffb0d24e249bd25d8ed44b3a2 100644 (file)
@@ -2,13 +2,14 @@ Summary:      Collecting and processing NetFlow data
 Summary(pl.UTF-8):     Gromadzenie i przetwarzanie informacji o przepływie w sieci
 Name:          flow-tools
 Version:       0.68.5
-Release:       6
+Release:       7
 License:       BSD
 Group:         Applications/Networking
 Source0:       http://flow-tools.googlecode.com/files/%{name}-%{version}.tar.bz2
 # Source0-md5: 3c5e75da2822ab6b4947c928c09ea365
 Patch0:                %{name}-shebang.patch
 Patch1:                format-security.patch
+Patch2:                openssl.patch
 URL:           http://code.google.com/p/flow-tools/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -72,6 +73,7 @@ Statyczna biblioteka flow-tools.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
diff --git a/openssl.patch b/openssl.patch
new file mode 100644 (file)
index 0000000..a3a3a12
--- /dev/null
@@ -0,0 +1,39 @@
+--- flow-tools-0.68.5/lib/ftxlate.c.org        2018-09-26 09:03:18.093012789 +0200
++++ flow-tools-0.68.5/lib/ftxlate.c    2018-09-26 09:04:46.108939269 +0200
+@@ -2040,21 +2040,21 @@ static int cryptopan_init(struct cryptop
+   /* init crypto */
+-  if (!(cp->cipher_ctx = (EVP_CIPHER_CTX*) malloc(sizeof(EVP_CIPHER_CTX)))) {
++  cp->cipher_ctx = EVP_CIPHER_CTX_new();
++  if (cp->cipher_ctx == NULL)
+     return -1;
+-  }
+-
+-  EVP_CIPHER_CTX_init(cp->cipher_ctx);
+   /* disable padding */
+   if (!(EVP_CIPHER_CTX_set_padding(cp->cipher_ctx, 0))) {
+     cryptopan_free(cp);
++    EVP_CIPHER_CTX_free(cp->cipher_ctx);
+     return -1;
+   }
+   /* init encryption */
+   if (!(EVP_EncryptInit(cp->cipher_ctx, EVP_aes_128_ecb(), key, NULL))) {
+     cryptopan_free(cp);
++    EVP_CIPHER_CTX_free(cp->cipher_ctx);
+     return -1;
+   }
+@@ -2062,8 +2062,10 @@ static int cryptopan_init(struct cryptop
+   i = 16;
+   if (!(EVP_EncryptUpdate(cp->cipher_ctx, cp->m_pad, &i, key+16, i))) {
+     cryptopan_free(cp);
++    EVP_CIPHER_CTX_free(cp->cipher_ctx);
+     return -1;
+   }
++  EVP_CIPHER_CTX_free(cp->cipher_ctx);
+ #endif /* HAVE_OPENSSL */
This page took 0.084373 seconds and 4 git commands to generate.