]> git.pld-linux.org Git - packages/flixengine.git/blob - flixengine.spec
- 8.0.10.1
[packages/flixengine.git] / flixengine.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  python          # do not build Python bindings
5 %bcond_without  java            # do not build Java bindings
6 %bcond_with     tests           # perform "make test". needs running flixd on localhost
7 %bcond_without  demo    # use production tarball (you need one too:))
8 #
9 %ifarch %{x8664}
10 %undefine       with_python
11 %undefine       with_java
12 %endif
13 #
14 %define         full_version    %{version}%{?with_demo:_DEMO}%{?_extra}
15 %define         _extra  %{nil}
16 #
17 %include        /usr/lib/rpm/macros.perl
18 Summary:        On2 Flix Engine
19 Summary(pl.UTF-8):      Silnik On2 Flix
20 Name:           flixengine
21 Version:        8.0.10.1
22 Release:        0.1
23 License:        (probably) not distributable
24 Group:          Applications
25 # download demo from http://flix.on2.com/demos/
26 # check for newer versions at http://flix.on2.com/flix/download/
27 # Source0Download:      http://flix.on2.com/demos/flixenginelinuxdemo.tar.gz
28 %if %{with demo}
29 Source0:        %{name}linuxdemo-%{version}.tar.gz
30 # NoSource0-md5:        3d0accb19f6d9dcd6ea2cd139a150d9e
31 NoSource:       0
32 %endif
33 %if %{without demo}
34 # Source1Download:      http://flix.on2.com/flix/download/flix-engine-installer-linux-%{version}.tar.gz
35 Source1:        flix-engine-installer-linux-%{version}%{?_extra}.tar.gz
36 # NoSource1-md5:        ecf91acf067775e27059977b7a5a8da7
37 NoSource:       1
38 %endif
39 Source2:        %{name}.init
40 Source3:        %{name}.sysconfig
41 Patch0:         %{name}-libdir.patch
42 Patch1:         %{name}-phploader.patch
43 URL:            http://www.on2.com/developer/flix-engine-sdk
44 BuildRequires:  bash
45 %{?with_java:BuildRequires:     jre}
46 BuildRequires:  perl-base
47 BuildRequires:  php-devel
48 %{?with_python:BuildRequires:   python}
49 BuildRequires:  rpm-perlprov >= 4.1-13
50 BuildRequires:  rpmbuild(macros) >= 1.344
51 %if %{with autodeps}
52 BuildRequires:  ffmpeg-libs
53 BuildRequires:  lame-libs
54 %endif
55 Requires(post,postun):  /sbin/ldconfig
56 Requires(post,preun):   /sbin/chkconfig
57 Requires(postun):       /usr/sbin/groupdel
58 Requires(postun):       /usr/sbin/userdel
59 Requires(pre):  /bin/id
60 Requires(pre):  /usr/bin/getgid
61 Requires(pre):  /usr/sbin/groupadd
62 Requires(pre):  /usr/sbin/useradd
63 Requires:       portmap
64 Requires:       rc-scripts >= 0.4.1.5
65 Provides:       group(flixd)
66 Provides:       user(flixd)
67 ExclusiveArch:  %{ix86} %{x8664}
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # should not provide such deps
71 %define         _noautoprov libavutil.so.49 libavformat.so.50 libavcodec.so.51
72 # need to provide it for flixd, but we don't want package name dep here
73 %define         _noautoreq %{_noautoprov}
74
75 %define         _sysconfdir             /etc/on2
76
77 %description
78 The On2 Flix Engine provides many of the Flash 8 video encoding
79 features of our industry leading On2 Flix Pro video encoder in a
80 powerful software SDK.
81
82 The Engine enables you to add the power and efficiency of Flash video
83 with On2 VP6 encoding to your intranet, website and other server-based
84 applications, preserve alpha channel in the video output, and much
85 more.
86
87 The major feature of the On2 Flix Engine 8 is support for Adobe Flash
88 8 video with the On2 VP6 codec and FLV video output that can be played
89 directly in the Flash Player, streamed through the Adobe Flash Media
90 Server, or imported into Flash Studio. The new FLV output also is
91 fully compliant with FLV format metadata and Adobe Flash Player
92 standards.
93
94 %description -l pl.UTF-8
95 Silnik On2 Flix Engine udostępnia wiele spośród możliwości
96 kodowania filmów Flash 8 wiodącego kodera On2 Flix Pro w postaci
97 potężnego SDK.
98
99 Silnik pozwala wykorzystywać możliwości i wydajność filmów Flash
100 z kodowaniem On2 VP6 w intranecie, na stronie WWW i w innych
101 zastosowaniach serwerowych, z zachowaniem kanału alpha na wyjściu
102 obrazu i innymi opcjami.
103
104 Główną cechą silnika On2 Flix Engine 8 jest obsługa filmów Adobe
105 Flash 8 z kodekiem On2 VP6 oraz wyjściem obrazu FLV, które można
106 odtwarzać bezpośrednio w odtwarzaczu Flash, przekazywać strumieniem
107 poprzez Adobe Flash Media Server lub importować do Flash Studio. Nowe
108 wyjście FLV jest także w pełni zgodne z formatem metadanych FLV i
109 standardami Adobe Flash Playera.
110
111 %package libs
112 Summary:        Shared libraries for On2 Flix Engine
113 Summary(pl.UTF-8):      Biblioteki współdzielone silnika On2 Flix
114 Group:          Libraries
115
116 %description libs
117 Shared libraries for On2 Flix Engine.
118
119 %description libs -l pl.UTF-8
120 Biblioteki współdzielone silnika On2 Flix.
121
122 %package devel
123 Summary:        Header files for On2 Flix Engine library
124 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki silnika On2 Flix
125 Group:          Development/Libraries
126
127 %description devel
128 Header files for On2 Flix Engine library.
129
130 %description devel -l pl.UTF-8
131 Pliki nagłówkowe biblioteki silnika On2 Flix.
132
133 %package -n java-flixengine
134 Summary:        Java bindings for On2 Flix Engine
135 Summary(pl.UTF-8):      Wiązania Javy dla silnika On2 Flix
136 Group:          Libraries
137 Requires:       %{name}-libs = %{version}-%{release}
138 Requires:       jpackage-utils
139
140 %description -n java-flixengine
141 Java bindings for On2 Flix Engine.
142
143 %description -n java-flixengine -l pl.UTF-8
144 Wiązania Javy dla silnika On2 Flix.
145
146 %package -n perl-flixengine
147 Summary:        Perl bindings for On2 Flix Engine
148 Summary(pl.UTF-8):      Wiązania perla dla silnika On2 Flix
149 Group:          Libraries
150 Requires:       %{name}-libs = %{version}-%{release}
151
152 %description -n perl-flixengine
153 Perl bindings for On2 Flix Engine.
154
155 %description -n perl-flixengine -l pl.UTF-8
156 Wiązania perla dla silnika On2 Flix.
157
158 %package -n php-flixengine
159 Summary:        PHP bindings for On2 Flix Engine
160 Summary(pl.UTF-8):      Wiązania PHP dla silnika On2 Flix
161 %{?requires_php_extension}
162 Group:          Libraries
163 Requires:       %{name}-libs = %{version}-%{release}
164 Requires:       php-common >= 4:5.0.4
165
166 %description -n php-flixengine
167 PHP bindings for On2 Flix Engine.
168
169 %description -n php-flixengine -l pl.UTF-8
170 Wiązania PHP dla silnika On2 Flix.
171
172 %package -n python-flixengine
173 Summary:        Python bindings for On2 Flix Engine
174 Summary(pl.UTF-8):      Wiązania Pythona dla silnika On2 Flix
175 Group:          Libraries
176 Requires:       %{name}-libs = %{version}-%{release}
177
178 %description -n python-flixengine
179 Python bindings for On2 Flix Engine.
180
181 %description -n python-flixengine -l pl.UTF-8
182 Wiązania Pythona dla silnika On2 Flix.
183
184 %package apidocs
185 Summary:        HTML API Documentation for On2 Flix Engine
186 Summary(pl.UTF-8):      Dokumentacja HTML API dla silnika On2 Flix
187 Group:          Documentation
188 Obsoletes:      flixengine-docs
189
190 %description apidocs
191 HTML API Documentation for On2 Flix Engine.
192
193 %description apidocs -l pl.UTF-8
194 Dokumentacja HTML API dla silnika On2 Flix.
195
196 %prep
197 %setup -q -T -b %{?with_demo:0}%{!?with_demo:1} -n flix-engine-installer-linux-%{full_version}
198 bin=flix-engine-installer-linux-%{full_version}.bin
199 tar=flix-engine-linux-%{full_version}.tar.gz
200
201 OFFSET=$( awk -F= '/OFFSET=/{print $2; exit}' $bin)
202 dd bs=8 if=$bin of=$tar skip=$OFFSET
203 %{__tar} zxf $tar
204
205 %patch0 -p1
206 %patch1 -p1
207
208 %{__sed} -ne '/## FUNCTIONS common/,/## END - common function/p' $bin > functions.sh
209 cat <<'EOF' > install.sh
210 #!/bin/bash
211 export VERSION=%{full_version}
212 %{?with_demo:export FLIXENGINEDEMO=1}
213 export nullout=/dev/null
214 export tempdir=%{_builddir}/flix-engine-installer-linux-%{full_version}
215
216 . $(dirname "$0")/functions.sh
217 cd .flix-engine-installation-files
218
219 export -f getinput inset ynanswer
220 instlog=install.log
221 ./install.sh "$@" | tee -i $instlog
222 if [ -f "$instlog" ]; then
223         echo "Local system info:" >>$instlog
224         uname -a 2>/dev/null >>$instlog
225         head /etc/*version* 2>/dev/null >>$instlog
226         head /etc/*release* 2>/dev/null >>$instlog
227         cat /proc/cpuinfo 2>/dev/null >>$instlog
228         /lib/ld-linux.so.2 /lib/libc.so.6 2>/dev/null >>$instlog
229         echo "---" 2>/dev/null >>$instlog
230         /lib/ld-linux.so.2 /lib32/libc.so.6 2>/dev/null >>$instlog
231         echo "---" 2>/dev/null >>$instlog
232         /lib/libc.so.6 2>/dev/null >>$instlog
233         echo "---" 2>/dev/null >>$instlog
234         file /lib/libc.so.6 2>/dev/null >>$instlog
235         echo "---" 2>/dev/null >>$instlog
236         /sbin/ifconfig -a 2>/dev/null >>$instlog
237
238         echo "A log of this installation can be found here:"
239         echo "  $instlog"
240         echo
241 fi
242 EOF
243 chmod +x install.sh
244
245 cd .flix-engine-installation-files
246 %{__sed} -i -e '
247 # force installing initscript into buildroot without detection
248 s,^initchk$,inittype=sysv1; INITDIR=$RPM_BUILD_ROOT/etc/rc.d/init.d,
249
250 # cls is annoying
251 s,clear 2>\$nullout,#&,
252
253 # we want to install examples, but not compile them in install
254 # and somewhy --no-compile didn not work, had to specify also --no-modules,
255 # which made no modules installed either, chicken-egg problem.
256 s,COMPILEMODULES=y,COMPILEMODULES=n,
257 s,INSTALLEDPERLFILES="n",INSTALLEDPERLFILES="y",
258 s,INSTALLEDPHPFILES="n",INSTALLEDPHPFILES="y",
259 s,INSTALLEDPYTHONFILES="n",INSTALLEDPYTHONFILES="y",
260 s,INSTALLEDFLIXLIBRARIES="n",INSTALLEDFLIXLIBRARIES="y",
261 s,INSTALLEDJAVAFILES="n",INSTALLEDJAVAFILES="y",
262
263 ' install.sh
264
265 # remove backups from patching as we use globs to package files to buildroot
266 find flixsamples '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
267
268 %build
269 cd .flix-engine-installation-files
270 PWD=$(pwd)
271
272 ln -snf flixhdrs flixengine2
273 export C_INCLUDE_PATH=$PWD
274
275 %ifarch %{x8664}
276 export LD_LIBRARY_PATH=$PWD/testing/lib64
277 ldconfig -n testing/lib64
278 %else
279 export LD_LIBRARY_PATH=$PWD/flixlibs
280 ldconfig -n flixlibs
281 %endif
282 export LIBRARY_PATH=$LD_LIBRARY_PATH
283
284 # PHP
285 %{__make} -C flixphp \
286         CC="%{__cc}" \
287         -f target.mk
288
289 # Perl
290 cd flixperl
291 %{__perl} Makefile.PL \
292         INSTALLDIRS=vendor
293 %{__make} \
294         CC="%{__cc}" \
295         OPTIMIZE="%{rpmcflags}"
296 %{?with_tests:%{__make} test}
297 cd ..
298
299 %if %{with python}
300 cd flixpython
301 %{__python} setup.py build
302 cd ..
303 %endif
304
305 %if %{with java}
306 %{__make} -C flixjava \
307         CC="%{__cc}" \
308         -f target.mk
309 %endif
310
311 %install
312 rm -rf $RPM_BUILD_ROOT
313 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
314
315 ./install.sh \
316         --prefix=$RPM_BUILD_ROOT%{_prefix} \
317         --mandir=$RPM_BUILD_ROOT%{_mandir} \
318         --mencoderbin=$RPM_BUILD_ROOT%{_bindir} \
319         --flixsamples=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
320         --pidfile=$RPM_BUILD_ROOT/var/run/flixd/flixd.pid \
321         --authdir=$RPM_BUILD_ROOT%{_sysconfdir} \
322         --just-install \
323         --offline \
324         --yesireadtheon2license \
325         --no-compile \
326         --no-modules \
327         --no-init \
328         --noprereqlibs
329
330 rm -f $RPM_BUILD_ROOT/etc/rc.d/init.d/flixengine
331 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/flixd
332 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/flixd
333
334 # mencoder-flixengine searches for codecs from /usr/lib/win32 and there's no
335 # way to override it by commandline arg or env var.
336 ln -s codecs $RPM_BUILD_ROOT%{_prefix}/lib/win32
337
338 cd .flix-engine-installation-files
339 install lget on2_host_info $RPM_BUILD_ROOT%{_sbindir}
340
341 # symlink without buildroot
342 ln -snf %{_docdir}/on2/flixengine/html/c/cli.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c/README-cli.html
343
344 # install bindings
345 # PHP
346 %{__make} -C flixphp \
347         install \
348         PHPINST=%{php_extensiondir} \
349         DESTDIR=$RPM_BUILD_ROOT \
350         -f target.mk
351 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
352 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/flixengine.ini
353 ; Enable flixengine extension module
354 ;extension=flixengine2.so
355 EOF
356 # symlink without buildroot
357 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/php
358 ln -snf %{_docdir}/on2/flixengine/html/phpcgi.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/php/README-cgi.html
359 ln -snf %{_docdir}/on2/flixengine/html/phpcli.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/php/README-cli.html
360
361 # Perl
362 cd flixperl
363 %{__make} pure_install \
364         DESTDIR=$RPM_BUILD_ROOT
365 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/On2/flixengine2/.packlist
366 cd ..
367 # symlink without buildroot
368 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/perl
369 ln -snf %{_docdir}/on2/flixengine/html/perlcgi.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/perl/README-cgi.html
370 ln -snf %{_docdir}/on2/flixengine/html/perlcli.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/perl/README-cli.html
371
372 %if %{with python}
373 cd flixpython
374 %{__python} setup.py install \
375         --optimize=2 \
376         --root=$RPM_BUILD_ROOT
377 %py_postclean
378 cd ..
379 # symlink without buildroot
380 ln -snf %{_docdir}/on2/flixengine/html/pythoncgi.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/python/README-cgi.html
381 ln -snf %{_docdir}/on2/flixengine/html/pythoncli.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/python/README-cli.html
382 %endif
383
384 rm -f $RPM_BUILD_ROOT%{_docdir}/on2/flixengine/javadoc
385 %if %{with java}
386 %{__make} -C flixjava \
387         SOINST=$RPM_BUILD_ROOT%{_libdir} \
388         JARINST=$RPM_BUILD_ROOT%{_javadir} \
389         install \
390         -f target.mk
391
392 # symlink without buildroot
393 ln -snf %{_prefix}/src/flixmodules/flixjava/doc $RPM_BUILD_ROOT%{_docdir}/on2/flixengine/javadoc
394 ln -snf %{_docdir}/on2/flixengine/html/javacli.html $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/java/README-cli.html
395 %endif
396
397 %ifarch %{x8664}
398 cp -a testing/lib64/libflixengine2.so* $RPM_BUILD_ROOT%{_libdir}
399 # flixd linked statically and other libs are 64 bit
400 rm -f $RPM_BUILD_ROOT%{_prefix}/lib/libflixengine2*.so*
401 %endif
402
403 # we have already newer soname for libavformat.so in ffmpeg-libs
404 # copy from bundled ones.
405 install supportlibs/libavformat.so.51.12.2 $RPM_BUILD_ROOT%{_prefix}/lib
406 install supportlibs/libavcodec.so.51.41.0 $RPM_BUILD_ROOT%{_prefix}/lib
407 install supportlibs/libavutil.so.49.5.0 $RPM_BUILD_ROOT%{_prefix}/lib
408
409 # avoid collision from mplayer package
410 mv $RPM_BUILD_ROOT%{_bindir}/mencoder{,-flixengine}
411
412 # do not put hardware fingerprint to rpm package
413 > $RPM_BUILD_ROOT%{_sysconfdir}/hostinfo
414 touch $RPM_BUILD_ROOT%{_sysconfdir}/flixengine.lic
415 install -d $RPM_BUILD_ROOT/var/run/flixd
416 install -d $RPM_BUILD_ROOT/var/log
417 touch $RPM_BUILD_ROOT/var/log/flixd.log
418
419 # use poldek -e
420 rm -f $RPM_BUILD_ROOT%{_sbindir}/flix-engine-uninstall.sh
421
422 # make it somewhat easier to acquire license registration
423 install -d $RPM_BUILD_ROOT%{_sysconfdir}
424 cat > $RPM_BUILD_ROOT%{_sysconfdir}/flixd-license.conf <<'EOF'
425 FLIX_USERNAME='<username>'
426 FLIX_SERIAL='<serial>'
427 EOF
428
429 install -d $RPM_BUILD_ROOT%{_sbindir}
430 cat > $RPM_BUILD_ROOT%{_sbindir}/flixd-license-get <<'EOF'
431 #!/bin/sh
432 . %{_sysconfdir}/flixd-license.conf
433
434 %{_sbindir}/lget -u "$FLIX_USERNAME" -s "$FLIX_SERIAL" -i %{_sysconfdir}/hostinfo -o %{_sysconfdir}/flixengine.lic -a 'On2FlixEngine/%{full_version} (%(uname -o))'
435 EOF
436
437 %clean
438 rm -rf $RPM_BUILD_ROOT
439
440 %pre
441 %groupadd -g 179 flixd
442 %useradd -u 179 -g flixd -c "On2 Flixd" flixd
443
444 %post
445 /sbin/ldconfig
446 /sbin/chkconfig --add flixd
447 if [ ! -f /var/log/flixd.log ]; then
448         touch /var/log/flixd.log
449         chown root:flixd /var/log/flixd.log
450         chmod 660 /var/log/flixd.log
451 fi
452 if [ ! -s %{_sysconfdir}/hostinfo ]; then
453         %{_sbindir}/on2_host_info > %{_sysconfdir}/hostinfo
454 %banner -e %{name} <<EOF
455 To register your copy of flixd fill %{_sysconfdir}/flixd-license.conf
456 and afterwards call: %{_sbindir}/flixd-license-get
457 EOF
458 fi
459 %service flixd restart
460
461 %preun
462 if [ "$1" = "0" ]; then
463         %service -q flixd stop
464         /sbin/chkconfig --del flixd
465 fi
466
467 %postun
468 /sbin/ldconfig
469 if [ "$1" = "0" ]; then
470         %userremove flixd
471         %groupremove flixd
472 fi
473
474 %post   libs -p /sbin/ldconfig
475 %postun libs -p /sbin/ldconfig
476
477 %post -n php-flixengine
478 %php_webserver_restart
479
480 %postun -n php-flixengine
481 if [ "$1" = 0 ]; then
482         %php_webserver_restart
483 fi
484
485 %files
486 %defattr(644,root,root,755)
487 %doc doc/*
488 %{?with_java:%exclude %{_docdir}/on2/flixengine/javadoc}
489 %dir %{_sysconfdir}
490 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/flixd-license.conf
491 %attr(640,root,flixd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostinfo
492 %attr(640,root,flixd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/flixengine.lic
493 %attr(755,root,root) %{_prefix}/lib/libavformat.so.*.*.*
494 %attr(755,root,root) %{_prefix}/lib/libavcodec.so.*.*.*
495 %attr(755,root,root) %{_prefix}/lib/libavutil.so.*.*.*
496 %attr(755,root,root) %{_sbindir}/flixd
497 %attr(755,root,root) %{_sbindir}/flixd-license-get
498 %attr(755,root,root) %{_sbindir}/lget
499 %attr(755,root,root) %{_sbindir}/on2_host_info
500 %attr(754,root,root) /etc/rc.d/init.d/flixd
501 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/flixd
502 %{_prefix}/lib/win32
503
504 %{_mandir}/man8/flixd.8*
505 %dir %attr(771,root,flixd) /var/run/flixd
506 %ghost %attr(660,root,flixd) /var/log/flixd.log
507 %attr(755,root,root) %{_bindir}/mencoder-flixengine
508
509 %files libs
510 %defattr(644,root,root,755)
511 %ifarch %{x8664}
512 %attr(755,root,root) %{_libdir}/libflixengine2.so.*.*
513 %else
514 %attr(755,root,root) %{_libdir}/libflixengine2.so.*.*
515 %attr(755,root,root) %{_libdir}/libflixengine2_core.so.*.*
516 %endif
517 %dir %{_examplesdir}/%{name}-%{version}
518
519 %files devel
520 %defattr(644,root,root,755)
521 %ifarch %{x8664}
522 %attr(755,root,root) %{_libdir}/libflixengine2.so
523 %else
524 %attr(755,root,root) %{_libdir}/libflixengine2.so
525 %attr(755,root,root) %{_libdir}/libflixengine2_core.so
526 %endif
527 %{_includedir}/flixengine2
528 %{_examplesdir}/%{name}-%{version}/c
529
530 %if %{with java}
531 %files -n java-flixengine
532 %defattr(644,root,root,755)
533 %doc %{_docdir}/on2/flixengine/javadoc
534 # perhaps these should be:
535 # /usr/%{_lib}/jvm/java-sun-1.6.0/jre/lib/%{arch}/libflixengine2_jni.so
536 # /usr/%{_lib}/jvm/java-sun-1.6.0/jre/lib/ext/flixengine2.jar
537 %attr(755,root,root) %{_libdir}/libflixengine2_jni.so
538 %{_javadir}/flixengine2.jar
539 %{_examplesdir}/%{name}-%{version}/java
540 %endif
541
542 %files -n perl-flixengine
543 %defattr(644,root,root,755)
544 %dir %{perl_vendorarch}/On2
545 %{perl_vendorarch}/On2/flixengine2.pm
546 %dir %{perl_vendorarch}/auto/On2
547 %dir %{perl_vendorarch}/auto/On2/flixengine2
548 %{perl_vendorarch}/auto/On2/flixengine2/flixengine2.bs
549 %attr(755,root,root) %{perl_vendorarch}/auto/On2/flixengine2/flixengine2.so
550 %{_examplesdir}/%{name}-%{version}/perl
551
552 %files -n php-flixengine
553 %defattr(644,root,root,755)
554 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/flixengine.ini
555 %attr(755,root,root) %{php_extensiondir}/flixengine2.so
556 %{_prefix}/lib/flixengine2.php
557 %{_examplesdir}/%{name}-%{version}/php
558
559 %if %{with python}
560 %files -n python-flixengine
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{py_sitedir}/_flixengine2.so
563 %{py_sitedir}/flixengine2.pyc
564 %{py_sitedir}/flixengine2.pyo
565 %{_examplesdir}/%{name}-%{version}/python
566 %endif
567
568 %files apidocs
569 %defattr(644,root,root,755)
570 %{_docdir}/on2
This page took 0.132202 seconds and 4 git commands to generate.