]> git.pld-linux.org Git - packages/flite.git/blob - flite.spec
- -alsa.patch removed; build with `--with-audio=oss' because emacspeak
[packages/flite.git] / flite.spec
1 #
2 # NOTE: - building is memory consuming (up to c.a. 537MB)
3 # TODO: - review -link, version patches
4 #       - --disable-static doesn't work
5 #       - install manpages via makefile
6 #
7 # Conditional build:
8 %bcond_without  static_libs # don't pack static liraries
9 #
10 Name:           flite
11 Version:        1.2
12 Release:        0.2
13 Summary:        flite - a small, fast speech synthesis engine
14 Summary(ru_RU.KOI8-R):flite - ÍÁÌÅÎØËÏÅ, ÂÙÓÔÒÏÅ ÓÒÅÄÓÔ×Ï ÄÌÑ ÓÉÎÔÅÚÁ ÒÅÞÉ
15 License:        Custom, see COPYING
16 Group:          Applications/Sound
17 Source0:        http://www.speech.cs.cmu.edu/flite/packed/flite-1.2/%{name}-%{version}-release.tar.bz2
18 # Source0-md5:  24c1576f5b3eb23ecedf4bebde96710f
19 # ALT Linux patches:
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-fix-readonly-assignments.patch
22 # Debian patches:
23 Patch2:         %{name}-doc.patch
24 Patch3:         %{name}-version.patch
25 #
26 Patch4:         %{name}-DESTDIR.patch
27 Patch5:         %{name}-fix-audiodriver-setup.patch
28 URL:            http://cmuflite.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  alsa-lib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Flite - a small, fast speech synthesis engine. It is the latest
36 addition to the suite of free software synthesis tools including
37 University of Edinburgh's Festival Speech Synthesis System and
38 Carnegie Mellon University's FestVox project, tools, scripts and
39 documentation for building synthetic voices. However, flite itself
40 does not require either of these systems to compile and run.
41
42 %description -l ru_RU.KOI8-R
43 Flite -- ÍÁÌÅÎØËÏÅ, ÂÙÓÔÒÏÅ ÓÒÅÄÓÔ×Ï ÄÌÑ ÓÉÎÔÅÚÁ ÒÅÞÉ. üÔÏ ÐÏÓÌÅÄÎÅÅ
44 ÄÏÂÁ×ÌÅÎÉÅ Ë ÎÁÂÏÒÕ Ó×ÏÂÏÄÎÏÇÏ ÐÒÏÇÒÁÍÍÎÏÇÏ ÏÂÅÓÐÅÞÅÎÉÑ ÄÌÑ ÓÉÎÔÅÚÁ
45 ÒÅÞÉ, ÐÒÏÅËÔÙ FestVox É Festival. ïÄÎÁËÏ, ÓÁÍ flite ÎÅ ÔÒÅÂÕÅÔ ÎÉ
46 ÏÄÎÏÇÏ ÉÚ ÜÔÉÈ ÐÁËÅÔÏ× ÄÌÑ ËÏÍÐÉÌÑÃÉÉ É ÚÁÐÕÓËÁ.
47
48 %package devel
49 Summary:        development files for flite
50 Group:          Applications/Sound
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 development files for flite, a small, fast speech synthesis engine
55
56 %description devel -l ru_RU.KOI8-R
57 æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ flite - ÍÁÌÅÎØËÏÇÏ, ÂÙÓÔÒÏÇÏ
58 ÓÒÅÄÓÔ×Á ÄÌÑ ÓÉÎÔÅÚÁ ÒÅÞÉ.
59
60 %package static
61 Summary:        static development files for flite
62 Group:          Applications/Sound
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 static development files for flite, a small, fast speech synthesis
67 engine
68
69 %description static -l ru_RU.KOI8-R
70 óÔÁÔÉÞÅÓËÉÅ ÆÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ flite - ÍÁÌÅÎØËÏÇÏ,
71 ÂÙÓÔÒÏÇÏ ÓÒÅÄÓÔ×Á ÄÌÑ ÓÉÎÔÅÚÁ ÒÅÞÉ.
72
73 %prep
74 %setup -qn %{name}-%{version}-release
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78 %patch3 -p1
79 %patch4 -p1
80 %patch5 -p1
81
82 %build
83 cp -f /usr/share/automake/config.sub .
84 %{__autoconf}
85 %configure \
86         --with-audio=oss \
87         --enable-shared \
88         %{!?with_static_libs:--disable-static} \
89         --with-vox=cmu_us_kal16
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 # temp. workaround - put manpages in better place and install them via Makefile
96 install -d $RPM_BUILD_ROOT%{_mandir}/man1
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install debian/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ACKNOWLEDGEMENTS README COPYING doc/html
112 %attr(755,root,root) %{_bindir}/*
113 %attr(755,root,root) %{_libdir}/lib*.so.*.*
114 %{_mandir}/man1/*.1*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %{_includedir}/*
119 %attr(755,root,root) %{_libdir}/lib*.so
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/lib*.a
125 %endif
This page took 0.092713 seconds and 3 git commands to generate.