]> git.pld-linux.org Git - packages/fleet.git/blob - fleet.spec
new, version 0.9.0
[packages/fleet.git] / fleet.spec
1 Summary:        A distributed init system
2 Name:           fleet
3 Version:        0.9.0
4 Release:        0.1
5 License:        Apache v2.0
6 Group:          Base
7 Source0:        https://github.com/coreos/fleet/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  7535590f5513d0da0048a0ba5da616ba
9 URL:            https://github.com/coreos/fleet/
10 BuildRequires:  golang >= 1.2.1-3
11 BuildRequires:  systemd-devel
12 ExclusiveArch:  %{x8664}
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 fleet ties together systemd and etcd into a distributed init system.
17
18 Think of it as an extension of systemd that operates at the cluster
19 level instead of the machine level. This project is very low level and
20 is designed as a foundation for higher order orchestration.
21
22 %prep
23 %setup -q
24
25 %build
26 sh -x build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name}}
31 install -p bin/fleetctl $RPM_BUILD_ROOT%{_bindir}
32 install -p bin/fleetd $RPM_BUILD_ROOT%{_bindir}
33 cp -p %{name}.conf.sample $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
34
35 %clean
36 rm -rf $RPM_BUILD_ROOT
37
38 %files
39 %defattr(644,root,root,755)
40 %doc Documentation/ examples/ CONTRIBUTING.md DCO LICENSE MAINTAINERS NOTICE README.md
41 %dir %attr(750,root,root) %{_sysconfdir}/%{name}
42 %attr(750,root,root) %{_sysconfdir}/%{name}/%{name}.conf
43 %attr(755,root,root) %{_bindir}/fleetctl
44 %attr(755,root,root) %{_bindir}/fleetd
This page took 0.107245 seconds and 4 git commands to generate.