]> git.pld-linux.org Git - packages/flashrom.git/blame - flashrom.spec
- updated to 1.2
[packages/flashrom.git] / flashrom.spec
CommitLineData
ff69fcfa
JB
1#
2# Conditional build:
3%bcond_without ftdi # FTDI chips
fac14747 4%bcond_without jaylink # J-Link chips
ff69fcfa 5#
7cbc1f08 6Summary: Tool Flashing your BIOS from the Unix/Linux command line
e8789d13 7Summary(pl.UTF-8): Narzędzie do aktualizacji BIOS-u z linii poleceń Uniksa/Linuksa
7cbc1f08 8Name: flashrom
6c110f50 9Version: 1.2
7cbc1f08 10Release: 1
31451be6 11License: GPL v2+
563c0602 12Group: Applications/System
fac14747 13Source0: https://download.flashrom.org/releases/%{name}-v%{version}.tar.bz2
6c110f50 14# Source0-md5: 7f8e4b87087eb12ecee0fcc5445b4956
fac14747 15URL: https://www.flashrom.org/Flashrom
5cd34de0 16%{?with_ftdi:BuildRequires: libftdi1-devel >= 1.0}
fac14747 17%{?with_jaylink:BuildRequires: libjaylink-devel}
5cd34de0 18BuildRequires: libusb-devel >= 1.0
e41553f7 19BuildRequires: pciutils-devel
3610a7aa 20BuildRequires: pkgconfig
7cbc1f08 21BuildRequires: zlib-devel
5e9e0782 22ExclusiveArch: %{ix86} %{x8664} x32 mips ppc ppc64 sparc sparcv9 sparc64
7cbc1f08 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _sbindir /sbin
26
27%description
28flashrom is a utility for identifying, reading, writing, verifying and
29erasing flash chips. It's often used to flash BIOS / EFI / coreboot /
30firmware images.
fac14747
JB
31 - Supports more than 470 flash chips, 291 chipsets, 500 mainboards,
32 79 PCI devices, 17 USB devices and various parallel/serial port
33 programmers.
e8789d13 34 - Supports parallel, LPC, FWH and SPI flash interfaces and various
fac14747
JB
35 chip packages (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32, TSOP40,
36 TSOP48, BGA and more)
e8789d13
JB
37 - No physical access needed, root access is sufficient.
38 - No bootable floppy disk, bootable CD-ROM or other media needed.
39 - No keyboard or monitor needed. Simply reflash remotely via SSH.
40 - No instant reboot needed. Reflash your chip in a running system,
41 verify it, be happy. The new firmware will be present next time you
42 boot.
85a10d97
ŁK
43 - Crossflashing and hotflashing is possible as long as the flash chips
44 are electrically and logically compatible (same protocol). Great for
45 recovery.
e8789d13 46 - Scriptability. Reflash a whole pool of identical machines at the
85a10d97
ŁK
47 same time from the command line. It is recommended to check flashrom
48 output and error codes.
e8789d13 49 - Speed. flashrom is often much faster than most vendor flash tools.
fac14747
JB
50 - Portability. Supports DOS, Linux, FreeBSD (including
51 Debian/kFreeBSD), NetBSD, OpenBSD, DragonFly BSD, Solaris, Mac OS
52 X, and other Unix-like OSes, as well as GNU Hurd.
7cbc1f08 53
54%description -l pl.UTF-8
8d0a87ec 55flashrom to narzędzie do identyfikacji, odczytu, zapisu, weryfikacji i
e8789d13
JB
56kasowania układów flash. Jest często używany do programowania obrazów
57BIOS-u / EFI / coreboot / firmware'u.
fac14747
JB
58 - Obsługuje ponad 470 układów flash, 291 chipsetów, 500 płyt głównych,
59 79 urządzeń PCI, 17 urządzeń USB i różne programatory podłączane
60 przez port równoległy/szeregowy.
61 - Wspiera układy flash równoległe, LPC, FWH i SPI o różnych
e8789d13 62 obudowach/wyprowadzeniach (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32,
fac14747 63 TSOP40, TSOP48, BGA i inne)
e8789d13
JB
64 - Nie wymaga fizycznego dostępu, wystarczy dostęp do konta roota.
65 - Nie potrzebuje bootowalnej dyskietki, rozruchowego dysku CD-ROM lub
66 innych nośników.
67 - Nie jest wymagana klawiatura ani monitor. Wystarczy przeprogramować
68 zdalnie poprzez SSH.
69 - Nie ma potrzeby ponownego uruchamiania komputera. Wystarczy
70 przeprogramować układ w uruchomionym systemie, zweryfikować i być
fac14747
JB
71 szczęśliwym. Nowy firmware będzie dostępny po następnym
72 uruchomieniu.
e8789d13 73 - Crossflashing i hotflashing są możliwe na tyle, na ile układy flash
85a10d97
ŁK
74 są elektrycznie i logicznie kompatybilne (ten sam protokół). Jest to
75 świetna metoda do przywracania sprzętu ze źle zaprogramowanym
e8789d13
JB
76 firmwarem/BIOS-em.
77 - Pozwala na tworzenie skryptów do wielokrotnego programowania.
78 Programowanie identycznych maszyn w tym samym czasie z wiersza
fac14747
JB
79 poleceń. Zaleca się sprawdzanie komunikatów programu flashrom i
80 kodów błędów.
e8789d13
JB
81 - Szybkość. flashrom jest często znacznie szybszy niż większość
82 sprzedawanych narzędzi do flashowania.
fac14747
JB
83 - Przenośność. Obsługuje systemy DOS, Linux, FreeBSD (w tym
84 Debian/kFreeBSD), Dragonfly BSD, Solaris, Mac OS X oraz inne
85 systemy operacyjne oparte na Uniksie, a także GNU Hurd.
7cbc1f08 86
87%prep
fac14747 88%setup -q -n %{name}-v%{version}
7cbc1f08 89
90%build
91%{__make} \
92 CC='%{__cc}' \
7a9c4678 93 CFLAGS="%{rpmcflags}" \
ff69fcfa 94 LDFLAGS="%{rpmldflags}" \
fac14747
JB
95 %{!?with_ftdi:CONFIG_FT2232_SPI=no} \
96 %{?with_jaylink:CONFIG_JLINK_SPI=yes}
7cbc1f08 97
98%install
99rm -rf $RPM_BUILD_ROOT
6bee105c 100install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
7cbc1f08 101install %{name} $RPM_BUILD_ROOT%{_sbindir}
7cbc1f08 102install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%files
108%defattr(644,root,root,755)
e8789d13 109%doc README
7cbc1f08 110%attr(755,root,root) %{_sbindir}/flashrom
111%{_mandir}/man8/flashrom.8*
This page took 0.060766 seconds and 4 git commands to generate.