]> git.pld-linux.org Git - packages/flake8.git/blobdiff - flake8.spec
Release 3 (by relup.sh)
[packages/flake8.git] / flake8.spec
index db39321139ceadd33eb5fab246fa7930a126113a..552e2671c2d368d418a0daededd282de3add6b46 100644 (file)
@@ -2,58 +2,63 @@
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
-%bcond_without tests   # pytest tests
+%bcond_with    tests   # pytest tests
 %bcond_without doc     # Sphinx documentation
 
-Summary:       The modular source code checker: pycodestyle, pyflakes and co
+Summary:       The modular source code checker: pycodestyle, pyflakes and co.
 Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Name:          flake8
-Version:       3.5.0
-Release:       1
+# before updating to 4.x fork python-flake8.spec with last 3.x version
+Version:       3.9.2
+Release:       3
 License:       MIT
 Group:         Development/Tools
 #Source0Download: https://pypi.org/simple/flake8/
 Source0:       https://files.pythonhosted.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
-# Source0-md5: 7e5fe39d578a2c2d0962b61b35b8c3fc
-Patch0:                %{name}-mock.patch
+# Source0-md5: 5c102972d3d0f35255c56a20613fcec5
+Patch0:                %{name}-duplicate.patch
 URL:           https://gitlab.com/pycqa/flake8
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: rpm-pythonprov
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.7
-BuildRequires: python-setuptools >= 30
+BuildRequires: python-setuptools >= 1:30
 %if %{with tests}
 BuildRequires: python-configparser
 BuildRequires: python-enum34
+BuildRequires: python-functools32
+BuildRequires: python-importlib_metadata
 BuildRequires: python-mccabe >= 0.6.0
 BuildRequires: python-mccabe < 0.7.0
 BuildRequires: python-mock >= 2.0.0
-BuildRequires: python-pycodestyle >= 2.0.0
-BuildRequires: python-pycodestyle < 2.4.0
-BuildRequires: python-pyflakes >= 1.5.0
-BuildRequires: python-pyflakes < 1.7.0
+BuildRequires: python-pycodestyle >= 2.7.0
+BuildRequires: python-pycodestyle < 2.8.0
+BuildRequires: python-pyflakes >= 2.3.0
+BuildRequires: python-pyflakes < 2.4.0
 BuildRequires: python-pytest
-BuildRequires: python-pytest-runner
+BuildRequires: python-typing
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.4
-BuildRequires: python3-setuptools >= 30
+BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-setuptools >= 1:30
 %if %{with tests}
+%if "%{py3_ver}" < "3.8"
+BuildRequires: python3-importlib_metadata
+%endif
 BuildRequires: python3-mccabe >= 0.6.0
 BuildRequires: python3-mccabe < 0.7.0
-BuildRequires: python3-pycodestyle >= 2.0.0
-BuildRequires: python3-pycodestyle < 2.4.0
-BuildRequires: python3-pyflakes >= 1.5.0
-BuildRequires: python3-pyflakes < 1.7.0
+BuildRequires: python3-pycodestyle >= 2.7.0
+BuildRequires: python3-pycodestyle < 2.8.0
+BuildRequires: python3-pyflakes >= 2.3.0
+BuildRequires: python3-pyflakes < 2.4.0
 BuildRequires: python3-pytest
-BuildRequires: python3-pytest-runner
 BuildRequires: sed >= 4.0
 %endif
 %endif
 %if %{with doc}
 BuildRequires: python3-sphinx-prompt
-BuildRequires: sphinx-pdg-3
+BuildRequires: sphinx-pdg-3 >= 1.3
 %endif
 %if %{with python3}
 Requires:      python3-flake8 = %{version}-%{release}
@@ -77,10 +82,16 @@ dla narzędzi:
 - skrypt McCabe autorstwa Neda Batcheldera
 
 %package -n python-flake8
-Summary:       The modular source code checker: pycodestyle, pyflakes and co
+Summary:       The modular source code checker: pycodestyle, pyflakes and co.
 Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Group:         Libraries/Python
+Requires:      python-mccabe >= 0.6.0
+Requires:      python-mccabe < 0.7.0
 Requires:      python-modules >= 1:2.7
+Requires:      python-pycodestyle >= 2.7.0
+Requires:      python-pycodestyle < 2.8.0
+Requires:      python-pyflakes >= 2.3.0
+Requires:      python-pyflakes < 2.4.0
 
 %description -n python-flake8
 The modular source code checker. It is a wrapper around these tools:
@@ -99,7 +110,13 @@ dla narzędzi:
 Summary:       The modular source code checker: pycodestyle, pyflakes and co
 Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Group:         Libraries/Python
+Requires:      python3-mccabe >= 0.6.0
+Requires:      python3-mccabe < 0.7.0
 Requires:      python3-modules >= 1:3.4
+Requires:      python3-pycodestyle >= 2.7.0
+Requires:      python3-pycodestyle < 2.8.0
+Requires:      python3-pyflakes >= 2.3.0
+Requires:      python3-pyflakes < 2.4.0
 
 %description -n python3-flake8
 The modular source code checker. It is a wrapper around these tools:
@@ -131,14 +148,26 @@ Dokumentacja API modułu Pythona flake8.
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTHONPATH=$(pwd)/src \
+%{__python} -m pytest -rw tests
+%endif
 %endif
 
 %if %{with python3}
 # don't require standalone mock
 %{__sed} -i -e 's/import mock/from unittest import mock/' $(grep 'import mock' tests/ -rl)
 
-%py3_build %{?with_tests:test}
+%py3_build
+
+%if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest -rw tests
+%endif
 %endif
 
 %if %{with doc}
@@ -159,11 +188,6 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %py3_install
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/flake8{,-3}
-
-# avoid dependencies on python3egg(configparser), python3egg(enum34)
-%{__sed} -i -e "/^\[:python_version *< *'3\.2']/,/^$/ d" \
-       -e "/^\[:python_version *< *'3\.4']/,/^$/ d" \
-       $RPM_BUILD_ROOT%{py3_sitescriptdir}/flake8-%{version}-py*.egg-info/requires.txt
 %endif
 
 ln -s flake-%{!?with_python3:2}%{?with_python3:3} $RPM_BUILD_ROOT%{_bindir}/flake8
This page took 0.075926 seconds and 4 git commands to generate.