]> git.pld-linux.org Git - packages/flake8.git/blobdiff - flake8.spec
Release 3 (by relup.sh)
[packages/flake8.git] / flake8.spec
index ba8d9aa3c68c5bd3f1ca08368a4ddd47228ff1f6..552e2671c2d368d418a0daededd282de3add6b46 100644 (file)
@@ -2,41 +2,63 @@
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
-%bcond_without tests   # do not perform "make test"
+%bcond_with    tests   # pytest tests
+%bcond_without doc     # Sphinx documentation
 
-Summary:       The modular source code checker: pep8, pyflakes and co
-Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pep8, pyflakes itp.
+Summary:       The modular source code checker: pycodestyle, pyflakes and co.
+Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Name:          flake8
-Version:       2.5.4
-Release:       1
+# before updating to 4.x fork python-flake8.spec with last 3.x version
+Version:       3.9.2
+Release:       3
 License:       MIT
 Group:         Development/Tools
-#Source0Download: https://pypi.python.org/simple/flake8/
-Source0:       https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
-# Source0-md5: a4585b3569b95c3f66acb8294a7f06ef
-URL:           https://pypi.python.org/pypi/flake8
+#Source0Download: https://pypi.org/simple/flake8/
+Source0:       https://files.pythonhosted.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
+# Source0-md5: 5c102972d3d0f35255c56a20613fcec5
+Patch0:                %{name}-duplicate.patch
+URL:           https://gitlab.com/pycqa/flake8
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: rpm-pythonprov
 %if %{with python2}
-BuildRequires: python-modules >= 1:2.5
-BuildRequires: python-setuptools
+BuildRequires: python-modules >= 1:2.7
+BuildRequires: python-setuptools >= 1:30
 %if %{with tests}
-BuildRequires: python-mccabe >= 0.2.1
-BuildRequires: python-mock
-BuildRequires: python-nose
-BuildRequires: python-pep8 >= 1.5.7
-BuildRequires: python-pyflakes >= 0.8.1
+BuildRequires: python-configparser
+BuildRequires: python-enum34
+BuildRequires: python-functools32
+BuildRequires: python-importlib_metadata
+BuildRequires: python-mccabe >= 0.6.0
+BuildRequires: python-mccabe < 0.7.0
+BuildRequires: python-mock >= 2.0.0
+BuildRequires: python-pycodestyle >= 2.7.0
+BuildRequires: python-pycodestyle < 2.8.0
+BuildRequires: python-pyflakes >= 2.3.0
+BuildRequires: python-pyflakes < 2.4.0
+BuildRequires: python-pytest
+BuildRequires: python-typing
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.2
-BuildRequires: python3-setuptools
+BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-setuptools >= 1:30
 %if %{with tests}
-BuildRequires: python3-mccabe >= 0.2.1
-BuildRequires: python3-nose
-BuildRequires: python3-pep8 >= 1.5.7
-BuildRequires: python3-pyflakes >= 0.8.1
+%if "%{py3_ver}" < "3.8"
+BuildRequires: python3-importlib_metadata
 %endif
+BuildRequires: python3-mccabe >= 0.6.0
+BuildRequires: python3-mccabe < 0.7.0
+BuildRequires: python3-pycodestyle >= 2.7.0
+BuildRequires: python3-pycodestyle < 2.8.0
+BuildRequires: python3-pyflakes >= 2.3.0
+BuildRequires: python3-pyflakes < 2.4.0
+BuildRequires: python3-pytest
+BuildRequires: sed >= 4.0
+%endif
+%endif
+%if %{with doc}
+BuildRequires: python3-sphinx-prompt
+BuildRequires: sphinx-pdg-3 >= 1.3
 %endif
 %if %{with python3}
 Requires:      python3-flake8 = %{version}-%{release}
@@ -49,64 +71,109 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 The modular source code checker. It is a wrapper around these tools:
 - PyFlakes
-- pep8
+- pycodestyle
 - Ned Batchelder's McCabe script
 
 %description -l pl.UTF-8
 Modularne narzędzie do sprawdzania kodu źródłowego. Jest to opakowanie
 dla narzędzi:
 - PyFlakes
-- pep8
+- pycodestyle
 - skrypt McCabe autorstwa Neda Batcheldera
 
 %package -n python-flake8
-Summary:       The modular source code checker: pep8, pyflakes and co
-Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pep8, pyflakes itp.
+Summary:       The modular source code checker: pycodestyle, pyflakes and co.
+Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Group:         Libraries/Python
-Requires:      python-modules
+Requires:      python-mccabe >= 0.6.0
+Requires:      python-mccabe < 0.7.0
+Requires:      python-modules >= 1:2.7
+Requires:      python-pycodestyle >= 2.7.0
+Requires:      python-pycodestyle < 2.8.0
+Requires:      python-pyflakes >= 2.3.0
+Requires:      python-pyflakes < 2.4.0
 
 %description -n python-flake8
 The modular source code checker. It is a wrapper around these tools:
 - PyFlakes
-- pep8
+- pycodestyle
 - Ned Batchelder's McCabe script
 
 %description -n python-flake8 -l pl.UTF-8
 Modularne narzędzie do sprawdzania kodu źródłowego. Jest to opakowanie
 dla narzędzi:
 - PyFlakes
-- pep8
+- pycodestyle
 - skrypt McCabe autorstwa Neda Batcheldera
 
 %package -n python3-flake8
-Summary:       The modular source code checker: pep8, pyflakes and co
-Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pep8, pyflakes itp.
+Summary:       The modular source code checker: pycodestyle, pyflakes and co
+Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-mccabe >= 0.6.0
+Requires:      python3-mccabe < 0.7.0
+Requires:      python3-modules >= 1:3.4
+Requires:      python3-pycodestyle >= 2.7.0
+Requires:      python3-pycodestyle < 2.8.0
+Requires:      python3-pyflakes >= 2.3.0
+Requires:      python3-pyflakes < 2.4.0
 
 %description -n python3-flake8
 The modular source code checker. It is a wrapper around these tools:
 - PyFlakes
-- pep8
+- pycodestyle
 - Ned Batchelder's McCabe script
 
 %description -n python3-flake8 -l pl.UTF-8
 Modularne narzędzie do sprawdzania kodu źródłowego. Jest to opakowanie
 dla narzędzi:
 - PyFlakes
-- pep8
+- pycodestyle
 - skrypt McCabe autorstwa Neda Batcheldera
 
+%package -n python-flake8-apidocs
+Summary:       API documentation for Python flake8 module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona flake8
+Group:         Documentation
+
+%description -n python-flake8-apidocs
+API documentation for Python flake8 module.
+
+%description -n python-flake8-apidocs -l pl.UTF-8
+Dokumentacja API modułu Pythona flake8.
+
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTHONPATH=$(pwd)/src \
+%{__python} -m pytest -rw tests
+%endif
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+# don't require standalone mock
+%{__sed} -i -e 's/import mock/from unittest import mock/' $(grep 'import mock' tests/ -rl)
+
+%py3_build
+
+%if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest -rw tests
+%endif
+%endif
+
+%if %{with doc}
+cd docs/source
+PYTHONPATH=$(pwd)/../../src \
+sphinx-build-3 -b html . _build/html
 %endif
 
 %install
@@ -114,26 +181,28 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %py_install
-cp -p $RPM_BUILD_ROOT%{_bindir}/flake8{,-2}
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/flake8{,-2}
 %py_postclean
 %endif
 
 %if %{with python3}
 %py3_install
-cp -p $RPM_BUILD_ROOT%{_bindir}/flake8{,-3}
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/flake8{,-3}
 %endif
 
+ln -s flake-%{!?with_python3:2}%{?with_python3:3} $RPM_BUILD_ROOT%{_bindir}/flake8
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.rst CONTRIBUTORS.txt LICENSE README.rst
 %attr(755,root,root) %{_bindir}/flake8
 
 %if %{with python2}
 %files -n python-flake8
 %defattr(644,root,root,755)
+%doc CONTRIBUTORS.txt LICENSE README.rst
 %attr(755,root,root) %{_bindir}/flake8-2
 %{py_sitescriptdir}/flake8
 %{py_sitescriptdir}/flake8-%{version}-py*.egg-info
@@ -142,7 +211,14 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-flake8
 %defattr(644,root,root,755)
+%doc CONTRIBUTORS.txt LICENSE README.rst
 %attr(755,root,root) %{_bindir}/flake8-3
 %{py3_sitescriptdir}/flake8
 %{py3_sitescriptdir}/flake8-%{version}-py*.egg-info
 %endif
+
+%if %{with doc}
+%files -n python-flake8-apidocs
+%defattr(644,root,root,755)
+%doc docs/source/_build/html/{_modules,_static,internal,plugin-development,release-notes,user,*.html,*.js}
+%endif
This page took 0.102324 seconds and 4 git commands to generate.