]> git.pld-linux.org Git - packages/flake8.git/blobdiff - flake8.spec
Release 3 (by relup.sh)
[packages/flake8.git] / flake8.spec
index 6bcfc9689f5b16f57012a5f1a464bcd853a3e492..552e2671c2d368d418a0daededd282de3add6b46 100644 (file)
@@ -2,54 +2,56 @@
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
-%bcond_without tests   # pytest tests
+%bcond_with    tests   # pytest tests
 %bcond_without doc     # Sphinx documentation
 
-Summary:       The modular source code checker: pycodestyle, pyflakes and co
+Summary:       The modular source code checker: pycodestyle, pyflakes and co.
 Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Name:          flake8
-Version:       3.7.8
-Release:       1
+# before updating to 4.x fork python-flake8.spec with last 3.x version
+Version:       3.9.2
+Release:       3
 License:       MIT
 Group:         Development/Tools
 #Source0Download: https://pypi.org/simple/flake8/
 Source0:       https://files.pythonhosted.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
-# Source0-md5: 147957dd7f8af16117ae5c3e6b82df74
+# Source0-md5: 5c102972d3d0f35255c56a20613fcec5
+Patch0:                %{name}-duplicate.patch
 URL:           https://gitlab.com/pycqa/flake8
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: rpm-pythonprov
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.7
-BuildRequires: python-setuptools >= 30
+BuildRequires: python-setuptools >= 1:30
 %if %{with tests}
 BuildRequires: python-configparser
-BuildRequires: python-entrypoints >= 0.3
-BuildRequires: python-entrypoints < 0.4
 BuildRequires: python-enum34
 BuildRequires: python-functools32
+BuildRequires: python-importlib_metadata
 BuildRequires: python-mccabe >= 0.6.0
 BuildRequires: python-mccabe < 0.7.0
 BuildRequires: python-mock >= 2.0.0
-BuildRequires: python-pycodestyle >= 2.5.0
-BuildRequires: python-pycodestyle < 2.6.0
-BuildRequires: python-pyflakes >= 2.1.0
-BuildRequires: python-pyflakes < 2.2.0
+BuildRequires: python-pycodestyle >= 2.7.0
+BuildRequires: python-pycodestyle < 2.8.0
+BuildRequires: python-pyflakes >= 2.3.0
+BuildRequires: python-pyflakes < 2.4.0
 BuildRequires: python-pytest
 BuildRequires: python-typing
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.4
-BuildRequires: python3-setuptools >= 30
+BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-setuptools >= 1:30
 %if %{with tests}
-BuildRequires: python3-entrypoints >= 0.3
-BuildRequires: python3-entrypoints < 0.4
+%if "%{py3_ver}" < "3.8"
+BuildRequires: python3-importlib_metadata
+%endif
 BuildRequires: python3-mccabe >= 0.6.0
 BuildRequires: python3-mccabe < 0.7.0
-BuildRequires: python3-pycodestyle >= 2.5.0
-BuildRequires: python3-pycodestyle < 2.6.0
-BuildRequires: python3-pyflakes >= 2.1.0
-BuildRequires: python3-pyflakes < 2.2.0
+BuildRequires: python3-pycodestyle >= 2.7.0
+BuildRequires: python3-pycodestyle < 2.8.0
+BuildRequires: python3-pyflakes >= 2.3.0
+BuildRequires: python3-pyflakes < 2.4.0
 BuildRequires: python3-pytest
 BuildRequires: sed >= 4.0
 %endif
@@ -80,10 +82,16 @@ dla narzędzi:
 - skrypt McCabe autorstwa Neda Batcheldera
 
 %package -n python-flake8
-Summary:       The modular source code checker: pycodestyle, pyflakes and co
+Summary:       The modular source code checker: pycodestyle, pyflakes and co.
 Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Group:         Libraries/Python
+Requires:      python-mccabe >= 0.6.0
+Requires:      python-mccabe < 0.7.0
 Requires:      python-modules >= 1:2.7
+Requires:      python-pycodestyle >= 2.7.0
+Requires:      python-pycodestyle < 2.8.0
+Requires:      python-pyflakes >= 2.3.0
+Requires:      python-pyflakes < 2.4.0
 
 %description -n python-flake8
 The modular source code checker. It is a wrapper around these tools:
@@ -102,7 +110,13 @@ dla narzędzi:
 Summary:       The modular source code checker: pycodestyle, pyflakes and co
 Summary(pl.UTF-8):     Modularne narzędzie do sprawdzania kodu źródłowego: pycodestyle, pyflakes itp.
 Group:         Libraries/Python
+Requires:      python3-mccabe >= 0.6.0
+Requires:      python3-mccabe < 0.7.0
 Requires:      python3-modules >= 1:3.4
+Requires:      python3-pycodestyle >= 2.7.0
+Requires:      python3-pycodestyle < 2.8.0
+Requires:      python3-pyflakes >= 2.3.0
+Requires:      python3-pyflakes < 2.4.0
 
 %description -n python3-flake8
 The modular source code checker. It is a wrapper around these tools:
@@ -130,12 +144,14 @@ Dokumentacja API modułu Pythona flake8.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %if %{with python2}
 %py_build
 
 %if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
 PYTHONPATH=$(pwd)/src \
 %{__python} -m pytest -rw tests
 %endif
@@ -148,6 +164,7 @@ PYTHONPATH=$(pwd)/src \
 %py3_build
 
 %if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
 PYTHONPATH=$(pwd)/src \
 %{__python3} -m pytest -rw tests
 %endif
This page took 0.027016 seconds and 4 git commands to generate.