]> git.pld-linux.org Git - packages/flac.git/blame_incremental - flac.spec
- new URLs, updated to 1.3.0
[packages/flac.git] / flac.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4%bcond_without xmms # don't build XMMS plugin
5
6Summary: Free Lossless Audio Codec
7Summary(pl.UTF-8): Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8Name: flac
9Version: 1.3.0
10Release: 1
11License: BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
12Group: Libraries
13Source0: http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
14# Source0-md5: 13b5c214cee8373464d3d65dee362cdd
15URL: http://xiph.org/flac/
16BuildRequires: autoconf >= 2.60
17BuildRequires: automake >= 1:1.11
18# for AM_ICONV
19BuildRequires: gettext-devel
20BuildRequires: libogg-devel >= 2:1.0
21BuildRequires: libstdc++-devel
22BuildRequires: libtool >= 2:2
23%{?with_xmms:BuildRequires: rpmbuild(macros) >= 1.125}
24BuildRequires: tar >= 1:1.22
25%{?with_xmms:BuildRequires: xmms-devel >= 0.9.5.1}
26BuildRequires: xz
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30FLAC is an Open Source lossless audio codec developed by Josh Coalson.
31
32%description -l pl.UTF-8
33FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
34przez Josha Coalsona.
35
36%package devel
37Summary: FLAC - development files
38Summary(pl.UTF-8): FLAC - pliki nagłówkowe
39License: BSD
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: libogg-devel >= 2:1.0
43# for -c++ only
44#Requires: libstdc++-devel
45
46%description devel
47The package contains the development header files for FLAC libraries.
48
49%description devel -l pl.UTF-8
50Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
51
52%package static
53Summary: FLAC - static libraries
54Summary(pl.UTF-8): FLAC - biblioteki statyczne
55License: BSD
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60The package contains FLAC static libraries.
61
62%description static -l pl.UTF-8
63Ten pakiet zawiera biblioteki statyczne FLAC.
64
65%package c++
66Summary: FLAC++ - C++ API for FLAC codec
67Summary(pl.UTF-8): FLAC++ - API C++ do kodeka FLAC
68Group: Libraries
69Requires: %{name} = %{version}-%{release}
70
71%description c++
72FLAC++ - C++ API for FLAC codec.
73
74%description c++ -l pl.UTF-8
75FLAC++ - API C++ do kodeka FLAC.
76
77%package c++-devel
78Summary: Header files for FLAC++ library
79Summary(pl.UTF-8): Pliki nagłówkowe biblioteki FLAC++
80Group: Development/Libraries
81Requires: %{name}-c++ = %{version}-%{release}
82Requires: %{name}-devel = %{version}-%{release}
83
84%description c++-devel
85Header files for FLAC++ library.
86
87%description c++-devel -l pl.UTF-8
88Pliki nagłówkowe biblioteki FLAC++.
89
90%package c++-static
91Summary: Static FLAC++ library
92Summary(pl.UTF-8): Statyczna biblioteka FLAC++
93Group: Development/Libraries
94Requires: %{name}-c++-devel = %{version}-%{release}
95
96%description c++-static
97Static FLAC++ library.
98
99%description c++-static -l pl.UTF-8
100Statyczna biblioteka FLAC++.
101
102%package -n xmms-input-flac
103Summary: Free Lossless Audio Codec - XMMS plugin
104Summary(pl.UTF-8): Wtyczka FLAC dla XMMS
105License: GPL v2+
106Group: Libraries
107Requires: %{name} = %{version}-%{release}
108Requires: xmms >= 0.9.5.1
109
110%description -n xmms-input-flac
111FLAC input plugin for XMMS.
112
113%description -n xmms-input-flac -l pl.UTF-8
114Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
115
116%prep
117%setup -q
118
119%{__rm} m4/ogg.m4
120
121%build
122%{__libtoolize}
123%{__aclocal} -I m4
124%{__autoconf}
125%{__autoheader}
126%{__automake}
127%configure \
128 --disable-silent-rules \
129 %{?with_static_libs:--enable-static} \
130 %{!?with_xmms:--disable-xmms-plugin}
131
132%{__make}
133
134%install
135rm -rf $RPM_BUILD_ROOT
136
137%{__make} install \
138 DESTDIR=$RPM_BUILD_ROOT
139
140# no makefiles in doc dirs
141%{__rm} doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
142%{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
143%if %{with static_libs}
144%{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.a
145%endif
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post -p /sbin/ldconfig
151%postun -p /sbin/ldconfig
152
153%post c++ -p /sbin/ldconfig
154%postun c++ -p /sbin/ldconfig
155
156%files
157%defattr(644,root,root,755)
158%doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
159%lang(ru) %doc doc/html/ru
160%attr(755,root,root) %{_bindir}/flac
161%attr(755,root,root) %{_bindir}/metaflac
162%attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
163%attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
164%{_mandir}/man1/flac.1*
165%{_mandir}/man1/metaflac.1*
166
167%files devel
168%defattr(644,root,root,755)
169%attr(755,root,root) %{_libdir}/libFLAC.so
170%{_libdir}/libFLAC.la
171%{_includedir}/FLAC
172%{_pkgconfigdir}/flac.pc
173%{_aclocaldir}/libFLAC.m4
174
175%if %{with static_libs}
176%files static
177%defattr(644,root,root,755)
178%{_libdir}/libFLAC.a
179%endif
180
181%files c++
182%defattr(644,root,root,755)
183%attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
184%attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
185
186%files c++-devel
187%defattr(644,root,root,755)
188%attr(755,root,root) %{_libdir}/libFLAC++.so
189%{_libdir}/libFLAC++.la
190%{_includedir}/FLAC++
191%{_pkgconfigdir}/flac++.pc
192%{_aclocaldir}/libFLAC++.m4
193
194%if %{with static_libs}
195%files c++-static
196%defattr(644,root,root,755)
197%{_libdir}/libFLAC++.a
198%endif
199
200%if %{with xmms}
201%files -n xmms-input-flac
202%defattr(644,root,root,755)
203%attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
204%endif
This page took 0.301338 seconds and 4 git commands to generate.