]> git.pld-linux.org Git - packages/flac.git/commitdiff
- new URLs, updated to 1.3.0
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Jun 2013 14:37:17 +0000 (16:37 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Jun 2013 14:37:17 +0000 (16:37 +0200)
- removed obsolete gcc44,lt,crbug-111390,deb-643377 patches
- dropped outdated without_xmms patch, use configure switch instead

crbug-111390.patch [deleted file]
deb-643377.patch [deleted file]
flac-gcc44.patch [deleted file]
flac-lt.patch [deleted file]
flac-without_xmms.patch [deleted file]
flac.spec

diff --git a/crbug-111390.patch b/crbug-111390.patch
deleted file mode 100644 (file)
index 5886772..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-chrome fixes
-https://code.google.com/p/chromium/issues/detail?id=111390
-
-also in upstream:c
-http://git.xiph.org/?p=flac.git;a=commitdiff;h=6c8d740c1a0bf01605bdd05fe6765ff841dd082a
-http://git.xiph.org/?p=flac.git;a=commitdiff;h=19e3918d4e35f4ab99e7fcc58c169025c576dd16
---- flac-1.2.1/src/libFLAC/md5.c       2007-09-10 23:49:47.000000000 +0000
-+++ ../chromium-browser-23.0.1271.64/src/third_party/flac/src/libFLAC/md5.c    2012-10-31 19:03:12.000000000 +0000
-@@ -263,12 +263,12 @@
-       byteSwap(ctx->buf, 4);
-       memcpy(digest, ctx->buf, 16);
--      memset(ctx, 0, sizeof(ctx));    /* In case it's sensitive */
-       if(0 != ctx->internal_buf) {
-               free(ctx->internal_buf);
-               ctx->internal_buf = 0;
-               ctx->capacity = 0;
-       }
-+      memset(ctx, 0, sizeof(*ctx));   /* In case it's sensitive */
- }
- /*
diff --git a/deb-643377.patch b/deb-643377.patch
deleted file mode 100644 (file)
index fc12d6b..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-From: Erik de Castro Lopo <erikd@mega-nerd.com>
-Date: Mon, 13 Feb 2012 08:58:08 +0000 (+1100)
-Subject: Fix -Werror=format-security errors.
-X-Git-Url: http://git.xiph.org/?p=flac.git;a=commitdiff_plain;h=a4ffcc0239cbf7384146f0d0e6770e1dbb1b58c4
-
-Fix -Werror=format-security errors.
-
-Fixes "format not a string literal and no format arguments
- [-Werror=format-security]" errors.
-
-Patch from Fabian Greffrath <fabian+debian@greffrath.com> via Debian.
-Closes Debian bug #643377.
----
-
---- flac-1.2.1/src/test_grabbag/cuesheet/main.c~       2007-02-02 06:26:04.000000000 +0000
-+++ flac-1.2.1/src/test_grabbag/cuesheet/main.c        2012-11-12 22:19:10.859497990 +0000
-@@ -115,12 +115,12 @@
-       const char *usage = "usage: test_cuesheet cuesheet_file lead_out_offset [ cdda ]\n";
-       if(argc > 1 && 0 == strcmp(argv[1], "-h")) {
--              printf(usage);
-+              printf("%s", usage);
-               return 0;
-       }
-       if(argc < 3 || argc > 4) {
--              fprintf(stderr, usage);
-+              fprintf(stderr, "%s", usage);
-               return 255;
-       }
-@@ -129,7 +129,7 @@
-               if(0 == strcmp(argv[3], "cdda"))
-                       is_cdda = true;
-               else {
--                      fprintf(stderr, usage);
-+                      fprintf(stderr, "%s", usage);
-                       return 255;
-               }
-       }
-diff --git a/src/test_grabbag/picture/main.c b/src/test_grabbag/picture/main.c
-index b59afd1..a1880ae 100644
---- a/src/test_grabbag/picture/main.c
-+++ b/src/test_grabbag/picture/main.c
-@@ -211,12 +211,12 @@ int main(int argc, char *argv[])
-       const char *usage = "usage: test_pictures path_prefix\n";
-       if(argc > 1 && 0 == strcmp(argv[1], "-h")) {
--              printf(usage);
-+              printf("%s", usage);
-               return 0;
-       }
-       if(argc != 2) {
--              fprintf(stderr, usage);
-+              fprintf(stderr, "%s", usage);
-               return 255;
-       }
-diff --git a/src/test_seeking/main.c b/src/test_seeking/main.c
-index d1f11d6..589e859 100644
---- a/src/test_seeking/main.c
-+++ b/src/test_seeking/main.c
-@@ -418,7 +418,7 @@ int main(int argc, char *argv[])
-       static const char * const usage = "usage: test_seeking file.flac [#seeks] [#samples-in-file.flac] [file.raw]\n";
-       if (argc < 2 || argc > 5) {
--              fprintf(stderr, usage);
-+              fprintf(stderr, "%s", usage);
-               return 1;
-       }
diff --git a/flac-gcc44.patch b/flac-gcc44.patch
deleted file mode 100644 (file)
index c61b44f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urN flac-1.2.1/examples/cpp/encode/file/main.cpp flac-1.2.1.new/examples/cpp/encode/file/main.cpp
---- flac-1.2.1/examples/cpp/encode/file/main.cpp       2007-09-13 17:58:03.000000000 +0200
-+++ flac-1.2.1.new/examples/cpp/encode/file/main.cpp   2009-05-30 14:46:26.680924245 +0200
-@@ -30,6 +30,7 @@
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include "FLAC++/metadata.h"
- #include "FLAC++/encoder.h"
diff --git a/flac-lt.patch b/flac-lt.patch
deleted file mode 100644 (file)
index dc2802b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN flac-1.2.1/configure.in flac-1.2.1.new/configure.in
---- flac-1.2.1/configure.in    2007-09-13 17:48:42.000000000 +0200
-+++ flac-1.2.1.new/configure.in        2009-05-30 14:43:18.867607346 +0200
-@@ -29,6 +29,10 @@
- # one that builds only static.  This is because the resulting libtool
- # does not allow us to choose which to build at runtime.
- AM_PROG_LIBTOOL
-+
-+dnl when using libtool 2.x create libtool early, because it's used in configure
-+m4_ifdef([LT_OUTPUT], [LT_OUTPUT])
-+
- sed -e 's/^build_old_libs=yes/build_old_libs=no/' libtool > libtool-disable-static
- chmod +x libtool-disable-static
diff --git a/flac-without_xmms.patch b/flac-without_xmms.patch
deleted file mode 100644 (file)
index 9e3dcbe..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -urN aaa/flac-1.1.3/configure.in flac-1.1.3/configure.in
---- aaa/flac-1.1.3/configure.in        2006-11-20 22:29:34.000000000 +0100
-+++ flac-1.1.3/configure.in    2006-12-03 21:58:01.413969320 +0100
-@@ -225,10 +225,6 @@
-       no)  enable_xmms_plugin=false ;;
-       *) AC_MSG_ERROR(bad value ${enableval} for --enable-xmms-plugin) ;;
- esac],[enable_xmms_plugin=true])
--if test "x$enable_xmms_plugin" != xfalse ; then
--      AM_PATH_XMMS(0.9.5.1, , AC_MSG_WARN([*** XMMS >= 0.9.5.1 not installed - XMMS support will not be built]))
--fi
--AM_CONDITIONAL(FLaC__HAS_XMMS, test -n "$XMMS_INPUT_PLUGIN_DIR")
- dnl build FLAC++ or not
- AC_ARG_ENABLE([cpplibs],
-diff -urN aaa/flac-1.1.3/src/Makefile.am flac-1.1.3/src/Makefile.am
---- aaa/flac-1.1.3/src/Makefile.am     2006-10-14 05:35:42.000000000 +0200
-+++ flac-1.1.3/src/Makefile.am 2006-12-03 21:59:27.660857800 +0100
-@@ -15,10 +15,6 @@
- #  restrictive of those mentioned above.  See the file COPYING.Xiph in this
- #  distribution.
--if FLaC__HAS_XMMS
--XMMS_DIRS = plugin_common plugin_xmms
--endif
--
- if FLaC__WITH_CPPLIBS
- CPPLIBS_DIRS = libFLAC++ test_libFLAC++
- endif
index ed76c6bc7b7503504eba0eebd46b493f3132e526..a49ad94f299ad1f4c262a54ec75bb24c44675a8f 100644 (file)
--- a/flac.spec
+++ b/flac.spec
@@ -6,27 +6,24 @@
 Summary:       Free Lossless Audio Codec
 Summary(pl.UTF-8):     Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
 Name:          flac
-Version:       1.2.1
-Release:       7
-License:       BSD (libFLAC/libFLAC++), GPL (programs and plugins)
+Version:       1.3.0
+Release:       1
+License:       BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
-# Source0-md5: 153c8b15a54da428d1f0fadc756c22c7
-Patch0:                %{name}-without_xmms.patch
-Patch1:                %{name}-lt.patch
-Patch2:                %{name}-gcc44.patch
-Patch3:                crbug-111390.patch
-Patch4:                deb-643377.patch
-URL:           http://flac.sourceforge.net/
-BuildRequires: autoconf
-BuildRequires: automake >= 1:1.7
+Source0:       http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
+# Source0-md5: 13b5c214cee8373464d3d65dee362cdd
+URL:           http://xiph.org/flac/
+BuildRequires: autoconf >= 2.60
+BuildRequires: automake >= 1:1.11
 # for AM_ICONV
 BuildRequires: gettext-devel
 BuildRequires: libogg-devel >= 2:1.0
 BuildRequires: libstdc++-devel
-BuildRequires: libtool >= 2:1.4d-3
+BuildRequires: libtool >= 2:2
 %{?with_xmms:BuildRequires:    rpmbuild(macros) >= 1.125}
+BuildRequires: tar >= 1:1.22
 %{?with_xmms:BuildRequires:    xmms-devel >= 0.9.5.1}
+BuildRequires: xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -108,7 +105,7 @@ Summary(pl.UTF-8):  Wtyczka FLAC dla XMMS
 License:       GPL v2+
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      xmms
+Requires:      xmms >= 0.9.5.1
 
 %description -n xmms-input-flac
 FLAC input plugin for XMMS.
@@ -118,11 +115,6 @@ Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
 
 %prep
 %setup -q
-%{!?with_xmms:%patch0 -p1}
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %{__rm} m4/ogg.m4
 
@@ -133,7 +125,9 @@ Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
 %{__autoheader}
 %{__automake}
 %configure \
-       %{!?with_static_libs:--disable-static}
+       --disable-silent-rules \
+       %{?with_static_libs:--enable-static} \
+       %{!?with_xmms:--disable-xmms-plugin}
 
 %{__make}
 
@@ -144,8 +138,11 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # no makefiles in doc dirs
-rm -f doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
-rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
+%{__rm} doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
+%{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
+%if %{with static_libs}
+%{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.a
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.128768 seconds and 4 git commands to generate.