]> git.pld-linux.org Git - packages/firstboot.git/blame - firstboot.spec
- for anaconda
[packages/firstboot.git] / firstboot.spec
CommitLineData
5ef8d4b3
ER
1Summary: Initial system configuration utility
2Name: firstboot
3Version: 1.4.6
4Release: 0.1
5License: GPL
6Group: Base
7URL: http://fedora.redhat.com/projects/config-tools/
8Source0: %{name}-%{version}.tar.bz2
9# Source0-md5: bea227cd82be988b9638e239f3380dfb
10BuildRequires: gettext-devel
11#Requires: /etc/init.d
12#Requires: authconfig-gtk
13#Requires: chkconfig
14#Requires: firstboot-tui
15#Requires: libuser
16#Requires: metacity
17Requires: python-pygtk-gtk
18Requires: python-rhpl
19Requires: python-rhpxl
20#Requires: redhat-artwork
21#Requires: redhat-logos
22#Requires: system-config-date >= 1.7.9
23#Requires: system-config-display
24#Requires: system-config-keyboard
25#Requires: system-config-language
26#Requires: system-config-network
27#Requires: system-config-securitylevel
28#Requires: system-config-soundcard
29#Requires: system-config-users
30ExcludeArch: s390 s390x ppc64
31ExclusiveOS: Linux
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36The firstboot utility runs after installation. It guides the user
37through a series of steps that allows for easier configuration of the
38machine.
39
40%package tui
41Summary: A text interface for firstboot
42Group: Base
43#Requires: /etc/init.d
44#Requires: authconfig
45#Requires: chkconfig
46#Requires: netconfig
47#Requires: ntsysv
48#Requires: python
49#Requires: python-rhpl
50#Requires: system-config-securitylevel-tui
51#Requires: usermode >= 1.36
52
53%description tui
54firstboot-tui is a text interface for initial system configuration.
55
56%prep
57%setup -q
58
59%build
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%{__make} install \
65 INSTROOT=$RPM_BUILD_ROOT
66
67%py_comp $RPM_BUILD_ROOT/usr/share/firstboot
68%py_ocomp $RPM_BUILD_ROOT/usr/share/firstboot
69%py_postclean /usr/share/firstboot
70
71%find_lang %{name}
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post tui
77#/sbin/chkconfig --add firstboot
78
79%preun tui
80if [ "$1" = 0 ]; then
81 /sbin/chkconfig --del firstboot
82fi
83
84%files -f %{name}.lang
85%defattr(644,root,root,755)
86%dir /usr/share/firstboot
87%dir /usr/share/firstboot/modules
88%dir /usr/share/firstboot/pixmaps
89/usr/share/firstboot/exceptionWindow.py[co]
90/usr/share/firstboot/firstbootWindow.py[co]
91/usr/share/firstboot/firstboot_module_window.py[co]
92/usr/share/firstboot/xfirstboot.py[co]
93/usr/share/firstboot/modules/*
94/usr/share/firstboot/pixmaps/*
95
96%files -f %{name}.lang tui
97%defattr(644,root,root,755)
98%attr(754,root,root) /etc/rc.d/init.d/firstboot
99%dir /usr/share/firstboot/
100%attr(755,root,root) %{_sbindir}/firstboot
101/usr/share/firstboot/constants_text.py[co]
102/usr/share/firstboot/eula_strings.py[co]
103/usr/share/firstboot/firstboot.py[co]
104/usr/share/firstboot/firstbootBackend.py[co]
105/usr/share/firstboot/functions.py[co]
106/usr/share/firstboot/textWindow.py[co]
This page took 0.422099 seconds and 4 git commands to generate.