]> git.pld-linux.org Git - packages/firewall-init-ipchains.git/blob - firewall-init-ipchains.spec
d83cd7eb5f90f91d87f8c9908e0c478f14a78654
[packages/firewall-init-ipchains.git] / firewall-init-ipchains.spec
1 Summary:        Firewall SysV-init style start-up script
2 Summary(pl):    Skrypt startowy firewalla
3 Name:           firewall-init
4 Version:        2.1
5 Release:        2@2.2
6 License:        BSD
7 Group:          Networking/Admin
8 Source0:        ftp://ftp.lj.pl/pub/linux/%{name}-%{version}.tar.gz
9 Requires:       ipchains
10 Prereq:         rc-scripts
11 Prereq:         /sbin/chkconfig
12 Buildarch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Firewall-init is meant to provide an easy to use interface to start
17 and stopping the kernel IP packet filters and accounting through
18 ipchains(8).
19
20 %description -l pl
21 Dziêki firewall-init uzyskuje siê ³atwy interfejs do startowania i
22 stopowania filtrów IP j±dra oraz zliczania pakietów poprzez
23 ipchains(8).
24
25 %prep
26 %setup -q
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT/etc/{sysconfig/firewall-rules,rc.d/init.d}
31
32 install firewall.init $RPM_BUILD_ROOT/etc/rc.d/init.d/firewall
33 install firewall $RPM_BUILD_ROOT/etc/sysconfig/
34
35 for i in input output forward; do
36         echo '#<policy> <proto> <s_addr/s_mask> <s_port> <d_addr/d_mask> <d_port> <interface> <options>' > \
37                 $RPM_BUILD_ROOT/etc/sysconfig/firewall-rules/${i}
38 done
39
40 gzip -9nf README
41
42 %post
43 /sbin/chkconfig --add firewall
44
45 %postun
46 if [ "$1" = "0" ]; then
47         /sbin/chkconfig --del firewall
48 fi
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README.gz input.example
56 %attr(600,root,root) %verify(not size mtime md5) %config(noreplace) /etc/sysconfig/firewall
57 %attr(600,root,root) %verify(not size mtime md5) %config(noreplace) /etc/sysconfig/firewall-rules/*
58 %attr(700,root,root) %dir /etc/sysconfig/firewall-rules
59 %attr(754,root,root) /etc/rc.d/init.d/firewall
This page took 0.046668 seconds and 2 git commands to generate.