]> git.pld-linux.org Git - packages/firestarter.git/blob - firestarter.spec
92383a4f3416bdfb9885ed045a6a75ce3e95dd59
[packages/firestarter.git] / firestarter.spec
1 Summary:        A GNOME firewall tool
2 Summary(pl):    Narzêdzie do konfiguracji firewalla dzia³aj±ce w ¶rodowisku GNOME
3 Name:           firestarter
4 Version:        1.0.3
5 Release:        2
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/firestarter/%{name}-%{version}.tar.gz
9 # Source0-md5:  f46860a9e16dac4b693bd05f16370b03
10 Source1:        %{name}.init
11 Patch0:         %{name}-desktop.patch
12 Patch1:         %{name}-locale_names.patch
13 Patch2:         %{name}-script.patch
14 URL:            http://www.fs-security.com/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  gtk+2-devel >= 1:2.0.0
19 BuildRequires:  intltool
20 BuildRequires:  libgnome-devel >= 2.0.0
21 BuildRequires:  libgnomeui-devel >= 2.0.0
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  sed >= 4.0
25 Requires(post,preun):   /sbin/chkconfig
26 Requires:       iptables
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FireStarter is an easy-to-use, yet powerful, Linux firewall tool for
31 GNOME. Use it to quickly set up a secure environment using the
32 firewall creation wizard, or use it's monitoring and administrating
33 features with your old firewall scripts.
34
35 %description -l pl
36 FireStarter jest ³atwym w u¿yciu, lecz potê¿nym narzêdziem do
37 konfiguracji firewalla dzia³aj±cym w ¶rodowisku GNOME. Mo¿esz go u¿yæ,
38 by szybko stworzyæ bezpieczne ¶rodowisko korzystaj±c z kreatora
39 tworzenia firewalla, lub skorzystaæ z jego mo¿liwo¶ci monitorowania i
40 administrowania wraz z istniej±cymi regu³ami firewalla.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47
48 mv -f po/{no,nb}.po
49
50 %build
51 %{__libtoolize}
52 %{__aclocal}
53 %{__autoconf}
54 %{__automake}
55 %configure
56 %{__sed} -i 's/xml::\/etc\//xml::\$PREFIX\/etc\//' Makefile
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d}
62 install -d $RPM_BUILD_ROOT%{_sbindir}
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT \
66         Applicationsdir=%{_desktopdir}
67
68 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/firestarter
69 install firestarter.pam $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/firestarter
70
71 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound
72 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound
73 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/configuration
74 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-hosts
75 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-ports
76 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firestarter.sh
77 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firewall
78 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/sysctl-tuning
79 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-pre
80 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-post
81 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-from
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-service
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/forward
84 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/setup
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-from
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-service
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-to
88 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-from
89 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-service
90 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-to
91 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/setup
92
93 mv $RPM_BUILD_ROOT%{_bindir}/firestarter $RPM_BUILD_ROOT%{_sbindir}
94
95 echo -e "#!/bin/sh
96 if [ -x %{_bindir}/gksudo ] ; then
97         gksudo -g %{_sbindir}/firestarter
98 elif [ -x %{_bindir}/kdesu ] ; then
99         kdesu %{_sbindir}/firestarter
100 else
101         %{_sbindir}/firestarter
102 fi" > $RPM_BUILD_ROOT%{_bindir}/firestarter
103
104 %find_lang %{name} --with-gnome
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 %gconf_schema_install firestarter.schemas
111 %update_desktop_database_post
112 /sbin/chkconfig --add firestarter
113 if [ -f /var/lock/subsys/firestarter ]; then
114         /etc/rc.d/init.d/firestarter restart 1>&2
115 else
116         echo "Run \"/etc/rc.d/init.d/firestarter start\" to start firestarter."
117 fi
118
119 %preun
120 if [ $1 = 0 ]; then
121     %gconf_schema_uninstall firestarter.schemas
122         if [ -f /var/lock/subsys/firestarter ]; then
123                 /etc/rc.d/init.d/firestarter stop 1>&2
124         fi
125         /sbin/chkconfig --del firestarter
126 fi
127
128 %postun
129 %update_desktop_database_postun
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc README ChangeLog AUTHORS TODO CREDITS
134 %attr(755,root,root) %{_bindir}/firestarter
135 %attr(755,root,root) %{_sbindir}/firestarter
136 %attr(754,root,root) /etc/rc.d/init.d/*
137 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/firestarter
138 %{_desktopdir}/firestarter.desktop
139 %{_datadir}/%{name}
140 %{_pixmapsdir}/*
141 %dir %attr(700,root,root) %{_sysconfdir}/%{name}
142 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/inbound
143 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/outbound
144 %config(noreplace) %attr(700,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firestarter.sh
145 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/inbound/*
146 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/outbound/*
147 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/configuration
148 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/events-filter-*
149 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firewall
150 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/non-routables
151 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/sysctl-tuning
152 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/user-*
153 %{_sysconfdir}/gconf/schemas/*
This page took 0.072124 seconds and 2 git commands to generate.