]> git.pld-linux.org Git - packages/firestarter.git/blob - firestarter.spec
- fix DHCP requests
[packages/firestarter.git] / firestarter.spec
1 Summary:        A GNOME firewall tool
2 Summary(pl):    Narzêdzie do konfiguracji firewalla dzia³aj±ce w ¶rodowisku GNOME
3 Name:           firestarter
4 Version:        1.0.3
5 Release:        0.5
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/firestarter/%{name}-%{version}.tar.gz
9 # Source0-md5:  f46860a9e16dac4b693bd05f16370b03
10 Source1:        %{name}.init
11 Patch0:         %{name}-acfix.patch
12 Patch1:         %{name}-desktop.patch
13 Patch2:         %{name}-locale_names.patch
14 Patch3:         %{name}-script.patch
15 URL:            http://www.fs-security.com/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  gtk+2-devel >= 1:2.0.0
20 BuildRequires:  intltool
21 BuildRequires:  libgnome-devel >= 2.0.0
22 BuildRequires:  libgnomeui-devel >= 2.0.0
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig
25 BuildRequires:  sed >= 4.0
26 Requires(post,preun):   /sbin/chkconfig
27 Requires:       iptables
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 FireStarter is an easy-to-use, yet powerful, Linux firewall tool for
32 GNOME. Use it to quickly set up a secure environment using the
33 firewall creation wizard, or use it's monitoring and administrating
34 features with your old firewall scripts.
35
36 %description -l pl
37 FireStarter jest ³atwym w u¿yciu, lecz potê¿nym narzêdziem do
38 konfiguracji firewalla dzia³aj±cym w ¶rodowisku GNOME. Mo¿esz go u¿yæ,
39 by szybko stworzyæ bezpieczne ¶rodowisko korzystaj±c z kreatora
40 tworzenia firewalla, lub skorzystaæ z jego mo¿liwo¶ci monitorowania i
41 administrowania wraz z istniej±cymi regu³ami firewalla.
42
43 %prep
44 %setup -q
45 #%patch0 -p0 # really required?
46 %patch1 -p1
47 %patch2 -p1
48 %patch3 -p1
49
50 mv -f po/{no,nb}.po
51
52 %build
53 %{__libtoolize}
54 %{__aclocal}
55 %{__autoconf}
56 %{__automake}
57 %configure
58 %{__sed} -i 's/xml::\/etc\//xml::\$PREFIX\/etc\//' Makefile
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d}
64 install -d $RPM_BUILD_ROOT%{_sbindir}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT \
68         Applicationsdir=%{_desktopdir}
69
70 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/firestarter
71 install firestarter.pam $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/firestarter
72
73 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound
74 install -d $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound
75 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/configuration
76 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-hosts
77 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/events-filter-ports
78 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firestarter.sh
79 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/firewall
80 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/sysctl-tuning
81 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-pre
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/user-post
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-from
84 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/allow-service
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/forward
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/inbound/setup
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-from
88 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-service
89 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/allow-to
90 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-from
91 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-service
92 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/deny-to
93 touch $RPM_BUILD_ROOT%{_sysconfdir}/firestarter/outbound/setup
94
95 mv $RPM_BUILD_ROOT%{_bindir}/firestarter $RPM_BUILD_ROOT%{_sbindir}
96
97 echo -e "#!/bin/sh
98 if [ -x %{_bindir}/gnomesu ] ; then
99         gnomesu %{_sbindir}/firestarter
100 elif [ -x %{_bindir}/kdesu ] ; then
101         kdesu %{_sbindir}/firestarter
102 else
103         %{_sbindir}/firestarter
104 fi" > $RPM_BUILD_ROOT%{_bindir}/firestarter
105
106 %find_lang %{name} --with-gnome
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %gconf_schema_install firestarter.schemas
113 %update_desktop_database_post
114 /sbin/chkconfig --add firestarter
115 if [ -f /var/lock/subsys/firestarter ]; then
116         /etc/rc.d/init.d/firestarter restart 1>&2
117 else
118         echo "Run \"/etc/rc.d/init.d/firestarter start\" to start firestarter."
119 fi
120
121 %preun
122 if [ $1 = 0 ]; then
123     %gconf_schema_uninstall firestarter.schemas
124         if [ -f /var/lock/subsys/firestarter ]; then
125                 /etc/rc.d/init.d/firestarter stop 1>&2
126         fi
127         /sbin/chkconfig --del firestarter
128 fi
129
130 %postun
131 %update_desktop_database_postun
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc README ChangeLog AUTHORS TODO CREDITS
136 %attr(755,root,root) %{_bindir}/firestarter
137 %attr(755,root,root) %{_sbindir}/firestarter
138 %attr(754,root,root) /etc/rc.d/init.d/*
139 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/firestarter
140 %{_desktopdir}/firestarter.desktop
141 %{_datadir}/%{name}
142 %{_pixmapsdir}/*
143 %dir %attr(700,root,root) %{_sysconfdir}/%{name}
144 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/inbound
145 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/outbound
146 %config(noreplace) %attr(700,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firestarter.sh
147 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/inbound/*
148 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/outbound/*
149 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/configuration
150 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/events-filter-*
151 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/firewall
152 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/non-routables
153 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/sysctl-tuning
154 %config(noreplace) %attr(440,root,root) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/user-*
155 %{_sysconfdir}/gconf/schemas/*
This page took 0.098742 seconds and 3 git commands to generate.