]> git.pld-linux.org Git - packages/firelogd.git/blob - firelogd.spec
- tabs in preamble
[packages/firelogd.git] / firelogd.spec
1
2 %define         _ver    1.3
3 %define         _rev    5
4
5 Summary:        Firewall log analyzer and report generator
6 Summary(pl.UTF-8):      Analizator logów firewalla i generator raportów
7 Name:           firelogd
8 Version:        %{_ver}_%{_rev}
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        http://rouxdoo.freeshell.org/dmn/current/%{name}-%{_ver}-%{_rev}.tgz
13 # Source0-md5:  41c19fb70e25cf9da3a480b2da46e0ff
14 Source1:        %{name}.conf
15 Source2:        %{name}.init
16 Source3:        %{name}.sysconfig
17 Patch0:         %{name}-opt.patch
18 URL:            http://rouxdoo.freeshell.org/dmn/
19 BuildRequires:  ctags
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is a program that will parse ipchains or netfilter (iptables) log
24 data in real time. It will queue up a small batch of alerts and mail
25 them to you. It can also be used to parse an existing log file and it
26 will take log data on standard input for formatting.
27
28 %description -l pl.UTF-8
29 To jest program, który przetwarza logi ipchains lub iptables w czasie
30 rzeczywistym. Kolejkuje kilka ostrzeżeń i wysyła je pocztą. Może być
31 także użyty do przetworzenia istniejącego pliku logów i wyświetlenia
32 go w zadanym formacie.
33
34 %package scripts
35 Summary:        Scripts to run firelogd as daemon
36 Summary(pl.UTF-8):      Skrypty do uruchamiania firelogd jako demona
37 Group:          Daemons
38 Requires(post,preun):   /sbin/chkconfig
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       rc-scripts
41
42 %description scripts
43 Scripts to run firelogd as daemon.
44
45 %description scripts -l pl.UTF-8
46 Skrypty do uruchamiania firelogd jako demona.
47
48 %prep
49 %setup -q -n %{name}-%{_ver}
50 %patch0 -p1
51
52 %build
53 %{__make} \
54         CC="%{__cc}" \
55         OPT="%{rpmcflags}"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},%{_sysconfdir},/var/log} \
60         $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
61
62 install firelogd   $RPM_BUILD_ROOT%{_sbindir}
63 gzip -dc firelogd.8.gz > $RPM_BUILD_ROOT%{_mandir}/man8/firelogd.8
64 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
65 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
66 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
67
68 mkfifo $RPM_BUILD_ROOT/var/log/kernelpipe
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post scripts
74 /sbin/chkconfig --add firelogd
75 if [ -f /var/lock/subsys/firelogd ]; then
76         /etc/rc.d/init.d/firelogd restart >&2
77 else
78         echo "Run \"/etc/rc.d/init.d/firelogd start\" to start firelogd." >&2
79         echo "Remember to configure syslogd to log kern.* to |/var/log/kernelpipe (fifo)." >&2
80 fi
81
82 %preun scripts
83 if [ "$1" = "0" ]; then
84         if [ -f /var/lock/subsys/firelogd ]; then
85                 /etc/rc.d/init.d/firelogd stop
86         fi
87         /sbin/chkconfig --del firelogd
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README TEMPLATES BUGS
93 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/firelogd.conf
94 %attr(755,root,root) %{_sbindir}/*
95 %{_mandir}/man8/*
96
97 %files scripts
98 %defattr(644,root,root,755)
99 %attr(754,root,root) /etc/rc.d/init.d/%{name}
100 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
101 %attr(640,root,root) /var/log/kernelpipe
This page took 0.064613 seconds and 3 git commands to generate.