]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- reverted
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 #
13 %if %{without gnome}
14 %undefine       with_gnomeui
15 %undefine       with_gnomevfs
16 %endif
17 %define         firefox_ver     2.0.0.14
18 #
19 Summary:        Firefox Community Edition web browser
20 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
21 Name:           mozilla-firefox
22 Version:        %{firefox_ver}
23 Release:        2
24 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
25 Group:          X11/Applications/Networking
26 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
27 # Source0-md5:  9e9c13ba7b81f93f2fa10c6f256ee31e
28 Source1:        %{name}.desktop
29 Source2:        %{name}.sh
30 Patch0:         mozilla-install.patch
31 Patch1:         %{name}-lib_path.patch
32 Patch2:         %{name}-fonts.patch
33 Patch3:         %{name}-myspell.patch
34 Patch4:         %{name}-pango-cursor-position.patch
35 Patch5:         %{name}-pango-ligatures.patch
36 Patch6:         %{name}-pango-cursor-position-more.patch
37 Patch7:         %{name}-pango-justified-range.patch
38 Patch8:         %{name}-pango-printing.patch
39 Patch9:         %{name}-pango-underline.patch
40 Patch10:        %{name}-xft-randewidth.patch
41 Patch11:        %{name}-ti-agent.patch
42 Patch12:        %{name}-agent.patch
43 # if ac rebuild is needed...
44 #PatchX:                %{name}-ac.patch
45 URL:            http://www.mozilla.org/projects/firefox/
46 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
47 BuildRequires:  automake
48 BuildRequires:  cairo-devel >= 1.0.0
49 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
50 BuildRequires:  gtk+2-devel >= 1:2.0.0
51 BuildRequires:  krb5-devel
52 BuildRequires:  libIDL-devel >= 0.8.0
53 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
54 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
55 BuildRequires:  libjpeg-devel >= 6b
56 BuildRequires:  libpng-devel >= 1.2.7
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  myspell-devel
59 BuildRequires:  nspr-devel >= 1:4.6.3
60 BuildRequires:  nss-devel >= 1:3.11.3-3
61 BuildRequires:  pango-devel >= 1:1.6.0
62 BuildRequires:  perl-modules >= 5.004
63 BuildRequires:  pkgconfig
64 BuildRequires:  rpm >= 4.4.9-56
65 BuildRequires:  rpmbuild(macros) >= 1.356
66 BuildRequires:  xorg-lib-libXext-devel
67 BuildRequires:  xorg-lib-libXft-devel >= 2.1
68 BuildRequires:  xorg-lib-libXinerama-devel
69 BuildRequires:  xorg-lib-libXp-devel
70 BuildRequires:  xorg-lib-libXt-devel
71 BuildRequires:  zip
72 BuildRequires:  zlib-devel >= 1.2.3
73 Requires(post): mktemp >= 1.5-18
74 Requires:       browser-plugins >= 2.0
75 Requires:       nspr >= 1:4.6.3
76 Requires:       nss >= 1:3.11.3
77 Provides:       wwwbrowser
78 Obsoletes:      mozilla-firebird
79 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
80 Obsoletes:      mozilla-firefox-libs
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 # firefox/thunderbird/seamonkey provide their own versions
84 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
85 %define         _noautoprovfiles        %{_libdir}/%{name}/components
86 # we don't want these to satisfy xulrunner-devel
87 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
88 # and as we don't provide them, don't require either
89 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
90
91 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
92
93 %description
94 Firefox Community Edition is an open-source web browser, designed for
95 standards compliance, performance and portability.
96
97 %description -l pl.UTF-8
98 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
99 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
100 o zgodności ze standardami, wydajnością i przenośnością.
101
102 %prep
103 %setup -qc
104 cd mozilla
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110 %patch5 -p1
111 %patch6 -p1
112 %patch7 -p1
113 %patch8 -p0
114 %patch9 -p1
115 %patch10 -p1
116 %if "%{pld_release}" == "ti"
117 %patch11 -p1
118 %else
119 %patch12 -p1
120 %endif
121
122 %build
123 cd mozilla
124
125 cp -f %{_datadir}/automake/config.* build/autoconf
126 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
127 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
128
129 cat << 'EOF' > .mozconfig
130 . $topsrcdir/browser/config/mozconfig
131
132 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
133 ac_cv_visibility_pragma=no
134
135 # Options for 'configure' (same as command-line options).
136 ac_add_options --prefix=%{_prefix}
137 ac_add_options --exec-prefix=%{_exec_prefix}
138 ac_add_options --bindir=%{_bindir}
139 ac_add_options --sbindir=%{_sbindir}
140 ac_add_options --sysconfdir=%{_sysconfdir}
141 ac_add_options --datadir=%{_datadir}
142 ac_add_options --includedir=%{_includedir}
143 ac_add_options --libdir=%{_libdir}
144 ac_add_options --libexecdir=%{_libexecdir}
145 ac_add_options --localstatedir=%{_localstatedir}
146 ac_add_options --sharedstatedir=%{_sharedstatedir}
147 ac_add_options --mandir=%{_mandir}
148 ac_add_options --infodir=%{_infodir}
149 %if %{?debug:1}0
150 ac_add_options --disable-optimize
151 ac_add_options --enable-debug
152 ac_add_options --enable-debug-modules
153 ac_add_options --enable-debugger-info-modules
154 ac_add_options --enable-crash-on-assert
155 %else
156 ac_add_options --disable-debug
157 ac_add_options --disable-debug-modules
158 ac_add_options --disable-logging
159 ac_add_options --enable-optimize="%{rpmcflags}"
160 %endif
161 %if %{with tests}
162 ac_add_options --enable-tests
163 %else
164 ac_add_options --disable-tests
165 %endif
166 %if %{with gnomeui}
167 ac_add_options --enable-gnomeui
168 %else
169 ac_add_options --disable-gnomeui
170 %endif
171 %if %{with gnomevfs}
172 ac_add_options --enable-gnomevfs
173 %else
174 ac_add_options --disable-gnomevfs
175 %endif
176 ac_add_options --disable-freetype2
177 ac_add_options --disable-installer
178 ac_add_options --disable-javaxpcom
179 ac_add_options --disable-updater
180 ac_add_options --enable-default-toolkit=gtk2
181 ac_add_options --enable-svg
182 ac_add_options --enable-system-cairo
183 ac_add_options --enable-system-myspell
184 ac_add_options --enable-xft
185 ac_add_options --with-distribution-id=org.pld-linux
186 ac_add_options --with-system-jpeg
187 ac_add_options --with-system-nspr
188 ac_add_options --with-system-nss
189 ac_add_options --with-system-png
190 ac_add_options --with-system-zlib
191 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
192 EOF
193
194 %{__make} -j1 -f client.mk build \
195         CC="%{__cc}" \
196         CXX="%{__cxx}"
197
198 %install
199 rm -rf $RPM_BUILD_ROOT
200 cd mozilla
201 install -d \
202         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
203         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
204         $RPM_BUILD_ROOT%{_datadir}/%{name}
205
206 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
207
208 %{__make} -C obj-%{_target_cpu}/xpinstall/packager stage-package \
209         DESTDIR=$RPM_BUILD_ROOT \
210         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
211         PKG_SKIP_STRIP=1
212
213 # move arch independant ones to datadir
214 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
215 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
216 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
217 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
218 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
219 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
220 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
221 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
222 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
223 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
224 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
225 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
226 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
227 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
228 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
229 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
230
231 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
232 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
233
234 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
235 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
236
237 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
238
239 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
240
241 # header/development files
242 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
243 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
244 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
245
246 # files created by regxpcom and firefox -register
247 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
248 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
249
250 # what's this? it's content is invalid anyway.
251 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
252 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
253
254 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
255 #!/bin/sh
256 umask 022
257 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
258
259 # it attempts to touch files in $HOME/.mozilla
260 # beware if you run this with sudo!!!
261 export HOME=$(mktemp -d)
262 # also TMPDIR could be pointing to sudo user's homedir
263 unset TMPDIR TMP || :
264
265 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
266 %{_libdir}/%{name}/firefox -register
267
268 rm -rf $HOME
269 EOF
270
271 %clean
272 rm -rf $RPM_BUILD_ROOT
273
274 %pretrans
275 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
276         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
277 fi
278 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
279         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
280                 install -d %{_datadir}/%{name}
281                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
282         fi
283 done
284 exit 0
285
286 %post
287 %{_sbindir}/%{name}-chrome+xpcom-generate
288 %update_browser_plugins
289
290 %postun
291 if [ "$1" = 0 ]; then
292         %update_browser_plugins
293 fi
294
295 %files
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_bindir}/%{name}
298 %attr(755,root,root) %{_bindir}/firefox
299 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
300
301 # browser plugins v2
302 %{_browserpluginsconfdir}/browsers.d/%{name}.*
303 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
304
305 %dir %{_libdir}/%{name}
306 %attr(755,root,root) %{_libdir}/%{name}/*.so
307
308 %dir %{_libdir}/%{name}/components
309 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
310 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
311 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
312 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
313 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
314 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
315 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
316 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
317 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
318 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
319 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
320 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
321 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
322 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
323 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
324 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
325 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
326 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
327 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
328 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
329 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
330 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
331 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
332 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
333 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
334 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
335 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
336 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
337 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
340 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
341 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
342 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
361 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
362 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
363 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
364 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
365 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
366 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
367 %{_libdir}/%{name}/components/accessibility-atk.xpt
368 %{_libdir}/%{name}/components/accessibility.xpt
369 %{_libdir}/%{name}/components/alerts.xpt
370 %{_libdir}/%{name}/components/appshell.xpt
371 %{_libdir}/%{name}/components/appstartup.xpt
372 %{_libdir}/%{name}/components/autocomplete.xpt
373 %{_libdir}/%{name}/components/autoconfig.xpt
374 %{_libdir}/%{name}/components/bookmarks.xpt
375 %{_libdir}/%{name}/components/browsercompsbase.xpt
376 %{_libdir}/%{name}/components/browser-feeds.xpt
377 %{_libdir}/%{name}/components/browsersearch.xpt
378 %{_libdir}/%{name}/components/caps.xpt
379 %{_libdir}/%{name}/components/chardet.xpt
380 %{_libdir}/%{name}/components/chrome.xpt
381 %{_libdir}/%{name}/components/commandhandler.xpt
382 %{_libdir}/%{name}/components/commandlines.xpt
383 %{_libdir}/%{name}/components/composer.xpt
384 %{_libdir}/%{name}/components/content_base.xpt
385 %{_libdir}/%{name}/components/content_htmldoc.xpt
386 %{_libdir}/%{name}/components/content_html.xpt
387 %{_libdir}/%{name}/components/content_xmldoc.xpt
388 %{_libdir}/%{name}/components/content_xslt.xpt
389 %{_libdir}/%{name}/components/content_xtf.xpt
390 %{_libdir}/%{name}/components/cookie.xpt
391 %{_libdir}/%{name}/components/directory.xpt
392 %{_libdir}/%{name}/components/docshell.xpt
393 %{_libdir}/%{name}/components/dom_base.xpt
394 %{_libdir}/%{name}/components/dom_canvas.xpt
395 %{_libdir}/%{name}/components/dom_core.xpt
396 %{_libdir}/%{name}/components/dom_css.xpt
397 %{_libdir}/%{name}/components/dom_events.xpt
398 %{_libdir}/%{name}/components/dom_html.xpt
399 %{_libdir}/%{name}/components/dom_loadsave.xpt
400 %{_libdir}/%{name}/components/dom_range.xpt
401 %{_libdir}/%{name}/components/dom_sidebar.xpt
402 %{_libdir}/%{name}/components/dom_storage.xpt
403 %{_libdir}/%{name}/components/dom_stylesheets.xpt
404 %{_libdir}/%{name}/components/dom_svg.xpt
405 %{_libdir}/%{name}/components/dom_traversal.xpt
406 %{_libdir}/%{name}/components/dom_views.xpt
407 %{_libdir}/%{name}/components/dom_xbl.xpt
408 %{_libdir}/%{name}/components/dom_xpath.xpt
409 %{_libdir}/%{name}/components/dom.xpt
410 %{_libdir}/%{name}/components/dom_xul.xpt
411 %{_libdir}/%{name}/components/downloads.xpt
412 %{_libdir}/%{name}/components/editor.xpt
413 %{_libdir}/%{name}/components/embed_base.xpt
414 %{_libdir}/%{name}/components/extensions.xpt
415 %{_libdir}/%{name}/components/exthandler.xpt
416 %{_libdir}/%{name}/components/fastfind.xpt
417 %{_libdir}/%{name}/components/FeedConverter.js
418 %{_libdir}/%{name}/components/FeedProcessor.js
419 %{_libdir}/%{name}/components/feeds.xpt
420 %{_libdir}/%{name}/components/FeedWriter.js
421 %{_libdir}/%{name}/components/filepicker.xpt
422 %{_libdir}/%{name}/components/find.xpt
423 %{_libdir}/%{name}/components/gfx.xpt
424 %{_libdir}/%{name}/components/gksvgrenderer.xpt
425 %{_libdir}/%{name}/components/history.xpt
426 %{_libdir}/%{name}/components/htmlparser.xpt
427 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
428 %{_libdir}/%{name}/components/imglib2.xpt
429 %{_libdir}/%{name}/components/inspector.xpt
430 %{_libdir}/%{name}/components/intl.xpt
431 %{_libdir}/%{name}/components/jar.xpt
432 %{_libdir}/%{name}/components/jsconsole-clhandler.js
433 %{_libdir}/%{name}/components/jsconsole.xpt
434 %{_libdir}/%{name}/components/jsdservice.xpt
435 %{_libdir}/%{name}/components/layout_base.xpt
436 %{_libdir}/%{name}/components/layout_printing.xpt
437 %{_libdir}/%{name}/components/layout_xul_tree.xpt
438 %{_libdir}/%{name}/components/layout_xul.xpt
439 %{_libdir}/%{name}/components/locale.xpt
440 %{_libdir}/%{name}/components/lwbrk.xpt
441 %{_libdir}/%{name}/components/microsummaries.xpt
442 %{_libdir}/%{name}/components/migration.xpt
443 %{_libdir}/%{name}/components/mimetype.xpt
444 %{_libdir}/%{name}/components/mozbrwsr.xpt
445 %{_libdir}/%{name}/components/mozfind.xpt
446 %{_libdir}/%{name}/components/mozgnome.xpt
447 %{_libdir}/%{name}/components/necko_about.xpt
448 %{_libdir}/%{name}/components/necko_cache.xpt
449 %{_libdir}/%{name}/components/necko_cookie.xpt
450 %{_libdir}/%{name}/components/necko_data.xpt
451 %{_libdir}/%{name}/components/necko_dns.xpt
452 %{_libdir}/%{name}/components/necko_file.xpt
453 %{_libdir}/%{name}/components/necko_ftp.xpt
454 %{_libdir}/%{name}/components/necko_http.xpt
455 %{_libdir}/%{name}/components/necko_res.xpt
456 %{_libdir}/%{name}/components/necko_socket.xpt
457 %{_libdir}/%{name}/components/necko_strconv.xpt
458 %{_libdir}/%{name}/components/necko_viewsource.xpt
459 %{_libdir}/%{name}/components/necko.xpt
460 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
461 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
462 %{_libdir}/%{name}/components/nsBrowserGlue.js
463 %{_libdir}/%{name}/components/nsCloseAllWindows.js
464 %{_libdir}/%{name}/components/nsDefaultCLH.js
465 %{_libdir}/%{name}/components/nsDictionary.js
466 %{_libdir}/%{name}/components/nsExtensionManager.js
467 %{_libdir}/%{name}/components/nsFilePicker.js
468 %{_libdir}/%{name}/components/nsHelperAppDlg.js
469 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
470 %{_libdir}/%{name}/components/nsKillAll.js
471 %{_libdir}/%{name}/components/nsMicrosummaryService.js
472 %{_libdir}/%{name}/components/nsProgressDialog.js
473 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
474 %{_libdir}/%{name}/components/nsResetPref.js
475 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
476 %{_libdir}/%{name}/components/nsSearchService.js
477 %{_libdir}/%{name}/components/nsSearchSuggestions.js
478 %{_libdir}/%{name}/components/nsSessionStartup.js
479 %{_libdir}/%{name}/components/nsSessionStore.js
480 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
481 %{_libdir}/%{name}/components/nsSidebar.js
482 %{_libdir}/%{name}/components/nsUpdateService.js
483 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
484 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
485 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
486 %{_libdir}/%{name}/components/nsURLFormatter.js
487 %{_libdir}/%{name}/components/nsXmlRpcClient.js
488 %{_libdir}/%{name}/components/oji.xpt
489 %{_libdir}/%{name}/components/passwordmgr.xpt
490 %{_libdir}/%{name}/components/pipboot.xpt
491 %{_libdir}/%{name}/components/pipnss.xpt
492 %{_libdir}/%{name}/components/pippki.xpt
493 %{_libdir}/%{name}/components/plugin.xpt
494 %{_libdir}/%{name}/components/prefetch.xpt
495 %{_libdir}/%{name}/components/pref.xpt
496 %{_libdir}/%{name}/components/profile.xpt
497 %{_libdir}/%{name}/components/progressDlg.xpt
498 %{_libdir}/%{name}/components/proxyObjInst.xpt
499 %{_libdir}/%{name}/components/rdf.xpt
500 %{_libdir}/%{name}/components/safebrowsing.xpt
501 %{_libdir}/%{name}/components/satchel.xpt
502 %{_libdir}/%{name}/components/saxparser.xpt
503 %{_libdir}/%{name}/components/search.xpt
504 %{_libdir}/%{name}/components/sessionstore.xpt
505 %{_libdir}/%{name}/components/shellservice.xpt
506 %{_libdir}/%{name}/components/shistory.xpt
507 %{_libdir}/%{name}/components/spellchecker.xpt
508 %{_libdir}/%{name}/components/storage.xpt
509 %{_libdir}/%{name}/components/toolkitprofile.xpt
510 %{_libdir}/%{name}/components/toolkitremote.xpt
511 %{_libdir}/%{name}/components/txmgr.xpt
512 %{_libdir}/%{name}/components/txtsvc.xpt
513 %{_libdir}/%{name}/components/uconv.xpt
514 %{_libdir}/%{name}/components/unicharutil.xpt
515 %{_libdir}/%{name}/components/update.xpt
516 %{_libdir}/%{name}/components/uriloader.xpt
517 %{_libdir}/%{name}/components/url-classifier.xpt
518 %{_libdir}/%{name}/components/urlformatter.xpt
519 %{_libdir}/%{name}/components/webBrowser_core.xpt
520 %{_libdir}/%{name}/components/webbrowserpersist.xpt
521 %{_libdir}/%{name}/components/WebContentConverter.js
522 %{_libdir}/%{name}/components/webshell_idls.xpt
523 %{_libdir}/%{name}/components/websrvcs.xpt
524 %{_libdir}/%{name}/components/widget.xpt
525 %{_libdir}/%{name}/components/windowds.xpt
526 %{_libdir}/%{name}/components/windowwatcher.xpt
527 %{_libdir}/%{name}/components/xml-rpc.xpt
528 %{_libdir}/%{name}/components/xpcom_base.xpt
529 %{_libdir}/%{name}/components/xpcom_components.xpt
530 %{_libdir}/%{name}/components/xpcom_ds.xpt
531 %{_libdir}/%{name}/components/xpcom_io.xpt
532 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
533 %{_libdir}/%{name}/components/xpcom_threads.xpt
534 %{_libdir}/%{name}/components/xpcom_xpti.xpt
535 %{_libdir}/%{name}/components/xpconnect.xpt
536 %{_libdir}/%{name}/components/xpinstall.xpt
537 %{_libdir}/%{name}/components/xulapp.xpt
538 %{_libdir}/%{name}/components/xuldoc.xpt
539 %{_libdir}/%{name}/components/xultmpl.xpt
540 %dir %{_libdir}/%{name}/plugins
541 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
542 %attr(755,root,root) %{_libdir}/%{name}/*.sh
543 %attr(755,root,root) %{_libdir}/%{name}/m*
544 %attr(755,root,root) %{_libdir}/%{name}/f*
545 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
546 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
547 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
548 %{_pixmapsdir}/mozilla-firefox.png
549 %{_desktopdir}/mozilla-firefox.desktop
550
551 # symlinks
552 %{_libdir}/%{name}/chrome
553 %{_libdir}/%{name}/defaults
554 %{_libdir}/%{name}/dictionaries
555 %{_libdir}/%{name}/extensions
556 %{_libdir}/%{name}/greprefs
557 %{_libdir}/%{name}/icons
558 %{_libdir}/%{name}/init.d
559 %{_libdir}/%{name}/res
560 %{_libdir}/%{name}/searchplugins
561
562 # browserconfig
563 %{_libdir}/%{name}/browserconfig.properties
564
565 %{_libdir}/%{name}/LICENSE
566 %{_libdir}/%{name}/README.txt
567
568 %dir %{_datadir}/%{name}
569 %{_datadir}/%{name}/chrome
570 %{_datadir}/%{name}/defaults
571 %{_datadir}/%{name}/greprefs
572 %{_datadir}/%{name}/icons
573 %{_datadir}/%{name}/init.d
574 %{_datadir}/%{name}/res
575 %{_datadir}/%{name}/searchplugins
576
577 %dir %{_datadir}/%{name}/extensions
578 # -dom-inspector subpackage?
579 %{_datadir}/%{name}/extensions/inspector@mozilla.org
580 # the signature of the default theme
581 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
582
583 # files created by regxpcom and firefox -register
584 %ghost %{_libdir}/%{name}/components/compreg.dat
585 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.071447 seconds and 4 git commands to generate.