]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- updated to 2.0.0.8, removed obsolete nopangoxft patch, renumbered patches
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 %bcond_with     tidy            # htmlvalidator extension (tidy)
13 #
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %undefine       with_gnomevfs
17 %endif
18 %define         tidy_ver        0.8.4.1
19 %define         firefox_ver     2.0.0.8
20 #
21 Summary:        Firefox Community Edition web browser
22 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
23 Name:           mozilla-firefox
24 Version:        %{firefox_ver}
25 Release:        1
26 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
27 Group:          X11/Applications/Networking
28 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
29 # Source0-md5:  f4ffac67751bc3e556c4926da2e0b65a
30 Source1:        http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
31 # Source1-md5:  2cab81118267fc87c9ebbfa6fb44b113
32 Source2:        %{name}.desktop
33 Source3:        %{name}.sh
34 Patch0:         mozilla-install.patch
35 Patch1:         %{name}-lib_path.patch
36 Patch2:         %{name}-addon-tidy.patch
37 Patch3:         %{name}-fonts.patch
38 Patch4:         %{name}-agent.patch
39 Patch5:         %{name}-myspell.patch
40 # if ac rebuild is needed...
41 #PatchX:                %{name}-ac.patch
42 URL:            http://www.mozilla.org/projects/firefox/
43 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
44 BuildRequires:  automake
45 BuildRequires:  cairo-devel >= 1.0.0
46 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
47 BuildRequires:  gtk+2-devel >= 1:2.0.0
48 BuildRequires:  krb5-devel
49 BuildRequires:  libIDL-devel >= 0.8.0
50 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
52 BuildRequires:  libjpeg-devel >= 6b
53 BuildRequires:  libpng-devel >= 1.2.7
54 BuildRequires:  libstdc++-devel
55 BuildRequires:  myspell-devel
56 BuildRequires:  nspr-devel >= 1:4.6.3
57 BuildRequires:  nss-devel >= 1:3.11.3-3
58 %{?with_tidy:BuildRequires:     opensp-devel >= 2:1.5.2-4}
59 BuildRequires:  pango-devel >= 1:1.6.0
60 BuildRequires:  perl-modules >= 5.004
61 BuildRequires:  pkgconfig
62 BuildRequires:  rpmbuild(macros) >= 1.356
63 BuildRequires:  xorg-lib-libXext-devel
64 BuildRequires:  xorg-lib-libXft-devel >= 2.1
65 BuildRequires:  xorg-lib-libXinerama-devel
66 BuildRequires:  xorg-lib-libXp-devel
67 BuildRequires:  xorg-lib-libXt-devel
68 BuildRequires:  zip
69 BuildRequires:  zlib-devel >= 1.2.3
70 Requires(post): mktemp >= 1.5-18
71 Requires:       %{name}-lang-resources = %{version}
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73 Requires:       browser-plugins >= 2.0
74 Requires:       nspr >= 1:4.6.3
75 Requires:       nss >= 1:3.11.3
76 Provides:       wwwbrowser
77 Obsoletes:      mozilla-firebird
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 # firefox/thunderbird/seamonkey provide their own versions
81 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
82 %define         _noautoprovfiles        %{_libdir}/%{name}/components
83 # we don't want these to satisfy xulrunner-devel
84 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
85 # and as we don't provide them, don't require either
86 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
87
88 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
89
90 %description
91 Firefox Community Edition is an open-source web browser, designed for
92 standards compliance, performance and portability.
93
94 %description -l pl.UTF-8
95 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
96 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
97 o zgodności ze standardami, wydajnością i przenośnością.
98
99 %package libs
100 Summary:        Firefox Community Edition shared libraries
101 Summary(pl.UTF-8):      Biblioteki współdzielone przeglądarki Firefox Community Edition
102 Group:          Libraries
103 Conflicts:      mozilla-firefox < 2.0-1.4
104
105 %description libs
106 Firefox Community Edition shared libraries.
107
108 %description libs -l pl.UTF-8
109 Biblioteki współdzielone przeglądarki Firefox Community Edition.
110
111 %package addon-tidy
112 Summary:        HTML Validator for Firefox
113 Summary(pl.UTF-8):      Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
114 Version:        %{tidy_ver}
115 License:        GPL
116 Group:          X11/Applications/Networking
117 URL:            http://users.skynet.be/mgueury/mozilla/
118 Requires:       %{name} = %{firefox_ver}-%{release}
119
120 %description addon-tidy
121 HTML Validator is a Mozilla extension that adds HTML validation inside
122 Firefox. The number of errors of a HTML page is seen on the form of an
123 icon in the status bar when browsing.
124
125 %description addon-tidy -l pl.UTF-8
126 HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
127 poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
128 HTML można zobaczyć w postaci ikony na pasku stanu.
129
130 %package lang-en
131 Summary:        English resources for Firefox Community Edition
132 Summary(pl.UTF-8):      Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
133 Version:        %{firefox_ver}
134 Group:          X11/Applications/Networking
135 Requires:       %{name} = %{firefox_ver}-%{release}
136 Provides:       %{name}-lang-resources = %{firefox_ver}-%{release}
137
138 %description lang-en
139 English resources for Firefox Community Edition.
140
141 %description lang-en -l pl.UTF-8
142 Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
143
144 %prep
145 %setup -qc %{?with_tidy:-a1}
146 %if %{with tidy}
147 mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
148 mv mozilla_tidy_source/tidy_extension .
149 rm -rf mozilla/extensions/tidy/opensp
150 %endif
151 cd mozilla
152 %patch0 -p1
153 %patch1 -p1
154 %{?with_tidy:%patch2 -p1}
155 %patch3 -p1
156 %patch4 -p1
157 %patch5 -p1
158
159 # use system
160 #rm -rf mozilla/nsprpub mozilla/security/nss
161
162 %build
163 cd mozilla
164 export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
165 export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
166
167 cp -f %{_datadir}/automake/config.* build/autoconf
168 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
169 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
170
171 cat << 'EOF' > .mozconfig
172 . $topsrcdir/browser/config/mozconfig
173
174 # Options for 'configure' (same as command-line options).
175 ac_add_options --prefix=%{_prefix}
176 ac_add_options --exec-prefix=%{_exec_prefix}
177 ac_add_options --bindir=%{_bindir}
178 ac_add_options --sbindir=%{_sbindir}
179 ac_add_options --sysconfdir=%{_sysconfdir}
180 ac_add_options --datadir=%{_datadir}
181 ac_add_options --includedir=%{_includedir}
182 ac_add_options --libdir=%{_libdir}
183 ac_add_options --libexecdir=%{_libexecdir}
184 ac_add_options --localstatedir=%{_localstatedir}
185 ac_add_options --sharedstatedir=%{_sharedstatedir}
186 ac_add_options --mandir=%{_mandir}
187 ac_add_options --infodir=%{_infodir}
188 %if %{?debug:1}0
189 ac_add_options --disable-optimize
190 ac_add_options --enable-debug
191 ac_add_options --enable-debug-modules
192 ac_add_options --enable-debugger-info-modules
193 ac_add_options --enable-crash-on-assert
194 %else
195 ac_add_options --disable-debug
196 ac_add_options --disable-logging
197 ac_add_options --enable-optimize="%{rpmcflags}"
198 %endif
199 %if %{with tests}
200 ac_add_options --enable-tests
201 %else
202 ac_add_options --disable-tests
203 %endif
204 %if %{with gnomeui}
205 ac_add_options --enable-gnomeui
206 %else
207 ac_add_options --disable-gnomeui
208 %endif
209 %if %{with gnomevfs}
210 ac_add_options --enable-gnomevfs
211 %else
212 ac_add_options --disable-gnomevfs
213 %endif
214 ac_add_options --disable-freetype2
215 ac_add_options --disable-installer
216 ac_add_options --disable-javaxpcom
217 ac_add_options --disable-updater
218 ac_add_options --enable-default-toolkit=gtk2
219 ac_add_options --enable-svg
220 ac_add_options --enable-system-cairo
221 ac_add_options --enable-system-myspell
222 ac_add_options --enable-xft
223 ac_add_options --with-distribution-id=org.pld-linux
224 ac_add_options --with-system-nspr
225 ac_add_options --with-system-nss
226 ac_add_options --with-system-zlib
227 ac_add_options --with-system-jpeg
228 ac_add_options --with-system-png
229 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
230 ac_cv_visibility_pragma=no
231 EOF
232
233 %{__make} -j1 -f client.mk build \
234         CC="%{__cc}" \
235         CXX="%{__cxx}"
236
237 %install
238 rm -rf $RPM_BUILD_ROOT
239 cd mozilla
240 install -d \
241         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
242         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
243         $RPM_BUILD_ROOT%{_datadir}/%{name}
244
245 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
246
247 %{__make} -C xpinstall/packager stage-package \
248         DESTDIR=$RPM_BUILD_ROOT \
249         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
250         PKG_SKIP_STRIP=1
251
252 # move arch independant ones to datadir
253 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
254 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
255 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
256 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
257 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
258 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
259 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
260 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
261 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
262 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
263 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
264 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
265 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
266 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
267 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
268 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
269
270 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
271 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
272
273 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
274 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
275
276 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
277
278 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
279
280 # header/development files
281 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
282 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
283 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
284
285 # files created by regxpcom and firefox -register
286 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
287 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
288
289 # what's this? it's content is invalid anyway.
290 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
291 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
292
293 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
294 #!/bin/sh
295 umask 022
296 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
297
298 # it attempts to touch files in $HOME/.mozilla
299 # beware if you run this with sudo!!!
300 export HOME=$(mktemp -d)
301 # also TMPDIR could be pointing to sudo user's homedir
302 unset TMPDIR TMP || :
303
304 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
305 %{_libdir}/%{name}/firefox -register
306
307 rm -rf $HOME
308 EOF
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %pretrans
314 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
315         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
316 fi
317 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
318         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
319                 install -d %{_datadir}/%{name}
320                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
321         fi
322 done
323 exit 0
324
325 %post
326 %{_sbindir}/%{name}-chrome+xpcom-generate
327 %update_browser_plugins
328
329 %postun
330 if [ "$1" = 0 ]; then
331         %update_browser_plugins
332 fi
333
334 %files
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_bindir}/%{name}
337 %attr(755,root,root) %{_bindir}/firefox
338 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
339
340 # browser plugins v2
341 %{_browserpluginsconfdir}/browsers.d/%{name}.*
342 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
343
344 %dir %{_libdir}/%{name}/components
345 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
361 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
362 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
363 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
364 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
365 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
366 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
367 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
368 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
369 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
370 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
371 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
372 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
373 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
374 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
375 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
376 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
377 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
378 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
379 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
380 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
381 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
382 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
383 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
384 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
385 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
386 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
387 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
388 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
389 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
390 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
391 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
392 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
393 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
394 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
395 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
396 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
397 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
398 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
399 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
400 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
401 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
402 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
403 %{_libdir}/%{name}/components/accessibility-atk.xpt
404 %{_libdir}/%{name}/components/accessibility.xpt
405 %{_libdir}/%{name}/components/alerts.xpt
406 %{_libdir}/%{name}/components/appshell.xpt
407 %{_libdir}/%{name}/components/appstartup.xpt
408 %{_libdir}/%{name}/components/autocomplete.xpt
409 %{_libdir}/%{name}/components/autoconfig.xpt
410 %{_libdir}/%{name}/components/bookmarks.xpt
411 %{_libdir}/%{name}/components/browsercompsbase.xpt
412 %{_libdir}/%{name}/components/browser-feeds.xpt
413 %{_libdir}/%{name}/components/browsersearch.xpt
414 %{_libdir}/%{name}/components/caps.xpt
415 %{_libdir}/%{name}/components/chardet.xpt
416 %{_libdir}/%{name}/components/chrome.xpt
417 %{_libdir}/%{name}/components/commandhandler.xpt
418 %{_libdir}/%{name}/components/commandlines.xpt
419 %{_libdir}/%{name}/components/composer.xpt
420 %{_libdir}/%{name}/components/content_base.xpt
421 %{_libdir}/%{name}/components/content_htmldoc.xpt
422 %{_libdir}/%{name}/components/content_html.xpt
423 %{_libdir}/%{name}/components/content_xmldoc.xpt
424 %{_libdir}/%{name}/components/content_xslt.xpt
425 %{_libdir}/%{name}/components/content_xtf.xpt
426 %{_libdir}/%{name}/components/cookie.xpt
427 %{_libdir}/%{name}/components/directory.xpt
428 %{_libdir}/%{name}/components/docshell.xpt
429 %{_libdir}/%{name}/components/dom_base.xpt
430 %{_libdir}/%{name}/components/dom_canvas.xpt
431 %{_libdir}/%{name}/components/dom_core.xpt
432 %{_libdir}/%{name}/components/dom_css.xpt
433 %{_libdir}/%{name}/components/dom_events.xpt
434 %{_libdir}/%{name}/components/dom_html.xpt
435 %{_libdir}/%{name}/components/dom_loadsave.xpt
436 %{_libdir}/%{name}/components/dom_range.xpt
437 %{_libdir}/%{name}/components/dom_sidebar.xpt
438 %{_libdir}/%{name}/components/dom_storage.xpt
439 %{_libdir}/%{name}/components/dom_stylesheets.xpt
440 %{_libdir}/%{name}/components/dom_svg.xpt
441 %{_libdir}/%{name}/components/dom_traversal.xpt
442 %{_libdir}/%{name}/components/dom_views.xpt
443 %{_libdir}/%{name}/components/dom_xbl.xpt
444 %{_libdir}/%{name}/components/dom_xpath.xpt
445 %{_libdir}/%{name}/components/dom.xpt
446 %{_libdir}/%{name}/components/dom_xul.xpt
447 %{_libdir}/%{name}/components/downloads.xpt
448 %{_libdir}/%{name}/components/editor.xpt
449 %{_libdir}/%{name}/components/embed_base.xpt
450 %{_libdir}/%{name}/components/extensions.xpt
451 %{_libdir}/%{name}/components/exthandler.xpt
452 %{_libdir}/%{name}/components/fastfind.xpt
453 %{_libdir}/%{name}/components/FeedConverter.js
454 %{_libdir}/%{name}/components/FeedProcessor.js
455 %{_libdir}/%{name}/components/feeds.xpt
456 %{_libdir}/%{name}/components/FeedWriter.js
457 %{_libdir}/%{name}/components/filepicker.xpt
458 %{_libdir}/%{name}/components/find.xpt
459 %{_libdir}/%{name}/components/gfx.xpt
460 %{_libdir}/%{name}/components/gksvgrenderer.xpt
461 %{_libdir}/%{name}/components/history.xpt
462 %{_libdir}/%{name}/components/htmlparser.xpt
463 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
464 %{_libdir}/%{name}/components/imglib2.xpt
465 %{_libdir}/%{name}/components/inspector.xpt
466 %{_libdir}/%{name}/components/intl.xpt
467 %{_libdir}/%{name}/components/jar.xpt
468 %{_libdir}/%{name}/components/jsconsole-clhandler.js
469 %{_libdir}/%{name}/components/jsconsole.xpt
470 %{_libdir}/%{name}/components/jsdservice.xpt
471 %{_libdir}/%{name}/components/layout_base.xpt
472 %{_libdir}/%{name}/components/layout_printing.xpt
473 %{_libdir}/%{name}/components/layout_xul_tree.xpt
474 %{_libdir}/%{name}/components/layout_xul.xpt
475 %{_libdir}/%{name}/components/locale.xpt
476 %{_libdir}/%{name}/components/lwbrk.xpt
477 %{_libdir}/%{name}/components/microsummaries.xpt
478 %{_libdir}/%{name}/components/migration.xpt
479 %{_libdir}/%{name}/components/mimetype.xpt
480 %{_libdir}/%{name}/components/mozbrwsr.xpt
481 %{_libdir}/%{name}/components/mozfind.xpt
482 %{_libdir}/%{name}/components/mozgnome.xpt
483 %{_libdir}/%{name}/components/necko_about.xpt
484 %{_libdir}/%{name}/components/necko_cache.xpt
485 %{_libdir}/%{name}/components/necko_cookie.xpt
486 %{_libdir}/%{name}/components/necko_data.xpt
487 %{_libdir}/%{name}/components/necko_dns.xpt
488 %{_libdir}/%{name}/components/necko_file.xpt
489 %{_libdir}/%{name}/components/necko_ftp.xpt
490 %{_libdir}/%{name}/components/necko_http.xpt
491 %{_libdir}/%{name}/components/necko_res.xpt
492 %{_libdir}/%{name}/components/necko_socket.xpt
493 %{_libdir}/%{name}/components/necko_strconv.xpt
494 %{_libdir}/%{name}/components/necko_viewsource.xpt
495 %{_libdir}/%{name}/components/necko.xpt
496 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
497 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
498 %{_libdir}/%{name}/components/nsBrowserGlue.js
499 %{_libdir}/%{name}/components/nsCloseAllWindows.js
500 %{_libdir}/%{name}/components/nsDefaultCLH.js
501 %{_libdir}/%{name}/components/nsDictionary.js
502 %{_libdir}/%{name}/components/nsExtensionManager.js
503 %{_libdir}/%{name}/components/nsFilePicker.js
504 %{_libdir}/%{name}/components/nsHelperAppDlg.js
505 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
506 %{_libdir}/%{name}/components/nsKillAll.js
507 %{_libdir}/%{name}/components/nsMicrosummaryService.js
508 %{_libdir}/%{name}/components/nsProgressDialog.js
509 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
510 %{_libdir}/%{name}/components/nsResetPref.js
511 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
512 %{_libdir}/%{name}/components/nsSearchService.js
513 %{_libdir}/%{name}/components/nsSearchSuggestions.js
514 %{_libdir}/%{name}/components/nsSessionStartup.js
515 %{_libdir}/%{name}/components/nsSessionStore.js
516 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
517 %{_libdir}/%{name}/components/nsSidebar.js
518 %{_libdir}/%{name}/components/nsUpdateService.js
519 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
520 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
521 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
522 %{_libdir}/%{name}/components/nsURLFormatter.js
523 %{_libdir}/%{name}/components/nsXmlRpcClient.js
524 %{_libdir}/%{name}/components/oji.xpt
525 %{_libdir}/%{name}/components/passwordmgr.xpt
526 %{_libdir}/%{name}/components/pipboot.xpt
527 %{_libdir}/%{name}/components/pipnss.xpt
528 %{_libdir}/%{name}/components/pippki.xpt
529 %{_libdir}/%{name}/components/plugin.xpt
530 %{_libdir}/%{name}/components/prefetch.xpt
531 %{_libdir}/%{name}/components/pref.xpt
532 %{_libdir}/%{name}/components/profile.xpt
533 %{_libdir}/%{name}/components/progressDlg.xpt
534 %{_libdir}/%{name}/components/proxyObjInst.xpt
535 %{_libdir}/%{name}/components/rdf.xpt
536 %{_libdir}/%{name}/components/safebrowsing.xpt
537 %{_libdir}/%{name}/components/satchel.xpt
538 %{_libdir}/%{name}/components/saxparser.xpt
539 %{_libdir}/%{name}/components/search.xpt
540 %{_libdir}/%{name}/components/sessionstore.xpt
541 %{_libdir}/%{name}/components/shellservice.xpt
542 %{_libdir}/%{name}/components/shistory.xpt
543 %{_libdir}/%{name}/components/spellchecker.xpt
544 %{_libdir}/%{name}/components/storage.xpt
545 %{_libdir}/%{name}/components/toolkitprofile.xpt
546 %{_libdir}/%{name}/components/toolkitremote.xpt
547 %{_libdir}/%{name}/components/txmgr.xpt
548 %{_libdir}/%{name}/components/txtsvc.xpt
549 %{_libdir}/%{name}/components/uconv.xpt
550 %{_libdir}/%{name}/components/unicharutil.xpt
551 %{_libdir}/%{name}/components/update.xpt
552 %{_libdir}/%{name}/components/uriloader.xpt
553 %{_libdir}/%{name}/components/url-classifier.xpt
554 %{_libdir}/%{name}/components/urlformatter.xpt
555 %{_libdir}/%{name}/components/webBrowser_core.xpt
556 %{_libdir}/%{name}/components/webbrowserpersist.xpt
557 %{_libdir}/%{name}/components/WebContentConverter.js
558 %{_libdir}/%{name}/components/webshell_idls.xpt
559 %{_libdir}/%{name}/components/websrvcs.xpt
560 %{_libdir}/%{name}/components/widget.xpt
561 %{_libdir}/%{name}/components/windowds.xpt
562 %{_libdir}/%{name}/components/windowwatcher.xpt
563 %{_libdir}/%{name}/components/xml-rpc.xpt
564 %{_libdir}/%{name}/components/xpcom_base.xpt
565 %{_libdir}/%{name}/components/xpcom_components.xpt
566 %{_libdir}/%{name}/components/xpcom_ds.xpt
567 %{_libdir}/%{name}/components/xpcom_io.xpt
568 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
569 %{_libdir}/%{name}/components/xpcom_threads.xpt
570 %{_libdir}/%{name}/components/xpcom_xpti.xpt
571 %{_libdir}/%{name}/components/xpconnect.xpt
572 %{_libdir}/%{name}/components/xpinstall.xpt
573 %{_libdir}/%{name}/components/xulapp.xpt
574 %{_libdir}/%{name}/components/xuldoc.xpt
575 %{_libdir}/%{name}/components/xultmpl.xpt
576 %dir %{_libdir}/%{name}/plugins
577 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
578 %attr(755,root,root) %{_libdir}/%{name}/*.sh
579 %attr(755,root,root) %{_libdir}/%{name}/m*
580 %attr(755,root,root) %{_libdir}/%{name}/f*
581 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
582 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
583 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
584 %{_pixmapsdir}/mozilla-firefox.png
585 %{_desktopdir}/mozilla-firefox.desktop
586
587 # symlinks
588 %{_libdir}/%{name}/chrome
589 %{_libdir}/%{name}/defaults
590 %{_libdir}/%{name}/dictionaries
591 %{_libdir}/%{name}/extensions
592 %{_libdir}/%{name}/greprefs
593 %{_libdir}/%{name}/icons
594 %{_libdir}/%{name}/init.d
595 %{_libdir}/%{name}/res
596 %{_libdir}/%{name}/searchplugins
597
598 # browserconfig
599 %{_libdir}/%{name}/browserconfig.properties
600
601 %{_libdir}/%{name}/LICENSE
602 %{_libdir}/%{name}/README.txt
603
604 %dir %{_datadir}/%{name}
605 %{_datadir}/%{name}/chrome
606 %{_datadir}/%{name}/defaults
607 %{_datadir}/%{name}/greprefs
608 %{_datadir}/%{name}/icons
609 %{_datadir}/%{name}/init.d
610 %{_datadir}/%{name}/res
611 %{_datadir}/%{name}/searchplugins
612
613 %dir %{_datadir}/%{name}/extensions
614 # -dom-inspector subpackage?
615 %{_datadir}/%{name}/extensions/inspector@mozilla.org
616 # the signature of the default theme
617 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
618
619 # files created by regxpcom and firefox -register
620 %ghost %{_libdir}/%{name}/components/compreg.dat
621 %ghost %{_libdir}/%{name}/components/xpti.dat
622
623 %files libs
624 %defattr(644,root,root,755)
625 %dir %{_libdir}/%{name}
626 %attr(755,root,root) %{_libdir}/%{name}/*.so
627
628 %files lang-en
629 %defattr(644,root,root,755)
630 %{_datadir}/%{name}/chrome/en-US.jar
631 %{_datadir}/%{name}/chrome/en-US.manifest
632
633 %if %{with tidy}
634 %files addon-tidy
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
637 %{_libdir}/%{name}/components/nstidy.xpt
638 %endif
This page took 0.205344 seconds and 4 git commands to generate.