]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- updated configure options
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 %bcond_with     tidy            # enable htmlvalidator extension (tidy)
13 #
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %undefine       with_gnomevfs
17 %endif
18 %define         tidy_ver        0.8.4.0
19 %define         firefox_ver     2.0.0.6
20 #
21 Summary:        Firefox Community Edition web browser
22 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
23 Name:           mozilla-firefox
24 Version:        %{firefox_ver}
25 Release:        1
26 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
27 Group:          X11/Applications/Networking
28 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
29 # Source0-md5:  16fb252fb7b0371894f7101b88fd9076
30 Source1:        http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
31 # Source1-md5:  cd5d54c47f08286605eaaa308536d4ab
32 Source2:        %{name}.desktop
33 Source3:        %{name}.sh
34 Patch0:         mozilla-install.patch
35 Patch1:         %{name}-lib_path.patch
36 Patch2:         %{name}-addon-tidy.patch
37 Patch3:         %{name}-nopangoxft.patch
38 Patch5:         %{name}-fonts.patch
39 Patch6:         %{name}-agent.patch
40 Patch7:         %{name}-myspell.patch
41 # if ac rebuild is needed...
42 #PatchX:                %{name}-ac.patch
43 URL:            http://www.mozilla.org/projects/firefox/
44 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
45 BuildRequires:  automake
46 BuildRequires:  cairo-devel >= 1.0.0
47 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
48 BuildRequires:  gtk+2-devel >= 1:2.0.0
49 BuildRequires:  krb5-devel
50 BuildRequires:  libIDL-devel >= 0.8.0
51 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
52 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
53 BuildRequires:  libjpeg-devel >= 6b
54 BuildRequires:  libpng-devel >= 1.2.7
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  myspell-devel
57 BuildRequires:  nspr-devel >= 1:4.6.3
58 BuildRequires:  nss-devel >= 1:3.11.3-3
59 %{?with_tidy:BuildRequires:     opensp-devel >= 2:1.5.2-4}
60 BuildRequires:  pango-devel >= 1:1.6.0
61 BuildRequires:  perl-modules >= 5.004
62 BuildRequires:  pkgconfig
63 BuildRequires:  rpmbuild(macros) >= 1.356
64 BuildRequires:  xorg-lib-libXext-devel
65 BuildRequires:  xorg-lib-libXft-devel >= 2.1
66 BuildRequires:  xorg-lib-libXinerama-devel
67 BuildRequires:  xorg-lib-libXp-devel
68 BuildRequires:  xorg-lib-libXt-devel
69 BuildRequires:  zip
70 BuildRequires:  zlib-devel >= 1.2.3
71 Requires(post): mktemp >= 1.5-18
72 Requires:       %{name}-lang-resources = %{version}
73 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
74 Requires:       browser-plugins >= 2.0
75 Requires:       nspr >= 1:4.6.3
76 Requires:       nss >= 1:3.11.3
77 Provides:       wwwbrowser
78 Obsoletes:      mozilla-firebird
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 # firefox/thunderbird/seamonkey provide their own versions
82 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
83 %define         _noautoprovfiles        %{_libdir}/%{name}/components
84 # we don't want these to satisfy xulrunner-devel
85 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
86 # and as we don't provide them, don't require either
87 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
88
89 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
90
91 %description
92 Firefox Community Edition is an open-source web browser, designed for
93 standards compliance, performance and portability.
94
95 %description -l pl.UTF-8
96 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
97 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
98 o zgodności ze standardami, wydajnością i przenośnością.
99
100 %package libs
101 Summary:        Firefox Community Edition shared libraries
102 Summary(pl.UTF-8):      Biblioteki współdzielone przeglądarki Firefox Community Edition
103 Group:          Libraries
104 Conflicts:      mozilla-firefox < 2.0-1.4
105
106 %description libs
107 Firefox Community Edition shared libraries.
108
109 %description libs -l pl.UTF-8
110 Biblioteki współdzielone przeglądarki Firefox Community Edition.
111
112 %package addon-tidy
113 Summary:        HTML Validator for Firefox
114 Summary(pl.UTF-8):      Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
115 Version:        %{tidy_ver}
116 License:        GPL
117 Group:          X11/Applications/Networking
118 Requires:       %{name} = %{firefox_ver}-%{release}
119
120 %description addon-tidy
121 HTML Validator is a Mozilla extension that adds HTML validation inside
122 Firefox. The number of errors of a HTML page is seen on the form of an
123 icon in the status bar when browsing.
124
125 %description addon-tidy -l pl.UTF-8
126 HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
127 poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
128 HTML można zobaczyć w postaci ikony na pasku stanu.
129
130 %package lang-en
131 Summary:        English resources for Firefox Community Edition
132 Summary(pl.UTF-8):      Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
133 Version:        %{firefox_ver}
134 Group:          X11/Applications/Networking
135 Requires:       %{name} = %{firefox_ver}-%{release}
136 Provides:       %{name}-lang-resources = %{firefox_ver}-%{release}
137
138 %description lang-en
139 English resources for Firefox Community Edition.
140
141 %description lang-en -l pl.UTF-8
142 Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
143
144 %prep
145 %setup -qc %{?with_tidy:-a1}
146 %if %{with tidy}
147 mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
148 mv mozilla_tidy_source/tidy_extension .
149 rm -rf mozilla/extensions/tidy/opensp
150 %endif
151 cd mozilla
152 %patch0 -p1
153 %patch1 -p1
154 %{?with_tidy:%patch2 -p1}
155 %patch3 -p1
156 %patch5 -p1
157 %patch6 -p1
158 %patch7 -p1
159
160 # use system
161 #rm -rf mozilla/nsprpub mozilla/security/nss
162
163 %build
164 cd mozilla
165 export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
166 export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
167
168 cp -f %{_datadir}/automake/config.* build/autoconf
169 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
170 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
171
172 cat << 'EOF' > .mozconfig
173 . $topsrcdir/browser/config/mozconfig
174
175 # Options for 'configure' (same as command-line options).
176 ac_add_options --prefix=%{_prefix}
177 ac_add_options --exec-prefix=%{_exec_prefix}
178 ac_add_options --bindir=%{_bindir}
179 ac_add_options --sbindir=%{_sbindir}
180 ac_add_options --sysconfdir=%{_sysconfdir}
181 ac_add_options --datadir=%{_datadir}
182 ac_add_options --includedir=%{_includedir}
183 ac_add_options --libdir=%{_libdir}
184 ac_add_options --libexecdir=%{_libexecdir}
185 ac_add_options --localstatedir=%{_localstatedir}
186 ac_add_options --sharedstatedir=%{_sharedstatedir}
187 ac_add_options --mandir=%{_mandir}
188 ac_add_options --infodir=%{_infodir}
189 %if %{?debug:1}0
190 ac_add_options --disable-optimize
191 ac_add_options --enable-debug
192 ac_add_options --enable-debug-modules
193 ac_add_options --enable-debugger-info-modules
194 ac_add_options --enable-crash-on-assert
195 %else
196 ac_add_options --disable-debug
197 ac_add_options --disable-logging
198 ac_add_options --enable-optimize="%{rpmcflags}"
199 %endif
200 %if %{with tests}
201 ac_add_options --enable-tests
202 %else
203 ac_add_options --disable-tests
204 %endif
205 %if %{with gnomeui}
206 ac_add_options --enable-gnomeui
207 %else
208 ac_add_options --disable-gnomeui
209 %endif
210 %if %{with gnomevfs}
211 ac_add_options --enable-gnomevfs
212 %else
213 ac_add_options --disable-gnomevfs
214 %endif
215 ac_add_options --disable-freetype2
216 ac_add_options --disable-installer
217 ac_add_options --disable-javaxpcom
218 ac_add_options --disable-updater
219 ac_add_options --enable-default-toolkit=gtk2
220 ac_add_options --enable-svg
221 ac_add_options --enable-system-cairo
222 ac_add_options --enable-system-myspell
223 ac_add_options --enable-xft
224 ac_add_options --with-distribution-id=org.pld-linux
225 ac_add_options --with-system-nspr
226 ac_add_options --with-system-nss
227 ac_add_options --with-system-zlib
228 ac_add_options --with-system-jpeg
229 ac_add_options --with-system-png
230 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
231 ac_cv_visibility_pragma=no
232 EOF
233
234 %{__make} -j1 -f client.mk build \
235         CC="%{__cc}" \
236         CXX="%{__cxx}"
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 cd mozilla
241 install -d \
242         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
243         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
244         $RPM_BUILD_ROOT%{_datadir}/%{name}
245
246 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
247
248 %{__make} -C xpinstall/packager stage-package \
249         DESTDIR=$RPM_BUILD_ROOT \
250         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
251         PKG_SKIP_STRIP=1
252
253 # move arch independant ones to datadir
254 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
255 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
256 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
257 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
258 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
259 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
260 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
261 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
262 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
263 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
264 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
265 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
266 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
267 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
268 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
269 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
270
271 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
272 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
273
274 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
275 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
276
277 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
278
279 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
280
281 # header/development files
282 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
283 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
284 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
285
286 # files created by regxpcom and firefox -register
287 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
288 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
289
290 # what's this? it's content is invalid anyway.
291 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
292 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
293
294 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
295 #!/bin/sh
296 umask 022
297 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
298
299 # it attempts to touch files in $HOME/.mozilla
300 # beware if you run this with sudo!!!
301 export HOME=$(mktemp -d)
302 # also TMPDIR could be pointing to sudo user's homedir
303 unset TMPDIR TMP || :
304
305 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
306 %{_libdir}/%{name}/firefox -register
307
308 rm -rf $HOME
309 EOF
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %pretrans
315 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
316         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
317 fi
318 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
319         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
320                 install -d %{_datadir}/%{name}
321                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
322         fi
323 done
324 exit 0
325
326 %post
327 %{_sbindir}/%{name}-chrome+xpcom-generate
328 %update_browser_plugins
329
330 %postun
331 if [ "$1" = 0 ]; then
332         %update_browser_plugins
333 fi
334
335 %files
336 %defattr(644,root,root,755)
337 %attr(755,root,root) %{_bindir}/%{name}
338 %attr(755,root,root) %{_bindir}/firefox
339 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
340
341 # browser plugins v2
342 %{_browserpluginsconfdir}/browsers.d/%{name}.*
343 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
344
345 %dir %{_libdir}/%{name}/components
346 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
361 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
362 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
363 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
364 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
365 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
366 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
367 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
368 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
369 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
370 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
371 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
372 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
373 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
374 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
375 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
376 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
377 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
378 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
379 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
380 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
381 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
382 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
383 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
384 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
385 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
386 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
387 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
388 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
389 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
390 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
391 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
392 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
393 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
394 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
395 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
396 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
397 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
398 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
399 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
400 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
401 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
402 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
403 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
404 %{_libdir}/%{name}/components/accessibility-atk.xpt
405 %{_libdir}/%{name}/components/accessibility.xpt
406 %{_libdir}/%{name}/components/alerts.xpt
407 %{_libdir}/%{name}/components/appshell.xpt
408 %{_libdir}/%{name}/components/appstartup.xpt
409 %{_libdir}/%{name}/components/autocomplete.xpt
410 %{_libdir}/%{name}/components/autoconfig.xpt
411 %{_libdir}/%{name}/components/bookmarks.xpt
412 %{_libdir}/%{name}/components/browsercompsbase.xpt
413 %{_libdir}/%{name}/components/browser-feeds.xpt
414 %{_libdir}/%{name}/components/browsersearch.xpt
415 %{_libdir}/%{name}/components/caps.xpt
416 %{_libdir}/%{name}/components/chardet.xpt
417 %{_libdir}/%{name}/components/chrome.xpt
418 %{_libdir}/%{name}/components/commandhandler.xpt
419 %{_libdir}/%{name}/components/commandlines.xpt
420 %{_libdir}/%{name}/components/composer.xpt
421 %{_libdir}/%{name}/components/content_base.xpt
422 %{_libdir}/%{name}/components/content_htmldoc.xpt
423 %{_libdir}/%{name}/components/content_html.xpt
424 %{_libdir}/%{name}/components/content_xmldoc.xpt
425 %{_libdir}/%{name}/components/content_xslt.xpt
426 %{_libdir}/%{name}/components/content_xtf.xpt
427 %{_libdir}/%{name}/components/cookie.xpt
428 %{_libdir}/%{name}/components/directory.xpt
429 %{_libdir}/%{name}/components/docshell.xpt
430 %{_libdir}/%{name}/components/dom_base.xpt
431 %{_libdir}/%{name}/components/dom_canvas.xpt
432 %{_libdir}/%{name}/components/dom_core.xpt
433 %{_libdir}/%{name}/components/dom_css.xpt
434 %{_libdir}/%{name}/components/dom_events.xpt
435 %{_libdir}/%{name}/components/dom_html.xpt
436 %{_libdir}/%{name}/components/dom_loadsave.xpt
437 %{_libdir}/%{name}/components/dom_range.xpt
438 %{_libdir}/%{name}/components/dom_sidebar.xpt
439 %{_libdir}/%{name}/components/dom_storage.xpt
440 %{_libdir}/%{name}/components/dom_stylesheets.xpt
441 %{_libdir}/%{name}/components/dom_svg.xpt
442 %{_libdir}/%{name}/components/dom_traversal.xpt
443 %{_libdir}/%{name}/components/dom_views.xpt
444 %{_libdir}/%{name}/components/dom_xbl.xpt
445 %{_libdir}/%{name}/components/dom_xpath.xpt
446 %{_libdir}/%{name}/components/dom.xpt
447 %{_libdir}/%{name}/components/dom_xul.xpt
448 %{_libdir}/%{name}/components/downloads.xpt
449 %{_libdir}/%{name}/components/editor.xpt
450 %{_libdir}/%{name}/components/embed_base.xpt
451 %{_libdir}/%{name}/components/extensions.xpt
452 %{_libdir}/%{name}/components/exthandler.xpt
453 %{_libdir}/%{name}/components/fastfind.xpt
454 %{_libdir}/%{name}/components/FeedConverter.js
455 %{_libdir}/%{name}/components/FeedProcessor.js
456 %{_libdir}/%{name}/components/feeds.xpt
457 %{_libdir}/%{name}/components/FeedWriter.js
458 %{_libdir}/%{name}/components/filepicker.xpt
459 %{_libdir}/%{name}/components/find.xpt
460 %{_libdir}/%{name}/components/gfx.xpt
461 %{_libdir}/%{name}/components/gksvgrenderer.xpt
462 %{_libdir}/%{name}/components/history.xpt
463 %{_libdir}/%{name}/components/htmlparser.xpt
464 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
465 %{_libdir}/%{name}/components/imglib2.xpt
466 %{_libdir}/%{name}/components/inspector.xpt
467 %{_libdir}/%{name}/components/intl.xpt
468 %{_libdir}/%{name}/components/jar.xpt
469 %{_libdir}/%{name}/components/jsconsole-clhandler.js
470 %{_libdir}/%{name}/components/jsconsole.xpt
471 %{_libdir}/%{name}/components/jsdservice.xpt
472 %{_libdir}/%{name}/components/layout_base.xpt
473 %{_libdir}/%{name}/components/layout_printing.xpt
474 %{_libdir}/%{name}/components/layout_xul_tree.xpt
475 %{_libdir}/%{name}/components/layout_xul.xpt
476 %{_libdir}/%{name}/components/locale.xpt
477 %{_libdir}/%{name}/components/lwbrk.xpt
478 %{_libdir}/%{name}/components/microsummaries.xpt
479 %{_libdir}/%{name}/components/migration.xpt
480 %{_libdir}/%{name}/components/mimetype.xpt
481 %{_libdir}/%{name}/components/mozbrwsr.xpt
482 %{_libdir}/%{name}/components/mozfind.xpt
483 %{_libdir}/%{name}/components/mozgnome.xpt
484 %{_libdir}/%{name}/components/necko_about.xpt
485 %{_libdir}/%{name}/components/necko_cache.xpt
486 %{_libdir}/%{name}/components/necko_cookie.xpt
487 %{_libdir}/%{name}/components/necko_data.xpt
488 %{_libdir}/%{name}/components/necko_dns.xpt
489 %{_libdir}/%{name}/components/necko_file.xpt
490 %{_libdir}/%{name}/components/necko_ftp.xpt
491 %{_libdir}/%{name}/components/necko_http.xpt
492 %{_libdir}/%{name}/components/necko_res.xpt
493 %{_libdir}/%{name}/components/necko_socket.xpt
494 %{_libdir}/%{name}/components/necko_strconv.xpt
495 %{_libdir}/%{name}/components/necko_viewsource.xpt
496 %{_libdir}/%{name}/components/necko.xpt
497 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
498 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
499 %{_libdir}/%{name}/components/nsBrowserGlue.js
500 %{_libdir}/%{name}/components/nsCloseAllWindows.js
501 %{_libdir}/%{name}/components/nsDefaultCLH.js
502 %{_libdir}/%{name}/components/nsDictionary.js
503 %{_libdir}/%{name}/components/nsExtensionManager.js
504 %{_libdir}/%{name}/components/nsFilePicker.js
505 %{_libdir}/%{name}/components/nsHelperAppDlg.js
506 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
507 %{_libdir}/%{name}/components/nsKillAll.js
508 %{_libdir}/%{name}/components/nsMicrosummaryService.js
509 %{_libdir}/%{name}/components/nsProgressDialog.js
510 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
511 %{_libdir}/%{name}/components/nsResetPref.js
512 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
513 %{_libdir}/%{name}/components/nsSearchService.js
514 %{_libdir}/%{name}/components/nsSearchSuggestions.js
515 %{_libdir}/%{name}/components/nsSessionStartup.js
516 %{_libdir}/%{name}/components/nsSessionStore.js
517 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
518 %{_libdir}/%{name}/components/nsSidebar.js
519 %{_libdir}/%{name}/components/nsUpdateService.js
520 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
521 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
522 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
523 %{_libdir}/%{name}/components/nsURLFormatter.js
524 %{_libdir}/%{name}/components/nsXmlRpcClient.js
525 %{_libdir}/%{name}/components/oji.xpt
526 %{_libdir}/%{name}/components/passwordmgr.xpt
527 %{_libdir}/%{name}/components/pipboot.xpt
528 %{_libdir}/%{name}/components/pipnss.xpt
529 %{_libdir}/%{name}/components/pippki.xpt
530 %{_libdir}/%{name}/components/plugin.xpt
531 %{_libdir}/%{name}/components/prefetch.xpt
532 %{_libdir}/%{name}/components/pref.xpt
533 %{_libdir}/%{name}/components/profile.xpt
534 %{_libdir}/%{name}/components/progressDlg.xpt
535 %{_libdir}/%{name}/components/proxyObjInst.xpt
536 %{_libdir}/%{name}/components/rdf.xpt
537 %{_libdir}/%{name}/components/safebrowsing.xpt
538 %{_libdir}/%{name}/components/satchel.xpt
539 %{_libdir}/%{name}/components/saxparser.xpt
540 %{_libdir}/%{name}/components/search.xpt
541 %{_libdir}/%{name}/components/sessionstore.xpt
542 %{_libdir}/%{name}/components/shellservice.xpt
543 %{_libdir}/%{name}/components/shistory.xpt
544 %{_libdir}/%{name}/components/spellchecker.xpt
545 %{_libdir}/%{name}/components/storage.xpt
546 %{_libdir}/%{name}/components/toolkitprofile.xpt
547 %{_libdir}/%{name}/components/toolkitremote.xpt
548 %{_libdir}/%{name}/components/txmgr.xpt
549 %{_libdir}/%{name}/components/txtsvc.xpt
550 %{_libdir}/%{name}/components/uconv.xpt
551 %{_libdir}/%{name}/components/unicharutil.xpt
552 %{_libdir}/%{name}/components/update.xpt
553 %{_libdir}/%{name}/components/uriloader.xpt
554 %{_libdir}/%{name}/components/url-classifier.xpt
555 %{_libdir}/%{name}/components/urlformatter.xpt
556 %{_libdir}/%{name}/components/webBrowser_core.xpt
557 %{_libdir}/%{name}/components/webbrowserpersist.xpt
558 %{_libdir}/%{name}/components/WebContentConverter.js
559 %{_libdir}/%{name}/components/webshell_idls.xpt
560 %{_libdir}/%{name}/components/websrvcs.xpt
561 %{_libdir}/%{name}/components/widget.xpt
562 %{_libdir}/%{name}/components/windowds.xpt
563 %{_libdir}/%{name}/components/windowwatcher.xpt
564 %{_libdir}/%{name}/components/xml-rpc.xpt
565 %{_libdir}/%{name}/components/xpcom_base.xpt
566 %{_libdir}/%{name}/components/xpcom_components.xpt
567 %{_libdir}/%{name}/components/xpcom_ds.xpt
568 %{_libdir}/%{name}/components/xpcom_io.xpt
569 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
570 %{_libdir}/%{name}/components/xpcom_threads.xpt
571 %{_libdir}/%{name}/components/xpcom_xpti.xpt
572 %{_libdir}/%{name}/components/xpconnect.xpt
573 %{_libdir}/%{name}/components/xpinstall.xpt
574 %{_libdir}/%{name}/components/xulapp.xpt
575 %{_libdir}/%{name}/components/xuldoc.xpt
576 %{_libdir}/%{name}/components/xultmpl.xpt
577 %dir %{_libdir}/%{name}/plugins
578 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
579 %attr(755,root,root) %{_libdir}/%{name}/*.sh
580 %attr(755,root,root) %{_libdir}/%{name}/m*
581 %attr(755,root,root) %{_libdir}/%{name}/f*
582 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
583 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
584 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
585 %{_pixmapsdir}/mozilla-firefox.png
586 %{_desktopdir}/mozilla-firefox.desktop
587
588 # symlinks
589 %{_libdir}/%{name}/chrome
590 %{_libdir}/%{name}/defaults
591 %{_libdir}/%{name}/dictionaries
592 %{_libdir}/%{name}/extensions
593 %{_libdir}/%{name}/greprefs
594 %{_libdir}/%{name}/icons
595 %{_libdir}/%{name}/init.d
596 %{_libdir}/%{name}/res
597 %{_libdir}/%{name}/searchplugins
598
599 # browserconfig
600 %{_libdir}/%{name}/browserconfig.properties
601
602 %{_libdir}/%{name}/LICENSE
603 %{_libdir}/%{name}/README.txt
604
605 %dir %{_datadir}/%{name}
606 %{_datadir}/%{name}/chrome
607 %{_datadir}/%{name}/defaults
608 %{_datadir}/%{name}/greprefs
609 %{_datadir}/%{name}/icons
610 %{_datadir}/%{name}/init.d
611 %{_datadir}/%{name}/res
612 %{_datadir}/%{name}/searchplugins
613
614 %dir %{_datadir}/%{name}/extensions
615 # -dom-inspector subpackage?
616 %{_datadir}/%{name}/extensions/inspector@mozilla.org
617 # the signature of the default theme
618 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
619
620 # files created by regxpcom and firefox -register
621 %ghost %{_libdir}/%{name}/components/compreg.dat
622 %ghost %{_libdir}/%{name}/components/xpti.dat
623
624 %files libs
625 %defattr(644,root,root,755)
626 %dir %{_libdir}/%{name}
627 %attr(755,root,root) %{_libdir}/%{name}/*.so
628
629 %files lang-en
630 %defattr(644,root,root,755)
631 %{_datadir}/%{name}/chrome/en-US.jar
632 %{_datadir}/%{name}/chrome/en-US.manifest
633
634 %if %{with tidy}
635 %files addon-tidy
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
638 %attr(755,root,root) %{_libdir}/%{name}/components/libtodel.so
639 %{_libdir}/%{name}/components/nstidy.xpt
640 %endif
This page took 0.113209 seconds and 4 git commands to generate.