]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- up to 1.0.7
[packages/firefox.git] / mozilla-firefox.spec
1 #
2 # TODO:
3 # - handle locales differently (runtime, since it's possible to do)
4 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
5 #   for hints how to make locales and other stuff like extensions working
6 # - unpackaged files check
7 #   /usr/lib/mozilla-firefox/LICENSE
8 #   /usr/lib/mozilla-firefox/README.txt
9 #   /usr/lib/mozilla-firefox/browserconfig.properties
10 #   /usr/lib/mozilla-firefox/chrome/chatzilla.jar
11 #   /usr/lib/mozilla-firefox/chrome/chromelist.txt
12 #   /usr/lib/mozilla-firefox/chrome/content-packs.jar
13 #   /usr/lib/mozilla-firefox/chrome/embed-sample.jar
14 #   /usr/lib/mozilla-firefox/chrome/installed-chrome.txt
15 #   /usr/lib/mozilla-firefox/components/myspell/en-US.aff
16 #   /usr/lib/mozilla-firefox/components/myspell/en-US.dic
17 #   /usr/lib/mozilla-firefox/init.d/README
18 #
19 # Conditional build:
20 %bcond_with     tests   # enable tests (whatever they check)
21 %bcond_without  ft218   # compile with freetype < 2.1.8
22 #
23 Summary:        Mozilla Firefox web browser
24 Summary(pl):    Mozilla Firefox - przegl±darka WWW
25 Name:           mozilla-firefox
26 Version:        1.0.7
27 Release:        1
28 License:        MPL/LGPL
29 Group:          X11/Applications/Networking
30 Source0:        http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
31 # Source0-md5:  5704a8c36de84b408e069afb0c5bc1df
32 Source1:        %{name}.desktop
33 Source2:        %{name}.sh
34 Patch0:         %{name}-alpha-gcc3.patch
35 Patch1:         %{name}-gfx.patch
36 Patch2:         %{name}-nss.patch
37 Patch3:         %{name}-lib_path.patch
38 Patch4:         %{name}-freetype.patch
39 Patch5:         %{name}-searchplugins.patch
40 Patch6:         %{name}-gcc-bugs.patch
41 URL:            http://www.mozilla.org/projects/firefox/
42 BuildRequires:  automake
43 %if %{with ft218}
44 BuildRequires:  freetype-devel >= 1:2.1.9
45 %else
46 BuildRequires:  freetype-devel >= 2.1.3
47 BuildRequires:  freetype-devel < 1:2.1.8
48 BuildConflicts: freetype-devel = 2.1.8
49 %endif
50 BuildRequires:  gtk+2-devel >= 1:2.0.0
51 BuildRequires:  heimdal-devel >= 0.7
52 BuildRequires:  libIDL-devel >= 0.8.0
53 BuildRequires:  libjpeg-devel >= 6b
54 BuildRequires:  libpng-devel >= 1.2.0
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  nspr-devel >= 1:4.6-0.20041030.1
57 BuildRequires:  nss-devel >= 3.8
58 BuildRequires:  pango-devel >= 1:1.1.0
59 BuildRequires:  perl-modules
60 BuildRequires:  pkgconfig
61 BuildRequires:  zip
62 Requires:       %{name}-lang-resources = %{version}
63 %if %{with ft218}
64 Requires:       freetype >= 1:2.1.3
65 %else
66 Requires:       freetype >= 2.1.3
67 Conflicts:      freetype = 2.1.8
68 %endif
69 Requires:       nspr >= 1:4.6-0.20041030.1
70 Requires:       nss >= 3.8
71 Obsoletes:      mozilla-firebird
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _firefoxdir     %{_libdir}/%{name}
75 # mozilla and firefox provide their own versions
76 %define         _noautoreqdep           libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so
77 %define         _noautoprovfiles        libplc4.so libplds4.so
78
79 %description
80 Mozilla Firefox is an open-source web browser, designed for standards
81 compliance, performance and portability.
82
83 %description -l pl
84 Mozilla Firefox jest open sourcow± przegl±dark± sieci WWW, stworzon± z
85 my¶l± o zgodno¶ci ze standardami, wydajno¶ci± i przeno¶no¶ci±.
86
87 %package devel
88 Summary:        Headers for developing programs that will use Mozilla Firefox
89 Summary(pl):    Mozilla Firefox - pliki nag³ówkowe i biblioteki
90 Group:          X11/Development/Libraries
91 Obsoletes:      mozilla-devel
92 Requires:       %{name} = %{epoch}:%{version}-%{release}
93 Requires:       nspr-devel >= 1:4.6-0.20041030.1
94
95 %description devel
96 Mozilla development package.
97
98 %description devel -l pl
99 Biblioteki i pliki nag³ówkowe.
100
101 %package lang-en
102 Summary:        English resources for Mozilla-firefox
103 Summary(pl):    Anglojêzyczne zasoby dla Mozilla-FireFox
104 Group:          X11/Applications/Networking
105 Requires(post,postun):  %{name} = %{version}-%{release}
106 Requires(post,postun):  textutils
107 Requires:       %{name} = %{version}-%{release}
108 Provides:       %{name}-lang-resources = %{version}-%{release}
109
110 %description lang-en
111 English resources for Mozilla-firefox
112
113 %description lang-en -l pl
114 Anglojêzyczne zasoby dla Mozilla-FireFox
115
116 %prep
117 %setup -q -c
118 cd mozilla
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123 %{?with_ft218:%patch4 -p1}
124 %patch5 -p0
125 %patch6 -p0
126 sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
127
128 %build
129 cd mozilla
130 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
131 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
132 export MOZ_PHOENIX="1"
133 export BUILD_OFFICIAL="1"
134 export MOZILLA_OFFICIAL="1"
135
136 cp -f %{_datadir}/automake/config.* build/autoconf
137 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
138 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
139 %configure2_13 \
140 %if %{?debug:1}0
141         --enable-debug \
142         --enable-debug-modules \
143 %else
144         --disable-debug \
145         --disable-debug-modules \
146 %endif
147         --disable-composer \
148         --disable-dtd-debug \
149         --disable-installer \
150         --disable-jsd \
151         --disable-ldap \
152         --disable-mailnews \
153 %if %{with tests}
154         --enable-tests \
155 %else
156         --disable-tests \
157 %endif
158         --disable-xprint \
159         --enable-crypto \
160         --enable-freetype2 \
161         --enable-mathml \
162         --enable-optimize="%{rpmcflags}" \
163         --enable-reorder \
164         --enable-strip \
165         --enable-strip-libs \
166         --enable-xinerama \
167         --enable-xft \
168         --enable-default-toolkit="gtk2" \
169         --with-pthreads \
170         --with-system-nspr \
171         --with-system-jpeg \
172         --with-system-png \
173         --with-system-zlib \
174         --enable-single-profile \
175         --disable-profilesharing \
176         --enable-extensions=default
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182 cd mozilla
183 install -d \
184         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
185         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
186         $RPM_BUILD_ROOT{%{_includedir}/%{name}/idl,%{_pkgconfigdir}}
187         
188 %{__make} -C xpinstall/packager \
189         MOZ_PKG_APPNAME="mozilla-firefox" \
190         MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
191         EXCLUDE_NSPR_LIBS=1
192
193 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
194
195 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*-linux-gnu.tar.gz
196
197 install other-licenses/branding/firefox/content/icon32.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
198 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
199 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
200
201 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
202
203 grep locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-en-US-installed-chrome.txt
204 grep -v locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-misc-installed-chrome.txt
205
206 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki
207 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
208
209 # header/developement files
210 cp -rfL dist/include/*  $RPM_BUILD_ROOT%{_includedir}/%{name}
211 cp -rfL dist/idl/*      $RPM_BUILD_ROOT%{_includedir}/%{name}/idl
212
213 install dist/bin/regchrome $RPM_BUILD_ROOT%{_bindir}
214 install dist/bin/regxpcom $RPM_BUILD_ROOT%{_bindir}
215 install dist/bin/xpidl $RPM_BUILD_ROOT%{_bindir}
216 install dist/bin/xpt_dump $RPM_BUILD_ROOT%{_bindir}
217 install dist/bin/xpt_link $RPM_BUILD_ROOT%{_bindir}
218
219 ln -sf %{_includedir}/mozilla-firefox/necko/nsIURI.h \
220         $RPM_BUILD_ROOT%{_includedir}/mozilla-firefox/nsIURI.h
221         
222 # CA certificates
223 ln -s %{_libdir}/libnssckbi.so $RPM_BUILD_ROOT%{_firefoxdir}/libnssckbi.so
224
225 # pkgconfig files
226 for f in build/unix/*.pc ; do
227         sed -e 's/firefox-%{version}/mozilla-firefox/' $f \
228             > $RPM_BUILD_ROOT%{_pkgconfigdir}/$(basename $f)
229 done
230
231 # already provided by standalone packages
232 rm -f $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-{nss,nspr}.pc
233
234 sed -i -e 's#firefox-nspr =.*#mozilla-nspr#g' -e 's#irefox-nss =.*#mozilla-nss#g' \
235         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
236
237 # includedir/dom CFLAGS         
238 sed -i -e '/Cflags:/{/{includedir}\/dom/!s,$, -I${includedir}/dom,}' \
239         $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-plugin.pc
240         
241 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/firefox-chrome+xpcom-generate
242 #!/bin/sh
243 umask 022
244 cat %{_firefoxdir}/chrome/*-installed-chrome.txt > %{_firefoxdir}/chrome/installed-chrome.txt
245 rm -f %{_firefoxdir}/chrome/{chrome.rdf,overlayinfo/*/*/*.rdf}
246 rm -f %{_firefoxdir}/components/{compreg,xpti}.dat
247 MOZILLA_FIVE_HOME=%{_firefoxdir}
248 export MOZILLA_FIVE_HOME
249
250 # PATH
251 PATH=%{_firefoxdir}:$PATH
252 export PATH
253
254 # added /usr/lib : don't load your local library
255 LD_LIBRARY_PATH=%{_firefoxdir}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
256 export LD_LIBRARY_PATH
257
258 unset TMPDIR TMP || :
259 %{_firefoxdir}/regxpcom
260 %{_firefoxdir}/regchrome
261 %{_firefoxdir}/firefox -register
262 EOF
263
264 %clean
265 rm -rf $RPM_BUILD_ROOT
266
267 %post
268 %{_sbindir}/firefox-chrome+xpcom-generate
269
270 %postun
271 if [ "$1" != "0" ]; then
272         %{_sbindir}/firefox-chrome+xpcom-generate
273 fi
274
275 %preun
276 if [ "$1" == "0" ]; then
277         rm -rf %{_firefoxdir}/chrome/overlayinfo
278         rm -f  %{_firefoxdir}/chrome/*.rdf
279         rm -rf %{_firefoxdir}/components
280         rm -rf %{_firefoxdir}/extensions
281 fi
282
283 %post lang-en
284 umask 022
285 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
286
287 %postun lang-en
288 umask 022
289 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
290
291 %files
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_bindir}/mozilla*
294 %attr(755,root,root) %{_sbindir}/*
295 %dir %{_firefoxdir}
296 %{_firefoxdir}/res
297 %dir %{_firefoxdir}/components
298 %attr(755,root,root) %{_firefoxdir}/components/*.so
299 %{_firefoxdir}/components/*.js
300 %{_firefoxdir}/components/*.xpt
301 %{_firefoxdir}/plugins
302 %{_firefoxdir}/searchplugins
303 %{_firefoxdir}/icons
304 %{_firefoxdir}/defaults
305 %{_firefoxdir}/greprefs
306 %dir %{_firefoxdir}/init.d
307 %attr(755,root,root) %{_firefoxdir}/*.so
308 %attr(755,root,root) %{_firefoxdir}/*.sh
309 %attr(755,root,root) %{_firefoxdir}/m*
310 %attr(755,root,root) %{_firefoxdir}/f*
311 %attr(755,root,root) %{_firefoxdir}/reg*
312 %attr(755,root,root) %{_firefoxdir}/x*
313 %attr(755,root,root) %{_firefoxdir}/T*
314 %ifarch %{ix86}
315 %attr(755,root,root) %{_firefoxdir}/elf-dynstr-gc
316 %endif
317 %{_firefoxdir}/bloaturls.txt
318 %{_pixmapsdir}/*
319 %{_desktopdir}/*
320
321 %dir %{_firefoxdir}/chrome
322 %{_firefoxdir}/chrome/browser.jar
323 # -chat subpackage?
324 #%{_firefoxdir}/chrome/chatzilla.jar
325 %{_firefoxdir}/chrome/classic.jar
326 %{_firefoxdir}/chrome/comm.jar
327 #%{_firefoxdir}/chrome/content-packs.jar
328 %{_firefoxdir}/chrome/help.jar
329 # -dom-inspector subpackage?
330 %{_firefoxdir}/chrome/inspector.jar
331 %{_firefoxdir}/chrome/modern.jar
332 %{_firefoxdir}/chrome/pip*.jar
333 %{_firefoxdir}/chrome/toolkit.jar
334 %{_firefoxdir}/chrome/mozilla-firefox-misc-installed-chrome.txt
335 %dir %{_firefoxdir}/chrome/icons
336 %{_firefoxdir}/chrome/icons/default
337
338 %files devel
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_bindir}/regchrome
341 %attr(755,root,root) %{_bindir}/regxpcom
342 %attr(755,root,root) %{_bindir}/xpidl
343 %attr(755,root,root) %{_bindir}/xpt_dump
344 %attr(755,root,root) %{_bindir}/xpt_link
345 %{_includedir}/%{name}
346 %{_pkgconfigdir}/*
347
348 %files lang-en
349 %defattr(644,root,root,755)
350 %{_firefoxdir}/chrome/en-US.jar
351 %{_firefoxdir}/chrome/mozilla-firefox-en-US-installed-chrome.txt
This page took 0.062145 seconds and 4 git commands to generate.