]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- cleanups, order configure options
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 %bcond_with     tidy            # htmlvalidator extension (tidy)
13 #
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %undefine       with_gnomevfs
17 %endif
18 %define         tidy_ver        0.8.4.1
19 %define         firefox_ver     2.0.0.8
20 #
21 Summary:        Firefox Community Edition web browser
22 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
23 Name:           mozilla-firefox
24 Version:        %{firefox_ver}
25 Release:        3
26 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
27 Group:          X11/Applications/Networking
28 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
29 # Source0-md5:  f4ffac67751bc3e556c4926da2e0b65a
30 Source1:        http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
31 # Source1-md5:  2cab81118267fc87c9ebbfa6fb44b113
32 Source2:        %{name}.desktop
33 Source3:        %{name}.sh
34 Patch0:         mozilla-install.patch
35 Patch1:         %{name}-lib_path.patch
36 Patch2:         %{name}-addon-tidy.patch
37 Patch3:         %{name}-fonts.patch
38 Patch4:         %{name}-agent.patch
39 Patch5:         %{name}-myspell.patch
40 # if ac rebuild is needed...
41 #PatchX:                %{name}-ac.patch
42 URL:            http://www.mozilla.org/projects/firefox/
43 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
44 BuildRequires:  automake
45 BuildRequires:  cairo-devel >= 1.0.0
46 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
47 BuildRequires:  gtk+2-devel >= 1:2.0.0
48 BuildRequires:  krb5-devel
49 BuildRequires:  libIDL-devel >= 0.8.0
50 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
52 BuildRequires:  libjpeg-devel >= 6b
53 BuildRequires:  libpng-devel >= 1.2.7
54 BuildRequires:  libstdc++-devel
55 BuildRequires:  myspell-devel
56 BuildRequires:  nspr-devel >= 1:4.6.3
57 BuildRequires:  nss-devel >= 1:3.11.3-3
58 %{?with_tidy:BuildRequires:     opensp-devel >= 2:1.5.2-4}
59 BuildRequires:  pango-devel >= 1:1.6.0
60 BuildRequires:  perl-modules >= 5.004
61 BuildRequires:  pkgconfig
62 BuildRequires:  rpmbuild(macros) >= 1.356
63 BuildRequires:  xorg-lib-libXext-devel
64 BuildRequires:  xorg-lib-libXft-devel >= 2.1
65 BuildRequires:  xorg-lib-libXinerama-devel
66 BuildRequires:  xorg-lib-libXp-devel
67 BuildRequires:  xorg-lib-libXt-devel
68 BuildRequires:  zip
69 BuildRequires:  zlib-devel >= 1.2.3
70 Requires(post): mktemp >= 1.5-18
71 Requires:       browser-plugins >= 2.0
72 Requires:       nspr >= 1:4.6.3
73 Requires:       nss >= 1:3.11.3
74 Provides:       wwwbrowser
75 Obsoletes:      mozilla-firebird
76 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
77 Obsoletes:      mozilla-firefox-libs
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 # firefox/thunderbird/seamonkey provide their own versions
81 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
82 %define         _noautoprovfiles        %{_libdir}/%{name}/components
83 # we don't want these to satisfy xulrunner-devel
84 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
85 # and as we don't provide them, don't require either
86 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
87
88 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
89
90 %description
91 Firefox Community Edition is an open-source web browser, designed for
92 standards compliance, performance and portability.
93
94 %description -l pl.UTF-8
95 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
96 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
97 o zgodności ze standardami, wydajnością i przenośnością.
98
99 %package addon-tidy
100 Summary:        HTML Validator for Firefox
101 Summary(pl.UTF-8):      Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
102 Version:        %{tidy_ver}
103 License:        GPL
104 Group:          X11/Applications/Networking
105 URL:            http://users.skynet.be/mgueury/mozilla/
106 Requires:       %{name} = %{firefox_ver}-%{release}
107
108 %description addon-tidy
109 HTML Validator is a Mozilla extension that adds HTML validation inside
110 Firefox. The number of errors of a HTML page is seen on the form of an
111 icon in the status bar when browsing.
112
113 %description addon-tidy -l pl.UTF-8
114 HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
115 poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
116 HTML można zobaczyć w postaci ikony na pasku stanu.
117
118 %prep
119 %setup -qc %{?with_tidy:-a1}
120 %if %{with tidy}
121 mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
122 mv mozilla_tidy_source/tidy_extension .
123 rm -rf mozilla/extensions/tidy/opensp
124 %endif
125 cd mozilla
126 %patch0 -p1
127 %patch1 -p1
128 %{?with_tidy:%patch2 -p1}
129 %patch3 -p1
130 %patch4 -p1
131 %patch5 -p1
132
133 %build
134 cd mozilla
135
136 cp -f %{_datadir}/automake/config.* build/autoconf
137 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
138 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
139
140 cat << 'EOF' > .mozconfig
141 . $topsrcdir/browser/config/mozconfig
142
143 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
144 ac_cv_visibility_pragma=no
145
146 # Options for 'configure' (same as command-line options).
147 ac_add_options --prefix=%{_prefix}
148 ac_add_options --exec-prefix=%{_exec_prefix}
149 ac_add_options --bindir=%{_bindir}
150 ac_add_options --sbindir=%{_sbindir}
151 ac_add_options --sysconfdir=%{_sysconfdir}
152 ac_add_options --datadir=%{_datadir}
153 ac_add_options --includedir=%{_includedir}
154 ac_add_options --libdir=%{_libdir}
155 ac_add_options --libexecdir=%{_libexecdir}
156 ac_add_options --localstatedir=%{_localstatedir}
157 ac_add_options --sharedstatedir=%{_sharedstatedir}
158 ac_add_options --mandir=%{_mandir}
159 ac_add_options --infodir=%{_infodir}
160 %if %{?debug:1}0
161 ac_add_options --disable-optimize
162 ac_add_options --enable-debug
163 ac_add_options --enable-debug-modules
164 ac_add_options --enable-debugger-info-modules
165 ac_add_options --enable-crash-on-assert
166 %else
167 ac_add_options --disable-debug
168 ac_add_options --disable-debug-modules
169 ac_add_options --disable-logging
170 ac_add_options --enable-optimize="%{rpmcflags}"
171 %endif
172 %if %{with tests}
173 ac_add_options --enable-tests
174 %else
175 ac_add_options --disable-tests
176 %endif
177 %if %{with gnomeui}
178 ac_add_options --enable-gnomeui
179 %else
180 ac_add_options --disable-gnomeui
181 %endif
182 %if %{with gnomevfs}
183 ac_add_options --enable-gnomevfs
184 %else
185 ac_add_options --disable-gnomevfs
186 %endif
187 ac_add_options --disable-freetype2
188 ac_add_options --disable-installer
189 ac_add_options --disable-javaxpcom
190 ac_add_options --disable-updater
191 ac_add_options --enable-default-toolkit=gtk2
192 ac_add_options --enable-svg
193 ac_add_options --enable-system-cairo
194 ac_add_options --enable-system-myspell
195 ac_add_options --enable-xft
196 ac_add_options --with-distribution-id=org.pld-linux
197 ac_add_options --with-system-jpeg
198 ac_add_options --with-system-nspr
199 ac_add_options --with-system-nss
200 ac_add_options --with-system-png
201 ac_add_options --with-system-zlib
202 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
203 EOF
204
205 %{__make} -j1 -f client.mk build \
206         CC="%{__cc}" \
207         CXX="%{__cxx}"
208
209 %install
210 rm -rf $RPM_BUILD_ROOT
211 cd mozilla
212 install -d \
213         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
214         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
215         $RPM_BUILD_ROOT%{_datadir}/%{name}
216
217 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
218
219 %{__make} -C obj-%{_target_cpu}/xpinstall/packager stage-package \
220         DESTDIR=$RPM_BUILD_ROOT \
221         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
222         PKG_SKIP_STRIP=1
223
224 # move arch independant ones to datadir
225 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
226 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
227 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
228 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
229 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
230 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
231 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
232 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
233 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
234 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
235 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
236 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
237 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
238 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
239 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
240 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
241
242 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
243 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
244
245 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
246 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
247
248 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
249
250 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
251
252 # header/development files
253 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
254 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
255 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
256
257 # files created by regxpcom and firefox -register
258 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
259 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
260
261 # what's this? it's content is invalid anyway.
262 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
263 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
264
265 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
266 #!/bin/sh
267 umask 022
268 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
269
270 # it attempts to touch files in $HOME/.mozilla
271 # beware if you run this with sudo!!!
272 export HOME=$(mktemp -d)
273 # also TMPDIR could be pointing to sudo user's homedir
274 unset TMPDIR TMP || :
275
276 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
277 %{_libdir}/%{name}/firefox -register
278
279 rm -rf $HOME
280 EOF
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %pretrans
286 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
287         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
288 fi
289 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
290         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
291                 install -d %{_datadir}/%{name}
292                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
293         fi
294 done
295 exit 0
296
297 %post
298 %{_sbindir}/%{name}-chrome+xpcom-generate
299 %update_browser_plugins
300
301 %postun
302 if [ "$1" = 0 ]; then
303         %update_browser_plugins
304 fi
305
306 %files
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_bindir}/%{name}
309 %attr(755,root,root) %{_bindir}/firefox
310 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
311
312 # browser plugins v2
313 %{_browserpluginsconfdir}/browsers.d/%{name}.*
314 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
315
316 %dir %{_libdir}/%{name}
317 %attr(755,root,root) %{_libdir}/%{name}/*.so
318
319 %dir %{_libdir}/%{name}/components
320 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
321 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
322 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
323 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
324 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
325 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
326 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
327 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
328 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
329 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
330 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
331 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
332 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
333 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
334 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
335 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
336 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
337 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
340 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
341 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
342 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
347 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
348 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
351 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
352 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
361 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
362 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
363 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
364 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
365 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
366 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
367 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
368 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
369 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
370 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
371 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
372 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
373 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
374 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
375 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
376 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
377 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
378 %{_libdir}/%{name}/components/accessibility-atk.xpt
379 %{_libdir}/%{name}/components/accessibility.xpt
380 %{_libdir}/%{name}/components/alerts.xpt
381 %{_libdir}/%{name}/components/appshell.xpt
382 %{_libdir}/%{name}/components/appstartup.xpt
383 %{_libdir}/%{name}/components/autocomplete.xpt
384 %{_libdir}/%{name}/components/autoconfig.xpt
385 %{_libdir}/%{name}/components/bookmarks.xpt
386 %{_libdir}/%{name}/components/browsercompsbase.xpt
387 %{_libdir}/%{name}/components/browser-feeds.xpt
388 %{_libdir}/%{name}/components/browsersearch.xpt
389 %{_libdir}/%{name}/components/caps.xpt
390 %{_libdir}/%{name}/components/chardet.xpt
391 %{_libdir}/%{name}/components/chrome.xpt
392 %{_libdir}/%{name}/components/commandhandler.xpt
393 %{_libdir}/%{name}/components/commandlines.xpt
394 %{_libdir}/%{name}/components/composer.xpt
395 %{_libdir}/%{name}/components/content_base.xpt
396 %{_libdir}/%{name}/components/content_htmldoc.xpt
397 %{_libdir}/%{name}/components/content_html.xpt
398 %{_libdir}/%{name}/components/content_xmldoc.xpt
399 %{_libdir}/%{name}/components/content_xslt.xpt
400 %{_libdir}/%{name}/components/content_xtf.xpt
401 %{_libdir}/%{name}/components/cookie.xpt
402 %{_libdir}/%{name}/components/directory.xpt
403 %{_libdir}/%{name}/components/docshell.xpt
404 %{_libdir}/%{name}/components/dom_base.xpt
405 %{_libdir}/%{name}/components/dom_canvas.xpt
406 %{_libdir}/%{name}/components/dom_core.xpt
407 %{_libdir}/%{name}/components/dom_css.xpt
408 %{_libdir}/%{name}/components/dom_events.xpt
409 %{_libdir}/%{name}/components/dom_html.xpt
410 %{_libdir}/%{name}/components/dom_loadsave.xpt
411 %{_libdir}/%{name}/components/dom_range.xpt
412 %{_libdir}/%{name}/components/dom_sidebar.xpt
413 %{_libdir}/%{name}/components/dom_storage.xpt
414 %{_libdir}/%{name}/components/dom_stylesheets.xpt
415 %{_libdir}/%{name}/components/dom_svg.xpt
416 %{_libdir}/%{name}/components/dom_traversal.xpt
417 %{_libdir}/%{name}/components/dom_views.xpt
418 %{_libdir}/%{name}/components/dom_xbl.xpt
419 %{_libdir}/%{name}/components/dom_xpath.xpt
420 %{_libdir}/%{name}/components/dom.xpt
421 %{_libdir}/%{name}/components/dom_xul.xpt
422 %{_libdir}/%{name}/components/downloads.xpt
423 %{_libdir}/%{name}/components/editor.xpt
424 %{_libdir}/%{name}/components/embed_base.xpt
425 %{_libdir}/%{name}/components/extensions.xpt
426 %{_libdir}/%{name}/components/exthandler.xpt
427 %{_libdir}/%{name}/components/fastfind.xpt
428 %{_libdir}/%{name}/components/FeedConverter.js
429 %{_libdir}/%{name}/components/FeedProcessor.js
430 %{_libdir}/%{name}/components/feeds.xpt
431 %{_libdir}/%{name}/components/FeedWriter.js
432 %{_libdir}/%{name}/components/filepicker.xpt
433 %{_libdir}/%{name}/components/find.xpt
434 %{_libdir}/%{name}/components/gfx.xpt
435 %{_libdir}/%{name}/components/gksvgrenderer.xpt
436 %{_libdir}/%{name}/components/history.xpt
437 %{_libdir}/%{name}/components/htmlparser.xpt
438 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
439 %{_libdir}/%{name}/components/imglib2.xpt
440 %{_libdir}/%{name}/components/inspector.xpt
441 %{_libdir}/%{name}/components/intl.xpt
442 %{_libdir}/%{name}/components/jar.xpt
443 %{_libdir}/%{name}/components/jsconsole-clhandler.js
444 %{_libdir}/%{name}/components/jsconsole.xpt
445 %{_libdir}/%{name}/components/jsdservice.xpt
446 %{_libdir}/%{name}/components/layout_base.xpt
447 %{_libdir}/%{name}/components/layout_printing.xpt
448 %{_libdir}/%{name}/components/layout_xul_tree.xpt
449 %{_libdir}/%{name}/components/layout_xul.xpt
450 %{_libdir}/%{name}/components/locale.xpt
451 %{_libdir}/%{name}/components/lwbrk.xpt
452 %{_libdir}/%{name}/components/microsummaries.xpt
453 %{_libdir}/%{name}/components/migration.xpt
454 %{_libdir}/%{name}/components/mimetype.xpt
455 %{_libdir}/%{name}/components/mozbrwsr.xpt
456 %{_libdir}/%{name}/components/mozfind.xpt
457 %{_libdir}/%{name}/components/mozgnome.xpt
458 %{_libdir}/%{name}/components/necko_about.xpt
459 %{_libdir}/%{name}/components/necko_cache.xpt
460 %{_libdir}/%{name}/components/necko_cookie.xpt
461 %{_libdir}/%{name}/components/necko_data.xpt
462 %{_libdir}/%{name}/components/necko_dns.xpt
463 %{_libdir}/%{name}/components/necko_file.xpt
464 %{_libdir}/%{name}/components/necko_ftp.xpt
465 %{_libdir}/%{name}/components/necko_http.xpt
466 %{_libdir}/%{name}/components/necko_res.xpt
467 %{_libdir}/%{name}/components/necko_socket.xpt
468 %{_libdir}/%{name}/components/necko_strconv.xpt
469 %{_libdir}/%{name}/components/necko_viewsource.xpt
470 %{_libdir}/%{name}/components/necko.xpt
471 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
472 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
473 %{_libdir}/%{name}/components/nsBrowserGlue.js
474 %{_libdir}/%{name}/components/nsCloseAllWindows.js
475 %{_libdir}/%{name}/components/nsDefaultCLH.js
476 %{_libdir}/%{name}/components/nsDictionary.js
477 %{_libdir}/%{name}/components/nsExtensionManager.js
478 %{_libdir}/%{name}/components/nsFilePicker.js
479 %{_libdir}/%{name}/components/nsHelperAppDlg.js
480 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
481 %{_libdir}/%{name}/components/nsKillAll.js
482 %{_libdir}/%{name}/components/nsMicrosummaryService.js
483 %{_libdir}/%{name}/components/nsProgressDialog.js
484 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
485 %{_libdir}/%{name}/components/nsResetPref.js
486 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
487 %{_libdir}/%{name}/components/nsSearchService.js
488 %{_libdir}/%{name}/components/nsSearchSuggestions.js
489 %{_libdir}/%{name}/components/nsSessionStartup.js
490 %{_libdir}/%{name}/components/nsSessionStore.js
491 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
492 %{_libdir}/%{name}/components/nsSidebar.js
493 %{_libdir}/%{name}/components/nsUpdateService.js
494 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
495 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
496 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
497 %{_libdir}/%{name}/components/nsURLFormatter.js
498 %{_libdir}/%{name}/components/nsXmlRpcClient.js
499 %{_libdir}/%{name}/components/oji.xpt
500 %{_libdir}/%{name}/components/passwordmgr.xpt
501 %{_libdir}/%{name}/components/pipboot.xpt
502 %{_libdir}/%{name}/components/pipnss.xpt
503 %{_libdir}/%{name}/components/pippki.xpt
504 %{_libdir}/%{name}/components/plugin.xpt
505 %{_libdir}/%{name}/components/prefetch.xpt
506 %{_libdir}/%{name}/components/pref.xpt
507 %{_libdir}/%{name}/components/profile.xpt
508 %{_libdir}/%{name}/components/progressDlg.xpt
509 %{_libdir}/%{name}/components/proxyObjInst.xpt
510 %{_libdir}/%{name}/components/rdf.xpt
511 %{_libdir}/%{name}/components/safebrowsing.xpt
512 %{_libdir}/%{name}/components/satchel.xpt
513 %{_libdir}/%{name}/components/saxparser.xpt
514 %{_libdir}/%{name}/components/search.xpt
515 %{_libdir}/%{name}/components/sessionstore.xpt
516 %{_libdir}/%{name}/components/shellservice.xpt
517 %{_libdir}/%{name}/components/shistory.xpt
518 %{_libdir}/%{name}/components/spellchecker.xpt
519 %{_libdir}/%{name}/components/storage.xpt
520 %{_libdir}/%{name}/components/toolkitprofile.xpt
521 %{_libdir}/%{name}/components/toolkitremote.xpt
522 %{_libdir}/%{name}/components/txmgr.xpt
523 %{_libdir}/%{name}/components/txtsvc.xpt
524 %{_libdir}/%{name}/components/uconv.xpt
525 %{_libdir}/%{name}/components/unicharutil.xpt
526 %{_libdir}/%{name}/components/update.xpt
527 %{_libdir}/%{name}/components/uriloader.xpt
528 %{_libdir}/%{name}/components/url-classifier.xpt
529 %{_libdir}/%{name}/components/urlformatter.xpt
530 %{_libdir}/%{name}/components/webBrowser_core.xpt
531 %{_libdir}/%{name}/components/webbrowserpersist.xpt
532 %{_libdir}/%{name}/components/WebContentConverter.js
533 %{_libdir}/%{name}/components/webshell_idls.xpt
534 %{_libdir}/%{name}/components/websrvcs.xpt
535 %{_libdir}/%{name}/components/widget.xpt
536 %{_libdir}/%{name}/components/windowds.xpt
537 %{_libdir}/%{name}/components/windowwatcher.xpt
538 %{_libdir}/%{name}/components/xml-rpc.xpt
539 %{_libdir}/%{name}/components/xpcom_base.xpt
540 %{_libdir}/%{name}/components/xpcom_components.xpt
541 %{_libdir}/%{name}/components/xpcom_ds.xpt
542 %{_libdir}/%{name}/components/xpcom_io.xpt
543 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
544 %{_libdir}/%{name}/components/xpcom_threads.xpt
545 %{_libdir}/%{name}/components/xpcom_xpti.xpt
546 %{_libdir}/%{name}/components/xpconnect.xpt
547 %{_libdir}/%{name}/components/xpinstall.xpt
548 %{_libdir}/%{name}/components/xulapp.xpt
549 %{_libdir}/%{name}/components/xuldoc.xpt
550 %{_libdir}/%{name}/components/xultmpl.xpt
551 %dir %{_libdir}/%{name}/plugins
552 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
553 %attr(755,root,root) %{_libdir}/%{name}/*.sh
554 %attr(755,root,root) %{_libdir}/%{name}/m*
555 %attr(755,root,root) %{_libdir}/%{name}/f*
556 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
557 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
558 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
559 %{_pixmapsdir}/mozilla-firefox.png
560 %{_desktopdir}/mozilla-firefox.desktop
561
562 # symlinks
563 %{_libdir}/%{name}/chrome
564 %{_libdir}/%{name}/defaults
565 %{_libdir}/%{name}/dictionaries
566 %{_libdir}/%{name}/extensions
567 %{_libdir}/%{name}/greprefs
568 %{_libdir}/%{name}/icons
569 %{_libdir}/%{name}/init.d
570 %{_libdir}/%{name}/res
571 %{_libdir}/%{name}/searchplugins
572
573 # browserconfig
574 %{_libdir}/%{name}/browserconfig.properties
575
576 %{_libdir}/%{name}/LICENSE
577 %{_libdir}/%{name}/README.txt
578
579 %dir %{_datadir}/%{name}
580 %{_datadir}/%{name}/chrome
581 %{_datadir}/%{name}/defaults
582 %{_datadir}/%{name}/greprefs
583 %{_datadir}/%{name}/icons
584 %{_datadir}/%{name}/init.d
585 %{_datadir}/%{name}/res
586 %{_datadir}/%{name}/searchplugins
587
588 %dir %{_datadir}/%{name}/extensions
589 # -dom-inspector subpackage?
590 %{_datadir}/%{name}/extensions/inspector@mozilla.org
591 # the signature of the default theme
592 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
593
594 # files created by regxpcom and firefox -register
595 %ghost %{_libdir}/%{name}/components/compreg.dat
596 %ghost %{_libdir}/%{name}/components/xpti.dat
597
598 %if %{with tidy}
599 %files addon-tidy
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
602 %{_libdir}/%{name}/components/nstidy.xpt
603 %endif
This page took 0.062061 seconds and 4 git commands to generate.