]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- 2.0.0.10
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 #
13 %if %{without gnome}
14 %undefine       with_gnomeui
15 %undefine       with_gnomevfs
16 %endif
17 %define         firefox_ver     2.0.0.10
18 #
19 Summary:        Firefox Community Edition web browser
20 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
21 Name:           mozilla-firefox
22 Version:        %{firefox_ver}
23 Release:        1
24 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
25 Group:          X11/Applications/Networking
26 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
27 # Source0-md5:  5c2f13d6a27f462ec6b862dafca22e7b
28 Source1:        %{name}.desktop
29 Source2:        %{name}.sh
30 Patch0:         mozilla-install.patch
31 Patch1:         %{name}-lib_path.patch
32 Patch2:         %{name}-fonts.patch
33 Patch3:         %{name}-agent.patch
34 Patch4:         %{name}-myspell.patch
35 # if ac rebuild is needed...
36 #PatchX:                %{name}-ac.patch
37 URL:            http://www.mozilla.org/projects/firefox/
38 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
39 BuildRequires:  automake
40 BuildRequires:  cairo-devel >= 1.0.0
41 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
42 BuildRequires:  gtk+2-devel >= 1:2.0.0
43 BuildRequires:  krb5-devel
44 BuildRequires:  libIDL-devel >= 0.8.0
45 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
46 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
47 BuildRequires:  libjpeg-devel >= 6b
48 BuildRequires:  libpng-devel >= 1.2.7
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  myspell-devel
51 BuildRequires:  nspr-devel >= 1:4.6.3
52 BuildRequires:  nss-devel >= 1:3.11.3-3
53 BuildRequires:  pango-devel >= 1:1.6.0
54 BuildRequires:  perl-modules >= 5.004
55 BuildRequires:  pkgconfig
56 BuildRequires:  rpmbuild(macros) >= 1.356
57 BuildRequires:  xorg-lib-libXext-devel
58 BuildRequires:  xorg-lib-libXft-devel >= 2.1
59 BuildRequires:  xorg-lib-libXinerama-devel
60 BuildRequires:  xorg-lib-libXp-devel
61 BuildRequires:  xorg-lib-libXt-devel
62 BuildRequires:  zip
63 BuildRequires:  zlib-devel >= 1.2.3
64 Requires(post): mktemp >= 1.5-18
65 Requires:       browser-plugins >= 2.0
66 Requires:       nspr >= 1:4.6.3
67 Requires:       nss >= 1:3.11.3
68 Provides:       wwwbrowser
69 Obsoletes:      mozilla-firebird
70 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
71 Obsoletes:      mozilla-firefox-libs
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # firefox/thunderbird/seamonkey provide their own versions
75 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
76 %define         _noautoprovfiles        %{_libdir}/%{name}/components
77 # we don't want these to satisfy xulrunner-devel
78 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
79 # and as we don't provide them, don't require either
80 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
81
82 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
83
84 %description
85 Firefox Community Edition is an open-source web browser, designed for
86 standards compliance, performance and portability.
87
88 %description -l pl.UTF-8
89 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
90 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
91 o zgodności ze standardami, wydajnością i przenośnością.
92
93 %prep
94 %setup -qc
95 cd mozilla
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99 %patch3 -p1
100 %patch4 -p1
101
102 %build
103 cd mozilla
104
105 cp -f %{_datadir}/automake/config.* build/autoconf
106 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
107 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
108
109 cat << 'EOF' > .mozconfig
110 . $topsrcdir/browser/config/mozconfig
111
112 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
113 ac_cv_visibility_pragma=no
114
115 # Options for 'configure' (same as command-line options).
116 ac_add_options --prefix=%{_prefix}
117 ac_add_options --exec-prefix=%{_exec_prefix}
118 ac_add_options --bindir=%{_bindir}
119 ac_add_options --sbindir=%{_sbindir}
120 ac_add_options --sysconfdir=%{_sysconfdir}
121 ac_add_options --datadir=%{_datadir}
122 ac_add_options --includedir=%{_includedir}
123 ac_add_options --libdir=%{_libdir}
124 ac_add_options --libexecdir=%{_libexecdir}
125 ac_add_options --localstatedir=%{_localstatedir}
126 ac_add_options --sharedstatedir=%{_sharedstatedir}
127 ac_add_options --mandir=%{_mandir}
128 ac_add_options --infodir=%{_infodir}
129 %if %{?debug:1}0
130 ac_add_options --disable-optimize
131 ac_add_options --enable-debug
132 ac_add_options --enable-debug-modules
133 ac_add_options --enable-debugger-info-modules
134 ac_add_options --enable-crash-on-assert
135 %else
136 ac_add_options --disable-debug
137 ac_add_options --disable-debug-modules
138 ac_add_options --disable-logging
139 ac_add_options --enable-optimize="%{rpmcflags}"
140 %endif
141 %if %{with tests}
142 ac_add_options --enable-tests
143 %else
144 ac_add_options --disable-tests
145 %endif
146 %if %{with gnomeui}
147 ac_add_options --enable-gnomeui
148 %else
149 ac_add_options --disable-gnomeui
150 %endif
151 %if %{with gnomevfs}
152 ac_add_options --enable-gnomevfs
153 %else
154 ac_add_options --disable-gnomevfs
155 %endif
156 ac_add_options --disable-freetype2
157 ac_add_options --disable-installer
158 ac_add_options --disable-javaxpcom
159 ac_add_options --disable-updater
160 ac_add_options --enable-default-toolkit=gtk2
161 ac_add_options --enable-svg
162 ac_add_options --enable-system-cairo
163 ac_add_options --enable-system-myspell
164 ac_add_options --enable-xft
165 ac_add_options --with-distribution-id=org.pld-linux
166 ac_add_options --with-system-jpeg
167 ac_add_options --with-system-nspr
168 ac_add_options --with-system-nss
169 ac_add_options --with-system-png
170 ac_add_options --with-system-zlib
171 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
172 EOF
173
174 %{__make} -j1 -f client.mk build \
175         CC="%{__cc}" \
176         CXX="%{__cxx}"
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180 cd mozilla
181 install -d \
182         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
183         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
184         $RPM_BUILD_ROOT%{_datadir}/%{name}
185
186 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
187
188 %{__make} -C obj-%{_target_cpu}/xpinstall/packager stage-package \
189         DESTDIR=$RPM_BUILD_ROOT \
190         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
191         PKG_SKIP_STRIP=1
192
193 # move arch independant ones to datadir
194 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
195 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
196 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
197 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
198 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
199 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
200 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
201 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
202 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
203 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
204 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
205 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
206 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
207 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
208 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
209 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
210
211 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
212 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
213
214 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
215 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
216
217 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
218
219 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
220
221 # header/development files
222 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
223 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
224 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
225
226 # files created by regxpcom and firefox -register
227 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
228 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
229
230 # what's this? it's content is invalid anyway.
231 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
232 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
233
234 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
235 #!/bin/sh
236 umask 022
237 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
238
239 # it attempts to touch files in $HOME/.mozilla
240 # beware if you run this with sudo!!!
241 export HOME=$(mktemp -d)
242 # also TMPDIR could be pointing to sudo user's homedir
243 unset TMPDIR TMP || :
244
245 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
246 %{_libdir}/%{name}/firefox -register
247
248 rm -rf $HOME
249 EOF
250
251 %clean
252 rm -rf $RPM_BUILD_ROOT
253
254 %pretrans
255 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
256         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
257 fi
258 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
259         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
260                 install -d %{_datadir}/%{name}
261                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
262         fi
263 done
264 exit 0
265
266 %post
267 %{_sbindir}/%{name}-chrome+xpcom-generate
268 %update_browser_plugins
269
270 %postun
271 if [ "$1" = 0 ]; then
272         %update_browser_plugins
273 fi
274
275 %files
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_bindir}/%{name}
278 %attr(755,root,root) %{_bindir}/firefox
279 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
280
281 # browser plugins v2
282 %{_browserpluginsconfdir}/browsers.d/%{name}.*
283 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
284
285 %dir %{_libdir}/%{name}
286 %attr(755,root,root) %{_libdir}/%{name}/*.so
287
288 %dir %{_libdir}/%{name}/components
289 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
290 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
291 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
292 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
293 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
294 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
295 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
296 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
297 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
298 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
299 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
300 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
301 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
302 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
303 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
304 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
305 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
306 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
307 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
308 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
309 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
310 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
311 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
312 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
313 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
314 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
315 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
316 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
317 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
318 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
319 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
320 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
321 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
322 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
323 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
324 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
325 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
326 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
327 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
328 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
329 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
330 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
331 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
332 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
333 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
334 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
335 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
336 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
337 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
340 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
341 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
342 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
347 %{_libdir}/%{name}/components/accessibility-atk.xpt
348 %{_libdir}/%{name}/components/accessibility.xpt
349 %{_libdir}/%{name}/components/alerts.xpt
350 %{_libdir}/%{name}/components/appshell.xpt
351 %{_libdir}/%{name}/components/appstartup.xpt
352 %{_libdir}/%{name}/components/autocomplete.xpt
353 %{_libdir}/%{name}/components/autoconfig.xpt
354 %{_libdir}/%{name}/components/bookmarks.xpt
355 %{_libdir}/%{name}/components/browsercompsbase.xpt
356 %{_libdir}/%{name}/components/browser-feeds.xpt
357 %{_libdir}/%{name}/components/browsersearch.xpt
358 %{_libdir}/%{name}/components/caps.xpt
359 %{_libdir}/%{name}/components/chardet.xpt
360 %{_libdir}/%{name}/components/chrome.xpt
361 %{_libdir}/%{name}/components/commandhandler.xpt
362 %{_libdir}/%{name}/components/commandlines.xpt
363 %{_libdir}/%{name}/components/composer.xpt
364 %{_libdir}/%{name}/components/content_base.xpt
365 %{_libdir}/%{name}/components/content_htmldoc.xpt
366 %{_libdir}/%{name}/components/content_html.xpt
367 %{_libdir}/%{name}/components/content_xmldoc.xpt
368 %{_libdir}/%{name}/components/content_xslt.xpt
369 %{_libdir}/%{name}/components/content_xtf.xpt
370 %{_libdir}/%{name}/components/cookie.xpt
371 %{_libdir}/%{name}/components/directory.xpt
372 %{_libdir}/%{name}/components/docshell.xpt
373 %{_libdir}/%{name}/components/dom_base.xpt
374 %{_libdir}/%{name}/components/dom_canvas.xpt
375 %{_libdir}/%{name}/components/dom_core.xpt
376 %{_libdir}/%{name}/components/dom_css.xpt
377 %{_libdir}/%{name}/components/dom_events.xpt
378 %{_libdir}/%{name}/components/dom_html.xpt
379 %{_libdir}/%{name}/components/dom_loadsave.xpt
380 %{_libdir}/%{name}/components/dom_range.xpt
381 %{_libdir}/%{name}/components/dom_sidebar.xpt
382 %{_libdir}/%{name}/components/dom_storage.xpt
383 %{_libdir}/%{name}/components/dom_stylesheets.xpt
384 %{_libdir}/%{name}/components/dom_svg.xpt
385 %{_libdir}/%{name}/components/dom_traversal.xpt
386 %{_libdir}/%{name}/components/dom_views.xpt
387 %{_libdir}/%{name}/components/dom_xbl.xpt
388 %{_libdir}/%{name}/components/dom_xpath.xpt
389 %{_libdir}/%{name}/components/dom.xpt
390 %{_libdir}/%{name}/components/dom_xul.xpt
391 %{_libdir}/%{name}/components/downloads.xpt
392 %{_libdir}/%{name}/components/editor.xpt
393 %{_libdir}/%{name}/components/embed_base.xpt
394 %{_libdir}/%{name}/components/extensions.xpt
395 %{_libdir}/%{name}/components/exthandler.xpt
396 %{_libdir}/%{name}/components/fastfind.xpt
397 %{_libdir}/%{name}/components/FeedConverter.js
398 %{_libdir}/%{name}/components/FeedProcessor.js
399 %{_libdir}/%{name}/components/feeds.xpt
400 %{_libdir}/%{name}/components/FeedWriter.js
401 %{_libdir}/%{name}/components/filepicker.xpt
402 %{_libdir}/%{name}/components/find.xpt
403 %{_libdir}/%{name}/components/gfx.xpt
404 %{_libdir}/%{name}/components/gksvgrenderer.xpt
405 %{_libdir}/%{name}/components/history.xpt
406 %{_libdir}/%{name}/components/htmlparser.xpt
407 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
408 %{_libdir}/%{name}/components/imglib2.xpt
409 %{_libdir}/%{name}/components/inspector.xpt
410 %{_libdir}/%{name}/components/intl.xpt
411 %{_libdir}/%{name}/components/jar.xpt
412 %{_libdir}/%{name}/components/jsconsole-clhandler.js
413 %{_libdir}/%{name}/components/jsconsole.xpt
414 %{_libdir}/%{name}/components/jsdservice.xpt
415 %{_libdir}/%{name}/components/layout_base.xpt
416 %{_libdir}/%{name}/components/layout_printing.xpt
417 %{_libdir}/%{name}/components/layout_xul_tree.xpt
418 %{_libdir}/%{name}/components/layout_xul.xpt
419 %{_libdir}/%{name}/components/locale.xpt
420 %{_libdir}/%{name}/components/lwbrk.xpt
421 %{_libdir}/%{name}/components/microsummaries.xpt
422 %{_libdir}/%{name}/components/migration.xpt
423 %{_libdir}/%{name}/components/mimetype.xpt
424 %{_libdir}/%{name}/components/mozbrwsr.xpt
425 %{_libdir}/%{name}/components/mozfind.xpt
426 %{_libdir}/%{name}/components/mozgnome.xpt
427 %{_libdir}/%{name}/components/necko_about.xpt
428 %{_libdir}/%{name}/components/necko_cache.xpt
429 %{_libdir}/%{name}/components/necko_cookie.xpt
430 %{_libdir}/%{name}/components/necko_data.xpt
431 %{_libdir}/%{name}/components/necko_dns.xpt
432 %{_libdir}/%{name}/components/necko_file.xpt
433 %{_libdir}/%{name}/components/necko_ftp.xpt
434 %{_libdir}/%{name}/components/necko_http.xpt
435 %{_libdir}/%{name}/components/necko_res.xpt
436 %{_libdir}/%{name}/components/necko_socket.xpt
437 %{_libdir}/%{name}/components/necko_strconv.xpt
438 %{_libdir}/%{name}/components/necko_viewsource.xpt
439 %{_libdir}/%{name}/components/necko.xpt
440 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
441 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
442 %{_libdir}/%{name}/components/nsBrowserGlue.js
443 %{_libdir}/%{name}/components/nsCloseAllWindows.js
444 %{_libdir}/%{name}/components/nsDefaultCLH.js
445 %{_libdir}/%{name}/components/nsDictionary.js
446 %{_libdir}/%{name}/components/nsExtensionManager.js
447 %{_libdir}/%{name}/components/nsFilePicker.js
448 %{_libdir}/%{name}/components/nsHelperAppDlg.js
449 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
450 %{_libdir}/%{name}/components/nsKillAll.js
451 %{_libdir}/%{name}/components/nsMicrosummaryService.js
452 %{_libdir}/%{name}/components/nsProgressDialog.js
453 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
454 %{_libdir}/%{name}/components/nsResetPref.js
455 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
456 %{_libdir}/%{name}/components/nsSearchService.js
457 %{_libdir}/%{name}/components/nsSearchSuggestions.js
458 %{_libdir}/%{name}/components/nsSessionStartup.js
459 %{_libdir}/%{name}/components/nsSessionStore.js
460 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
461 %{_libdir}/%{name}/components/nsSidebar.js
462 %{_libdir}/%{name}/components/nsUpdateService.js
463 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
464 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
465 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
466 %{_libdir}/%{name}/components/nsURLFormatter.js
467 %{_libdir}/%{name}/components/nsXmlRpcClient.js
468 %{_libdir}/%{name}/components/oji.xpt
469 %{_libdir}/%{name}/components/passwordmgr.xpt
470 %{_libdir}/%{name}/components/pipboot.xpt
471 %{_libdir}/%{name}/components/pipnss.xpt
472 %{_libdir}/%{name}/components/pippki.xpt
473 %{_libdir}/%{name}/components/plugin.xpt
474 %{_libdir}/%{name}/components/prefetch.xpt
475 %{_libdir}/%{name}/components/pref.xpt
476 %{_libdir}/%{name}/components/profile.xpt
477 %{_libdir}/%{name}/components/progressDlg.xpt
478 %{_libdir}/%{name}/components/proxyObjInst.xpt
479 %{_libdir}/%{name}/components/rdf.xpt
480 %{_libdir}/%{name}/components/safebrowsing.xpt
481 %{_libdir}/%{name}/components/satchel.xpt
482 %{_libdir}/%{name}/components/saxparser.xpt
483 %{_libdir}/%{name}/components/search.xpt
484 %{_libdir}/%{name}/components/sessionstore.xpt
485 %{_libdir}/%{name}/components/shellservice.xpt
486 %{_libdir}/%{name}/components/shistory.xpt
487 %{_libdir}/%{name}/components/spellchecker.xpt
488 %{_libdir}/%{name}/components/storage.xpt
489 %{_libdir}/%{name}/components/toolkitprofile.xpt
490 %{_libdir}/%{name}/components/toolkitremote.xpt
491 %{_libdir}/%{name}/components/txmgr.xpt
492 %{_libdir}/%{name}/components/txtsvc.xpt
493 %{_libdir}/%{name}/components/uconv.xpt
494 %{_libdir}/%{name}/components/unicharutil.xpt
495 %{_libdir}/%{name}/components/update.xpt
496 %{_libdir}/%{name}/components/uriloader.xpt
497 %{_libdir}/%{name}/components/url-classifier.xpt
498 %{_libdir}/%{name}/components/urlformatter.xpt
499 %{_libdir}/%{name}/components/webBrowser_core.xpt
500 %{_libdir}/%{name}/components/webbrowserpersist.xpt
501 %{_libdir}/%{name}/components/WebContentConverter.js
502 %{_libdir}/%{name}/components/webshell_idls.xpt
503 %{_libdir}/%{name}/components/websrvcs.xpt
504 %{_libdir}/%{name}/components/widget.xpt
505 %{_libdir}/%{name}/components/windowds.xpt
506 %{_libdir}/%{name}/components/windowwatcher.xpt
507 %{_libdir}/%{name}/components/xml-rpc.xpt
508 %{_libdir}/%{name}/components/xpcom_base.xpt
509 %{_libdir}/%{name}/components/xpcom_components.xpt
510 %{_libdir}/%{name}/components/xpcom_ds.xpt
511 %{_libdir}/%{name}/components/xpcom_io.xpt
512 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
513 %{_libdir}/%{name}/components/xpcom_threads.xpt
514 %{_libdir}/%{name}/components/xpcom_xpti.xpt
515 %{_libdir}/%{name}/components/xpconnect.xpt
516 %{_libdir}/%{name}/components/xpinstall.xpt
517 %{_libdir}/%{name}/components/xulapp.xpt
518 %{_libdir}/%{name}/components/xuldoc.xpt
519 %{_libdir}/%{name}/components/xultmpl.xpt
520 %dir %{_libdir}/%{name}/plugins
521 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
522 %attr(755,root,root) %{_libdir}/%{name}/*.sh
523 %attr(755,root,root) %{_libdir}/%{name}/m*
524 %attr(755,root,root) %{_libdir}/%{name}/f*
525 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
526 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
527 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
528 %{_pixmapsdir}/mozilla-firefox.png
529 %{_desktopdir}/mozilla-firefox.desktop
530
531 # symlinks
532 %{_libdir}/%{name}/chrome
533 %{_libdir}/%{name}/defaults
534 %{_libdir}/%{name}/dictionaries
535 %{_libdir}/%{name}/extensions
536 %{_libdir}/%{name}/greprefs
537 %{_libdir}/%{name}/icons
538 %{_libdir}/%{name}/init.d
539 %{_libdir}/%{name}/res
540 %{_libdir}/%{name}/searchplugins
541
542 # browserconfig
543 %{_libdir}/%{name}/browserconfig.properties
544
545 %{_libdir}/%{name}/LICENSE
546 %{_libdir}/%{name}/README.txt
547
548 %dir %{_datadir}/%{name}
549 %{_datadir}/%{name}/chrome
550 %{_datadir}/%{name}/defaults
551 %{_datadir}/%{name}/greprefs
552 %{_datadir}/%{name}/icons
553 %{_datadir}/%{name}/init.d
554 %{_datadir}/%{name}/res
555 %{_datadir}/%{name}/searchplugins
556
557 %dir %{_datadir}/%{name}/extensions
558 # -dom-inspector subpackage?
559 %{_datadir}/%{name}/extensions/inspector@mozilla.org
560 # the signature of the default theme
561 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
562
563 # files created by regxpcom and firefox -register
564 %ghost %{_libdir}/%{name}/components/compreg.dat
565 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.140375 seconds and 4 git commands to generate.