]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- 3.0
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 #
13 %if %{without gnome}
14 %undefine       with_gnomeui
15 %undefine       with_gnomevfs
16 %endif
17 %define         firefox_ver     3.0
18 #
19 Summary:        Firefox Community Edition web browser
20 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
21 Name:           mozilla-firefox
22 Version:        %{firefox_ver}
23 Release:        0.1
24 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
25 Group:          X11/Applications/Networking
26 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
27 # Source0-md5:  4210ae0801df2eb498408533010d97c1
28 Source1:        %{name}.desktop
29 Source2:        %{name}.sh
30 Patch0:         mozilla-install.patch
31 Patch1:         %{name}-lib_path.patch
32 #Patch3:                %{name}-myspell.patch
33 #Patch4:                %{name}-pango-cursor-position.patch
34 #Patch5:                %{name}-pango-ligatures.patch
35 #Patch6:                %{name}-pango-cursor-position-more.patch
36 #Patch7:                %{name}-pango-justified-range.patch
37 #Patch8:                %{name}-pango-printing.patch
38 #Patch9:                %{name}-pango-underline.patch
39 #Patch10:       %{name}-xft-randewidth.patch
40 Patch11:        %{name}-ti-agent.patch
41 Patch12:        %{name}-agent.patch
42 # if ac rebuild is needed...
43 #PatchX:                %{name}-ac.patch
44 URL:            http://www.mozilla.org/projects/firefox/
45 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
46 BuildRequires:  automake
47 BuildRequires:  cairo-devel >= 1.0.0
48 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
49 BuildRequires:  gtk+2-devel >= 1:2.0.0
50 BuildRequires:  krb5-devel
51 BuildRequires:  libIDL-devel >= 0.8.0
52 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
53 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
54 BuildRequires:  libjpeg-devel >= 6b
55 BuildRequires:  libpng-devel >= 1.2.7
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  myspell-devel
58 BuildRequires:  nspr-devel >= 1:4.6.3
59 BuildRequires:  nss-devel >= 1:3.11.3-3
60 BuildRequires:  pango-devel >= 1:1.6.0
61 BuildRequires:  perl-modules >= 5.004
62 BuildRequires:  pkgconfig
63 BuildRequires:  rpm >= 4.4.9-56
64 BuildRequires:  rpmbuild(macros) >= 1.356
65 BuildRequires:  xorg-lib-libXext-devel
66 BuildRequires:  xorg-lib-libXft-devel >= 2.1
67 BuildRequires:  xorg-lib-libXinerama-devel
68 BuildRequires:  xorg-lib-libXp-devel
69 BuildRequires:  xorg-lib-libXt-devel
70 BuildRequires:  zip
71 BuildRequires:  zlib-devel >= 1.2.3
72 Requires(post): mktemp >= 1.5-18
73 Requires:       browser-plugins >= 2.0
74 Requires:       nspr >= 1:4.6.3
75 Requires:       nss >= 1:3.11.3
76 Provides:       wwwbrowser
77 Obsoletes:      mozilla-firebird
78 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
79 Obsoletes:      mozilla-firefox-libs
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 # firefox/thunderbird/seamonkey provide their own versions
83 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
84 %define         _noautoprovfiles        %{_libdir}/%{name}/components
85 # we don't want these to satisfy xulrunner-devel
86 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
87 # and as we don't provide them, don't require either
88 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
89
90 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
91
92 %description
93 Firefox Community Edition is an open-source web browser, designed for
94 standards compliance, performance and portability.
95
96 %description -l pl.UTF-8
97 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
98 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
99 o zgodności ze standardami, wydajnością i przenośnością.
100
101 %prep
102 %setup -qc
103 cd mozilla
104 %patch0 -p1
105 %patch1 -p1
106 #%patch3 -p1
107 #%patch4 -p1
108 #%patch5 -p1
109 #%patch6 -p1
110 #%patch7 -p1
111 #%patch8 -p0
112 #%patch9 -p1
113 #%patch10 -p1
114 %if "%{pld_release}" == "ti"
115 %patch11 -p1
116 %else
117 %patch12 -p1
118 %endif
119
120 %build
121 cd mozilla
122
123 cp -f %{_datadir}/automake/config.* build/autoconf
124 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
125 #cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
126
127 cat << 'EOF' > .mozconfig
128 . $topsrcdir/browser/config/mozconfig
129
130 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
131 ac_cv_visibility_pragma=no
132
133 # Options for 'configure' (same as command-line options).
134 ac_add_options --prefix=%{_prefix}
135 ac_add_options --exec-prefix=%{_exec_prefix}
136 ac_add_options --bindir=%{_bindir}
137 ac_add_options --sbindir=%{_sbindir}
138 ac_add_options --sysconfdir=%{_sysconfdir}
139 ac_add_options --datadir=%{_datadir}
140 ac_add_options --includedir=%{_includedir}
141 ac_add_options --libdir=%{_libdir}
142 ac_add_options --libexecdir=%{_libexecdir}
143 ac_add_options --localstatedir=%{_localstatedir}
144 ac_add_options --sharedstatedir=%{_sharedstatedir}
145 ac_add_options --mandir=%{_mandir}
146 ac_add_options --infodir=%{_infodir}
147 %if %{?debug:1}0
148 ac_add_options --disable-optimize
149 ac_add_options --enable-debug
150 ac_add_options --enable-debug-modules
151 ac_add_options --enable-debugger-info-modules
152 ac_add_options --enable-crash-on-assert
153 %else
154 ac_add_options --disable-debug
155 ac_add_options --disable-debug-modules
156 ac_add_options --disable-logging
157 ac_add_options --enable-optimize="%{rpmcflags}"
158 %endif
159 %if %{with tests}
160 ac_add_options --enable-tests
161 %else
162 ac_add_options --disable-tests
163 %endif
164 %if %{with gnomeui}
165 ac_add_options --enable-gnomeui
166 %else
167 ac_add_options --disable-gnomeui
168 %endif
169 %if %{with gnomevfs}
170 ac_add_options --enable-gnomevfs
171 %else
172 ac_add_options --disable-gnomevfs
173 %endif
174 ac_add_options --disable-installer
175 ac_add_options --disable-javaxpcom
176 ac_add_options --disable-updater
177 ac_add_options --enable-svg
178 ac_add_options --enable-system-cairo
179 ac_add_options --enable-system-myspell
180 ac_add_options --with-distribution-id=org.pld-linux
181 ac_add_options --with-system-jpeg
182 ac_add_options --with-system-nspr
183 ac_add_options --with-system-nss
184 ac_add_options --with-system-png
185 ac_add_options --with-system-zlib
186 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
187 EOF
188
189 %{__make} -j1 -f client.mk build \
190         CC="%{__cc}" \
191         CXX="%{__cxx}"
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195 cd mozilla
196
197 install -d \
198         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
199         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
200         $RPM_BUILD_ROOT%{_datadir}/%{name}
201
202 cd obj-%{_target_cpu}
203 [ -d dist/firefox ] || mkdir dist/firefox
204 %{__make} install \
205         DESTDIR=$RPM_BUILD_ROOT \
206         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
207         PKG_SKIP_STRIP=1
208 cd ..
209
210 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
211
212 # move arch independant ones to datadir
213 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
214 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
215 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
216 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
217 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
218 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
219 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
220 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
221 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
222 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
223 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
224 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
225 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
226 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
227
228 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
229 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
230
231 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
232 #ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
233
234 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
235
236 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
237
238 # files created by regxpcom and firefox -register
239 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
240 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
241
242 # what's this? it's content is invalid anyway.
243 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
244 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
245
246 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
247 #!/bin/sh
248 umask 022
249 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
250
251 # it attempts to touch files in $HOME/.mozilla
252 # beware if you run this with sudo!!!
253 export HOME=$(mktemp -d)
254 # also TMPDIR could be pointing to sudo user's homedir
255 unset TMPDIR TMP || :
256
257 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
258 %{_libdir}/%{name}/firefox -register
259
260 rm -rf $HOME
261 EOF
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %pretrans
267 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
268         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
269 fi
270 for d in chrome defaults extensions greprefs icons res searchplugins; do
271         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
272                 install -d %{_datadir}/%{name}
273                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
274         fi
275 done
276 exit 0
277
278 %post
279 %{_sbindir}/%{name}-chrome+xpcom-generate
280 %update_browser_plugins
281
282 %postun
283 if [ "$1" = 0 ]; then
284         %update_browser_plugins
285 fi
286
287 %files
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_bindir}/%{name}
290 %attr(755,root,root) %{_bindir}/firefox
291 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
292
293 # browser plugins v2
294 %{_browserpluginsconfdir}/browsers.d/%{name}.*
295 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
296
297 %dir %{_libdir}/%{name}
298 %attr(755,root,root) %{_libdir}/%{name}/*.so
299
300 %dir %{_libdir}/%{name}/components
301 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
302 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
303 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
304 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
305 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
306 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
307 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
308 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
309 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
310 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
311 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
312 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
313 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
314 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
315 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
316 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
317 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
318 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
319 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
320 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
321 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
322 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
323 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
324 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
325 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
326 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
327 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
328 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
329 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
330 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
331 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
332 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
333 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
334 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
335 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
336 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
337 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
340 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
341 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
342 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
359 %{_libdir}/%{name}/components/accessibility-atk.xpt
360 %{_libdir}/%{name}/components/accessibility.xpt
361 %{_libdir}/%{name}/components/alerts.xpt
362 %{_libdir}/%{name}/components/appshell.xpt
363 %{_libdir}/%{name}/components/appstartup.xpt
364 %{_libdir}/%{name}/components/autocomplete.xpt
365 %{_libdir}/%{name}/components/autoconfig.xpt
366 %{_libdir}/%{name}/components/bookmarks.xpt
367 %{_libdir}/%{name}/components/browsercompsbase.xpt
368 %{_libdir}/%{name}/components/browser-feeds.xpt
369 %{_libdir}/%{name}/components/browsersearch.xpt
370 %{_libdir}/%{name}/components/caps.xpt
371 %{_libdir}/%{name}/components/chardet.xpt
372 %{_libdir}/%{name}/components/chrome.xpt
373 %{_libdir}/%{name}/components/commandhandler.xpt
374 %{_libdir}/%{name}/components/commandlines.xpt
375 %{_libdir}/%{name}/components/composer.xpt
376 %{_libdir}/%{name}/components/content_base.xpt
377 %{_libdir}/%{name}/components/content_htmldoc.xpt
378 %{_libdir}/%{name}/components/content_html.xpt
379 %{_libdir}/%{name}/components/content_xmldoc.xpt
380 %{_libdir}/%{name}/components/content_xslt.xpt
381 %{_libdir}/%{name}/components/content_xtf.xpt
382 %{_libdir}/%{name}/components/cookie.xpt
383 %{_libdir}/%{name}/components/directory.xpt
384 %{_libdir}/%{name}/components/docshell.xpt
385 %{_libdir}/%{name}/components/dom_base.xpt
386 %{_libdir}/%{name}/components/dom_canvas.xpt
387 %{_libdir}/%{name}/components/dom_core.xpt
388 %{_libdir}/%{name}/components/dom_css.xpt
389 %{_libdir}/%{name}/components/dom_events.xpt
390 %{_libdir}/%{name}/components/dom_html.xpt
391 %{_libdir}/%{name}/components/dom_loadsave.xpt
392 %{_libdir}/%{name}/components/dom_range.xpt
393 %{_libdir}/%{name}/components/dom_sidebar.xpt
394 %{_libdir}/%{name}/components/dom_storage.xpt
395 %{_libdir}/%{name}/components/dom_stylesheets.xpt
396 %{_libdir}/%{name}/components/dom_svg.xpt
397 %{_libdir}/%{name}/components/dom_traversal.xpt
398 %{_libdir}/%{name}/components/dom_views.xpt
399 %{_libdir}/%{name}/components/dom_xbl.xpt
400 %{_libdir}/%{name}/components/dom_xpath.xpt
401 %{_libdir}/%{name}/components/dom.xpt
402 %{_libdir}/%{name}/components/dom_xul.xpt
403 %{_libdir}/%{name}/components/downloads.xpt
404 %{_libdir}/%{name}/components/editor.xpt
405 %{_libdir}/%{name}/components/embed_base.xpt
406 %{_libdir}/%{name}/components/extensions.xpt
407 %{_libdir}/%{name}/components/exthandler.xpt
408 %{_libdir}/%{name}/components/fastfind.xpt
409 %{_libdir}/%{name}/components/FeedConverter.js
410 %{_libdir}/%{name}/components/FeedProcessor.js
411 %{_libdir}/%{name}/components/feeds.xpt
412 %{_libdir}/%{name}/components/FeedWriter.js
413 %{_libdir}/%{name}/components/filepicker.xpt
414 %{_libdir}/%{name}/components/find.xpt
415 %{_libdir}/%{name}/components/gfx.xpt
416 %{_libdir}/%{name}/components/gksvgrenderer.xpt
417 %{_libdir}/%{name}/components/history.xpt
418 %{_libdir}/%{name}/components/htmlparser.xpt
419 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
420 %{_libdir}/%{name}/components/imglib2.xpt
421 %{_libdir}/%{name}/components/inspector.xpt
422 %{_libdir}/%{name}/components/intl.xpt
423 %{_libdir}/%{name}/components/jar.xpt
424 %{_libdir}/%{name}/components/jsconsole-clhandler.js
425 %{_libdir}/%{name}/components/jsconsole.xpt
426 %{_libdir}/%{name}/components/jsdservice.xpt
427 %{_libdir}/%{name}/components/layout_base.xpt
428 %{_libdir}/%{name}/components/layout_printing.xpt
429 %{_libdir}/%{name}/components/layout_xul_tree.xpt
430 %{_libdir}/%{name}/components/layout_xul.xpt
431 %{_libdir}/%{name}/components/locale.xpt
432 %{_libdir}/%{name}/components/lwbrk.xpt
433 %{_libdir}/%{name}/components/microsummaries.xpt
434 %{_libdir}/%{name}/components/migration.xpt
435 %{_libdir}/%{name}/components/mimetype.xpt
436 %{_libdir}/%{name}/components/mozbrwsr.xpt
437 %{_libdir}/%{name}/components/mozfind.xpt
438 %{_libdir}/%{name}/components/mozgnome.xpt
439 %{_libdir}/%{name}/components/necko_about.xpt
440 %{_libdir}/%{name}/components/necko_cache.xpt
441 %{_libdir}/%{name}/components/necko_cookie.xpt
442 %{_libdir}/%{name}/components/necko_data.xpt
443 %{_libdir}/%{name}/components/necko_dns.xpt
444 %{_libdir}/%{name}/components/necko_file.xpt
445 %{_libdir}/%{name}/components/necko_ftp.xpt
446 %{_libdir}/%{name}/components/necko_http.xpt
447 %{_libdir}/%{name}/components/necko_res.xpt
448 %{_libdir}/%{name}/components/necko_socket.xpt
449 %{_libdir}/%{name}/components/necko_strconv.xpt
450 %{_libdir}/%{name}/components/necko_viewsource.xpt
451 %{_libdir}/%{name}/components/necko.xpt
452 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
453 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
454 %{_libdir}/%{name}/components/nsBrowserGlue.js
455 %{_libdir}/%{name}/components/nsCloseAllWindows.js
456 %{_libdir}/%{name}/components/nsDefaultCLH.js
457 %{_libdir}/%{name}/components/nsDictionary.js
458 %{_libdir}/%{name}/components/nsExtensionManager.js
459 %{_libdir}/%{name}/components/nsFilePicker.js
460 %{_libdir}/%{name}/components/nsHelperAppDlg.js
461 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
462 %{_libdir}/%{name}/components/nsKillAll.js
463 %{_libdir}/%{name}/components/nsMicrosummaryService.js
464 %{_libdir}/%{name}/components/nsProgressDialog.js
465 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
466 %{_libdir}/%{name}/components/nsResetPref.js
467 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
468 %{_libdir}/%{name}/components/nsSearchService.js
469 %{_libdir}/%{name}/components/nsSearchSuggestions.js
470 %{_libdir}/%{name}/components/nsSessionStartup.js
471 %{_libdir}/%{name}/components/nsSessionStore.js
472 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
473 %{_libdir}/%{name}/components/nsSidebar.js
474 %{_libdir}/%{name}/components/nsUpdateService.js
475 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
476 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
477 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
478 %{_libdir}/%{name}/components/nsURLFormatter.js
479 %{_libdir}/%{name}/components/nsXmlRpcClient.js
480 %{_libdir}/%{name}/components/oji.xpt
481 %{_libdir}/%{name}/components/passwordmgr.xpt
482 %{_libdir}/%{name}/components/pipboot.xpt
483 %{_libdir}/%{name}/components/pipnss.xpt
484 %{_libdir}/%{name}/components/pippki.xpt
485 %{_libdir}/%{name}/components/plugin.xpt
486 %{_libdir}/%{name}/components/prefetch.xpt
487 %{_libdir}/%{name}/components/pref.xpt
488 %{_libdir}/%{name}/components/profile.xpt
489 %{_libdir}/%{name}/components/progressDlg.xpt
490 %{_libdir}/%{name}/components/proxyObjInst.xpt
491 %{_libdir}/%{name}/components/rdf.xpt
492 %{_libdir}/%{name}/components/safebrowsing.xpt
493 %{_libdir}/%{name}/components/satchel.xpt
494 %{_libdir}/%{name}/components/saxparser.xpt
495 %{_libdir}/%{name}/components/search.xpt
496 %{_libdir}/%{name}/components/sessionstore.xpt
497 %{_libdir}/%{name}/components/shellservice.xpt
498 %{_libdir}/%{name}/components/shistory.xpt
499 %{_libdir}/%{name}/components/spellchecker.xpt
500 %{_libdir}/%{name}/components/storage.xpt
501 %{_libdir}/%{name}/components/toolkitprofile.xpt
502 %{_libdir}/%{name}/components/toolkitremote.xpt
503 %{_libdir}/%{name}/components/txmgr.xpt
504 %{_libdir}/%{name}/components/txtsvc.xpt
505 %{_libdir}/%{name}/components/uconv.xpt
506 %{_libdir}/%{name}/components/unicharutil.xpt
507 %{_libdir}/%{name}/components/update.xpt
508 %{_libdir}/%{name}/components/uriloader.xpt
509 %{_libdir}/%{name}/components/url-classifier.xpt
510 %{_libdir}/%{name}/components/urlformatter.xpt
511 %{_libdir}/%{name}/components/webBrowser_core.xpt
512 %{_libdir}/%{name}/components/webbrowserpersist.xpt
513 %{_libdir}/%{name}/components/WebContentConverter.js
514 %{_libdir}/%{name}/components/webshell_idls.xpt
515 %{_libdir}/%{name}/components/websrvcs.xpt
516 %{_libdir}/%{name}/components/widget.xpt
517 %{_libdir}/%{name}/components/windowds.xpt
518 %{_libdir}/%{name}/components/windowwatcher.xpt
519 %{_libdir}/%{name}/components/xml-rpc.xpt
520 %{_libdir}/%{name}/components/xpcom_base.xpt
521 %{_libdir}/%{name}/components/xpcom_components.xpt
522 %{_libdir}/%{name}/components/xpcom_ds.xpt
523 %{_libdir}/%{name}/components/xpcom_io.xpt
524 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
525 %{_libdir}/%{name}/components/xpcom_threads.xpt
526 %{_libdir}/%{name}/components/xpcom_xpti.xpt
527 %{_libdir}/%{name}/components/xpconnect.xpt
528 %{_libdir}/%{name}/components/xpinstall.xpt
529 %{_libdir}/%{name}/components/xulapp.xpt
530 %{_libdir}/%{name}/components/xuldoc.xpt
531 %{_libdir}/%{name}/components/xultmpl.xpt
532 %dir %{_libdir}/%{name}/plugins
533 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
534 %attr(755,root,root) %{_libdir}/%{name}/*.sh
535 %attr(755,root,root) %{_libdir}/%{name}/m*
536 %attr(755,root,root) %{_libdir}/%{name}/f*
537 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
538 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
539 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
540 %{_pixmapsdir}/mozilla-firefox.png
541 %{_desktopdir}/mozilla-firefox.desktop
542
543 # symlinks
544 %{_libdir}/%{name}/chrome
545 %{_libdir}/%{name}/defaults
546 %{_libdir}/%{name}/dictionaries
547 %{_libdir}/%{name}/extensions
548 %{_libdir}/%{name}/greprefs
549 %{_libdir}/%{name}/icons
550 %{_libdir}/%{name}/res
551 %{_libdir}/%{name}/searchplugins
552
553 # browserconfig
554 %{_libdir}/%{name}/browserconfig.properties
555
556 %{_libdir}/%{name}/LICENSE
557 %{_libdir}/%{name}/README.txt
558
559 %dir %{_datadir}/%{name}
560 %{_datadir}/%{name}/chrome
561 %{_datadir}/%{name}/defaults
562 %{_datadir}/%{name}/greprefs
563 %{_datadir}/%{name}/icons
564 %{_datadir}/%{name}/res
565 %{_datadir}/%{name}/searchplugins
566
567 %dir %{_datadir}/%{name}/extensions
568 # -dom-inspector subpackage?
569 %{_datadir}/%{name}/extensions/inspector@mozilla.org
570 # the signature of the default theme
571 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
572
573 # files created by regxpcom and firefox -register
574 %ghost %{_libdir}/%{name}/components/compreg.dat
575 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.077372 seconds and 4 git commands to generate.