]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- restore explicit -fno-strict-aliasing.
[packages/firefox.git] / mozilla-firefox.spec
1 #
2 # TODO:
3 # - with new gcc version (it is possible that)
4 #   - -fvisibility=hiddenn and ac_cv_visibility_pragma=no can be removed
5 # - with new firefox version (it is possible that)
6 #   - -fno-strict-aliasing can be removed (needs to be tested carefuly,
7 #      not to be fixed soon, imho)
8 # - handle locales differently (runtime, since it's possible to do)
9 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
10 #   for hints how to make locales and other stuff like extensions working
11 # - rpm upgrade is broken. First you need uninstall Firefox 1.0.x.
12 #
13 # Conditional build:
14 %bcond_with     tests   # enable tests (whatever they check)
15 %bcond_without  gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
16 #
17 Summary:        Mozilla Firefox web browser
18 Summary(pl):    Mozilla Firefox - przegl±darka WWW
19 Name:           mozilla-firefox
20 Version:        1.5.0.4
21 Release:        1
22 License:        MPL/LGPL
23 Group:          X11/Applications/Networking
24 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
25 # Source0-md5:  4cb3d7c1b5345585750766c589308b5e
26 Source1:        %{name}.desktop
27 Source2:        %{name}.sh
28 Patch0:         %{name}-nss.patch
29 Patch1:         %{name}-lib_path.patch
30 Patch2:         %{name}-nss-system-nspr.patch
31 Patch3:         %{name}-nopangoxft.patch
32 Patch4:         %{name}-name.patch
33 # UPDATE or DROP?
34 #PatchX:        %{name}-searchplugins.patch
35 URL:            http://www.mozilla.org/projects/firefox/
36 %{?with_gnome:BuildRequires:    GConf2-devel >= 1.2.1}
37 BuildRequires:  automake
38 BuildRequires:  cairo-devel >= 1.0.0
39 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.0}
40 BuildRequires:  gtk+2-devel >= 1:2.0.0
41 BuildRequires:  heimdal-devel >= 0.7.1
42 BuildRequires:  libIDL-devel >= 0.8.0
43 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
44 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.2.0}
45 BuildRequires:  libjpeg-devel >= 6b
46 BuildRequires:  libpng-devel >= 1.2.7
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  nspr-devel >= 1:4.6.1-2
49 BuildRequires:  nss-devel >= 3.10.2
50 BuildRequires:  pango-devel >= 1:1.6.0
51 BuildRequires:  perl-modules >= 5.004
52 BuildRequires:  pkgconfig
53 BuildRequires:  xorg-lib-libXt-devel
54 BuildRequires:  zip
55 BuildRequires:  zlib-devel >= 1.2.3
56 Requires:       %{name}-lang-resources = %{version}
57 Requires:       nspr >= 1:4.6.1-2
58 Requires:       nss >= 3.10.2
59 Provides:       wwwbrowser
60 Obsoletes:      mozilla-firebird
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _firefoxdir     %{_libdir}/%{name}
64 # mozilla and firefox provide their own versions
65 %define         _noautoreqdep           libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so
66
67 %define         specflags       -fno-strict-aliasing
68
69 %description
70 Mozilla Firefox is an open-source web browser, designed for standards
71 compliance, performance and portability.
72
73 %description -l pl
74 Mozilla Firefox jest open sourcow± przegl±dark± sieci WWW, stworzon± z
75 my¶l± o zgodno¶ci ze standardami, wydajno¶ci± i przeno¶no¶ci±.
76
77 %package devel
78 Summary:        Headers for developing programs that will use Mozilla Firefox
79 Summary(pl):    Mozilla Firefox - pliki nag³ówkowe
80 Group:          X11/Development/Libraries
81 Requires:       %{name} = %{epoch}:%{version}-%{release}
82 Requires:       nspr-devel >= 1:4.6.1-2
83 Obsoletes:      mozilla-devel
84
85 %description devel
86 Mozilla Firefox development package.
87
88 %description devel -l pl
89 Pliki nag³ówkowe przegl±darki Mozilla Firefox.
90
91 %package lang-en
92 Summary:        English resources for Mozilla Firefox
93 Summary(pl):    Anglojêzyczne zasoby dla przegl±darki Mozilla Firefox
94 Group:          X11/Applications/Networking
95 Requires(post,postun):  %{name} = %{version}-%{release}
96 Requires(post,postun):  textutils
97 Requires:       %{name} = %{version}-%{release}
98 Provides:       %{name}-lang-resources = %{version}-%{release}
99
100 %description lang-en
101 English resources for Mozilla Firefox.
102
103 %description lang-en -l pl
104 Anglojêzyczne zasoby dla przegl±darki Mozilla Firefox.
105
106 %prep
107 %setup -q -n mozilla
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %patch3 -p1
112 %patch4 -p1
113
114 sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
115
116 %build
117 rm -f .mozconfig
118 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
119 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
120
121 cp -f %{_datadir}/automake/config.* build/autoconf
122 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
123 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
124
125 LIBIDL_CONFIG="%{_bindir}/libIDL-config-2"; export LIBIDL_CONFIG
126
127 cat << EOF > .mozconfig
128 . \$topsrcdir/browser/config/mozconfig
129
130 export BUILD_OFFICIAL=1
131 export MOZILLA_OFFICIAL=1
132 mk_add_options BUILD_OFFICIAL=1
133 mk_add_options MOZILLA_OFFICIAL=1
134
135 ac_add_options --prefix=%{_prefix}
136 ac_add_options --exec-prefix=%{_exec_prefix}
137 ac_add_options --bindir=%{_bindir}
138 ac_add_options --sbindir=%{_sbindir}
139 ac_add_options --sysconfdir=%{_sysconfdir}
140 ac_add_options --datadir=%{_datadir}
141 ac_add_options --includedir=%{_includedir}
142 ac_add_options --libdir=%{_libdir}
143 ac_add_options --libexecdir=%{_libexecdir}
144 ac_add_options --localstatedir=%{_localstatedir}
145 ac_add_options --sharedstatedir=%{_sharedstatedir}
146 ac_add_options --mandir=%{_mandir}
147 ac_add_options --infodir=%{_infodir}
148 ac_add_options --enable-optimize="%{rpmcflags}"
149 %if %{?debug:1}0
150 ac_add_options --enable-debug
151 ac_add_options --enable-debug-modules
152 %else
153 ac_add_options --disable-debug
154 ac_add_options --disable-debug-modules
155 %endif
156 %if %{with tests}
157 ac_add_options --enable-tests
158 %else
159 ac_add_options --disable-tests
160 %endif
161 ac_add_options --disable-composer
162 ac_add_options --disable-dtd-debug
163 ac_add_options --disable-freetype2
164 ac_add_options --disable-installer
165 ac_add_options --disable-jsd
166 ac_add_options --disable-ldap
167 ac_add_options --disable-mailnews
168 ac_add_options --disable-profilesharing
169 ac_add_options --disable-xprint
170 ac_add_options --enable-canvas
171 ac_add_options --enable-crypto
172 ac_add_options --enable-default-toolkit=gtk2
173 ac_add_options --enable-mathml
174 ac_add_options --enable-pango
175 ac_add_options --enable-reorder
176 ac_add_options --enable-single-profile
177 ac_add_options --enable-strip
178 ac_add_options --enable-strip-libs
179 ac_add_options --enable-svg
180 ac_add_options --enable-system-cairo
181 ac_add_options --enable-xft
182 ac_add_options --enable-xinerama
183 ac_add_options --enable-xpctools
184 ac_add_options --with-pthreads
185 ac_add_options --with-system-jpeg
186 ac_add_options --with-system-nspr
187 ac_add_options --with-system-png
188 ac_add_options --with-system-zlib
189 ac_cv_visibility_pragma=no
190 EOF
191
192 %{__make} -j1 -f client.mk build \
193         CC="%{__cc}" \
194         CXX="%{__cxx}"
195
196 %install
197 rm -rf $RPM_BUILD_ROOT
198 install -d \
199         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}{,extensions}} \
200         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
201         $RPM_BUILD_ROOT{%{_includedir}/%{name}/idl,%{_pkgconfigdir}}
202 # extensions dir is needed (it can be empty)
203
204 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
205
206 %{__make} -C xpinstall/packager \
207         MOZ_PKG_APPNAME="mozilla-firefox" \
208         MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
209         EXCLUDE_NSPR_LIBS=1
210
211 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
212
213 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*linux*.tar.gz
214
215 install other-licenses/branding/firefox/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
216 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
217 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
218
219 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
220
221 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki
222 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
223
224 # header/developement files
225 cp -rfL dist/include/*  $RPM_BUILD_ROOT%{_includedir}/%{name}
226 cp -rfL dist/idl/*      $RPM_BUILD_ROOT%{_includedir}/%{name}/idl
227
228 install dist/bin/regxpcom $RPM_BUILD_ROOT%{_bindir}
229 install dist/bin/xpidl $RPM_BUILD_ROOT%{_bindir}
230 install dist/bin/xpt_dump $RPM_BUILD_ROOT%{_bindir}
231 install dist/bin/xpt_link $RPM_BUILD_ROOT%{_bindir}
232
233 ln -sf %{_includedir}/mozilla-firefox/necko/nsIURI.h \
234         $RPM_BUILD_ROOT%{_includedir}/mozilla-firefox/nsIURI.h
235
236 # CA certificates
237 ln -s %{_libdir}/libnssckbi.so $RPM_BUILD_ROOT%{_firefoxdir}/libnssckbi.so
238
239 # pkgconfig files
240 for f in build/unix/*.pc ; do
241         sed -e 's/firefox-%{version}/mozilla-firefox/' $f \
242             > $RPM_BUILD_ROOT%{_pkgconfigdir}/$(basename $f)
243 done
244
245 # already provided by standalone packages
246 rm -f $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-{nss,nspr}.pc
247
248 sed -i -e 's#firefox-nspr =.*#mozilla-nspr#g' -e 's#irefox-nss =.*#mozilla-nss#g' \
249         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
250
251 # includedir/dom CFLAGS
252 sed -i -e '/Cflags:/{/{includedir}\/dom/!s,$, -I${includedir}/dom,}' \
253         $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-plugin.pc
254
255 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/firefox-chrome+xpcom-generate
256 #!/bin/sh
257 umask 022
258 rm -f %{_firefoxdir}/chrome/{chrome.rdf,overlayinfo/*/*/*.rdf}
259 rm -f %{_firefoxdir}/components/{compreg,xpti}.dat
260 MOZILLA_FIVE_HOME=%{_firefoxdir}
261 export MOZILLA_FIVE_HOME
262
263 # PATH
264 PATH=%{_firefoxdir}:$PATH
265 export PATH
266
267 # added /usr/lib : don't load your local library
268 LD_LIBRARY_PATH=%{_firefoxdir}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
269 export LD_LIBRARY_PATH
270
271 unset TMPDIR TMP || :
272 MOZILLA_FIVE_HOME=%{_firefoxdir} %{_firefoxdir}/regxpcom
273 MOZILLA_FIVE_HOME=%{_firefoxdir} %{_firefoxdir}/firefox -register
274 EOF
275
276 %clean
277 rm -rf $RPM_BUILD_ROOT
278
279 %post
280 %{_sbindir}/firefox-chrome+xpcom-generate
281
282 %postun
283 if [ "$1" = "0" ]; then
284         rm -rf %{_firefoxdir}/chrome/overlayinfo
285         rm -f  %{_firefoxdir}/chrome/*.rdf
286         rm -rf %{_firefoxdir}/components
287         rm -rf %{_firefoxdir}/extensions
288 fi
289
290 %triggerpostun -- %{name} < 1.5
291 %banner %{name} -e <<EOF
292 NOTICE:
293 If you have problem with upgrade from old mozilla-firefox 1.0.x,
294 you should remove it first and reinstall %{name}-%{version}
295 EOF
296
297 %files
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{_bindir}/mozilla*
300 %attr(755,root,root) %{_bindir}/firefox
301 %attr(755,root,root) %{_sbindir}/*
302 %dir %{_firefoxdir}
303 %{_firefoxdir}/res
304 %dir %{_firefoxdir}/components
305 %attr(755,root,root) %{_firefoxdir}/components/*.so
306 %{_firefoxdir}/components/*.js
307 %{_firefoxdir}/components/*.xpt
308 %dir %{_firefoxdir}/plugins
309 %attr(755,root,root) %{_firefoxdir}/plugins/*.so
310 %{_firefoxdir}/searchplugins
311 %{_firefoxdir}/icons
312 %{_firefoxdir}/defaults
313 %{_firefoxdir}/greprefs
314 %dir %{_firefoxdir}/extensions
315 %dir %{_firefoxdir}/init.d
316 %attr(755,root,root) %{_firefoxdir}/*.so
317 %attr(755,root,root) %{_firefoxdir}/*.sh
318 %attr(755,root,root) %{_firefoxdir}/m*
319 %attr(755,root,root) %{_firefoxdir}/f*
320 %attr(755,root,root) %{_firefoxdir}/reg*
321 %attr(755,root,root) %{_firefoxdir}/x*
322 %{_pixmapsdir}/*
323 %{_desktopdir}/*
324
325 %dir %{_firefoxdir}/chrome
326 %{_firefoxdir}/chrome/*.jar
327 %{_firefoxdir}/chrome/*.manifest
328 # -chat subpackage?
329 #%{_firefoxdir}/chrome/chatzilla.jar
330 #%{_firefoxdir}/chrome/content-packs.jar
331 %dir %{_firefoxdir}/chrome/icons
332 %{_firefoxdir}/chrome/icons/default
333
334 # -dom-inspector subpackage?
335 %dir %{_firefoxdir}/extensions/inspector@mozilla.org
336 %{_firefoxdir}/extensions/inspector@mozilla.org/*
337
338 %files devel
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_bindir}/regxpcom
341 %attr(755,root,root) %{_bindir}/xpidl
342 %attr(755,root,root) %{_bindir}/xpt_dump
343 %attr(755,root,root) %{_bindir}/xpt_link
344 %{_includedir}/%{name}
345 %{_pkgconfigdir}/*
346
347 %files lang-en
348 %defattr(644,root,root,755)
349 %{_firefoxdir}/chrome/en-US.jar
350 %{_firefoxdir}/chrome/en-US.manifest
This page took 0.057675 seconds and 3 git commands to generate.