]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- rel 2 (1 for ac)
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests           # enable tests (whatever they check)
9 %bcond_without  gnomeui         # disable gnomeui support
10 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
12 #
13 %if %{without gnome}
14 %undefine       with_gnomeui
15 %undefine       with_gnomevfs
16 %endif
17 %define         firefox_ver     2.0.0.11
18 #
19 Summary:        Firefox Community Edition web browser
20 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
21 Name:           mozilla-firefox
22 Version:        %{firefox_ver}
23 Release:        2
24 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
25 Group:          X11/Applications/Networking
26 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
27 # Source0-md5:  b2f982f9f3085195d4797957537ca75d
28 Source1:        %{name}.desktop
29 Source2:        %{name}.sh
30 Patch0:         mozilla-install.patch
31 Patch1:         %{name}-lib_path.patch
32 Patch2:         %{name}-fonts.patch
33 Patch3:         %{name}-agent.patch
34 Patch4:         %{name}-myspell.patch
35 Patch5:         %{name}-pango-cursor-position.patch
36 Patch6:         %{name}-pango-ligatures.patch
37 Patch7:         %{name}-pango-cursor-position-more.patch
38 Patch8:         %{name}-pango-justified-range.patch
39 Patch9:         %{name}-pango-printing.patch
40 Patch10:        %{name}-pango-underline.patch
41 Patch11:        %{name}-xft-randewidth.patch
42 # if ac rebuild is needed...
43 #PatchX:                %{name}-ac.patch
44 URL:            http://www.mozilla.org/projects/firefox/
45 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
46 BuildRequires:  automake
47 BuildRequires:  cairo-devel >= 1.0.0
48 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
49 BuildRequires:  gtk+2-devel >= 1:2.0.0
50 BuildRequires:  krb5-devel
51 BuildRequires:  libIDL-devel >= 0.8.0
52 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
53 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
54 BuildRequires:  libjpeg-devel >= 6b
55 BuildRequires:  libpng-devel >= 1.2.7
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  myspell-devel
58 BuildRequires:  nspr-devel >= 1:4.6.3
59 BuildRequires:  nss-devel >= 1:3.11.3-3
60 BuildRequires:  pango-devel >= 1:1.6.0
61 BuildRequires:  perl-modules >= 5.004
62 BuildRequires:  pkgconfig
63 BuildRequires:  rpmbuild(macros) >= 1.356
64 BuildRequires:  xorg-lib-libXext-devel
65 BuildRequires:  xorg-lib-libXft-devel >= 2.1
66 BuildRequires:  xorg-lib-libXinerama-devel
67 BuildRequires:  xorg-lib-libXp-devel
68 BuildRequires:  xorg-lib-libXt-devel
69 BuildRequires:  zip
70 BuildRequires:  zlib-devel >= 1.2.3
71 Requires(post): mktemp >= 1.5-18
72 Requires:       browser-plugins >= 2.0
73 Requires:       nspr >= 1:4.6.3
74 Requires:       nss >= 1:3.11.3
75 Provides:       wwwbrowser
76 Obsoletes:      mozilla-firebird
77 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
78 Obsoletes:      mozilla-firefox-libs
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 # firefox/thunderbird/seamonkey provide their own versions
82 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
83 %define         _noautoprovfiles        %{_libdir}/%{name}/components
84 # we don't want these to satisfy xulrunner-devel
85 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
86 # and as we don't provide them, don't require either
87 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
88
89 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
90
91 %description
92 Firefox Community Edition is an open-source web browser, designed for
93 standards compliance, performance and portability.
94
95 %description -l pl.UTF-8
96 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
97 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
98 o zgodności ze standardami, wydajnością i przenośnością.
99
100 %prep
101 %setup -qc
102 cd mozilla
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109 %patch6 -p1
110 %patch7 -p1
111 %patch8 -p1
112 %patch9 -p0
113 %patch10 -p1
114 %patch11 -p1
115
116 %build
117 cd mozilla
118
119 cp -f %{_datadir}/automake/config.* build/autoconf
120 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
121 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
122
123 cat << 'EOF' > .mozconfig
124 . $topsrcdir/browser/config/mozconfig
125
126 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
127 ac_cv_visibility_pragma=no
128
129 # Options for 'configure' (same as command-line options).
130 ac_add_options --prefix=%{_prefix}
131 ac_add_options --exec-prefix=%{_exec_prefix}
132 ac_add_options --bindir=%{_bindir}
133 ac_add_options --sbindir=%{_sbindir}
134 ac_add_options --sysconfdir=%{_sysconfdir}
135 ac_add_options --datadir=%{_datadir}
136 ac_add_options --includedir=%{_includedir}
137 ac_add_options --libdir=%{_libdir}
138 ac_add_options --libexecdir=%{_libexecdir}
139 ac_add_options --localstatedir=%{_localstatedir}
140 ac_add_options --sharedstatedir=%{_sharedstatedir}
141 ac_add_options --mandir=%{_mandir}
142 ac_add_options --infodir=%{_infodir}
143 %if %{?debug:1}0
144 ac_add_options --disable-optimize
145 ac_add_options --enable-debug
146 ac_add_options --enable-debug-modules
147 ac_add_options --enable-debugger-info-modules
148 ac_add_options --enable-crash-on-assert
149 %else
150 ac_add_options --disable-debug
151 ac_add_options --disable-debug-modules
152 ac_add_options --disable-logging
153 ac_add_options --enable-optimize="%{rpmcflags}"
154 %endif
155 %if %{with tests}
156 ac_add_options --enable-tests
157 %else
158 ac_add_options --disable-tests
159 %endif
160 %if %{with gnomeui}
161 ac_add_options --enable-gnomeui
162 %else
163 ac_add_options --disable-gnomeui
164 %endif
165 %if %{with gnomevfs}
166 ac_add_options --enable-gnomevfs
167 %else
168 ac_add_options --disable-gnomevfs
169 %endif
170 ac_add_options --disable-freetype2
171 ac_add_options --disable-installer
172 ac_add_options --disable-javaxpcom
173 ac_add_options --disable-updater
174 ac_add_options --enable-default-toolkit=gtk2
175 ac_add_options --enable-svg
176 ac_add_options --enable-system-cairo
177 ac_add_options --enable-system-myspell
178 ac_add_options --enable-xft
179 ac_add_options --with-distribution-id=org.pld-linux
180 ac_add_options --with-system-jpeg
181 ac_add_options --with-system-nspr
182 ac_add_options --with-system-nss
183 ac_add_options --with-system-png
184 ac_add_options --with-system-zlib
185 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
186 EOF
187
188 %{__make} -j1 -f client.mk build \
189         CC="%{__cc}" \
190         CXX="%{__cxx}"
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 cd mozilla
195 install -d \
196         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
197         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
198         $RPM_BUILD_ROOT%{_datadir}/%{name}
199
200 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
201
202 %{__make} -C obj-%{_target_cpu}/xpinstall/packager stage-package \
203         DESTDIR=$RPM_BUILD_ROOT \
204         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
205         PKG_SKIP_STRIP=1
206
207 # move arch independant ones to datadir
208 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
209 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
210 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
211 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
212 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
213 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
214 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
215 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
216 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
217 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
218 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
219 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
220 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
221 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
222 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
223 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
224
225 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
226 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
227
228 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
229 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
230
231 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
232
233 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
234
235 # header/development files
236 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
237 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
238 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
239
240 # files created by regxpcom and firefox -register
241 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
242 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
243
244 # what's this? it's content is invalid anyway.
245 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
246 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
247
248 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
249 #!/bin/sh
250 umask 022
251 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
252
253 # it attempts to touch files in $HOME/.mozilla
254 # beware if you run this with sudo!!!
255 export HOME=$(mktemp -d)
256 # also TMPDIR could be pointing to sudo user's homedir
257 unset TMPDIR TMP || :
258
259 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
260 %{_libdir}/%{name}/firefox -register
261
262 rm -rf $HOME
263 EOF
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %pretrans
269 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
270         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
271 fi
272 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
273         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
274                 install -d %{_datadir}/%{name}
275                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
276         fi
277 done
278 exit 0
279
280 %post
281 %{_sbindir}/%{name}-chrome+xpcom-generate
282 %update_browser_plugins
283
284 %postun
285 if [ "$1" = 0 ]; then
286         %update_browser_plugins
287 fi
288
289 %files
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_bindir}/%{name}
292 %attr(755,root,root) %{_bindir}/firefox
293 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
294
295 # browser plugins v2
296 %{_browserpluginsconfdir}/browsers.d/%{name}.*
297 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
298
299 %dir %{_libdir}/%{name}
300 %attr(755,root,root) %{_libdir}/%{name}/*.so
301
302 %dir %{_libdir}/%{name}/components
303 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
304 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
305 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
306 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
307 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
308 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
309 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
310 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
311 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
312 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
313 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
314 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
315 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
316 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
317 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
318 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
319 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
320 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
321 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
322 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
323 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
324 %{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
325 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
326 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
327 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
328 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
329 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
330 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
331 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
332 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
333 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
334 %{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
335 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
336 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
337 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
340 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
341 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
342 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
361 %{_libdir}/%{name}/components/accessibility-atk.xpt
362 %{_libdir}/%{name}/components/accessibility.xpt
363 %{_libdir}/%{name}/components/alerts.xpt
364 %{_libdir}/%{name}/components/appshell.xpt
365 %{_libdir}/%{name}/components/appstartup.xpt
366 %{_libdir}/%{name}/components/autocomplete.xpt
367 %{_libdir}/%{name}/components/autoconfig.xpt
368 %{_libdir}/%{name}/components/bookmarks.xpt
369 %{_libdir}/%{name}/components/browsercompsbase.xpt
370 %{_libdir}/%{name}/components/browser-feeds.xpt
371 %{_libdir}/%{name}/components/browsersearch.xpt
372 %{_libdir}/%{name}/components/caps.xpt
373 %{_libdir}/%{name}/components/chardet.xpt
374 %{_libdir}/%{name}/components/chrome.xpt
375 %{_libdir}/%{name}/components/commandhandler.xpt
376 %{_libdir}/%{name}/components/commandlines.xpt
377 %{_libdir}/%{name}/components/composer.xpt
378 %{_libdir}/%{name}/components/content_base.xpt
379 %{_libdir}/%{name}/components/content_htmldoc.xpt
380 %{_libdir}/%{name}/components/content_html.xpt
381 %{_libdir}/%{name}/components/content_xmldoc.xpt
382 %{_libdir}/%{name}/components/content_xslt.xpt
383 %{_libdir}/%{name}/components/content_xtf.xpt
384 %{_libdir}/%{name}/components/cookie.xpt
385 %{_libdir}/%{name}/components/directory.xpt
386 %{_libdir}/%{name}/components/docshell.xpt
387 %{_libdir}/%{name}/components/dom_base.xpt
388 %{_libdir}/%{name}/components/dom_canvas.xpt
389 %{_libdir}/%{name}/components/dom_core.xpt
390 %{_libdir}/%{name}/components/dom_css.xpt
391 %{_libdir}/%{name}/components/dom_events.xpt
392 %{_libdir}/%{name}/components/dom_html.xpt
393 %{_libdir}/%{name}/components/dom_loadsave.xpt
394 %{_libdir}/%{name}/components/dom_range.xpt
395 %{_libdir}/%{name}/components/dom_sidebar.xpt
396 %{_libdir}/%{name}/components/dom_storage.xpt
397 %{_libdir}/%{name}/components/dom_stylesheets.xpt
398 %{_libdir}/%{name}/components/dom_svg.xpt
399 %{_libdir}/%{name}/components/dom_traversal.xpt
400 %{_libdir}/%{name}/components/dom_views.xpt
401 %{_libdir}/%{name}/components/dom_xbl.xpt
402 %{_libdir}/%{name}/components/dom_xpath.xpt
403 %{_libdir}/%{name}/components/dom.xpt
404 %{_libdir}/%{name}/components/dom_xul.xpt
405 %{_libdir}/%{name}/components/downloads.xpt
406 %{_libdir}/%{name}/components/editor.xpt
407 %{_libdir}/%{name}/components/embed_base.xpt
408 %{_libdir}/%{name}/components/extensions.xpt
409 %{_libdir}/%{name}/components/exthandler.xpt
410 %{_libdir}/%{name}/components/fastfind.xpt
411 %{_libdir}/%{name}/components/FeedConverter.js
412 %{_libdir}/%{name}/components/FeedProcessor.js
413 %{_libdir}/%{name}/components/feeds.xpt
414 %{_libdir}/%{name}/components/FeedWriter.js
415 %{_libdir}/%{name}/components/filepicker.xpt
416 %{_libdir}/%{name}/components/find.xpt
417 %{_libdir}/%{name}/components/gfx.xpt
418 %{_libdir}/%{name}/components/gksvgrenderer.xpt
419 %{_libdir}/%{name}/components/history.xpt
420 %{_libdir}/%{name}/components/htmlparser.xpt
421 %{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
422 %{_libdir}/%{name}/components/imglib2.xpt
423 %{_libdir}/%{name}/components/inspector.xpt
424 %{_libdir}/%{name}/components/intl.xpt
425 %{_libdir}/%{name}/components/jar.xpt
426 %{_libdir}/%{name}/components/jsconsole-clhandler.js
427 %{_libdir}/%{name}/components/jsconsole.xpt
428 %{_libdir}/%{name}/components/jsdservice.xpt
429 %{_libdir}/%{name}/components/layout_base.xpt
430 %{_libdir}/%{name}/components/layout_printing.xpt
431 %{_libdir}/%{name}/components/layout_xul_tree.xpt
432 %{_libdir}/%{name}/components/layout_xul.xpt
433 %{_libdir}/%{name}/components/locale.xpt
434 %{_libdir}/%{name}/components/lwbrk.xpt
435 %{_libdir}/%{name}/components/microsummaries.xpt
436 %{_libdir}/%{name}/components/migration.xpt
437 %{_libdir}/%{name}/components/mimetype.xpt
438 %{_libdir}/%{name}/components/mozbrwsr.xpt
439 %{_libdir}/%{name}/components/mozfind.xpt
440 %{_libdir}/%{name}/components/mozgnome.xpt
441 %{_libdir}/%{name}/components/necko_about.xpt
442 %{_libdir}/%{name}/components/necko_cache.xpt
443 %{_libdir}/%{name}/components/necko_cookie.xpt
444 %{_libdir}/%{name}/components/necko_data.xpt
445 %{_libdir}/%{name}/components/necko_dns.xpt
446 %{_libdir}/%{name}/components/necko_file.xpt
447 %{_libdir}/%{name}/components/necko_ftp.xpt
448 %{_libdir}/%{name}/components/necko_http.xpt
449 %{_libdir}/%{name}/components/necko_res.xpt
450 %{_libdir}/%{name}/components/necko_socket.xpt
451 %{_libdir}/%{name}/components/necko_strconv.xpt
452 %{_libdir}/%{name}/components/necko_viewsource.xpt
453 %{_libdir}/%{name}/components/necko.xpt
454 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
455 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
456 %{_libdir}/%{name}/components/nsBrowserGlue.js
457 %{_libdir}/%{name}/components/nsCloseAllWindows.js
458 %{_libdir}/%{name}/components/nsDefaultCLH.js
459 %{_libdir}/%{name}/components/nsDictionary.js
460 %{_libdir}/%{name}/components/nsExtensionManager.js
461 %{_libdir}/%{name}/components/nsFilePicker.js
462 %{_libdir}/%{name}/components/nsHelperAppDlg.js
463 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
464 %{_libdir}/%{name}/components/nsKillAll.js
465 %{_libdir}/%{name}/components/nsMicrosummaryService.js
466 %{_libdir}/%{name}/components/nsProgressDialog.js
467 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
468 %{_libdir}/%{name}/components/nsResetPref.js
469 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
470 %{_libdir}/%{name}/components/nsSearchService.js
471 %{_libdir}/%{name}/components/nsSearchSuggestions.js
472 %{_libdir}/%{name}/components/nsSessionStartup.js
473 %{_libdir}/%{name}/components/nsSessionStore.js
474 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
475 %{_libdir}/%{name}/components/nsSidebar.js
476 %{_libdir}/%{name}/components/nsUpdateService.js
477 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
478 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
479 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
480 %{_libdir}/%{name}/components/nsURLFormatter.js
481 %{_libdir}/%{name}/components/nsXmlRpcClient.js
482 %{_libdir}/%{name}/components/oji.xpt
483 %{_libdir}/%{name}/components/passwordmgr.xpt
484 %{_libdir}/%{name}/components/pipboot.xpt
485 %{_libdir}/%{name}/components/pipnss.xpt
486 %{_libdir}/%{name}/components/pippki.xpt
487 %{_libdir}/%{name}/components/plugin.xpt
488 %{_libdir}/%{name}/components/prefetch.xpt
489 %{_libdir}/%{name}/components/pref.xpt
490 %{_libdir}/%{name}/components/profile.xpt
491 %{_libdir}/%{name}/components/progressDlg.xpt
492 %{_libdir}/%{name}/components/proxyObjInst.xpt
493 %{_libdir}/%{name}/components/rdf.xpt
494 %{_libdir}/%{name}/components/safebrowsing.xpt
495 %{_libdir}/%{name}/components/satchel.xpt
496 %{_libdir}/%{name}/components/saxparser.xpt
497 %{_libdir}/%{name}/components/search.xpt
498 %{_libdir}/%{name}/components/sessionstore.xpt
499 %{_libdir}/%{name}/components/shellservice.xpt
500 %{_libdir}/%{name}/components/shistory.xpt
501 %{_libdir}/%{name}/components/spellchecker.xpt
502 %{_libdir}/%{name}/components/storage.xpt
503 %{_libdir}/%{name}/components/toolkitprofile.xpt
504 %{_libdir}/%{name}/components/toolkitremote.xpt
505 %{_libdir}/%{name}/components/txmgr.xpt
506 %{_libdir}/%{name}/components/txtsvc.xpt
507 %{_libdir}/%{name}/components/uconv.xpt
508 %{_libdir}/%{name}/components/unicharutil.xpt
509 %{_libdir}/%{name}/components/update.xpt
510 %{_libdir}/%{name}/components/uriloader.xpt
511 %{_libdir}/%{name}/components/url-classifier.xpt
512 %{_libdir}/%{name}/components/urlformatter.xpt
513 %{_libdir}/%{name}/components/webBrowser_core.xpt
514 %{_libdir}/%{name}/components/webbrowserpersist.xpt
515 %{_libdir}/%{name}/components/WebContentConverter.js
516 %{_libdir}/%{name}/components/webshell_idls.xpt
517 %{_libdir}/%{name}/components/websrvcs.xpt
518 %{_libdir}/%{name}/components/widget.xpt
519 %{_libdir}/%{name}/components/windowds.xpt
520 %{_libdir}/%{name}/components/windowwatcher.xpt
521 %{_libdir}/%{name}/components/xml-rpc.xpt
522 %{_libdir}/%{name}/components/xpcom_base.xpt
523 %{_libdir}/%{name}/components/xpcom_components.xpt
524 %{_libdir}/%{name}/components/xpcom_ds.xpt
525 %{_libdir}/%{name}/components/xpcom_io.xpt
526 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
527 %{_libdir}/%{name}/components/xpcom_threads.xpt
528 %{_libdir}/%{name}/components/xpcom_xpti.xpt
529 %{_libdir}/%{name}/components/xpconnect.xpt
530 %{_libdir}/%{name}/components/xpinstall.xpt
531 %{_libdir}/%{name}/components/xulapp.xpt
532 %{_libdir}/%{name}/components/xuldoc.xpt
533 %{_libdir}/%{name}/components/xultmpl.xpt
534 %dir %{_libdir}/%{name}/plugins
535 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
536 %attr(755,root,root) %{_libdir}/%{name}/*.sh
537 %attr(755,root,root) %{_libdir}/%{name}/m*
538 %attr(755,root,root) %{_libdir}/%{name}/f*
539 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
540 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
541 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
542 %{_pixmapsdir}/mozilla-firefox.png
543 %{_desktopdir}/mozilla-firefox.desktop
544
545 # symlinks
546 %{_libdir}/%{name}/chrome
547 %{_libdir}/%{name}/defaults
548 %{_libdir}/%{name}/dictionaries
549 %{_libdir}/%{name}/extensions
550 %{_libdir}/%{name}/greprefs
551 %{_libdir}/%{name}/icons
552 %{_libdir}/%{name}/init.d
553 %{_libdir}/%{name}/res
554 %{_libdir}/%{name}/searchplugins
555
556 # browserconfig
557 %{_libdir}/%{name}/browserconfig.properties
558
559 %{_libdir}/%{name}/LICENSE
560 %{_libdir}/%{name}/README.txt
561
562 %dir %{_datadir}/%{name}
563 %{_datadir}/%{name}/chrome
564 %{_datadir}/%{name}/defaults
565 %{_datadir}/%{name}/greprefs
566 %{_datadir}/%{name}/icons
567 %{_datadir}/%{name}/init.d
568 %{_datadir}/%{name}/res
569 %{_datadir}/%{name}/searchplugins
570
571 %dir %{_datadir}/%{name}/extensions
572 # -dom-inspector subpackage?
573 %{_datadir}/%{name}/extensions/inspector@mozilla.org
574 # the signature of the default theme
575 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
576
577 # files created by regxpcom and firefox -register
578 %ghost %{_libdir}/%{name}/components/compreg.dat
579 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.065437 seconds and 3 git commands to generate.