]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- libXft no longer directly used
[packages/firefox.git] / mozilla-firefox.spec
1 # NOTE: PLD distributes iceweasel instead
2 #
3 # TODO:
4 # - handle locales differently (runtime, since it's possible to do)
5 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
6 #   for hints how to make locales
7 # - (12:22:58)  patrys:  can you also move _libdir/mozilla-firefox to just _libdir/firefox?
8 #   (12:23:25)  patrys:  it's not like we ship official firefox
9 # - fix wrapper script to allow playing with profiles (must not use -remote)
10 #
11 # Conditional build:
12 %bcond_with     tests           # enable tests (whatever they check)
13 %bcond_without  gnomeui         # disable gnomeui support
14 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
15 %bcond_without  kerberos        # disable krb5 support
16 %bcond_without  xulrunner       # system xulrunner
17
18 %if %{without gnome}
19 %undefine       with_gnomeui
20 %endif
21
22 %if %{without xulrunner}
23 # The actual sqlite version (see RHBZ#480989):
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 Summary:        Firefox Community Edition web browser
28 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
29 Name:           mozilla-firefox
30 Version:        7.0.1
31 Release:        1
32 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
33 Group:          X11/Applications/Networking
34 Source0:        http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
35 # Source0-md5:  5b212db48630ba93bb30ec63cca17f4d
36 Source1:        %{name}.desktop
37 Source2:        %{name}.sh
38 Patch0:         %{name}-install.patch
39 Patch1:         %{name}-gcc3.patch
40 Patch2:         %{name}-agent.patch
41 Patch3:         %{name}-agent-ac.patch
42 Patch4:         %{name}-ti-agent.patch
43 Patch5:         %{name}-branding.patch
44 Patch6:         %{name}-prefs.patch
45 Patch7:         %{name}-nss_cflags.patch
46 Patch8:         %{name}-no-subshell.patch
47 URL:            http://www.mozilla.org/projects/firefox/
48 BuildRequires:  GConf2-devel >= 1.2.1
49 BuildRequires:  OpenGL-devel
50 BuildRequires:  alsa-lib-devel
51 BuildRequires:  automake
52 BuildRequires:  bzip2-devel
53 BuildRequires:  cairo-devel >= 1.10.2-5
54 BuildRequires:  dbus-glib-devel >= 0.60
55 BuildRequires:  glib2-devel >= 1:2.18
56 BuildRequires:  gtk+2-devel >= 2:2.10
57 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
58 BuildRequires:  hunspell-devel
59 BuildRequires:  libIDL-devel >= 0.8.0
60 BuildRequires:  libdnet-devel
61 BuildRequires:  libevent-devel >= 1.4.7
62 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
63 BuildRequires:  libiw-devel
64 BuildRequires:  libjpeg-devel >= 6b
65 BuildRequires:  libnotify-devel >= 0.4
66 BuildRequires:  libpng(APNG)-devel >= 0.10
67 BuildRequires:  libpng-devel >= 1.4.1
68 BuildRequires:  libstdc++-devel
69 BuildRequires:  libvpx-devel
70 BuildRequires:  nspr-devel >= 1:4.8.8
71 BuildRequires:  nss-devel >= 1:3.12.10
72 BuildRequires:  pango-devel >= 1:1.14.0
73 BuildRequires:  perl-modules >= 5.004
74 BuildRequires:  pkgconfig
75 BuildRequires:  python-modules
76 BuildRequires:  rpm >= 4.4.9-56
77 BuildRequires:  rpmbuild(macros) >= 1.601
78 BuildRequires:  sqlite3-devel >= 3.7.5-2
79 BuildRequires:  startup-notification-devel >= 0.8
80 BuildRequires:  xorg-lib-libXScrnSaver-devel
81 BuildRequires:  xorg-lib-libXext-devel
82 BuildRequires:  xorg-lib-libXinerama-devel
83 BuildRequires:  xorg-lib-libXt-devel
84 %if %{with xulrunner}
85 BuildRequires:  xulrunner-devel >= 2:%{version}
86 %endif
87 BuildRequires:  zip
88 BuildRequires:  zlib-devel >= 1.2.3
89 Requires(post): mktemp >= 1.5-18
90 %if %{with xulrunner}
91 %requires_eq_to xulrunner xulrunner-devel
92 %else
93 Requires:       browser-plugins >= 2.0
94 Requires:       cairo >= 1.10.2-5
95 Requires:       dbus-glib >= 0.60
96 Requires:       gtk+2 >= 2:2.18
97 Requires:       libpng >= 1.4.1
98 Requires:       libpng(APNG) >= 0.10
99 Requires:       myspell-common
100 Requires:       nspr >= 1:4.8.8
101 Requires:       nss >= 1:3.12.10
102 Requires:       pango >= 1:1.14.0
103 Requires:       sqlite3 >= %{sqlite_build_version}
104 Requires:       startup-notification >= 0.8
105 %endif
106 Provides:       wwwbrowser
107 Obsoletes:      mozilla-firebird
108 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
109 Obsoletes:      mozilla-firefox-libs
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 # don't satisfy other packages (don't use %{name} here)
113 %define         _noautoprovfiles        %{_libdir}/mozilla-firefox
114 # and as we don't provide them, don't require either
115 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so %{!?with_xulrunner:libmozalloc.so}
116
117 %if "%{cc_version}" >= "3.4"
118 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
119 %else
120 %define         specflags       -fno-strict-aliasing
121 %endif
122
123 %description
124 Firefox Community Edition is an open-source web browser, designed for
125 standards compliance, performance and portability.
126
127 %description -l pl.UTF-8
128 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
129 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
130 o zgodności ze standardami, wydajnością i przenośnością.
131
132 %prep
133 %setup -qc
134 mv -f mozilla-release mozilla
135 cd mozilla
136
137 %patch0 -p1
138
139 %if "%{cc_version}" < "3.4"
140 %patch1 -p2
141 %endif
142
143 %if "%{pld_release}" == "th"
144 %patch2 -p1
145 %endif
146
147 %if "%{pld_release}" == "ac"
148 %patch3 -p1
149 %endif
150
151 %if "%{pld_release}" == "ti"
152 %patch4 -p1
153 %endif
154
155 %patch5 -p1
156 %patch6 -p1
157 %patch7 -p1
158 %patch8 -p2
159
160 %build
161 cd mozilla
162 cp -f %{_datadir}/automake/config.* build/autoconf
163
164 cat << EOF > .mozconfig
165 . \$topsrcdir/browser/config/mozconfig
166
167 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
168
169 # Options for 'configure' (same as command-line options).
170 ac_add_options --prefix=%{_prefix}
171 ac_add_options --exec-prefix=%{_exec_prefix}
172 ac_add_options --bindir=%{_bindir}
173 ac_add_options --sbindir=%{_sbindir}
174 ac_add_options --sysconfdir=%{_sysconfdir}
175 ac_add_options --datadir=%{_datadir}
176 ac_add_options --includedir=%{_includedir}
177 ac_add_options --libdir=%{_libdir}
178 ac_add_options --libexecdir=%{_libexecdir}
179 ac_add_options --localstatedir=%{_localstatedir}
180 ac_add_options --sharedstatedir=%{_sharedstatedir}
181 ac_add_options --mandir=%{_mandir}
182 ac_add_options --infodir=%{_infodir}
183 %if %{?debug:1}0
184 ac_add_options --disable-optimize
185 ac_add_options --enable-debug
186 ac_add_options --enable-debug-modules
187 ac_add_options --enable-debugger-info-modules
188 ac_add_options --enable-crash-on-assert
189 %else
190 ac_add_options --disable-debug
191 ac_add_options --disable-debug-modules
192 ac_add_options --disable-logging
193 ac_add_options --enable-optimize="%{rpmcflags} -Os"
194 %endif
195 ac_add_options --disable-strip
196 ac_add_options --disable-strip-libs
197 %if %{with tests}
198 ac_add_options --enable-tests
199 %else
200 ac_add_options --disable-tests
201 %endif
202 %if %{with gnomeui}
203 ac_add_options --enable-gnomeui
204 %else
205 ac_add_options --disable-gnomeui
206 %endif
207 ac_add_options --disable-gnomevfs
208 ac_add_options --disable-crashreporter
209 ac_add_options --disable-installer
210 ac_add_options --disable-javaxpcom
211 ac_add_options --disable-updater
212 ac_add_options --enable-gio
213 ac_add_options --enable-libxul
214 ac_add_options --enable-pango
215 ac_add_options --enable-shared-js
216 ac_add_options --enable-startup-notification
217 ac_add_options --enable-system-cairo
218 ac_add_options --enable-system-hunspell
219 ac_add_options --enable-system-sqlite
220 ac_add_options --with-distribution-id=org.pld-linux
221 %if %{with xulrunner}
222 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
223 %endif
224 ac_add_options --with-pthreads
225 ac_add_options --with-system-bz2
226 ac_add_options --with-system-jpeg
227 ac_add_options --with-system-libevent
228 ac_add_options --with-system-libvpx
229 ac_add_options --with-system-nspr
230 ac_add_options --with-system-nss
231 ac_add_options --with-system-png
232 ac_add_options --with-system-zlib
233 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
234 EOF
235
236 %{__make} -f client.mk build \
237         STRIP="/bin/true" \
238         CC="%{__cc}" \
239         CXX="%{__cxx}"
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243 cd mozilla
244 install -d \
245         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
246         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
247         $RPM_BUILD_ROOT%{_datadir}/%{name}
248
249 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
250
251 %{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
252         DESTDIR=$RPM_BUILD_ROOT \
253         MOZ_PKG_DIR=%{_libdir}/%{name} \
254         PKG_SKIP_STRIP=1
255
256 install -d \
257         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
258
259 %if %{with xulrunner}
260 # >= 5.0 seems to require this
261 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
262 %endif
263
264 # move arch independant ones to datadir
265 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
266 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
267 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
268 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
269 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
270 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
271 %if %{without xulrunner}
272 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
273 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
274 %endif
275
276 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
277 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
278 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
279 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
280 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
281 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
282 %if %{without xulrunner}
283 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
284 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
285 %endif
286
287 %if %{without xulrunner}
288 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
289 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
290 %endif
291
292 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
293 chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
294 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
295
296 cp -a browser/branding/unofficial/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
297 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
298
299 # files created by firefox -register
300 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
301 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
302
303 %if %{with xulrunner}
304 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
305 %endif
306 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
307
308 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
309 #!/bin/sh
310 umask 022
311 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
312
313 # it attempts to touch files in $HOME/.mozilla
314 # beware if you run this with sudo!!!
315 export HOME=$(mktemp -d)
316 # also TMPDIR could be pointing to sudo user's homedir
317 unset TMPDIR TMP || :
318
319 %{_libdir}/%{name}/firefox -register
320
321 rm -rf $HOME
322 EOF
323 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
324
325 %clean
326 rm -rf $RPM_BUILD_ROOT
327
328 %pretrans
329 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
330         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
331 fi
332 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
333         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
334                 install -d %{_datadir}/%{name}
335                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
336         fi
337 done
338 exit 0
339
340 %post
341 %{_sbindir}/%{name}-chrome+xpcom-generate
342 %update_browser_plugins
343
344 %postun
345 if [ "$1" = 0 ]; then
346         %update_browser_plugins
347 fi
348
349 %files
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_bindir}/%{name}
352 %attr(755,root,root) %{_bindir}/firefox
353 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
354
355 # browser plugins v2
356 %{_browserpluginsconfdir}/browsers.d/%{name}.*
357 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
358
359 %dir %{_libdir}/%{name}
360 %if %{without xulrunner}
361 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
362 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
363 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
364 %endif
365 %{_libdir}/%{name}/blocklist.xml
366
367 %if %{with crashreporter}
368 %{_libdir}/%{name}/crashreporter
369 %{_libdir}/%{name}/crashreporter-override.ini
370 %{_libdir}/%{name}/crashreporter.ini
371 %{_libdir}/%{name}/Throbber-small.gif
372 %endif
373
374 # config?
375 %{_libdir}/%{name}/application.ini
376 %{_libdir}/%{name}/chrome.manifest
377
378 %dir %{_libdir}/%{name}/components
379
380 %{_libdir}/%{name}/components/FeedConverter.js
381 %{_libdir}/%{name}/components/FeedWriter.js
382 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
383 %{_libdir}/%{name}/components/Weave.js
384 %{_libdir}/%{name}/components/WebContentConverter.js
385 %{_libdir}/%{name}/components/browser.xpt
386 %{_libdir}/%{name}/components/fuelApplication.js
387 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
388 %{_libdir}/%{name}/components/nsBrowserGlue.js
389 %{_libdir}/%{name}/components/nsPrivateBrowsingService.js
390 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
391 %{_libdir}/%{name}/components/nsSessionStartup.js
392 %{_libdir}/%{name}/components/nsSessionStore.js
393 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
394 %{_libdir}/%{name}/components/nsSidebar.js
395
396 %{_libdir}/%{name}/components/components.manifest
397 %{_libdir}/%{name}/components/interfaces.manifest
398
399 %if %{without xulrunner}
400 %{_libdir}/%{name}/platform.ini
401 %{_libdir}/%{name}/components/ConsoleAPI.js
402 %{_libdir}/%{name}/components/FeedProcessor.js
403 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
404 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
405 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
406 %{_libdir}/%{name}/components/TelemetryPing.js
407 %{_libdir}/%{name}/components/addonManager.js
408 %{_libdir}/%{name}/components/amContentHandler.js
409 %{_libdir}/%{name}/components/amWebInstallListener.js
410 %{_libdir}/%{name}/components/contentAreaDropListener.js
411 %{_libdir}/%{name}/components/contentSecurityPolicy.js
412 %{_libdir}/%{name}/components/crypto-SDR.js
413 %{_libdir}/%{name}/components/jsconsole-clhandler.js
414 %{_libdir}/%{name}/components/nsBadCertHandler.js
415 %{_libdir}/%{name}/components/nsBlocklistService.js
416 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
417 %{_libdir}/%{name}/components/nsContentPrefService.js
418 %{_libdir}/%{name}/components/nsDefaultCLH.js
419 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
420 %{_libdir}/%{name}/components/nsFilePicker.js
421 %{_libdir}/%{name}/components/nsFormAutoComplete.js
422 %{_libdir}/%{name}/components/nsFormHistory.js
423 %{_libdir}/%{name}/components/nsHandlerService.js
424 %{_libdir}/%{name}/components/nsHelperAppDlg.js
425 %{_libdir}/%{name}/components/nsINIProcessor.js
426 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
427 %{_libdir}/%{name}/components/nsLivemarkService.js
428 %{_libdir}/%{name}/components/nsLoginInfo.js
429 %{_libdir}/%{name}/components/nsLoginManager.js
430 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
431 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
432 %{_libdir}/%{name}/components/nsPlacesExpiration.js
433 %{_libdir}/%{name}/components/nsPrompter.js
434 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
435 %{_libdir}/%{name}/components/nsSearchService.js
436 %{_libdir}/%{name}/components/nsSearchSuggestions.js
437 %{_libdir}/%{name}/components/nsTaggingService.js
438 %{_libdir}/%{name}/components/nsTryToClose.js
439 %{_libdir}/%{name}/components/nsURLFormatter.js
440 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
441 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
442 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
443 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
444 %{_libdir}/%{name}/components/nsWebHandlerApp.js
445 %{_libdir}/%{name}/components/storage-Legacy.js
446 %{_libdir}/%{name}/components/storage-mozStorage.js
447 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
448 %endif
449
450 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
451 %if %{without xulrunner}
452 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
453 %endif
454
455 %if %{without xulrunner}
456 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
457 %endif
458
459 %attr(755,root,root) %{_libdir}/%{name}/firefox
460 %dir %{_libdir}/%{name}/plugins
461 %if %{without xulrunner}
462 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
463 %attr(755,root,root) %{_libdir}/%{name}/firefox-bin
464 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
465 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
466 %endif
467
468 %{_pixmapsdir}/mozilla-firefox.png
469 %{_desktopdir}/mozilla-firefox.desktop
470
471 # symlinks
472 %{_libdir}/%{name}/chrome
473 %{_libdir}/%{name}/defaults
474 %{_libdir}/%{name}/extensions
475 %{_libdir}/%{name}/icons
476 %{_libdir}/%{name}/modules
477 %{_libdir}/%{name}/searchplugins
478 %if %{with xulrunner}
479 %{_libdir}/%{name}/xulrunner
480 %else
481 %{_libdir}/%{name}/dictionaries
482 %{_libdir}/%{name}/greprefs.js
483 %{_libdir}/%{name}/res
484 %endif
485
486 %dir %{_datadir}/%{name}
487 %{_datadir}/%{name}/chrome
488 %{_datadir}/%{name}/defaults
489 %{_datadir}/%{name}/icons
490 %{_datadir}/%{name}/modules
491 %{_datadir}/%{name}/searchplugins
492 %if %{without xulrunner}
493 %{_datadir}/%{name}/greprefs.js
494 %{_datadir}/%{name}/res
495 %endif
496
497 %dir %{_datadir}/%{name}/extensions
498 # -dom-inspector subpackage?
499 #%{_datadir}/%{name}/extensions/inspector@mozilla.org
500 # the signature of the default theme
501 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
502
503 # files created by firefox -register
504 %ghost %{_libdir}/%{name}/components/compreg.dat
505 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.118325 seconds and 3 git commands to generate.