]> git.pld-linux.org Git - packages/firefox.git/blame - mozilla-firefox.spec
- updated to 3.6.13, fixes:
[packages/firefox.git] / mozilla-firefox.spec
CommitLineData
82f606de 1# NOTE: PLD distributes iceweasel instead
dfdf0ac8 2#
0d00fa1b
AM
3# TODO:
4# - handle locales differently (runtime, since it's possible to do)
5# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
f37c2ce5 6# for hints how to make locales
cec5c010
ER
7# - (12:22:58) patrys: can you also move _libdir/mozilla-firefox to just _libdir/firefox?
8# (12:23:25) patrys: it's not like we ship official firefox
0af918cf 9# - fix wrapper script to allow playing with profiles (must not use -remote)
2f695f11 10#
ca6a7239 11# Conditional build:
4ab16c9e
JB
12%bcond_with tests # enable tests (whatever they check)
13%bcond_without gnomeui # disable gnomeui support
14%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
15%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
2a673919 16%bcond_without kerberos # disable krb5 support
d97ddc70 17%bcond_without xulrunner # system xulrunner
2a673919 18
4ab16c9e
JB
19%if %{without gnome}
20%undefine with_gnomeui
21%undefine with_gnomevfs
22%endif
2a673919 23
d97ddc70
JB
24# convert firefox release number to platform version: 3.6.x -> 1.9.2.x
25%define xulrunner_main 1.9.2
26%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#3.6})
27
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
52dbdf60 33Summary: Firefox Community Edition web browser
948d1385 34Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
ea721d92 35Name: mozilla-firefox
17eb28c6 36Version: 3.6.13
e6902292 37Release: 1
4ab16c9e 38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
51c0f20a 39Group: X11/Applications/Networking
d97ddc70 40Source0: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
17eb28c6 41# Source0-md5: d7c90aed8209beefa74badf02e8eeae1
7c7475d0 42Source1: %{name}.desktop
43Source2: %{name}.sh
2a673919 44Patch0: %{name}-install.patch
6ef56845 45Patch1: %{name}-gcc3.patch
46Patch2: %{name}-agent.patch
47Patch3: %{name}-agent-ac.patch
20ac5a05 48Patch4: %{name}-ti-agent.patch
29b16068 49Patch5: %{name}-branding.patch
50Patch6: %{name}-prefs.patch
d1eea1c3 51Patch7: %{name}-nss_cflags.patch
d97ddc70
JB
52Patch8: %{name}-no-subshell.patch
53Patch9: %{name}-libpng.patch
5f561b4c 54URL: http://www.mozilla.org/projects/firefox/
4ab16c9e 55%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
d97ddc70 56BuildRequires: alsa-lib-devel
e933d2a8 57BuildRequires: automake
d97ddc70 58BuildRequires: bzip2-devel
82f606de 59BuildRequires: cairo-devel >= 1.8.8
09328230 60BuildRequires: dbus-glib-devel >= 0.60
4ab16c9e 61%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
2a673919 62BuildRequires: gtk+2-devel >= 2:2.10
2a673919 63%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
d97ddc70 64BuildRequires: hunspell-devel
8a88dcf7 65BuildRequires: libIDL-devel >= 0.8.0
d97ddc70 66BuildRequires: libdnet-devel
4ab16c9e
JB
67%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
68%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
d97ddc70 69BuildRequires: libiw-devel
ea721d92 70BuildRequires: libjpeg-devel >= 6b
17eb28c6 71BuildRequires: libnotify-devel >= 0.4
2a673919 72BuildRequires: libpng(APNG)-devel >= 0.10
82f606de 73BuildRequires: libpng-devel >= 1.2.17
ea721d92 74BuildRequires: libstdc++-devel
82f606de 75BuildRequires: nspr-devel >= 1:4.8.6
23618660 76BuildRequires: nss-devel >= 1:3.12.8
82f606de 77BuildRequires: pango-devel >= 1:1.14.0
56cf7ebf 78BuildRequires: perl-modules >= 5.004
1bb00684 79BuildRequires: pkgconfig
aef94f18 80BuildRequires: python-modules
6b1581cf 81BuildRequires: rpm >= 4.4.9-56
2a673919 82BuildRequires: rpmbuild(macros) >= 1.453
82f606de 83BuildRequires: sqlite3-devel >= 3.7.2
d97ddc70 84BuildRequires: startup-notification-devel >= 0.8
446ffaab
JB
85BuildRequires: xorg-lib-libXext-devel
86BuildRequires: xorg-lib-libXft-devel >= 2.1
87BuildRequires: xorg-lib-libXinerama-devel
88BuildRequires: xorg-lib-libXp-devel
de5abc0a 89BuildRequires: xorg-lib-libXt-devel
f99152f1 90%if %{with xulrunner}
d97ddc70 91BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
f99152f1 92%endif
b0a3aa79 93BuildRequires: zip
1dd3785b 94BuildRequires: zlib-devel >= 1.2.3
f37c2ce5 95Requires(post): mktemp >= 1.5-18
d97ddc70
JB
96%if %{with xulrunner}
97%requires_eq_to xulrunner xulrunner-devel
98%else
1408fb17 99Requires: browser-plugins >= 2.0
82f606de
JB
100Requires: cairo >= 1.8.8
101Requires: dbus-glib >= 0.60
d97ddc70 102Requires: gtk+2 >= 2:2.18
2a673919 103Requires: libpng(APNG) >= 0.10
d97ddc70 104Requires: myspell-common
82f606de 105Requires: nspr >= 1:4.8.6
23618660 106Requires: nss >= 1:3.12.8
82f606de 107Requires: pango >= 1:1.14.0
d97ddc70 108Requires: sqlite3 >= %{sqlite_build_version}
82f606de 109Requires: startup-notification >= 0.8
f99152f1 110%endif
0d52cac8 111Provides: wwwbrowser
51c0f20a 112Obsoletes: mozilla-firebird
2620301e 113Obsoletes: mozilla-firefox-lang-en < 2.0.0.8-3
c2814220 114Obsoletes: mozilla-firefox-libs
ea721d92 115BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
09328230
JB
117# don't satisfy other packages (don't use %{name} here)
118%define _noautoprovfiles %{_libdir}/mozilla-firefox
4c7e703c 119# and as we don't provide them, don't require either
e1d8b3ef 120%define _noautoreq libmozjs.so libxpcom.so libxul.so libjemalloc.so
c14d6140 121
2a673919 122%if "%{cc_version}" >= "3.4"
2de50ddb 123%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
2a673919
PZ
124%else
125%define specflags -fno-strict-aliasing
126%endif
d3b02e37 127
ea721d92 128%description
52dbdf60
ER
129Firefox Community Edition is an open-source web browser, designed for
130standards compliance, performance and portability.
ea721d92 131
eace6cdf 132%description -l pl.UTF-8
c0bec9dd 133Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
e236f127 134zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
135o zgodności ze standardami, wydajnością i przenośnością.
ea721d92 136
137%prep
d97ddc70
JB
138%setup -qc
139mv -f mozilla-%{xulrunner_main} mozilla
56143477 140cd mozilla
d97ddc70 141
d541162e 142%patch0 -p1
6ef56845 143
144%if "%{cc_version}" < "3.4"
145%patch1 -p2
146%endif
147
148%if "%{pld_release}" == "th"
8bc15110 149%patch2 -p1
2a673919 150%endif
6ef56845 151
152%if "%{pld_release}" == "ac"
153%patch3 -p1
154%endif
155
156%if "%{pld_release}" == "ti"
157%patch4 -p1
6b1581cf 158%endif
a4a42caf 159
29b16068 160%patch5 -p1
161%patch6 -p1
d1eea1c3 162%patch7 -p1
d97ddc70
JB
163%patch8 -p2
164%patch9 -p0
29b16068 165
ea721d92 166%build
56143477 167cd mozilla
52befddb 168cp -f %{_datadir}/automake/config.* build/autoconf
52befddb 169
d97ddc70
JB
170cat << EOF > .mozconfig
171. \$topsrcdir/browser/config/mozconfig
52befddb 172
2620301e 173mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
2620301e 174
f37c2ce5 175# Options for 'configure' (same as command-line options).
52befddb 176ac_add_options --prefix=%{_prefix}
177ac_add_options --exec-prefix=%{_exec_prefix}
178ac_add_options --bindir=%{_bindir}
179ac_add_options --sbindir=%{_sbindir}
180ac_add_options --sysconfdir=%{_sysconfdir}
181ac_add_options --datadir=%{_datadir}
182ac_add_options --includedir=%{_includedir}
183ac_add_options --libdir=%{_libdir}
184ac_add_options --libexecdir=%{_libexecdir}
185ac_add_options --localstatedir=%{_localstatedir}
186ac_add_options --sharedstatedir=%{_sharedstatedir}
187ac_add_options --mandir=%{_mandir}
188ac_add_options --infodir=%{_infodir}
cf471ce5 189%if %{?debug:1}0
f37c2ce5 190ac_add_options --disable-optimize
52befddb 191ac_add_options --enable-debug
192ac_add_options --enable-debug-modules
f37c2ce5
ER
193ac_add_options --enable-debugger-info-modules
194ac_add_options --enable-crash-on-assert
52befddb 195%else
196ac_add_options --disable-debug
2620301e 197ac_add_options --disable-debug-modules
f37c2ce5 198ac_add_options --disable-logging
2a673919 199ac_add_options --enable-optimize="%{rpmcflags} -Os"
52befddb 200%endif
d97ddc70
JB
201ac_add_options --disable-strip
202ac_add_options --disable-strip-libs
52befddb 203%if %{with tests}
204ac_add_options --enable-tests
c4f9bb37 205%else
52befddb 206ac_add_options --disable-tests
c4f9bb37 207%endif
6800f9e1 208%if %{with gnomeui}
f37c2ce5
ER
209ac_add_options --enable-gnomeui
210%else
f37c2ce5
ER
211ac_add_options --disable-gnomeui
212%endif
6800f9e1
JB
213%if %{with gnomevfs}
214ac_add_options --enable-gnomevfs
215%else
216ac_add_options --disable-gnomevfs
217%endif
2a673919 218ac_add_options --disable-crashreporter
52befddb 219ac_add_options --disable-installer
f37c2ce5
ER
220ac_add_options --disable-javaxpcom
221ac_add_options --disable-updater
2a673919 222ac_add_options --disable-xprint
d97ddc70
JB
223ac_add_options --enable-canvas
224ac_add_options --enable-libxul
225ac_add_options --enable-pango
2a673919 226ac_add_options --enable-startup-notification
164d575d 227ac_add_options --enable-svg
52befddb 228ac_add_options --enable-system-cairo
d97ddc70 229ac_add_options --enable-system-hunspell
dfdf0ac8 230ac_add_options --enable-system-sqlite
2a673919 231ac_add_options --enable-xinerama
f37c2ce5 232ac_add_options --with-distribution-id=org.pld-linux
f99152f1 233%if %{with xulrunner}
d97ddc70 234ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f99152f1 235%endif
2a673919 236ac_add_options --with-pthreads
d97ddc70 237ac_add_options --with-system-bz2
2620301e 238ac_add_options --with-system-jpeg
52befddb 239ac_add_options --with-system-nspr
f37c2ce5 240ac_add_options --with-system-nss
f37c2ce5 241ac_add_options --with-system-png
2620301e 242ac_add_options --with-system-zlib
6162f349 243ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
52befddb 244EOF
33f81726 245
1698621e 246%{__make} -j1 -f client.mk build \
2a673919 247 STRIP="/bin/true" \
3d445135 248 CC="%{__cc}" \
33f81726 249 CXX="%{__cxx}"
ea721d92 250
251%install
252rm -rf $RPM_BUILD_ROOT
56143477 253cd mozilla
45f27404 254install -d \
f37c2ce5 255 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
45f27404 256 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
93639547 257 $RPM_BUILD_ROOT%{_datadir}/%{name}
75e09104 258
8bc15110
PZ
259%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
260
2a673919 261%{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
d541162e 262 DESTDIR=$RPM_BUILD_ROOT \
6162f349 263 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
f37c2ce5 264 PKG_SKIP_STRIP=1
ea721d92 265
d97ddc70
JB
266install -d \
267 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
268
f86547d4
ER
269# move arch independant ones to datadir
270mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
271mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
f86547d4 272mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
f86547d4 273mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
2a673919 274mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
f86547d4 275mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
82f606de 276mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browserconfig.properties $RPM_BUILD_ROOT%{_datadir}/%{name}
f99152f1 277%if %{without xulrunner}
278mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
279mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
280%endif
d97ddc70 281
f86547d4
ER
282ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
283ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
f86547d4 284ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
2a673919 285ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
f86547d4 286ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
f86547d4 287ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
82f606de 288ln -s ../../share/%{name}/browserconfig.properties $RPM_BUILD_ROOT%{_libdir}/%{name}
f99152f1 289%if %{without xulrunner}
290ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
291ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
292%endif
f86547d4 293
f99152f1 294%if %{without xulrunner}
ade6d95c 295rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
4d687af8 296ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
f99152f1 297%endif
4d687af8 298
7c7475d0 299sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
82f606de 300chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
8bc15110 301ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
ea721d92 302
d97ddc70
JB
303cp -a browser/branding/unofficial/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
304cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
ea721d92 305
d97ddc70 306# files created by firefox -register
6162f349
ER
307touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
308touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
f37c2ce5 309
d97ddc70
JB
310%if %{with xulrunner}
311rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
312%endif
313rm $RPM_BUILD_ROOT%{_libdir}/%{name}/LICENSE
314rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
315rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
f86547d4 316
f37c2ce5 317cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
6d77929c 318#!/bin/sh
050f03d2 319umask 022
6162f349 320rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
3eeab518 321
f37c2ce5
ER
322# it attempts to touch files in $HOME/.mozilla
323# beware if you run this with sudo!!!
324export HOME=$(mktemp -d)
325# also TMPDIR could be pointing to sudo user's homedir
326unset TMPDIR TMP || :
3eeab518 327
6162f349 328%{_libdir}/%{name}/firefox -register
3eeab518 329
56143477 330rm -rf $HOME
6d77929c 331EOF
82f606de 332chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
3eeab518 333
6d77929c
JB
334%clean
335rm -rf $RPM_BUILD_ROOT
3eeab518 336
b1662829 337%pretrans
ade6d95c
ER
338if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
339 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
340fi
2a673919 341for d in chrome defaults extensions greprefs icons res searchplugins; do
f86547d4
ER
342 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
343 install -d %{_datadir}/%{name}
344 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
345 fi
346done
347exit 0
348
6d77929c 349%post
f37c2ce5 350%{_sbindir}/%{name}-chrome+xpcom-generate
4d9eecad
ER
351%update_browser_plugins
352
353%postun
354if [ "$1" = 0 ]; then
355 %update_browser_plugins
356fi
ea0245e6 357
ea721d92 358%files
359%defattr(644,root,root,755)
f37c2ce5 360%attr(755,root,root) %{_bindir}/%{name}
fb0d8197 361%attr(755,root,root) %{_bindir}/firefox
f37c2ce5
ER
362%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
363
4d9eecad
ER
364# browser plugins v2
365%{_browserpluginsconfdir}/browsers.d/%{name}.*
366%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
367
c2814220 368%dir %{_libdir}/%{name}
09328230
JB
369%if %{without xulrunner}
370%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
371%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
372%attr(755,root,root) %{_libdir}/%{name}/libxul.so
373%endif
2a673919
PZ
374%{_libdir}/%{name}/blocklist.xml
375
376%if %{with crashreporter}
377%{_libdir}/%{name}/crashreporter
378%{_libdir}/%{name}/crashreporter-override.ini
379%{_libdir}/%{name}/crashreporter.ini
380%{_libdir}/%{name}/Throbber-small.gif
381%endif
382
383# config?
384%{_libdir}/%{name}/.autoreg
385%{_libdir}/%{name}/application.ini
c2814220 386
6162f349 387%dir %{_libdir}/%{name}/components
2a673919 388
fd4f0696 389%{_libdir}/%{name}/components/FeedConverter.js
fd4f0696 390%{_libdir}/%{name}/components/FeedWriter.js
2a673919
PZ
391%{_libdir}/%{name}/components/WebContentConverter.js
392%{_libdir}/%{name}/components/browser.xpt
393%{_libdir}/%{name}/components/fuelApplication.js
f99152f1 394%{_libdir}/%{name}/components/nsBrowserContentHandler.js
395%{_libdir}/%{name}/components/nsBrowserGlue.js
396%{_libdir}/%{name}/components/nsMicrosummaryService.js
397%{_libdir}/%{name}/components/nsPlacesTransactionsService.js
d97ddc70 398%{_libdir}/%{name}/components/nsPrivateBrowsingService.js
f99152f1 399%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
f99152f1 400%{_libdir}/%{name}/components/nsSessionStartup.js
401%{_libdir}/%{name}/components/nsSessionStore.js
402%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
403%{_libdir}/%{name}/components/nsSidebar.js
404%if %{without xulrunner}
405%{_libdir}/%{name}/platform.ini
406%{_libdir}/%{name}/components/FeedProcessor.js
d97ddc70
JB
407%{_libdir}/%{name}/components/GPSDGeolocationProvider.js
408%{_libdir}/%{name}/components/NetworkGeolocationProvider.js
fd4f0696 409%{_libdir}/%{name}/components/jsconsole-clhandler.js
2a673919 410%{_libdir}/%{name}/components/nsAddonRepository.js
5259c459 411%{_libdir}/%{name}/components/nsBadCertHandler.js
2a673919 412%{_libdir}/%{name}/components/nsBlocklistService.js
2a673919
PZ
413%{_libdir}/%{name}/components/nsContentDispatchChooser.js
414%{_libdir}/%{name}/components/nsContentPrefService.js
fd4f0696 415%{_libdir}/%{name}/components/nsDefaultCLH.js
2a673919 416%{_libdir}/%{name}/components/nsDownloadManagerUI.js
fd4f0696
ER
417%{_libdir}/%{name}/components/nsExtensionManager.js
418%{_libdir}/%{name}/components/nsFilePicker.js
d97ddc70 419%{_libdir}/%{name}/components/nsFormAutoComplete.js
2a673919 420%{_libdir}/%{name}/components/nsHandlerService.js
fd4f0696 421%{_libdir}/%{name}/components/nsHelperAppDlg.js
82f606de 422%{_libdir}/%{name}/components/nsINIProcessor.js
2a673919
PZ
423%{_libdir}/%{name}/components/nsLivemarkService.js
424%{_libdir}/%{name}/components/nsLoginInfo.js
425%{_libdir}/%{name}/components/nsLoginManager.js
426%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
d97ddc70
JB
427%{_libdir}/%{name}/components/nsPlacesAutoComplete.js
428%{_libdir}/%{name}/components/nsPlacesDBFlush.js
fd4f0696 429%{_libdir}/%{name}/components/nsProxyAutoConfig.js
d97ddc70
JB
430%{_libdir}/%{name}/components/nsSearchService.js
431%{_libdir}/%{name}/components/nsSearchSuggestions.js
2a673919
PZ
432%{_libdir}/%{name}/components/nsTaggingService.js
433%{_libdir}/%{name}/components/nsTryToClose.js
434%{_libdir}/%{name}/components/nsURLFormatter.js
d97ddc70 435%{_libdir}/%{name}/components/nsUpdateTimerManager.js
fd4f0696
ER
436%{_libdir}/%{name}/components/nsUrlClassifierLib.js
437%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
2a673919
PZ
438%{_libdir}/%{name}/components/nsWebHandlerApp.js
439%{_libdir}/%{name}/components/pluginGlue.js
440%{_libdir}/%{name}/components/storage-Legacy.js
d97ddc70 441%{_libdir}/%{name}/components/storage-mozStorage.js
2a673919 442%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
f99152f1 443%endif
2a673919
PZ
444
445%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
446%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
f99152f1 447%if %{without xulrunner}
2a673919
PZ
448%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
449%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
f99152f1 450%endif
2a673919 451
82f606de 452%if %{with gnomevfs} && %{without xulrunner}
2a673919
PZ
453%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
454%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
455%endif
456
2a673919 457%attr(755,root,root) %{_libdir}/%{name}/firefox
d97ddc70 458%dir %{_libdir}/%{name}/plugins
f99152f1 459%if %{without xulrunner}
d97ddc70 460%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
2a673919 461%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
f99152f1 462%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
463%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
82f606de 464%attr(755,root,root) %{_libdir}/%{name}/plugin-container
f99152f1 465%endif
93639547
ER
466%{_pixmapsdir}/mozilla-firefox.png
467%{_desktopdir}/mozilla-firefox.desktop
cdbdbff1 468
f86547d4
ER
469# symlinks
470%{_libdir}/%{name}/chrome
471%{_libdir}/%{name}/defaults
f86547d4 472%{_libdir}/%{name}/extensions
f86547d4 473%{_libdir}/%{name}/icons
2a673919 474%{_libdir}/%{name}/modules
f86547d4 475%{_libdir}/%{name}/searchplugins
82f606de 476%{_libdir}/%{name}/browserconfig.properties
f99152f1 477%if %{without xulrunner}
478%{_libdir}/%{name}/dictionaries
479%{_libdir}/%{name}/greprefs
480%{_libdir}/%{name}/res
481%endif
f37c2ce5 482
f86547d4
ER
483%dir %{_datadir}/%{name}
484%{_datadir}/%{name}/chrome
485%{_datadir}/%{name}/defaults
f86547d4 486%{_datadir}/%{name}/icons
2a673919 487%{_datadir}/%{name}/modules
f86547d4 488%{_datadir}/%{name}/searchplugins
82f606de 489%{_datadir}/%{name}/browserconfig.properties
f99152f1 490%if %{without xulrunner}
491%{_datadir}/%{name}/greprefs
492%{_datadir}/%{name}/res
493%endif
f86547d4
ER
494
495%dir %{_datadir}/%{name}/extensions
496# -dom-inspector subpackage?
2a673919 497#%{_datadir}/%{name}/extensions/inspector@mozilla.org
f86547d4
ER
498# the signature of the default theme
499%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
f37c2ce5 500
d97ddc70 501# files created by firefox -register
6162f349
ER
502%ghost %{_libdir}/%{name}/components/compreg.dat
503%ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.156219 seconds and 4 git commands to generate.