]> git.pld-linux.org Git - packages/firefox.git/blame - mozilla-firefox.spec
- unified bconds (separate gnomeui/gnomevfs + gnome alias for convenience)
[packages/firefox.git] / mozilla-firefox.spec
CommitLineData
0d00fa1b
AM
1# TODO:
2# - handle locales differently (runtime, since it's possible to do)
3# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
f37c2ce5
ER
4# for hints how to make locales
5# - make it more pld-like (bookmarks, default page etc..)
2f695f11 6#
ca6a7239 7# Conditional build:
4ab16c9e
JB
8%bcond_with tests # enable tests (whatever they check)
9%bcond_without gnomeui # disable gnomeui support
10%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
12%bcond_with tidy # enable htmlvalidator extension (tidy)
5bc92bd8 13#
4ab16c9e
JB
14%if %{without gnome}
15%undefine with_gnomeui
16%undefine with_gnomevfs
17%endif
d4b72ea5 18%define tidy_ver 0.8.4.0
6ea8125b 19%define firefox_ver 2.0.0.6
c4f9bb37 20#
52dbdf60 21Summary: Firefox Community Edition web browser
948d1385 22Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
ea721d92 23Name: mozilla-firefox
bdf95a39 24Version: %{firefox_ver}
a366503f 25Release: 1
4ab16c9e 26License: MPL 1.1 or GPL v2+ or LGPL v2.1+
51c0f20a 27Group: X11/Applications/Networking
8359e4e0 28Source0: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
6ea8125b 29# Source0-md5: 16fb252fb7b0371894f7101b88fd9076
5bc92bd8 30Source1: http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
d4b72ea5 31# Source1-md5: cd5d54c47f08286605eaaa308536d4ab
5bc92bd8
ER
32Source2: %{name}.desktop
33Source3: %{name}.sh
d541162e 34Patch0: mozilla-install.patch
52befddb 35Patch1: %{name}-lib_path.patch
5bc92bd8 36Patch2: %{name}-addon-tidy.patch
52befddb 37Patch3: %{name}-nopangoxft.patch
52befddb 38Patch5: %{name}-fonts.patch
0ff56a51 39Patch6: %{name}-agent.patch
4d687af8 40Patch7: %{name}-myspell.patch
f37c2ce5
ER
41# if ac rebuild is needed...
42#PatchX: %{name}-ac.patch
5f561b4c 43URL: http://www.mozilla.org/projects/firefox/
4ab16c9e 44%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
e933d2a8 45BuildRequires: automake
56cf7ebf 46BuildRequires: cairo-devel >= 1.0.0
4ab16c9e 47%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
af914259 48BuildRequires: gtk+2-devel >= 1:2.0.0
809fe433 49BuildRequires: krb5-devel
8a88dcf7 50BuildRequires: libIDL-devel >= 0.8.0
4ab16c9e
JB
51%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
52%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
ea721d92 53BuildRequires: libjpeg-devel >= 6b
1dd3785b 54BuildRequires: libpng-devel >= 1.2.7
ea721d92 55BuildRequires: libstdc++-devel
4d687af8 56BuildRequires: myspell-devel
f37c2ce5
ER
57BuildRequires: nspr-devel >= 1:4.6.3
58BuildRequires: nss-devel >= 1:3.11.3-3
f0ef075d 59%{?with_tidy:BuildRequires: opensp-devel >= 2:1.5.2-4}
56cf7ebf 60BuildRequires: pango-devel >= 1:1.6.0
61BuildRequires: perl-modules >= 5.004
1bb00684 62BuildRequires: pkgconfig
4d9eecad 63BuildRequires: rpmbuild(macros) >= 1.356
446ffaab
JB
64BuildRequires: xorg-lib-libXext-devel
65BuildRequires: xorg-lib-libXft-devel >= 2.1
66BuildRequires: xorg-lib-libXinerama-devel
67BuildRequires: xorg-lib-libXp-devel
de5abc0a 68BuildRequires: xorg-lib-libXt-devel
b0a3aa79 69BuildRequires: zip
1dd3785b 70BuildRequires: zlib-devel >= 1.2.3
f37c2ce5 71Requires(post): mktemp >= 1.5-18
ca6a7239 72Requires: %{name}-lang-resources = %{version}
f37c2ce5 73Requires: %{name}-libs = %{epoch}:%{version}-%{release}
1408fb17 74Requires: browser-plugins >= 2.0
f37c2ce5 75Requires: nspr >= 1:4.6.3
1a285f98 76Requires: nss >= 1:3.11.3
0d52cac8 77Provides: wwwbrowser
51c0f20a 78Obsoletes: mozilla-firebird
ea721d92 79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
34dd92dd
JB
81# firefox/thunderbird/seamonkey provide their own versions
82%define _noautoreqdep libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
6162f349 83%define _noautoprovfiles %{_libdir}/%{name}/components
4c7e703c 84# we don't want these to satisfy xulrunner-devel
626daa28 85%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
4c7e703c 86# and as we don't provide them, don't require either
626daa28 87%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
c14d6140 88
2de50ddb 89%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
d3b02e37 90
ea721d92 91%description
52dbdf60
ER
92Firefox Community Edition is an open-source web browser, designed for
93standards compliance, performance and portability.
ea721d92 94
eace6cdf 95%description -l pl.UTF-8
c0bec9dd 96Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
e236f127 97zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
98o zgodności ze standardami, wydajnością i przenośnością.
ea721d92 99
f37c2ce5 100%package libs
52dbdf60 101Summary: Firefox Community Edition shared libraries
948d1385 102Summary(pl.UTF-8): Biblioteki współdzielone przeglądarki Firefox Community Edition
f37c2ce5 103Group: Libraries
7c40e3fe 104Conflicts: mozilla-firefox < 2.0-1.4
f37c2ce5
ER
105
106%description libs
52dbdf60 107Firefox Community Edition shared libraries.
f37c2ce5 108
eace6cdf
JR
109%description libs -l pl.UTF-8
110Biblioteki współdzielone przeglądarki Firefox Community Edition.
7c40e3fe 111
a42140da
JB
112%package addon-tidy
113Summary: HTML Validator for Firefox
114Summary(pl.UTF-8): Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
115Version: %{tidy_ver}
116License: GPL
117Group: X11/Applications/Networking
118Requires: %{name} = %{firefox_ver}-%{release}
119
120%description addon-tidy
121HTML Validator is a Mozilla extension that adds HTML validation inside
122Firefox. The number of errors of a HTML page is seen on the form of an
123icon in the status bar when browsing.
124
125%description addon-tidy -l pl.UTF-8
126HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
127poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
128HTML można zobaczyć w postaci ikony na pasku stanu.
129
f99898d5 130%package lang-en
131Summary: English resources for Firefox Community Edition
132Summary(pl.UTF-8): Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
bdf95a39 133Version: %{firefox_ver}
f99898d5 134Group: X11/Applications/Networking
d9e6d0b1 135Requires: %{name} = %{firefox_ver}-%{release}
bdf95a39 136Provides: %{name}-lang-resources = %{firefox_ver}-%{release}
f99898d5 137
138%description lang-en
139English resources for Firefox Community Edition.
140
141%description lang-en -l pl.UTF-8
142Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
143
ea721d92 144%prep
5bc92bd8
ER
145%setup -qc %{?with_tidy:-a1}
146%if %{with tidy}
147mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
148mv mozilla_tidy_source/tidy_extension .
149rm -rf mozilla/extensions/tidy/opensp
150%endif
56143477 151cd mozilla
d541162e 152%patch0 -p1
52befddb 153%patch1 -p1
e214dcc1 154%{?with_tidy:%patch2 -p1}
52befddb 155%patch3 -p1
52befddb 156%patch5 -p1
0ff56a51 157%patch6 -p1
4d687af8 158%patch7 -p1
a4a42caf 159
f37c2ce5
ER
160# use system
161#rm -rf mozilla/nsprpub mozilla/security/nss
162
ea721d92 163%build
56143477 164cd mozilla
f37c2ce5
ER
165export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
166export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
52befddb 167
168cp -f %{_datadir}/automake/config.* build/autoconf
169cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
170cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
171
52befddb 172cat << 'EOF' > .mozconfig
173. $topsrcdir/browser/config/mozconfig
174
f37c2ce5 175# Options for 'configure' (same as command-line options).
52befddb 176ac_add_options --prefix=%{_prefix}
177ac_add_options --exec-prefix=%{_exec_prefix}
178ac_add_options --bindir=%{_bindir}
179ac_add_options --sbindir=%{_sbindir}
180ac_add_options --sysconfdir=%{_sysconfdir}
181ac_add_options --datadir=%{_datadir}
182ac_add_options --includedir=%{_includedir}
183ac_add_options --libdir=%{_libdir}
184ac_add_options --libexecdir=%{_libexecdir}
185ac_add_options --localstatedir=%{_localstatedir}
186ac_add_options --sharedstatedir=%{_sharedstatedir}
187ac_add_options --mandir=%{_mandir}
188ac_add_options --infodir=%{_infodir}
cf471ce5 189%if %{?debug:1}0
f37c2ce5 190ac_add_options --disable-optimize
52befddb 191ac_add_options --enable-debug
192ac_add_options --enable-debug-modules
f37c2ce5
ER
193ac_add_options --enable-debugger-info-modules
194ac_add_options --enable-crash-on-assert
52befddb 195%else
196ac_add_options --disable-debug
f37c2ce5
ER
197ac_add_options --disable-logging
198ac_add_options --enable-optimize="%{rpmcflags}"
52befddb 199%endif
200%if %{with tests}
201ac_add_options --enable-tests
c4f9bb37 202%else
52befddb 203ac_add_options --disable-tests
c4f9bb37 204%endif
f37c2ce5
ER
205%if %{with gnome}
206ac_add_options --enable-gnomevfs
207ac_add_options --enable-gnomeui
208%else
209ac_add_options --disable-gnomevfs
210ac_add_options --disable-gnomeui
211%endif
52befddb 212ac_add_options --disable-freetype2
213ac_add_options --disable-installer
f37c2ce5
ER
214ac_add_options --disable-javaxpcom
215ac_add_options --disable-updater
52befddb 216ac_add_options --enable-default-toolkit=gtk2
164d575d 217ac_add_options --enable-svg
52befddb 218ac_add_options --enable-system-cairo
4d687af8 219ac_add_options --enable-system-myspell
52befddb 220ac_add_options --enable-xft
f37c2ce5 221ac_add_options --with-distribution-id=org.pld-linux
52befddb 222ac_add_options --with-system-nspr
f37c2ce5 223ac_add_options --with-system-nss
52befddb 224ac_add_options --with-system-zlib
f37c2ce5
ER
225ac_add_options --with-system-jpeg
226ac_add_options --with-system-png
6162f349 227ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
52befddb 228ac_cv_visibility_pragma=no
229EOF
33f81726 230
1698621e 231%{__make} -j1 -f client.mk build \
3d445135 232 CC="%{__cc}" \
33f81726 233 CXX="%{__cxx}"
ea721d92 234
235%install
236rm -rf $RPM_BUILD_ROOT
56143477 237cd mozilla
45f27404 238install -d \
f37c2ce5 239 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
45f27404 240 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
93639547 241 $RPM_BUILD_ROOT%{_datadir}/%{name}
75e09104 242
6162f349 243%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
4d9eecad 244
f37c2ce5 245%{__make} -C xpinstall/packager stage-package \
d541162e 246 DESTDIR=$RPM_BUILD_ROOT \
6162f349 247 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
f37c2ce5 248 PKG_SKIP_STRIP=1
ea721d92 249
f86547d4
ER
250# move arch independant ones to datadir
251mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
252mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
f86547d4
ER
253mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
254mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
255mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
256mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
257mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
258mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
259ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
260ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
f86547d4
ER
261ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
262ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
263ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
264ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
265ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
266ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
267
ade6d95c 268rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
4d687af8
ER
269ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
270
5bc92bd8 271sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
f37c2ce5 272ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
ea721d92 273
f37c2ce5 274install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
ea721d92 275
5bc92bd8 276install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
ea721d92 277
7c40e3fe 278# header/development files
93639547
ER
279rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
280rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
281rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
75e09104 282
f37c2ce5 283# files created by regxpcom and firefox -register
6162f349
ER
284touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
285touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
f37c2ce5 286
f86547d4
ER
287# what's this? it's content is invalid anyway.
288rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
a42140da 289rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
f86547d4 290
f37c2ce5 291cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
6d77929c 292#!/bin/sh
050f03d2 293umask 022
6162f349 294rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
3eeab518 295
f37c2ce5
ER
296# it attempts to touch files in $HOME/.mozilla
297# beware if you run this with sudo!!!
298export HOME=$(mktemp -d)
299# also TMPDIR could be pointing to sudo user's homedir
300unset TMPDIR TMP || :
3eeab518 301
6162f349
ER
302LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
303%{_libdir}/%{name}/firefox -register
3eeab518 304
56143477 305rm -rf $HOME
6d77929c 306EOF
3eeab518 307
6d77929c
JB
308%clean
309rm -rf $RPM_BUILD_ROOT
3eeab518 310
b1662829 311%pretrans
ade6d95c
ER
312if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
313 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
314fi
4d687af8 315for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
f86547d4
ER
316 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
317 install -d %{_datadir}/%{name}
318 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
319 fi
320done
321exit 0
322
6d77929c 323%post
f37c2ce5 324%{_sbindir}/%{name}-chrome+xpcom-generate
4d9eecad
ER
325%update_browser_plugins
326
327%postun
328if [ "$1" = 0 ]; then
329 %update_browser_plugins
330fi
ea0245e6 331
ea721d92 332%files
333%defattr(644,root,root,755)
f37c2ce5 334%attr(755,root,root) %{_bindir}/%{name}
fb0d8197 335%attr(755,root,root) %{_bindir}/firefox
f37c2ce5
ER
336%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
337
4d9eecad
ER
338# browser plugins v2
339%{_browserpluginsconfdir}/browsers.d/%{name}.*
340%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
341
6162f349 342%dir %{_libdir}/%{name}/components
fd4f0696
ER
343%attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
344%attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
345%attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
346%attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
347%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
348%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
349%attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
350%attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
351%attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
352%attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
353%attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
354%attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
355%attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
356%attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
357%attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
358%attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
359%attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
360%attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
361%attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
362%attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
363%attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
4ab16c9e 364%{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
fd4f0696
ER
365%attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
366%attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
367%attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
368%attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
369%attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
4ab16c9e 370%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
fd4f0696
ER
371%attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
372%attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
373%attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
4ab16c9e 374%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
fd4f0696
ER
375%attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
376%attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
377%attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
378%attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
379%attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
380%attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
381%attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
382%attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
383%attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
384%attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
385%attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
386%attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
387%attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
388%attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
389%attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
390%attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
391%attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
392%attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
393%attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
394%attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
395%attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
396%attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
397%attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
398%attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
399%attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
400%attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
fd4f0696
ER
401%{_libdir}/%{name}/components/accessibility-atk.xpt
402%{_libdir}/%{name}/components/accessibility.xpt
403%{_libdir}/%{name}/components/alerts.xpt
404%{_libdir}/%{name}/components/appshell.xpt
405%{_libdir}/%{name}/components/appstartup.xpt
406%{_libdir}/%{name}/components/autocomplete.xpt
407%{_libdir}/%{name}/components/autoconfig.xpt
408%{_libdir}/%{name}/components/bookmarks.xpt
409%{_libdir}/%{name}/components/browsercompsbase.xpt
410%{_libdir}/%{name}/components/browser-feeds.xpt
411%{_libdir}/%{name}/components/browsersearch.xpt
412%{_libdir}/%{name}/components/caps.xpt
413%{_libdir}/%{name}/components/chardet.xpt
414%{_libdir}/%{name}/components/chrome.xpt
415%{_libdir}/%{name}/components/commandhandler.xpt
416%{_libdir}/%{name}/components/commandlines.xpt
417%{_libdir}/%{name}/components/composer.xpt
418%{_libdir}/%{name}/components/content_base.xpt
419%{_libdir}/%{name}/components/content_htmldoc.xpt
420%{_libdir}/%{name}/components/content_html.xpt
421%{_libdir}/%{name}/components/content_xmldoc.xpt
422%{_libdir}/%{name}/components/content_xslt.xpt
423%{_libdir}/%{name}/components/content_xtf.xpt
424%{_libdir}/%{name}/components/cookie.xpt
425%{_libdir}/%{name}/components/directory.xpt
426%{_libdir}/%{name}/components/docshell.xpt
427%{_libdir}/%{name}/components/dom_base.xpt
428%{_libdir}/%{name}/components/dom_canvas.xpt
429%{_libdir}/%{name}/components/dom_core.xpt
430%{_libdir}/%{name}/components/dom_css.xpt
431%{_libdir}/%{name}/components/dom_events.xpt
432%{_libdir}/%{name}/components/dom_html.xpt
433%{_libdir}/%{name}/components/dom_loadsave.xpt
434%{_libdir}/%{name}/components/dom_range.xpt
435%{_libdir}/%{name}/components/dom_sidebar.xpt
436%{_libdir}/%{name}/components/dom_storage.xpt
437%{_libdir}/%{name}/components/dom_stylesheets.xpt
438%{_libdir}/%{name}/components/dom_svg.xpt
439%{_libdir}/%{name}/components/dom_traversal.xpt
440%{_libdir}/%{name}/components/dom_views.xpt
441%{_libdir}/%{name}/components/dom_xbl.xpt
442%{_libdir}/%{name}/components/dom_xpath.xpt
443%{_libdir}/%{name}/components/dom.xpt
444%{_libdir}/%{name}/components/dom_xul.xpt
445%{_libdir}/%{name}/components/downloads.xpt
446%{_libdir}/%{name}/components/editor.xpt
447%{_libdir}/%{name}/components/embed_base.xpt
448%{_libdir}/%{name}/components/extensions.xpt
449%{_libdir}/%{name}/components/exthandler.xpt
450%{_libdir}/%{name}/components/fastfind.xpt
451%{_libdir}/%{name}/components/FeedConverter.js
452%{_libdir}/%{name}/components/FeedProcessor.js
453%{_libdir}/%{name}/components/feeds.xpt
454%{_libdir}/%{name}/components/FeedWriter.js
455%{_libdir}/%{name}/components/filepicker.xpt
456%{_libdir}/%{name}/components/find.xpt
457%{_libdir}/%{name}/components/gfx.xpt
458%{_libdir}/%{name}/components/gksvgrenderer.xpt
459%{_libdir}/%{name}/components/history.xpt
460%{_libdir}/%{name}/components/htmlparser.xpt
4ab16c9e 461%{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
fd4f0696
ER
462%{_libdir}/%{name}/components/imglib2.xpt
463%{_libdir}/%{name}/components/inspector.xpt
464%{_libdir}/%{name}/components/intl.xpt
465%{_libdir}/%{name}/components/jar.xpt
466%{_libdir}/%{name}/components/jsconsole-clhandler.js
467%{_libdir}/%{name}/components/jsconsole.xpt
468%{_libdir}/%{name}/components/jsdservice.xpt
469%{_libdir}/%{name}/components/layout_base.xpt
470%{_libdir}/%{name}/components/layout_printing.xpt
471%{_libdir}/%{name}/components/layout_xul_tree.xpt
472%{_libdir}/%{name}/components/layout_xul.xpt
473%{_libdir}/%{name}/components/locale.xpt
474%{_libdir}/%{name}/components/lwbrk.xpt
475%{_libdir}/%{name}/components/microsummaries.xpt
476%{_libdir}/%{name}/components/migration.xpt
477%{_libdir}/%{name}/components/mimetype.xpt
478%{_libdir}/%{name}/components/mozbrwsr.xpt
479%{_libdir}/%{name}/components/mozfind.xpt
480%{_libdir}/%{name}/components/mozgnome.xpt
481%{_libdir}/%{name}/components/necko_about.xpt
482%{_libdir}/%{name}/components/necko_cache.xpt
483%{_libdir}/%{name}/components/necko_cookie.xpt
484%{_libdir}/%{name}/components/necko_data.xpt
485%{_libdir}/%{name}/components/necko_dns.xpt
486%{_libdir}/%{name}/components/necko_file.xpt
487%{_libdir}/%{name}/components/necko_ftp.xpt
488%{_libdir}/%{name}/components/necko_http.xpt
489%{_libdir}/%{name}/components/necko_res.xpt
490%{_libdir}/%{name}/components/necko_socket.xpt
491%{_libdir}/%{name}/components/necko_strconv.xpt
492%{_libdir}/%{name}/components/necko_viewsource.xpt
493%{_libdir}/%{name}/components/necko.xpt
494%{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
495%{_libdir}/%{name}/components/nsBrowserContentHandler.js
496%{_libdir}/%{name}/components/nsBrowserGlue.js
497%{_libdir}/%{name}/components/nsCloseAllWindows.js
498%{_libdir}/%{name}/components/nsDefaultCLH.js
499%{_libdir}/%{name}/components/nsDictionary.js
500%{_libdir}/%{name}/components/nsExtensionManager.js
501%{_libdir}/%{name}/components/nsFilePicker.js
502%{_libdir}/%{name}/components/nsHelperAppDlg.js
503%{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
504%{_libdir}/%{name}/components/nsKillAll.js
505%{_libdir}/%{name}/components/nsMicrosummaryService.js
506%{_libdir}/%{name}/components/nsProgressDialog.js
507%{_libdir}/%{name}/components/nsProxyAutoConfig.js
508%{_libdir}/%{name}/components/nsResetPref.js
509%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
510%{_libdir}/%{name}/components/nsSearchService.js
511%{_libdir}/%{name}/components/nsSearchSuggestions.js
512%{_libdir}/%{name}/components/nsSessionStartup.js
513%{_libdir}/%{name}/components/nsSessionStore.js
514%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
515%{_libdir}/%{name}/components/nsSidebar.js
516%{_libdir}/%{name}/components/nsUpdateService.js
517%{_libdir}/%{name}/components/nsUrlClassifierLib.js
518%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
519%{_libdir}/%{name}/components/nsUrlClassifierTable.js
520%{_libdir}/%{name}/components/nsURLFormatter.js
521%{_libdir}/%{name}/components/nsXmlRpcClient.js
522%{_libdir}/%{name}/components/oji.xpt
523%{_libdir}/%{name}/components/passwordmgr.xpt
524%{_libdir}/%{name}/components/pipboot.xpt
525%{_libdir}/%{name}/components/pipnss.xpt
526%{_libdir}/%{name}/components/pippki.xpt
527%{_libdir}/%{name}/components/plugin.xpt
528%{_libdir}/%{name}/components/prefetch.xpt
529%{_libdir}/%{name}/components/pref.xpt
530%{_libdir}/%{name}/components/profile.xpt
531%{_libdir}/%{name}/components/progressDlg.xpt
532%{_libdir}/%{name}/components/proxyObjInst.xpt
533%{_libdir}/%{name}/components/rdf.xpt
534%{_libdir}/%{name}/components/safebrowsing.xpt
535%{_libdir}/%{name}/components/satchel.xpt
536%{_libdir}/%{name}/components/saxparser.xpt
537%{_libdir}/%{name}/components/search.xpt
538%{_libdir}/%{name}/components/sessionstore.xpt
539%{_libdir}/%{name}/components/shellservice.xpt
540%{_libdir}/%{name}/components/shistory.xpt
541%{_libdir}/%{name}/components/spellchecker.xpt
542%{_libdir}/%{name}/components/storage.xpt
543%{_libdir}/%{name}/components/toolkitprofile.xpt
544%{_libdir}/%{name}/components/toolkitremote.xpt
545%{_libdir}/%{name}/components/txmgr.xpt
546%{_libdir}/%{name}/components/txtsvc.xpt
547%{_libdir}/%{name}/components/uconv.xpt
548%{_libdir}/%{name}/components/unicharutil.xpt
549%{_libdir}/%{name}/components/update.xpt
550%{_libdir}/%{name}/components/uriloader.xpt
551%{_libdir}/%{name}/components/url-classifier.xpt
552%{_libdir}/%{name}/components/urlformatter.xpt
553%{_libdir}/%{name}/components/webBrowser_core.xpt
554%{_libdir}/%{name}/components/webbrowserpersist.xpt
555%{_libdir}/%{name}/components/WebContentConverter.js
556%{_libdir}/%{name}/components/webshell_idls.xpt
557%{_libdir}/%{name}/components/websrvcs.xpt
558%{_libdir}/%{name}/components/widget.xpt
559%{_libdir}/%{name}/components/windowds.xpt
560%{_libdir}/%{name}/components/windowwatcher.xpt
561%{_libdir}/%{name}/components/xml-rpc.xpt
562%{_libdir}/%{name}/components/xpcom_base.xpt
563%{_libdir}/%{name}/components/xpcom_components.xpt
564%{_libdir}/%{name}/components/xpcom_ds.xpt
565%{_libdir}/%{name}/components/xpcom_io.xpt
566%{_libdir}/%{name}/components/xpcom_obsolete.xpt
567%{_libdir}/%{name}/components/xpcom_threads.xpt
568%{_libdir}/%{name}/components/xpcom_xpti.xpt
569%{_libdir}/%{name}/components/xpconnect.xpt
570%{_libdir}/%{name}/components/xpinstall.xpt
571%{_libdir}/%{name}/components/xulapp.xpt
572%{_libdir}/%{name}/components/xuldoc.xpt
573%{_libdir}/%{name}/components/xultmpl.xpt
6162f349
ER
574%dir %{_libdir}/%{name}/plugins
575%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
6162f349
ER
576%attr(755,root,root) %{_libdir}/%{name}/*.sh
577%attr(755,root,root) %{_libdir}/%{name}/m*
578%attr(755,root,root) %{_libdir}/%{name}/f*
579%attr(755,root,root) %{_libdir}/%{name}/regxpcom
93639547
ER
580%attr(755,root,root) %{_libdir}/%{name}/xpcshell
581%attr(755,root,root) %{_libdir}/%{name}/xpicleanup
582%{_pixmapsdir}/mozilla-firefox.png
583%{_desktopdir}/mozilla-firefox.desktop
cdbdbff1 584
f86547d4
ER
585# symlinks
586%{_libdir}/%{name}/chrome
587%{_libdir}/%{name}/defaults
588%{_libdir}/%{name}/dictionaries
589%{_libdir}/%{name}/extensions
590%{_libdir}/%{name}/greprefs
591%{_libdir}/%{name}/icons
592%{_libdir}/%{name}/init.d
593%{_libdir}/%{name}/res
594%{_libdir}/%{name}/searchplugins
f37c2ce5
ER
595
596# browserconfig
6162f349 597%{_libdir}/%{name}/browserconfig.properties
f37c2ce5 598
6162f349
ER
599%{_libdir}/%{name}/LICENSE
600%{_libdir}/%{name}/README.txt
f86547d4
ER
601
602%dir %{_datadir}/%{name}
603%{_datadir}/%{name}/chrome
604%{_datadir}/%{name}/defaults
f86547d4
ER
605%{_datadir}/%{name}/greprefs
606%{_datadir}/%{name}/icons
607%{_datadir}/%{name}/init.d
608%{_datadir}/%{name}/res
609%{_datadir}/%{name}/searchplugins
610
611%dir %{_datadir}/%{name}/extensions
612# -dom-inspector subpackage?
613%{_datadir}/%{name}/extensions/inspector@mozilla.org
614# the signature of the default theme
615%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
f37c2ce5
ER
616
617# files created by regxpcom and firefox -register
6162f349
ER
618%ghost %{_libdir}/%{name}/components/compreg.dat
619%ghost %{_libdir}/%{name}/components/xpti.dat
f37c2ce5
ER
620
621%files libs
622%defattr(644,root,root,755)
6162f349
ER
623%dir %{_libdir}/%{name}
624%attr(755,root,root) %{_libdir}/%{name}/*.so
f37c2ce5 625
cdbdbff1 626%files lang-en
ecf01c4d 627%defattr(644,root,root,755)
f86547d4
ER
628%{_datadir}/%{name}/chrome/en-US.jar
629%{_datadir}/%{name}/chrome/en-US.manifest
a42140da
JB
630
631%if %{with tidy}
632%files addon-tidy
633%defattr(644,root,root,755)
634%attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
635%attr(755,root,root) %{_libdir}/%{name}/components/libtodel.so
636%{_libdir}/%{name}/components/nstidy.xpt
637%endif
This page took 0.228459 seconds and 4 git commands to generate.