]> git.pld-linux.org Git - packages/filtergen.git/blob - filtergen.spec
- Prereq: /sbin/chkconfig is back (rc-scripts doesn't require chkconfig!)
[packages/filtergen.git] / filtergen.spec
1 Summary:        Simple packet filter generator
2 Summary(pl):    Prosty generator filtrów pakietów
3 Name:           filter
4 Version:        0.5
5 Release:        4
6 License:        GPL
7 Group:          Networking/Utilities
8 Group(de):      Netzwerkwesen/Werkzeuge
9 Group(es):      Red/Utilitarios
10 Group(pl):      Sieciowe/Narzêdzia
11 Group(pt_BR):   Rede/Utilitários
12 Source0:        http://hairy.beasts.org/filter/%{name}-%{version}.tar.gz
13 Source1:        %{name}.conf
14 Source2:        %{name}.sysconfig
15 Source3:        %{name}.init
16 URL:            http://hairy.beasts.org/filter/
17 BuildRequires:  flex
18 Prereq:         rc-scripts
19 Prereq:         /sbin/chkconfig
20 Provides:       firewall
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This tool is for generating packet filtering rules from a fairly high-
25 level description language. It doesn't support all of the whizz-bang
26 features of the latest and greatest packet filters, but supports a
27 decent subset which is sufficient for typical workstation.
28
29 It currently supports only Linux iptables and ipchains. Cisco IOS has
30 been begun, but is incomplete. Darren Reed's ipfilter may be supported
31 at some stage. It doesn't generate optimal rulesets, and has a few
32 limitations which need to be removed, but is still a useful tool.
33
34 Please read HONESTY file!
35
36 %description -l pl
37 To jest narzêdzie do generowania regu³ filtrowania pakietów z
38 wzglêdnie wysokopoziomowego jêzyka opisu. Nie obs³uguje wszystkich
39 zaawansowanych mo¿liwo¶ci najnowszych filtrów pakietów, ale wspiera
40 przyzwoity podzbiór, wystarczaj±cy dla typowych stacji roboczych.
41
42 Aktualnie obs³uguje tylko linuksowe iptables i ipchains. Obs³uga Cisco
43 IOS jest zaczêta, ale nie kompletna. ipfilter Darrena Reeda jest
44 obs³ugiwany czê¶ciowo. Nie generuje optymalnych regu³ek i ma parê
45 ograniczeñ, które powinny byæ usuniête, ale mimo to jest u¿ytecznym
46 narzêdziem.
47
48 Przeczytaj plik HONESTY!
49
50 %prep
51 %setup -q
52
53 %build
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/%{name}} \
59         $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,rc.d/init.d}
60
61 install filtergen $RPM_BUILD_ROOT%{_sbindir}
62 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/simple.conf
63 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
64 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
65 touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/generated_rules
66
67 gzip -9nf README HONESTY HISTORY TODO tests/*
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 /sbin/chkconfig --add filter
74 if [ -f /var/lock/subsys/filter ]; then
75         /etc/rc.d/init.d/filter restart >&2
76 else
77         echo "Run \"/etc/rc.d/init.d/filter start\" to start filter"
78 fi
79
80 %preun
81 if [ "$1" = "0" ]; then
82         if [ -f /var/lock/subsys/filter ]; then
83                 /etc/rc.d/init.d/filter stop >&2
84         fi
85         /sbin/chkconfig --del filter
86 fi
87
88 %files
89 %defattr(644,root,root,755)
90 %doc *.gz tests
91 %attr(755,root,root) %{_sbindir}/filtergen
92 %dir %{_sysconfdir}/%{name}
93 %attr(600,root,root) %{_sysconfdir}/%{name}/simple.conf
94 %attr(600,root,root) %{_sysconfdir}/%{name}/generated_rules
95 %attr(600,root,root) %{_sysconfdir}/sysconfig/%{name}
96 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
This page took 0.076874 seconds and 4 git commands to generate.