]> git.pld-linux.org Git - packages/fillets-ng.git/blob - fillets-ng.spec
- typos
[packages/fillets-ng.git] / fillets-ng.spec
1
2 %define _game_ver       0.7.4
3 %define _data_ver       0.7.4
4
5 Summary:        Fish Fillets - Next Generation
6 Summary(pl.UTF-8):      Fish Fillets - Next Generation (linuksowy port gry)
7 Name:           fillets-ng
8 Version:        %{_game_ver}
9 Release:        2
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        http://dl.sourceforge.net/fillets/%{name}-%{version}.tar.gz
13 # Source0-md5:  912c146e70d90092a3dc89928e0be0f8
14 Source1:        http://dl.sourceforge.net/fillets/%{name}-data-%{_data_ver}.tar.gz
15 # Source1-md5:  0a2a651342d1035c292817048a4e373c
16 Source2:        %{name}.desktop
17 Source3:        %{name}.png
18 Source4:        http://fillets.sourceforge.net/intro.avi
19 # Source4-md5:  1bb4daa05062cd0c8f867320d70e84d9
20 URL:            http://fillets.sourceforge.net/
21 BuildRequires:  SDL-devel >= 1.2.0
22 BuildRequires:  SDL_image-devel
23 BuildRequires:  SDL_mixer-devel
24 BuildRequires:  SDL_ttf-devel
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  fribidi-devel
28 BuildRequires:  lua50-devel
29 BuildRequires:  sed >= 4.0
30 Requires:       %{name}-data = %{version}-%{release}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define _gamedatadir    %{_datadir}/games/%{name}
34
35 %description
36 Fish Fillets NG is a Linux port of wonderful puzzle game Fish Fillets
37 from ALTAR interactive. Fish Fillets NG is strictly a puzzle game.
38 The goal in every of the seventy levels is always the same: find
39 a safe way out.
40
41 %description -l pl.UTF-8
42 Fish Fillets NG to port wspaniałej gry logicznej Fish Fillets
43 napisanej przez ALTAR interactive. To gra na myślenie. Zadanie gracza
44 w każdym z siedemdziesięciu poziomów jest zawsze takie same: odnaleźć
45 bezpieczne wyjście.
46
47 %package docs
48 Summary:        A manual for Fish Fillets NG
49 Summary(pl.UTF-8):      Instrukcja do Fish Fillets NG
50 Group:          X11/Applications/Games
51 Requires:       %{name} = %{version}-%{release}
52
53 %description docs
54 A manual for Fish Fillets NG.
55
56 %description docs -l pl.UTF-8
57 Instrukcja do Fish Fillets.
58
59 %package data
60 Summary:        Data files for Fish Fillets NG
61 Summary(pl.UTF-8):      Pliki z danymi dla Fish Fillets NG
62 Group:          X11/Applications/Games
63 Requires:       %{name} = %{version}-%{release}
64
65 %description data
66 Data files for Fish Fillets NG.
67
68 %description data -l pl.UTF-8
69 Pliki z danymi dla Fish Fillets NG
70
71 %package intro
72 Summary:        Introduction video to Fish Fillets NG game
73 Summary(pl.UTF-8):      Film wprowadzający do gry Fish Fillets NG
74 Group:          X11/Applications/Games
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       mplayer
77
78 %description intro
79 Introduction video to Fish Fillets NG game.
80
81 %description intro -l pl.UTF-8
82 Film wprowadzający do gry Fish Fillets NG.
83
84 %prep
85 %setup -q -a1
86
87 %build
88 %{__aclocal}
89 %{__autoconf}
90 %{__automake}
91
92 %configure \
93         --with-lua=/usr/include/lua50
94
95 # Now isn't that nasty? but I don't know how to do this better
96 find -name Makefile -exec \
97         %{__sed} -i 's|LUA_LIBS = -L/usr/include/lua50 -llua -llualib|LUA_LIBS = -llua50 -llualib50|' {} \
98         \;
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_desktopdir},%{_pixmapsdir}}
104 install -d $RPM_BUILD_ROOT%{_gamedatadir}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         bindir=%{_bindir}
109
110 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
111 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
112 cp -Rfa %{name}-data-%{_data_ver}/{images,font,music,script,sound} $RPM_BUILD_ROOT%{_gamedatadir}
113 cp -Rfa %{name}-data-%{_data_ver}/doc $RPM_BUILD_ROOT%{_datadir}/%{name}
114 mv $RPM_BUILD_ROOT%{_bindir}/fillets $RPM_BUILD_ROOT%{_bindir}/fillets.bin
115 cat > $RPM_BUILD_ROOT%{_bindir}/fillets << EOF
116 #!/bin/sh
117
118 %{_bindir}/fillets.bin systemdir=%{_gamedatadir} \$@
119 EOF
120
121 install %{SOURCE4} $RPM_BUILD_ROOT%{_gamedatadir}
122 cat > $RPM_BUILD_ROOT%{_desktopdir}/fillets-ng-intro.desktop << EOF
123 [Desktop Entry]
124 Name=Fish Fillets Intro
125 Comment=Fish Fillets NG - Introduction
126 Exec=mplayer -fs %{_gamedatadir}/intro.avi
127 Icon=fillets-ng.png
128 Terminal=false
129 Type=Application
130 Encoding=UTF-8
131 Categories=Game;LogicGame;
132 # vi: encoding=utf-8
133 EOF
134
135 find $RPM_BUILD_ROOT%{_gamedatadir} -type d -fprintf %{name}.dirs '%%%%dir %{_gamedatadir}/%%P\n'
136
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
143
144 %postun
145 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog NEWS TODO
150 %attr(755,root,root) %{_bindir}/*
151 %dir %{_datadir}/%{name}
152 %{_mandir}/man*/*
153 %{_desktopdir}/%{name}.desktop
154 %{_pixmapsdir}/%{name}.png
155
156 %files data -f %{name}.dirs
157 %defattr(644,root,root,755)
158 %doc %{_gamedatadir}/images/menu/flags/copyright
159 %{_gamedatadir}/font/*
160 %{_gamedatadir}/images/*.png
161 %{_gamedatadir}/images/*/*.png
162 %{_gamedatadir}/images/*/*.svg
163 %{_gamedatadir}/images/*/*.xcf
164 %{_gamedatadir}/images/*/*/*.png
165 %{_gamedatadir}/images/*/*/*/*.png
166 %{_gamedatadir}/images/*/*/*/*/*.png
167 %{_gamedatadir}/music/*.ogg
168 %{_gamedatadir}/script/*.lua
169 %{_gamedatadir}/script/*/*.lua
170 %{_gamedatadir}/sound/*/*.ogg
171 %{_gamedatadir}/sound/*/*/*.ogg
172 %{_gamedatadir}/sound/*/*/*/*.ogg
173
174 %files docs
175 %defattr(644,root,root,755)
176 %dir %{_datadir}/%{name}/doc
177 %{_datadir}/%{name}/doc/html
178
179 %files intro
180 %defattr(644,root,root,755)
181 %{_gamedatadir}/intro.avi
182 %{_desktopdir}/%{name}-intro.desktop
This page took 0.370446 seconds and 3 git commands to generate.