]> git.pld-linux.org Git - packages/fillets-ng.git/blob - fillets-ng.spec
- updated to 0.9.0
[packages/fillets-ng.git] / fillets-ng.spec
1
2 %define _game_ver       0.9.0
3 %define _data_ver       0.9.0
4
5 Summary:        Fish Fillets - Next Generation
6 Summary(pl.UTF-8):      Fish Fillets - Next Generation (linuksowy port gry)
7 Name:           fillets-ng
8 Version:        %{_game_ver}
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        http://dl.sourceforge.net/fillets/%{name}-%{version}.tar.gz
13 # Source0-md5:  e3796febd2fd876467d4283d95cbc9a5
14 Source1:        http://dl.sourceforge.net/fillets/%{name}-data-%{_data_ver}.tar.gz
15 # Source1-md5:  5d733a990212a4b038d1ee76f700c54e
16 Source2:        %{name}.desktop
17 Source3:        %{name}.png
18 URL:            http://fillets.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  SDL_ttf-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  fribidi-devel
26 BuildRequires:  lua50-devel
27 BuildRequires:  sed >= 4.0
28 Requires:       %{name}-data = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define _gamedatadir    %{_datadir}/games/%{name}
32
33 %description
34 Fish Fillets NG is a Linux port of wonderful puzzle game Fish Fillets
35 from ALTAR interactive. Fish Fillets NG is strictly a puzzle game.
36 The goal in every of the seventy levels is always the same: find
37 a safe way out.
38
39 %description -l pl.UTF-8
40 Fish Fillets NG to port wspaniałej gry logicznej Fish Fillets
41 napisanej przez ALTAR interactive. To gra na myślenie. Zadanie gracza
42 w każdym z siedemdziesięciu poziomów jest zawsze takie same: odnaleźć
43 bezpieczne wyjście.
44
45 %package docs
46 Summary:        A manual for Fish Fillets NG
47 Summary(pl.UTF-8):      Instrukcja do gry Fish Fillets NG
48 Group:          X11/Applications/Games
49 Requires:       %{name} = %{version}-%{release}
50
51 %description docs
52 A manual for Fish Fillets NG.
53
54 %description docs -l pl.UTF-8
55 Instrukcja do gry Fish Fillets.
56
57 %package data
58 Summary:        Data files for Fish Fillets NG
59 Summary(pl.UTF-8):      Pliki z danymi do gry Fish Fillets NG
60 Group:          X11/Applications/Games
61 Requires:       %{name} = %{version}-%{release}
62
63 %description data
64 Data files for Fish Fillets NG.
65
66 %description data -l pl.UTF-8
67 Pliki z danymi do gry Fish Fillets NG.
68
69 %package intro
70 Summary:        Introduction video to Fish Fillets NG game
71 Summary(pl.UTF-8):      Film wprowadzający do gry Fish Fillets NG
72 Group:          X11/Applications/Games
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       mplayer
75
76 %description intro
77 Introduction video to Fish Fillets NG game.
78
79 %description intro -l pl.UTF-8
80 Film wprowadzający do gry Fish Fillets NG.
81
82 %prep
83 %setup -q -a1
84
85 %build
86 %{__aclocal}
87 %{__autoconf}
88 %{__automake}
89
90 %configure \
91         --with-lua=/usr/include/lua50
92
93 # Now isn't that nasty? but I don't know how to do this better
94 find -name Makefile -exec \
95         %{__sed} -i 's|LUA_LIBS = -L/usr/include/lua50 -llua -llualib|LUA_LIBS = -llua50 -llualib50|' {} \
96         \;
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_desktopdir},%{_pixmapsdir}}
102 install -d $RPM_BUILD_ROOT%{_gamedatadir}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         bindir=%{_bindir}
107
108 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
109 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
110 cp -Rfa %{name}-data-%{_data_ver}/{images,font,music,script,sound} $RPM_BUILD_ROOT%{_gamedatadir}
111 cp -Rfa %{name}-data-%{_data_ver}/doc $RPM_BUILD_ROOT%{_datadir}/%{name}
112 mv $RPM_BUILD_ROOT%{_bindir}/fillets $RPM_BUILD_ROOT%{_bindir}/fillets.bin
113 cat > $RPM_BUILD_ROOT%{_bindir}/fillets << EOF
114 #!/bin/sh
115
116 %{_bindir}/fillets.bin systemdir=%{_gamedatadir} \$@
117 EOF
118
119 install %{name}-data-%{_data_ver}/images/menu/intro.mpg $RPM_BUILD_ROOT%{_gamedatadir}
120 cat > $RPM_BUILD_ROOT%{_desktopdir}/fillets-ng-intro.desktop << EOF
121 [Desktop Entry]
122 Name=Fish Fillets Intro
123 Comment=Fish Fillets NG - Introduction
124 Comment[pl]=Fish Fillets NG - Wprowadzenie
125 Exec=mplayer -fs %{_gamedatadir}/intro.mpg
126 Icon=fillets-ng.png
127 Terminal=false
128 Type=Application
129 Encoding=UTF-8
130 Categories=Game;LogicGame;
131 # vi: encoding=utf-8
132 EOF
133
134 find $RPM_BUILD_ROOT%{_gamedatadir} -type d -fprintf %{name}.dirs '%%%%dir %{_gamedatadir}/%%P\n'
135
136 rm -rf $RPM_BUILD_ROOT%{_gamedatadir}/images/menu/intro.mpg
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p      /sbin/postshell
142 -/usr/sbin/fix-info-dir -c %{_infodir}
143
144 %postun -p      /sbin/postshell
145 -/usr/sbin/fix-info-dir -c %{_infodir}
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog NEWS TODO
150 %attr(755,root,root) %{_bindir}/*
151 %dir %{_datadir}/%{name}
152 %{_mandir}/man6/fillets.*
153 %{_desktopdir}/%{name}.desktop
154 %{_pixmapsdir}/%{name}.png
155
156 %files data -f %{name}.dirs
157 %defattr(644,root,root,755)
158 %doc %{_gamedatadir}/images/menu/flags/copyright
159 %{_gamedatadir}/font/*
160 %{_gamedatadir}/images/*.png
161 %{_gamedatadir}/images/*/*.png
162 %{_gamedatadir}/images/*/*/*.png
163 %{_gamedatadir}/images/*/*/*/*.png
164 %{_gamedatadir}/images/*/*/*/*/*.png
165 %{_gamedatadir}/music/*.ogg
166 %{_gamedatadir}/script/*.lua
167 %{_gamedatadir}/script/*/*.lua
168 %{_gamedatadir}/sound/*/*.ogg
169 %{_gamedatadir}/sound/*/*/*.ogg
170 %{_gamedatadir}/sound/*/*/*/*.ogg
171
172 %files docs
173 %defattr(644,root,root,755)
174 %dir %{_datadir}/%{name}/doc
175 %{_datadir}/%{name}/doc/html
176
177 %files intro
178 %defattr(644,root,root,755)
179 %{_gamedatadir}/intro.mpg
180 %{_desktopdir}/%{name}-intro.desktop
This page took 0.099722 seconds and 3 git commands to generate.