]> git.pld-linux.org Git - packages/fillets-ng.git/blob - fillets-ng.spec
- updated to 0.7.4
[packages/fillets-ng.git] / fillets-ng.spec
1
2 %define _game_ver       0.7.4
3 %define _data_ver       0.7.4
4
5 Summary:        Fish Fillets - Next Generation
6 Summary(pl.UTF-8):      Fish Fillets - Next Generation (linuksowy port gry)
7 Name:           fillets-ng
8 Version:        %{_game_ver}
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        http://dl.sourceforge.net/fillets/%{name}-%{version}.tar.gz
13 # Source0-md5:  912c146e70d90092a3dc89928e0be0f8
14 Source1:        http://dl.sourceforge.net/fillets/%{name}-data-%{_data_ver}.tar.gz
15 # Source1-md5:  0a2a651342d1035c292817048a4e373c
16 Source2:        %{name}.desktop
17 Source3:        %{name}.png
18 URL:            http://fishfillets.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  SDL_ttf-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  fribidi-devel
26 BuildRequires:  lua50-devel
27 BuildRequires:  sed >= 4.0
28 Requires:       %{name}-data = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define _gamedatadir    %{_datadir}/games/%{name}
32
33 %description
34 Fish Fillets NG is a Linux port of wonderful puzzle game Fish Fillets
35 from ALTAR interactive. Fish Fillets NG is strictly a puzzle game.
36 The goal in every of the seventy levels is always the same: find
37 a safe way out.
38
39 %description -l pl.UTF-8
40 Fish Fillets NG to port wspaniałej gry logicznej Fish Fillets
41 napisanej przez ALTAR interactive. To gra na myślenie. Zadanie gracza
42 w każdym z siedemdziesięciu poziomów jest zawsze takie same: odnaleźć
43 bezpieczne wyjście.
44
45 %package docs
46 Summary:        A manual for Fish Fillets NG
47 Summary(pl.UTF-8):      Instrukcja do Fish Fillets NG
48 Group:          X11/Applications/Games
49 Requires:       %{name} = %{version}-%{release}
50
51 %description docs
52 A manual for Fish Fillets NG.
53
54 %description docs -l pl.UTF-8
55 Instrukcja do Fish Fillets.
56
57 %package data
58 Summary:        Data files for Fish Fillets NG
59 Summary(pl.UTF-8):      Pliki z danymi dla Fish Fillets NG
60 Group:          X11/Application/Games
61 Requires:       %{name} = %{version}-%{release}
62
63 %description data
64 Data files for Fish Fillets NG.
65
66 %description data -l pl.UTF-8
67 Pliki z danymi dla Fish Fillets NG
68
69 %prep
70 %setup -q -a1
71
72 %build
73 %{__aclocal}
74 %{__autoconf}
75 %{__automake}
76
77 %configure \
78         --with-lua=/usr/include/lua50
79
80 # Now isn't that nasty? but I don't know how to do this better
81 find -name Makefile -exec \
82         %{__sed} -i 's|LUA_LIBS = -L/usr/include/lua50 -llua -llualib|LUA_LIBS = -llua50 -llualib50|' {} \
83         \;
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_desktopdir},%{_pixmapsdir}}
89 install -d $RPM_BUILD_ROOT%{_gamedatadir}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT \
93         bindir=%{_bindir}
94
95 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
96 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
97 cp -Rfa %{name}-data-%{_data_ver}/{images,font,music,script,sound} $RPM_BUILD_ROOT%{_gamedatadir}
98 cp -Rfa %{name}-data-%{_data_ver}/doc $RPM_BUILD_ROOT%{_datadir}/%{name}
99 mv $RPM_BUILD_ROOT%{_bindir}/fillets $RPM_BUILD_ROOT%{_bindir}/fillets.bin
100 cat > $RPM_BUILD_ROOT%{_bindir}/fillets << EOF
101 #!/bin/sh
102
103 %{_bindir}/fillets.bin systemdir=%{_gamedatadir} \$@
104 EOF
105
106 find $RPM_BUILD_ROOT%{_gamedatadir} -type d -fprintf %{name}.dirs '%%%%dir %{_gamedatadir}/%%P\n'
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
113
114 %postun
115 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS TODO
120 %attr(755,root,root) %{_bindir}/*
121 %dir %{_datadir}/%{name}
122 %{_mandir}/man*/*
123 %{_desktopdir}/%{name}.desktop
124 %{_pixmapsdir}/%{name}.png
125
126 %files data -f %{name}.dirs
127 %defattr(644,root,root,755)
128 %doc %{_gamedatadir}/images/menu/flags/copyright
129 %{_gamedatadir}/font/*
130 %{_gamedatadir}/images/*.png
131 %{_gamedatadir}/images/*/*.png
132 %{_gamedatadir}/images/*/*.svg
133 %{_gamedatadir}/images/*/*.xcf
134 %{_gamedatadir}/images/*/*/*.png
135 %{_gamedatadir}/images/*/*/*/*.png
136 %{_gamedatadir}/images/*/*/*/*/*.png
137 %{_gamedatadir}/music/*.ogg
138 %{_gamedatadir}/script/*.lua
139 %{_gamedatadir}/script/*/*.lua
140 %{_gamedatadir}/sound/*/*.ogg
141 %{_gamedatadir}/sound/*/*/*.ogg
142 %{_gamedatadir}/sound/*/*/*/*.ogg
143
144 %files docs
145 %defattr(644,root,root,755)
146 %dir %{_datadir}/%{name}/doc
147 %{_datadir}/%{name}/doc/html
This page took 0.094606 seconds and 3 git commands to generate.