]> git.pld-linux.org Git - packages/file.git/blobdiff - file.spec
add mime type for *.m3u files; rel 4
[packages/file.git] / file.spec
index e7cdcabf4c9d73b4eb366ea679286f200db5f8cf..4af0c2852795a049c8aa4abfe6e681581990d86f 100644 (file)
--- a/file.spec
+++ b/file.spec
@@ -1,9 +1,14 @@
 #
 # Conditional build:
-%bcond_without python2         # don't build python-magic module for Python 2.x
-%bcond_without python3         # don't build python-magic module for Python 3.x
-%bcond_without static_libs     # don't build static libraries
-%bcond_without tests           # don't perform "make check"
+%bcond_without python2         # CPython 2.x python-magic module
+%bcond_without python3         # CPython 3.x python-magic module
+%bcond_without static_libs     # static library
+%bcond_without tests           # unit tests
+%bcond_without seccomp         # SECCOMP support
+
+%ifnarch %{x8664} aarch64
+%undefine      with_seccomp
+%endif
 
 Summary:       A utility for determining file types
 Summary(cs.UTF-8):     Program pro zjišťování typu souborů
@@ -29,37 +34,47 @@ Summary(uk.UTF-8):  Утиліта для визначення типів фай
 Summary(zh_CN.UTF-8):  判定文件类型的工具。
 Summary(zh_TW.UTF-8):  用於決定檔案類型的一個工具程式。
 Name:          file
-Version:       5.32
-Release:       1
+Version:       5.45
+Release:       4
 License:       distributable
 Group:         Applications/File
 Source0:       ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
-# Source0-md5: 4f2503752ff041895090ed6435610435
+# Source0-md5: 26b2a96d4e3a8938827a1e572afd527a
 Source1:       http://ftp1.pld-linux.org/people/glen/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 6a45bcaefd19b94db36a1b2b7c5b806b
 Source2:       %{name}-zisofs.magic
 Source3:       %{name}-mscompress.magic
 Source4:       %{name}-magic.mime-gen.awk
-Patch0:                %{name}-selinux.patch
-Patch1:                searchpath.patch
-Patch2:                automake.patch
-Patch4:                name-use-count.patch
+Patch0:                searchpath.patch
+Patch1:                automake.patch
+Patch2:                %{name}-gettext-no-random-translations.patch
+Patch3:                name-use-count.patch
+Patch4:                time_t-32bit.patch
+Patch5:                m3u-mime-type.patch
 URL:           http://www.darwinsys.com/file/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+BuildRequires: bzip2-devel
+%{?with_seccomp:BuildRequires: libseccomp-devel}
 BuildRequires: libtool >= 2:2.0
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: lzlib-devel
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.751
 %if %{with python2}
 BuildRequires: python-devel
 BuildRequires: python-modules
+BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
 %endif
 %if %{with python3}
 BuildRequires: python3-devel
 BuildRequires: python3-modules
+BuildRequires: python3-setuptools
 BuildRequires: rpm-pythonprov
 %endif
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 Requires(pretrans):    coreutils
 Requires:      libmagic = %{version}-%{release}
 Conflicts:     rpm-build < 4.4.1-9
@@ -207,8 +222,13 @@ Biblioteka funkcji operujących na pliku bazy danych magic.
 Summary:       Header files for libmagic library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libmagic
 Group:         Development/Libraries
+Requires:      bzip2-devel
 Requires:      libmagic = %{version}-%{release}
+%{?with_seccomp:Requires:      libseccomp-devel}
+Requires:      lzlib-devel
+Requires:      lzma-devel
 Requires:      zlib-devel
+Requires:      zstd-devel
 
 %description -n libmagic-devel
 Library of functions which operate on magic database file.
@@ -244,6 +264,7 @@ Summary(pl.UTF-8):  Wiązania Pythona 2 do biblioteki libmagic
 Group:         Libraries/Python
 Requires:      libmagic = %{version}-%{release}
 Requires:      python-libs
+BuildArch:     noarch
 
 %description -n python-magic
 Python 2 bindings for libmagic.
@@ -256,7 +277,8 @@ Summary:    Python 3 bindings for libmagic
 Summary(pl.UTF-8):     Wiązania Pythona 3 do biblioteki libmagic
 Group:         Libraries/Python
 Requires:      libmagic = %{version}-%{release}
-Requires:      python-libs
+Requires:      python3-libs
+BuildArch:     noarch
 
 %description -n python3-magic
 Python 3 bindings for libmagic.
@@ -269,9 +291,11 @@ Wiązania Pythona 3 do biblioteki libmagic.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
-%if "%{cc_version}" < "3.4"
+%if "%{_ver_lt '%{cc_version}' '3.4'}" == "1"
 %{__sed} -i -e 's,-Wextra,,' configure.ac
 %endif
 
@@ -286,11 +310,12 @@ cp -a python py3
 
 %build
 %{__libtoolize}
-%{__aclocal}
-%{__autoheader}
+%{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
+       %{!?with_seccomp:--disable-libseccomp} \
        --disable-silent-rules \
        --enable-fsect-man5 \
        %{?with_static_libs:--enable-static}
@@ -319,9 +344,9 @@ install -d $RPM_BUILD_ROOT/%{_lib}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libmagic.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libmagic.so.* $RPM_BUILD_ROOT/%{_lib}
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libmagic.so.*.*.*) \
-        $RPM_BUILD_ROOT%{_libdir}/libmagic.so
+       $RPM_BUILD_ROOT%{_libdir}/libmagic.so
 
 %if %{with python2}
 cd python
@@ -361,7 +386,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog COPYING README
+%doc ChangeLog COPYING
 %attr(755,root,root) %{_bindir}/file
 %{_datadir}/file
 %{_datadir}/misc/magic
@@ -390,6 +415,7 @@ fi
 %attr(755,root,root) %{_libdir}/libmagic.so
 %{_libdir}/libmagic.la
 %{_includedir}/magic.h
+%{_pkgconfigdir}/libmagic.pc
 %{_mandir}/man3/libmagic.3*
 
 %if %{with static_libs}
@@ -398,18 +424,18 @@ fi
 %{_libdir}/libmagic.a
 %endif
 
-%if %{with python3}
+%if %{with python2}
 %files -n python-magic
 %defattr(644,root,root,755)
-%doc python/README python/example.py
+%doc python/README.md python/example.py
 %{py_sitescriptdir}/magic.py[co]
 %{py_sitescriptdir}/file_magic-*-py*.egg-info
 %endif
 
-%if %{with_python3}
+%if %{with python3}
 %files -n python3-magic
 %defattr(644,root,root,755)
-%doc python/README python/example.py
+%doc python/README.md python/example.py
 %{py3_sitescriptdir}/magic.py
 %{py3_sitescriptdir}/__pycache__/magic.*.py[co]
 %{py3_sitescriptdir}/file_magic-*-py*.egg-info
This page took 0.527497 seconds and 4 git commands to generate.