]> git.pld-linux.org Git - packages/fiaif.git/blob - fiaif.spec
0cbb069cc0d017ba8a110c5effdbec6969187993
[packages/fiaif.git] / fiaif.spec
1 Summary:        Fiaif is an Intelligent Firewall for iptables based Linux systems
2 Summary(pl.UTF-8):   Fiaif - inteligentny firewall bazujący na iptables
3 Name:           fiaif
4 Version:        1.19.2
5 Release:        1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.fiaif.net/dist/%{name}_%{version}.tar.gz
9 # Source0-md5:  9042013b1aba5ce20e42c4c235094f82
10 URL:            http://www.fiaif.net/
11 BuildRequires:  tetex-dvips
12 BuildRequires:  tetex-fonts-jknappen
13 BuildRequires:  tetex-format-latex
14 BuildRequires:  tetex-latex-ams
15 BuildRequires:  tetex-latex-bibtex
16 BuildRequires:  tetex-latex-psnfss
17 BuildRequires:  tetex-makeindex
18 BuildRequires:  tetex-metafont
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       bash >= 2.04
21 Requires:       grep
22 Requires:       iptables >= 1.2.7a
23 Requires:       sh-utils
24 Requires:       textutils
25 Conflicts:      ipmasq, knetfilter, firewall-easy, shorewall, firewall-init
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Goal of FIAIF is to provide a highly customizable script for
31 setting up an iptables based firewall.
32
33 Unlike many other scripts, FIAIF can be truly customized allowing
34 multiple interfaces (or rather zones). There is no limit on the number
35 of zones. All configuration is done through configuration files. No
36 need to understand the script behind it all.
37
38 The script makes heavy use of stateful firewalling, and all RELATED
39 and ESTABLISHED packets are accepted on all chains. If you wish to
40 block something out, do not accept it in the first place.
41
42 The script is written in BASH. Though this is not the optimal program
43 to use, it means that you do not need to install extra interpreters on
44 your firewall. This allows you to have a minimalistic installation on
45 your firewall.
46
47 %description -l pl.UTF-8
48 Celem FIAIF jest udostępnienie wysoce dostosowawczego skryptu
49 ustawiania reguł ściany ogniowej opartej na netfiltrze.
50
51 W przeciwieństwie do innych skryptów, FIAIF umożliwia ustawianie reguł
52 na wielu interfejsach, a raczej strefach. Nie ma limitu stref. Całą
53 konfigurację przeprowadza się za pomocą plików konfiguracyjnych. Nie
54 ma potrzeby rozumienia stojącego za nimi skryptu.
55
56 Skrypt mocno używa zabezpieczeń typu stateful, przepuszczając
57 wszystkie pakiety RELATED i ESTABLISHED na wszystkich łańcuchach.
58 Żeby coś zablokować, wystarczy nie akceptować tego na początku.
59
60 Skrypt napisany jest w bashu, co pozwala na zmniejszenie koniecznej
61 instalacji na ścianie ogniowej.
62
63 %prep
64 %setup -q
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72 %{__make} install-config \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install prog/fiaif $RPM_BUILD_ROOT/etc/rc.d/init.d/fiaif
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /sbin/chkconfig --add fiaif
82 if [ -f /var/lib/fiaif/iptables ]; then
83         /etc/rc.d/init.d/fiaif force-reload >&2
84 else
85         echo "Configure fiaif and remove the line 'DONT_START=1'"
86         echo "from /etc/fiaif/fiaif.conf, then execute"
87         echo "'/etc/rc.d/init.d/fiaif start' to start fiaif."
88 fi
89
90 %preun
91 if [ "$1" = "0" ]; then
92         if [ -f /var/lib/fiaif/iptables ]; then
93                 /etc/rc.d/init.d/fiaif stop >&2
94         fi
95         /sbin/chkconfig --del fiaif
96 fi
97
98 %files
99 %defattr(644,root,root,755)
100 %doc doc/faq.txt doc/DHCP.txt doc/reporting_bugs.txt doc/upgrade.txt
101
102 %dir %attr(700,root,root) %{_sysconfdir}/fiaif
103 %dir %attr(700,root,root) /var/lib/fiaif
104 %attr(600,root,root) %{_sysconfdir}/cron.daily/fiaif
105 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/zone.dmz
106 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/zone.ext
107 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/zone.int
108 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/fiaif.conf
109 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/reserved_networks
110 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/private_networks
111 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/type_of_services
112 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fiaif/aliases
113
114 %attr(754,root,root) /etc/rc.d/init.d/fiaif
115 %attr(755,root,root) %{_sbindir}/fiaif-scan
116 %attr(755,root,root) %{_sbindir}/fiaif-getdev
117 %attr(755,root,root) %{_sbindir}/fiaif-update
118
119 %dir %{_datadir}/fiaif
120 %{_datadir}/fiaif/traffic-shaping.sh
121 %{_datadir}/fiaif/functions.sh
122 %{_datadir}/fiaif/zones.sh
123 %{_datadir}/fiaif/iptables.sh
124 %{_datadir}/fiaif/proc-check.sh
125 %{_datadir}/fiaif/sanity_check.sh
126 %{_datadir}/fiaif/constants.sh
127 %{_datadir}/fiaif/cleanup_rules.sh
128 %{_datadir}/fiaif/aliases.sh
129 %{_datadir}/fiaif/cleanup_rules.awk
130 %{_datadir}/fiaif/fiaif_rules.awk
131 %{_datadir}/fiaif/syntax.awk
132 %{_datadir}/fiaif/zone_rules.awk
133 %{_datadir}/fiaif/VERSION
134
135 %{_mandir}/man8/fiaif.8*
136 %{_mandir}/man5/zone.conf.5*
137 %{_mandir}/man5/fiaif.conf.5*
138 %{_mandir}/man8/fiaif-scan.8*
139 %{_mandir}/man8/fiaif-getdev.8*
140 %{_mandir}/man8/fiaif-update.8*
This page took 0.071059 seconds and 2 git commands to generate.