]> git.pld-linux.org Git - packages/fftw3.git/blob - fftw3.spec
- fixed
[packages/fftw3.git] / fftw3.spec
1 # TODO: move single and long-double libs to subpackages
2 Summary:        Fast Fourier transform library
3 Summary(pl):    Biblioteka z funkacjami szybkiej transformaty Fouriera
4 Summary(pt_BR): biblioteca fast fourier transform
5 Name:           fftw3
6 Version:        3.0
7 Release:        1
8 License:        GPL
9 Group:          Libraries
10 Source0:        ftp://ftp.fftw.org/pub/fftw/fftw-%{version}.tar.gz
11 Patch0:         %{name}-info.patch
12 Icon:           fftw-logo-thumb.gif
13 URL:            http://www.fftw.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 FFTW is a collection of fast C routines for computing the Discrete
21 Fourier Transform in one or more dimensions. It includes complex,
22 real, and parallel transforms, and can handle arbitrary array sizes
23 efficiently. This RPM package includes the double precision FFTW
24 uniprocessor and threads libraries.
25
26 %description -l pl
27 FFTW jest zbiorem szybkich funkcji C do obliczania dyskretnych
28 transformat Fouriera w jednym lub wiêcej wymiarach. Zawiera równie¿
29 zespolone, rzeczywiste oraz równoleg³e transformaty i potrafi wydajnie
30 radziæ sobie z tablicami o dowolnych rozmiarach. Ten pakiet RPM
31 zawiera wersje FFTW o podwójnej precyzji dla architektur
32 jednoprocesorowych oraz z obs³ug± w±tków.
33
34 %description -l pt_BR
35 FFTW é uma coleção de rotinas rápidas em C para computar a Discrete
36 Fourier Transform em uma ou mais dimensões. Incluindo transformações
37 complexas, reais e paralelas, também pode manipular vetores de tamanho
38 arbitrário eficientemente. Esse pacote RPM inclui bibliotecas FFTW com
39 suporte a threads, normal e dupla precisão (Os arquivos de precisão
40 normal tem um prefixo "s").
41
42 %package devel
43 Summary:        Header files and documentation for fftw
44 Summary(pl):    Pliki nag³ówkowe oraz dokumentacja do fftw
45 Summary(pt_BR): Headers e documentação do pacote FFTW
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}
48
49 %description devel
50 This package contains the header files and documentation you need to
51 develop programs using the FFTW (fast fourier transform library).
52
53 %description devel -l pl
54 Ten pakiet zawiera pliki nag³ówkowe oraz dokumetacjê potrzebne do
55 tworzenia programów u¿ywaj±cych biblioteki FFTW (wykonuj±cej szybk±
56 transformatê Fouriera).
57
58 %description devel -l pt_BR
59 Este pacote contém documentação e headers adicionais para desenvolver
60 programas usando a FFTW.
61
62 %package static
63 Summary:        Static fftw libraries
64 Summary(pl):    Statyczne biblioteki fftw
65 Summary(pt_BR): Bibliotecas estáticas do pacote FFTW
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}
68
69 %description static
70 Static fftw libraries.
71
72 %description static -l pl
73 Statyczne biblioteki fftw.
74
75 %description static -l pt_BR
76 Este pacote contém as bibliotecas estáticas do pacote FFTW.
77
78 %prep
79 %setup -q -n fftw-%{version}
80 %patch -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__automake}
87 # it seems to be safe because of runtime CPU detection
88 for ver in single double long-double ; do
89         OPTS=""
90         # k7,SSE,3dnow,altivec only for single
91         if [ "$ver" = "single" ]; then
92                 OPTS="
93 %ifarch athlon
94                 --enable-k7
95 %endif
96 %ifarch i686 athlon
97         --enable-sse
98 %endif
99 %ifarch i586 k6
100         --enable-3dnow
101 %endif
102 %ifarch ppc
103         --enable-altivec
104 %endif
105                 "
106         fi
107 %ifarch i686
108         # SSE2 only for double
109         if [ "$ver" = "double" ]; then
110                 OPTS="--enable-sse2"
111         endif
112 %endif
113 %configure \
114         --enable-shared \
115         --enable-threads \
116         --enable-$ver \
117         $OPTS \
118         --%{!?debug:dis}%{?debug:en}able-debug
119
120 %{__make}
121 %{__make} install DESTDIR=`pwd`/inst-$ver
122         if [ "$ver" != "long-double" ]; then
123 %{__make} clean
124         fi
125 done
126
127 # remake docs removed by make clean
128 %{__make} fftw-faq.html -C doc/FAQ
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 # this installs last configured version (long-double)
134 %{__make} install DESTDIR=$RPM_BUILD_ROOT
135
136 # duplicates
137 rm -rf inst-*{%{_bindir}/fftw-wisdom-to-conf,%{_includedir}} \
138         inst-*{%{_infodir},%{_mandir}/man1/fftw-wisdom-to-conf.1}
139
140 # install prepared remaining versions
141 tar cf - -C inst-single . | tar xf - -C $RPM_BUILD_ROOT
142 tar cf - -C inst-double . | tar xf - -C $RPM_BUILD_ROOT
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %post devel
151 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
152
153 %postun devel
154 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS COPYRIGHT ChangeLog NEWS README TODO
159 %attr(755,root,root) %{_bindir}/fftw*-wisdom*
160 %attr(755,root,root) %{_libdir}/libfftw3*.so.*.*.*
161 %{_mandir}/man1/fftw*-wisdom*.1*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %doc doc/html doc/FAQ/fftw-faq.html
166 %attr(755,root,root) %{_libdir}/libfftw3*.so
167 %{_libdir}/libfftw3*.la
168 %{_includedir}/fftw3.*
169 %{_infodir}/fftw3.info*
170 %{_pkgconfigdir}/fftw3*.pc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libfftw3*.a
This page took 0.094543 seconds and 3 git commands to generate.