]> git.pld-linux.org Git - packages/fftw.git/blob - fftw.spec
- raw version by Dax Kelson <dax@gurulabs.com>.
[packages/fftw.git] / fftw.spec
1 # RPM spec file for FFTW.
2 # This file is used to build Redhat Package Manager packages for the
3 # FFTW library.  Such packages make it easy to install and uninstall
4 # the library and related files from binaries or source.
5 #
6 # This spec file is for version 2.1.2 of FFTW, and will need to be
7 # modified for future releases.  First, the string "2.1.2" should
8 # be replaced everywhere in this file with the new version number.
9 # Second, the shared library version numbers (in the %files list)
10 # will need to be updated.  Any other changes in the installed files
11 # list, build commands, etcetera will of course also require changes.
12 #
13 # The icon associated with this package can be downloaded from:
14 #     http://theory.lcs.mit.edu/~fftw/fftw-logo-thumb.gif
15 # and will need to be placed in the SOURCES directory to build the RPM.
16 #
17 Name: fftw
18 Summary: fast fourier transform library
19 Version: 2.1.2
20 Release: 3
21 Copyright: GPL
22 Icon: fftw-logo-thumb.gif
23 Group: Libraries
24 Prefix: /usr
25 Source: ftp://theory.lcs.mit.edu/pub/fftw/fftw-2.1.2.tar.gz
26 URL: http://theory.lcs.mit.edu/~fftw
27 BuildRoot: /var/tmp/fftw-%{PACKAGE_VERSION}-root
28
29 %description
30 FFTW is a collection of fast C routines for computing the Discrete Fourier
31 Transform in one or more dimensions.  It includes complex, real, and
32 parallel transforms, and can handle arbitrary array sizes efficiently.
33 This RPM package includes both the double- and single-precision FFTW
34 uniprocessor and threads libraries.
35 %package devel
36 Summary: headers, libraries, & docs for FFTW fast fourier transform library
37 Group: Development/Libraries
38 Prefix: /usr
39 Requires: fftw = 2.1.2
40 %description devel
41 This package contains the additional header files, documentation, and
42 libraries you need to develop programs using the FFTW fast fourier
43 transform library.
44
45 %prep
46 %setup
47
48 %ifarch i386
49 ./configure --enable-shared --enable-type-prefix --enable-i386-hacks --enable-threads --prefix=%prefix
50 %else
51 ./configure --enable-shared --enable-type-prefix --enable-threads --prefix=%prefix
52 %endif
53
54 %build
55
56 make
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 make prefix=$RPM_BUILD_ROOT%{prefix} install
62
63 # hack to also compile/install single-precision version:
64 make distclean
65 %ifarch i386
66 ./configure --enable-shared --enable-type-prefix --enable-threads --enable-float --prefix=%prefix --enable-i386-hacks
67 %else
68 ./configure --enable-shared --enable-type-prefix --enable-threads --enable-float --prefix=%prefix
69 %endif
70 make prefix=$RPM_BUILD_ROOT%{prefix} install
71
72 %files
73 /usr/lib/libdfftw.so.2.0.4
74 /usr/lib/libdfftw_threads.so.2.0.4
75 /usr/lib/libdrfftw.so.2.0.4
76 /usr/lib/libdrfftw_threads.so.2.0.4
77 /usr/lib/libsfftw.so.2.0.4
78 /usr/lib/libsfftw_threads.so.2.0.4
79 /usr/lib/libsrfftw.so.2.0.4
80 /usr/lib/libsrfftw_threads.so.2.0.4
81 /usr/lib/libdfftw.so.2
82 /usr/lib/libdfftw_threads.so.2
83 /usr/lib/libdrfftw.so.2
84 /usr/lib/libdrfftw_threads.so.2
85 /usr/lib/libsfftw.so.2
86 /usr/lib/libsfftw_threads.so.2
87 /usr/lib/libsrfftw.so.2
88 /usr/lib/libsrfftw_threads.so.2
89 %files devel
90 /usr/info/fftw.info
91 /usr/info/fftw.info-1
92 /usr/info/fftw.info-2
93 /usr/info/fftw.info-3
94 /usr/info/fftw.info-4
95 /usr/info/fftw.info-5
96 /usr/include/dfftw.h
97 /usr/include/dfftw_threads.h
98 /usr/include/drfftw.h
99 /usr/include/drfftw_threads.h
100 /usr/include/sfftw.h
101 /usr/include/sfftw_threads.h
102 /usr/include/srfftw.h
103 /usr/include/srfftw_threads.h
104 /usr/lib/libdfftw.a
105 /usr/lib/libdfftw.la
106 /usr/lib/libdfftw.so
107 /usr/lib/libdfftw_threads.a
108 /usr/lib/libdfftw_threads.la
109 /usr/lib/libdfftw_threads.so
110 /usr/lib/libdrfftw.a
111 /usr/lib/libdrfftw.la
112 /usr/lib/libdrfftw.so
113 /usr/lib/libdrfftw_threads.a
114 /usr/lib/libdrfftw_threads.la
115 /usr/lib/libdrfftw_threads.so
116 /usr/lib/libsfftw.a
117 /usr/lib/libsfftw.la
118 /usr/lib/libsfftw.so
119 /usr/lib/libsfftw_threads.a
120 /usr/lib/libsfftw_threads.la
121 /usr/lib/libsfftw_threads.so
122 /usr/lib/libsrfftw.a
123 /usr/lib/libsrfftw.la
124 /usr/lib/libsrfftw.so
125 /usr/lib/libsrfftw_threads.a
126 /usr/lib/libsrfftw_threads.la
127 /usr/lib/libsrfftw_threads.so
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %changelog
133 * Tue Aug 03  1999 Dax Kelson <dax@gurulabs.com>
134 - Set prefix to /usr so there is no need to futz with ldconfig
This page took 0.043938 seconds and 3 git commands to generate.