]> git.pld-linux.org Git - packages/ffms2.git/commitdiff
- updated to 2.15 auto/th/ffmpegsource-2_15-1 auto/ti/ffmpegsource-2_15-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 29 Apr 2011 17:13:02 +0000 (17:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added c++ patch (fixes build with gcc 4.5)

Changed files:
    ffmpegsource-c++.patch -> 1.1
    ffmpegsource.spec -> 1.2

ffmpegsource-c++.patch [new file with mode: 0644]
ffmpegsource.spec

diff --git a/ffmpegsource-c++.patch b/ffmpegsource-c++.patch
new file mode 100644 (file)
index 0000000..c7e67d5
--- /dev/null
@@ -0,0 +1,11 @@
+--- ffmpegsource-2.15_src/src/core/utils.cpp.orig      2011-02-12 01:33:57.000000000 +0100
++++ ffmpegsource-2.15_src/src/core/utils.cpp   2011-04-29 19:00:44.272480825 +0200
+@@ -230,7 +230,7 @@
+ template<class T> static void safe_aligned_reallocz(T *&ptr, size_t old_size, size_t new_size) {
+       void *newalloc = av_mallocz(new_size);
+       if (newalloc) {
+-              memcpy(newalloc, ptr, min(old_size, new_size));
++              memcpy(newalloc, ptr, std::min(old_size, new_size));
+       }
+       av_free(ptr);
+       ptr = static_cast<T*>(newalloc);
index d9d10147f9faf3457ea30ce5928e799dd5c603b9..28927356fcc3d7c72635c3186ec749b457b67f9c 100644 (file)
@@ -1,12 +1,14 @@
 Summary:       FFmpegSource - FFmpeg wrapper library
 Summary(pl.UTF-8):     FFmpegSource - biblioteka obudowujÄ…ca FFmpeg
 Name:          ffmpegsource
-Version:       2.14
+Version:       2.15
 Release:       1
 License:       MIT (ffmpegsource itself), GPL v3+ (forced by ffmpeg)
 Group:         Libraries
+#Source0Download: http://code.google.com/p/ffmpegsource/downloads/list
 Source0:       http://ffmpegsource.googlecode.com/files/%{name}-%{version}_src.7z
-# Source0-md5: 59e7d09a4c8af57a7907b2ec58b9f249
+# Source0-md5: 0d0e2d4f6c4424e5f182f40f451c064e
+Patch0:                %{name}-c++.patch
 URL:           http://code.google.com/p/ffmpegsource/
 BuildRequires: autoconf >= 2.58
 BuildRequires: automake
@@ -67,7 +69,8 @@ Statyczna biblioteka FFmpegSource.
 %prep
 %setup -q -c -T -n %{name}-%{version}_src
 7z -o.. x %{SOURCE0}
-
+%undos src/core/utils.cpp
+%patch0 -p1
 %{__rm} configure
 
 %build
This page took 0.095573 seconds and 4 git commands to generate.